Update to 3.19.2
This commit is contained in:
parent
a3fc67c060
commit
a6595cacfa
25
5383.patch
25
5383.patch
@ -1,25 +0,0 @@
|
||||
From 23cd98a66a3eca1cc8e89a77f4fdf406c4f4c113 Mon Sep 17 00:00:00 2001
|
||||
From: Marc Chevrier <marc.chevrier@gmail.com>
|
||||
Date: Fri, 16 Oct 2020 11:36:53 +0200
|
||||
Subject: [PATCH] FindPython: Add support of version 3.10
|
||||
|
||||
---
|
||||
Modules/FindPython/Support.cmake | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Modules/FindPython/Support.cmake b/Modules/FindPython/Support.cmake
|
||||
index 7de2d29946..2b911ae7e3 100644
|
||||
--- a/Modules/FindPython/Support.cmake
|
||||
+++ b/Modules/FindPython/Support.cmake
|
||||
@@ -22,7 +22,7 @@ if (NOT DEFINED _${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR)
|
||||
message (FATAL_ERROR "FindPython: INTERNAL ERROR")
|
||||
endif()
|
||||
if (_${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR EQUAL "3")
|
||||
- set(_${_PYTHON_PREFIX}_VERSIONS 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
||||
+ set(_${_PYTHON_PREFIX}_VERSIONS 3.10 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
||||
elseif (_${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR EQUAL "2")
|
||||
set(_${_PYTHON_PREFIX}_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0)
|
||||
else()
|
||||
--
|
||||
GitLab
|
||||
|
42
5482.patch
42
5482.patch
@ -1,42 +0,0 @@
|
||||
From bb2ebbf2412ef9343f50a45868459ffb95fa9081 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
||||
Date: Mon, 9 Nov 2020 17:35:13 +0100
|
||||
Subject: [PATCH] FindPython{Interp,Libs}: Add support for version 3.10
|
||||
|
||||
Extend the change from commit 23cd98a66a (FindPython: Add support of
|
||||
version 3.10, 2020-10-16, v3.19.0-rc2~25^2) to cover the legacy
|
||||
`FindPython{Interp,Libs}` modules too.
|
||||
---
|
||||
Modules/FindPythonInterp.cmake | 2 +-
|
||||
Modules/FindPythonLibs.cmake | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Modules/FindPythonInterp.cmake b/Modules/FindPythonInterp.cmake
|
||||
index 1e01a99cbe..efe0f11901 100644
|
||||
--- a/Modules/FindPythonInterp.cmake
|
||||
+++ b/Modules/FindPythonInterp.cmake
|
||||
@@ -54,7 +54,7 @@ unset(_Python_NAMES)
|
||||
|
||||
set(_PYTHON1_VERSIONS 1.6 1.5)
|
||||
set(_PYTHON2_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0)
|
||||
-set(_PYTHON3_VERSIONS 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
||||
+set(_PYTHON3_VERSIONS 3.10 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
||||
|
||||
if(PythonInterp_FIND_VERSION)
|
||||
if(PythonInterp_FIND_VERSION_COUNT GREATER 1)
|
||||
diff --git a/Modules/FindPythonLibs.cmake b/Modules/FindPythonLibs.cmake
|
||||
index d3ec7beec6..396f0d2ed4 100644
|
||||
--- a/Modules/FindPythonLibs.cmake
|
||||
+++ b/Modules/FindPythonLibs.cmake
|
||||
@@ -79,7 +79,7 @@ set(CMAKE_FIND_FRAMEWORK LAST)
|
||||
|
||||
set(_PYTHON1_VERSIONS 1.6 1.5)
|
||||
set(_PYTHON2_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0)
|
||||
-set(_PYTHON3_VERSIONS 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
||||
+set(_PYTHON3_VERSIONS 3.10 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
||||
|
||||
if(PythonLibs_FIND_VERSION)
|
||||
if(PythonLibs_FIND_VERSION_COUNT GREATER 1)
|
||||
--
|
||||
GitLab
|
||||
|
@ -1,69 +0,0 @@
|
||||
diff -ur cmake-3.18.2.orig/Modules/FindBLAS.cmake cmake-3.18.2/Modules/FindBLAS.cmake
|
||||
--- cmake-3.18.2.orig/Modules/FindBLAS.cmake 2020-08-20 14:20:32.000000000 +0200
|
||||
+++ cmake-3.18.2/Modules/FindBLAS.cmake 2020-09-14 19:36:13.952349073 +0200
|
||||
@@ -27,6 +27,7 @@
|
||||
possibilities. List of vendors valid in this module:
|
||||
|
||||
* ``Goto``
|
||||
+ * ``FlexiBLAS``
|
||||
* ``OpenBLAS``
|
||||
* ``FLAME``
|
||||
* ``ATLAS PhiPACK``
|
||||
@@ -538,6 +539,22 @@
|
||||
""
|
||||
""
|
||||
""
|
||||
+ )
|
||||
+ endif()
|
||||
+endif()
|
||||
+
|
||||
+# FlexiBLAS? (http://www.mpi-magdeburg.mpg.de/mpcsc/software/FlexiBLAS/)
|
||||
+if(BLA_VENDOR STREQUAL "FlexiBLAS" OR BLA_VENDOR STREQUAL "All")
|
||||
+ if(NOT BLAS_LIBRARIES)
|
||||
+ check_blas_libraries(
|
||||
+ BLAS_LIBRARIES
|
||||
+ BLAS
|
||||
+ sgemm
|
||||
+ ""
|
||||
+ "flexiblas"
|
||||
+ ""
|
||||
+ ""
|
||||
+ ""
|
||||
)
|
||||
endif()
|
||||
endif()
|
||||
diff -ur cmake-3.18.2.orig/Modules/FindLAPACK.cmake cmake-3.18.2/Modules/FindLAPACK.cmake
|
||||
--- cmake-3.18.2.orig/Modules/FindLAPACK.cmake 2020-08-20 14:20:32.000000000 +0200
|
||||
+++ cmake-3.18.2/Modules/FindLAPACK.cmake 2020-09-14 19:38:43.204639078 +0200
|
||||
@@ -26,6 +26,7 @@
|
||||
If set, checks only the specified vendor, if not set checks all the
|
||||
possibilities. List of vendors valid in this module:
|
||||
|
||||
+ * ``FlexiBLAS``
|
||||
* ``OpenBLAS``
|
||||
* ``FLAME``
|
||||
* ``Intel10_32`` (intel mkl v10 32 bit)
|
||||
@@ -349,6 +350,23 @@
|
||||
""
|
||||
""
|
||||
""
|
||||
+ "${BLAS_LIBRARIES}"
|
||||
+ )
|
||||
+ endif()
|
||||
+ endif()
|
||||
+
|
||||
+ # FlexiBLAS? (http://www.mpi-magdeburg.mpg.de/mpcsc/software/FlexiBLAS/)
|
||||
+ if(BLA_VENDOR STREQUAL "FlexiBLAS" OR BLA_VENDOR STREQUAL "All")
|
||||
+ if(NOT LAPACK_LIBRARIES)
|
||||
+ check_lapack_libraries(
|
||||
+ LAPACK_LIBRARIES
|
||||
+ LAPACK
|
||||
+ cheev
|
||||
+ ""
|
||||
+ "flexiblas"
|
||||
+ ""
|
||||
+ ""
|
||||
+ ""
|
||||
"${BLAS_LIBRARIES}"
|
||||
)
|
||||
endif()
|
14
cmake.spec
14
cmake.spec
@ -63,21 +63,21 @@
|
||||
%{!?_vpath_builddir:%global _vpath_builddir %{_target_platform}}
|
||||
|
||||
%global major_version 3
|
||||
%global minor_version 18
|
||||
%global minor_version 19
|
||||
# Set to RC version if building RC, else %%{nil}
|
||||
#global rcsuf rc1
|
||||
%{?rcsuf:%global relsuf .%{rcsuf}}
|
||||
%{?rcsuf:%global versuf -%{rcsuf}}
|
||||
|
||||
# For handling bump release by rpmdev-bumpspec and mass rebuild
|
||||
%global baserelease 4
|
||||
%global baserelease 1
|
||||
|
||||
# Uncomment if building for EPEL
|
||||
#global name_suffix %%{major_version}
|
||||
%global orig_name cmake
|
||||
|
||||
Name: %{orig_name}%{?name_suffix}
|
||||
Version: %{major_version}.%{minor_version}.4
|
||||
Version: %{major_version}.%{minor_version}.2
|
||||
Release: %{baserelease}%{?relsuf}%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
@ -109,11 +109,6 @@ Patch101: %{name}-fedora-flag_release.patch
|
||||
# Add dl to CMAKE_DL_LIBS on MINGW
|
||||
# https://gitlab.kitware.com/cmake/cmake/issues/17600
|
||||
Patch102: %{name}-mingw-dl.patch
|
||||
# rhbz#1871346
|
||||
Patch103: %{name}-3.18.3-findblas.patch
|
||||
# Add Python 3.10 to the hadcoded lists of Python versions
|
||||
Patch104: https://gitlab.kitware.com/cmake/cmake/-/merge_requests/5383.patch
|
||||
Patch105: https://gitlab.kitware.com/cmake/cmake/-/merge_requests/5482.patch
|
||||
|
||||
# Patch for renaming on EPEL
|
||||
%if 0%{?name_suffix:1}
|
||||
@ -535,6 +530,9 @@ mv -f Modules/FindLibArchive.disabled Modules/FindLibArchive.cmake
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jan 11 2021 Cristian Morales Vega <christian.morales.vega@gmail.com> - 3.19.2-1
|
||||
- Update to 3.19.2
|
||||
|
||||
* Tue Dec 15 2020 Tom Stellard <tstellar@redhat.com> - 3.18.4-4
|
||||
- Update BuildRequires for eln
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (cmake-3.18.4.tar.gz) = 2f0c5647ed58bf911d0bfeafc7f22a3de09aa3be86301158fa51c8560e994534d7500869067432ecf91e82213a0b36ddb5db11c5c55d2ca5e5647ac9f75717b9
|
||||
SHA512 (cmake-3.19.2.tar.gz) = d811122af89d46174b8fdb2a26e8553200d9dc7eb6385ece4e4b3e7584880f73a799813d5a81e64e956fd2574b63264fa8944d862c74a076e9d61f5e6521e91a
|
||||
|
Loading…
Reference in New Issue
Block a user