Update to 3.4.0-rc1
This commit is contained in:
parent
4798c1522a
commit
a002bb282c
1
.gitignore
vendored
1
.gitignore
vendored
@ -41,3 +41,4 @@
|
||||
/cmake-3.3.0.tar.gz
|
||||
/cmake-3.3.1.tar.gz
|
||||
/cmake-3.3.2.tar.gz
|
||||
/cmake-3.4.0-rc1.tar.gz
|
||||
|
@ -1,34 +0,0 @@
|
||||
From ff5bb2efbe9f7bb4a1824b0ad727713fcd6bc54a Mon Sep 17 00:00:00 2001
|
||||
From: Roger Leigh <rleigh@codelibre.net>
|
||||
Date: Thu, 13 Aug 2015 23:34:39 +0100
|
||||
Subject: [PATCH 624/677] FindBoost: Add support for Boost 1.59
|
||||
|
||||
---
|
||||
Modules/FindBoost.cmake | 6 ++++--
|
||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Modules/FindBoost.cmake b/Modules/FindBoost.cmake
|
||||
index 05b552a..33e6a49 100644
|
||||
--- a/Modules/FindBoost.cmake
|
||||
+++ b/Modules/FindBoost.cmake
|
||||
@@ -512,13 +512,15 @@ else()
|
||||
# The user has not requested an exact version. Among known
|
||||
# versions, find those that are acceptable to the user request.
|
||||
set(_Boost_KNOWN_VERSIONS ${Boost_ADDITIONAL_VERSIONS}
|
||||
- "1.58.0" "1.58" "1.57.0" "1.57" "1.56.0" "1.56" "1.55.0" "1.55" "1.54.0" "1.54"
|
||||
- "1.53.0" "1.53" "1.52.0" "1.52" "1.51.0" "1.51"
|
||||
+
|
||||
+ "1.59.0" "1.59" "1.58.0" "1.58" "1.57.0" "1.57" "1.56.0" "1.56" "1.55.0" "1.55"
|
||||
+ "1.54.0" "1.54" "1.53.0" "1.53" "1.52.0" "1.52" "1.51.0" "1.51"
|
||||
"1.50.0" "1.50" "1.49.0" "1.49" "1.48.0" "1.48" "1.47.0" "1.47" "1.46.1"
|
||||
"1.46.0" "1.46" "1.45.0" "1.45" "1.44.0" "1.44" "1.43.0" "1.43" "1.42.0" "1.42"
|
||||
"1.41.0" "1.41" "1.40.0" "1.40" "1.39.0" "1.39" "1.38.0" "1.38" "1.37.0" "1.37"
|
||||
"1.36.1" "1.36.0" "1.36" "1.35.1" "1.35.0" "1.35" "1.34.1" "1.34.0"
|
||||
"1.34" "1.33.1" "1.33.0" "1.33")
|
||||
+
|
||||
set(_boost_TEST_VERSIONS)
|
||||
if(Boost_FIND_VERSION)
|
||||
set(_Boost_FIND_VERSION_SHORT "${Boost_FIND_VERSION_MAJOR}.${Boost_FIND_VERSION_MINOR}")
|
||||
--
|
||||
2.4.3
|
||||
|
@ -1,40 +0,0 @@
|
||||
From b9ec9392da21a3421e48c6961976060d872faffb Mon Sep 17 00:00:00 2001
|
||||
From: Rolf Eike Beer <eike@sf-mail.de>
|
||||
Date: Tue, 18 Aug 2015 12:14:43 +0200
|
||||
Subject: [PATCH 640/677] FindPkgConfig: remove variable dereference
|
||||
|
||||
If CMAKE_MINIMUM_REQUIRED_VERSION is not set because no
|
||||
cmake_minimum_required() call is present this line can lead to an error as that
|
||||
string is empty so too few arguments are passed to if():
|
||||
|
||||
See also "/var/tmp/paludis/build/kde-krdc-15.08.0/work/build/CMakeFiles/CMakeOutput.log".
|
||||
See also "/var/tmp/paludis/build/kde-krdc-15.08.0/work/build/CMakeFiles/CMakeError.log".
|
||||
CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:112 (elseif):
|
||||
given arguments:
|
||||
|
||||
"VERSION_LESS" "3.1"
|
||||
|
||||
Unknown arguments specified
|
||||
Call Stack (most recent call first):
|
||||
/usr/share/cmake/Modules/FindPkgConfig.cmake:501 (_pkgconfig_parse_options)
|
||||
/usr/share/cmake/Modules/FindOpenSSL.cmake:43 (pkg_check_modules)
|
||||
---
|
||||
Modules/FindPkgConfig.cmake | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Modules/FindPkgConfig.cmake b/Modules/FindPkgConfig.cmake
|
||||
index 526a62e..ae6903e 100644
|
||||
--- a/Modules/FindPkgConfig.cmake
|
||||
+++ b/Modules/FindPkgConfig.cmake
|
||||
@@ -109,7 +109,7 @@ macro(_pkgconfig_parse_options _result _is_req _is_silent _no_cmake_path _no_cma
|
||||
set(${_no_cmake_path} 1)
|
||||
set(${_no_cmake_environment_path} 1)
|
||||
endif()
|
||||
- elseif(${CMAKE_MINIMUM_REQUIRED_VERSION} VERSION_LESS 3.1)
|
||||
+ elseif(CMAKE_MINIMUM_REQUIRED_VERSION VERSION_LESS 3.1)
|
||||
set(${_no_cmake_path} 1)
|
||||
set(${_no_cmake_environment_path} 1)
|
||||
endif()
|
||||
--
|
||||
2.4.3
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up cmake-3.3.2/Modules/FindPythonLibs.cmake.orig cmake-3.3.2/Modules/FindPythonLibs.cmake
|
||||
--- cmake-3.3.2/Modules/FindPythonLibs.cmake.orig 2015-09-16 10:53:05.000000000 -0600
|
||||
+++ cmake-3.3.2/Modules/FindPythonLibs.cmake 2015-10-06 08:14:58.323564067 -0600
|
||||
@@ -55,7 +55,7 @@ CMAKE_FIND_FRAMEWORKS(Python)
|
||||
|
||||
set(_PYTHON1_VERSIONS 1.6 1.5)
|
||||
set(_PYTHON2_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0)
|
||||
-set(_PYTHON3_VERSIONS 3.4 3.3 3.2 3.1 3.0)
|
||||
+set(_PYTHON3_VERSIONS 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
|
||||
|
||||
if(PythonLibs_FIND_VERSION)
|
||||
if(PythonLibs_FIND_VERSION_COUNT GREATER 1)
|
@ -1,57 +0,0 @@
|
||||
From 97ffbcd8a4be25bbc661c68cb7d866bf9d5008d4 Mon Sep 17 00:00:00 2001
|
||||
From: Brad King <brad.king@kitware.com>
|
||||
Date: Fri, 11 Sep 2015 13:50:34 -0400
|
||||
Subject: [PATCH] CMakeParseImplicitLinkInfo: Do not match "VAR=..." as link
|
||||
line (#15737)
|
||||
|
||||
When compiling with
|
||||
|
||||
LDFLAGS='-Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld'
|
||||
|
||||
the compiler output includes a line like
|
||||
|
||||
COLLECT_GCC_OPTIONS='-specs=/usr/lib/rpm/redhat/redhat-hardened-ld' ...
|
||||
|
||||
that our link line regex matches due to an argument ending in "-ld".
|
||||
Since it is not really the link line no implicit link information is
|
||||
dectected. Exclude "VAR=..." lines from consideration as link lines to
|
||||
fix this.
|
||||
---
|
||||
Modules/CMakeParseImplicitLinkInfo.cmake | 2 +-
|
||||
Tests/CMakeTests/ImplicitLinkInfoTest.cmake.in | 7 +++++++
|
||||
2 files changed, 8 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Modules/CMakeParseImplicitLinkInfo.cmake b/Modules/CMakeParseImplicitLinkInfo.cmake
|
||||
index 8abc465..59092bd 100644
|
||||
--- a/Modules/CMakeParseImplicitLinkInfo.cmake
|
||||
+++ b/Modules/CMakeParseImplicitLinkInfo.cmake
|
||||
@@ -31,7 +31,7 @@ function(CMAKE_PARSE_IMPLICIT_LINK_INFO text lib_var dir_var fwk_var log_var obj
|
||||
# Construct a regex to match linker lines. It must match both the
|
||||
# whole line and just the command (argv[0]).
|
||||
set(linker_regex "^( *|.*[/\\])(${linker}|([^/\\]+-)?ld|collect2)[^/\\]*( |$)")
|
||||
- set(linker_exclude_regex "collect2 version ")
|
||||
+ set(linker_exclude_regex "collect2 version |^[A-Za-z0-9_]+=")
|
||||
set(log "${log} link line regex: [${linker_regex}]\n")
|
||||
string(REGEX REPLACE "\r?\n" ";" output_lines "${text}")
|
||||
foreach(line IN LISTS output_lines)
|
||||
diff --git a/Tests/CMakeTests/ImplicitLinkInfoTest.cmake.in b/Tests/CMakeTests/ImplicitLinkInfoTest.cmake.in
|
||||
index 055b183..da614e9 100644
|
||||
--- a/Tests/CMakeTests/ImplicitLinkInfoTest.cmake.in
|
||||
+++ b/Tests/CMakeTests/ImplicitLinkInfoTest.cmake.in
|
||||
@@ -105,6 +105,13 @@ set(linux64_test2_libs "c;/opt/sun/sunstudio12/prod/lib/amd64/libc_supp.a")
|
||||
set(linux64_test2_dirs "/opt/sun/sunstudio12/prod/lib/amd64;/lib64;/usr/lib64")
|
||||
list(APPEND platforms linux64_test2)
|
||||
|
||||
+# -specs=redhat-hardened-ld
|
||||
+set(linux64_test3_text "COLLECT_GCC_OPTIONS='-specs=/usr/lib/rpm/redhat/redhat-hardened-ld' '-v' '-O2' '-g' '-pipe' '-Wall' '-Werror=format-security' '-fexceptions' '-fstack-protector-strong' '--param' 'ssp-buffer-size=4' '-grecord-gcc-switches' '-specs=/usr/lib/rpm/redhat/redhat-hardened-cc1' '-m64' '-mtune=generic' '-I' '/usr/lib64/gfortran/modules' '-o' 'a.out' '-rdynamic' '-shared-libgcc' '-march=x86-64' '-pie'
|
||||
+ /usr/libexec/gcc/x86_64-redhat-linux/5.1.1/collect2 -plugin /usr/libexec/gcc/x86_64-redhat-linux/5.1.1/liblto_plugin.so -plugin-opt=/usr/libexec/gcc/x86_64-redhat-linux/5.1.1/lto-wrapper -plugin-opt=-fresolution=/tmp/ccNzxFD8.res -plugin-opt=-pass-through=-lgcc_s -plugin-opt=-pass-through=-lgcc -plugin-opt=-pass-through=-lquadmath -plugin-opt=-pass-through=-lm -plugin-opt=-pass-through=-lgcc_s -plugin-opt=-pass-through=-lgcc -plugin-opt=-pass-through=-lc -plugin-opt=-pass-through=-lgcc_s -plugin-opt=-pass-through=-lgcc --build-id --no-add-needed --eh-frame-hdr --hash-style=gnu -m elf_x86_64 -export-dynamic -dynamic-linker /lib64/ld-linux-x86-64.so.2 -z now -pie -o a.out /usr/lib/gcc/x86_64-redhat-linux/5.1.1/../../../../lib64/Scrt1.o /usr/lib/gcc/x86_64-redhat-linux/5.1.1/../../../../lib64/crti.o /usr/lib/gcc/x86_64-redhat-linux/5.1.1/crtbeginS.o -L/usr/lib/gcc/x86_64-redhat-linux/5.1.1 -L/usr/lib/gcc/x86_64-redhat-linux/5.1.1/../../../../lib64 -L/lib/../lib64 -L/usr/lib/../lib64 -L/usr/lib/gcc/x86_64-redhat-linux/5.1.1/../../.. -z relro dummy.o -lgfortran -lm -lgcc_s -lgcc -lquadmath -lm -lgcc_s -lgcc -lc -lgcc_s -lgcc /usr/lib/gcc/x86_64-redhat-linux/5.1.1/crtendS.o /usr/lib/gcc/x86_64-redhat-linux/5.1.1/../../../../lib64/crtn.o")
|
||||
+set(linux64_test3_libs "gfortran;m;quadmath;m;c")
|
||||
+set(linux64_test3_dirs "/usr/lib/gcc/x86_64-redhat-linux/5.1.1;/usr/lib64;/lib64;/usr/lib")
|
||||
+list(APPEND platforms linux64_test3)
|
||||
+
|
||||
#-----------------------------------------------------------------------------
|
||||
# Mac
|
||||
|
||||
--
|
||||
1.7.10.4
|
||||
|
27
cmake.spec
27
cmake.spec
@ -4,7 +4,7 @@
|
||||
# Set to bcond_with or use --without gui to disable qt4 gui build
|
||||
%bcond_without gui
|
||||
# Set to RC version if building RC, else %{nil}
|
||||
%define rcver %{nil}
|
||||
%define rcver -rc1
|
||||
|
||||
%define rpm_macros_dir %{_sysconfdir}/rpm
|
||||
%if 0%{?fedora}
|
||||
@ -12,8 +12,8 @@
|
||||
%endif
|
||||
|
||||
Name: cmake
|
||||
Version: 3.3.2
|
||||
Release: 2%{?dist}
|
||||
Version: 3.4.0
|
||||
Release: 0.1.rc1%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
Group: Development/Tools
|
||||
@ -23,7 +23,7 @@ Group: Development/Tools
|
||||
# some GPL-licensed bison-generated files, these all include an exception granting redistribution under terms of your choice
|
||||
License: BSD and MIT and zlib
|
||||
URL: http://www.cmake.org
|
||||
Source0: http://www.cmake.org/files/v3.3/cmake-%{version}%{?rcver}.tar.gz
|
||||
Source0: http://www.cmake.org/files/v3.4/cmake-%{version}%{?rcver}.tar.gz
|
||||
Source1: cmake-init.el
|
||||
Source2: macros.cmake
|
||||
# See https://bugzilla.redhat.com/show_bug.cgi?id=1202899
|
||||
@ -31,22 +31,10 @@ Source3: cmake.attr
|
||||
Source4: cmake.prov
|
||||
# Patch to find DCMTK in Fedora (bug #720140)
|
||||
Patch0: cmake-dcmtk.patch
|
||||
# Upstream patch to find python 3.5/3.6
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1269095
|
||||
Patch1: cmake-python3.5.patch
|
||||
# Patch to fix RindRuby vendor settings
|
||||
# http://public.kitware.com/Bug/view.php?id=12965
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=822796
|
||||
Patch2: cmake-findruby.patch
|
||||
# Fix issue with redhat-hardened-ld
|
||||
# http://www.cmake.org/Bug/view.php?id=15737
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1260490
|
||||
Patch3: cmake.git-97ffbcd8.patch
|
||||
|
||||
## upstream patches
|
||||
# some post v3.3.1 tag commits
|
||||
Patch624: 0624-FindBoost-Add-support-for-Boost-1.59.patch
|
||||
Patch640: 0640-FindPkgConfig-remove-variable-dereference.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -113,11 +101,7 @@ The %{name}-gui package contains the Qt based GUI for CMake.
|
||||
%setup -q -n %{name}-%{version}%{?rcver}
|
||||
# We cannot use backups with patches to Modules as they end up being installed
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch624 -p1
|
||||
%patch640 -p1
|
||||
|
||||
|
||||
%build
|
||||
@ -290,6 +274,9 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Oct 6 2015 Orion Poplawski <orion@cora.nwra.com> - 3.4.0-0.1.rc1
|
||||
- Update to 3.4.0-rc1
|
||||
|
||||
* Tue Oct 6 2015 Orion Poplawski <orion@cora.nwra.com> - 3.3.2-2
|
||||
- Add upstream patch to find python 3.5 (bug #1269095)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user