Update to 3.8.0-rc2
This commit is contained in:
parent
10e7a4e0f4
commit
9338710aca
1
.gitignore
vendored
1
.gitignore
vendored
@ -28,3 +28,4 @@
|
||||
/cmake-3.7.0.tar.gz
|
||||
/cmake-3.7.1.tar.gz
|
||||
/cmake-3.7.2.tar.gz
|
||||
/cmake-3.8.0-rc2.tar.gz
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up cmake-3.7.2/Utilities/KWIML/test/CMakeLists.txt.format cmake-3.7.2/Utilities/KWIML/test/CMakeLists.txt
|
||||
--- cmake-3.7.2/Utilities/KWIML/test/CMakeLists.txt.format 2017-01-13 07:05:42.000000000 -0700
|
||||
+++ cmake-3.7.2/Utilities/KWIML/test/CMakeLists.txt 2017-02-27 11:09:30.789844778 -0700
|
||||
@@ -10,7 +10,7 @@ endif()
|
||||
# Suppress printf/scanf format warnings; we test if the sizes match.
|
||||
foreach(lang C CXX)
|
||||
if(KWIML_LANGUAGE_${lang} AND CMAKE_${lang}_COMPILER_ID STREQUAL "GNU")
|
||||
- set(CMAKE_${lang}_FLAGS "${CMAKE_${lang}_FLAGS} -Wno-format")
|
||||
+ set(CMAKE_${lang}_FLAGS "${CMAKE_${lang}_FLAGS} -Wno-format -Wno-format-security")
|
||||
endif()
|
||||
endforeach()
|
||||
|
16
cmake.spec
16
cmake.spec
@ -33,17 +33,17 @@
|
||||
%{!?_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||
|
||||
%global major_version 3
|
||||
%global minor_version 7
|
||||
%global minor_version 8
|
||||
# Set to RC version if building RC, else %{nil}
|
||||
#global rcver rc3
|
||||
%global rcver rc2
|
||||
|
||||
# Uncomment if building for EPEL
|
||||
#global name_suffix %{major_version}
|
||||
%global orig_name cmake
|
||||
|
||||
Name: %{orig_name}%{?name_suffix}
|
||||
Version: %{major_version}.%{minor_version}.2
|
||||
Release: 4%{?dist}
|
||||
Version: %{major_version}.%{minor_version}.0
|
||||
Release: 0.1%{?rcver:.%{rcver}}%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
# most sources are BSD
|
||||
@ -66,9 +66,6 @@ Source4: %{name}.prov
|
||||
Patch2: %{name}-findruby.patch
|
||||
# replace release flag -O3 with -O2 for fedora
|
||||
Patch3: %{name}-fedora-flag_release.patch
|
||||
# Handle -Werror=format-security
|
||||
# https://gitlab.kitware.com/cmake/cmake/merge_requests/529
|
||||
Patch4: %{name}-format.patch
|
||||
|
||||
# Patch for renaming on EPEL
|
||||
%if 0%{?name_suffix:1}
|
||||
@ -91,6 +88,7 @@ BuildRequires: /usr/bin/sphinx-build
|
||||
BuildRequires: libarchive3-devel
|
||||
%endif
|
||||
BuildRequires: libuv-devel
|
||||
BuildRequires: rhash-devel
|
||||
BuildRequires: xz-devel
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: emacs
|
||||
@ -181,7 +179,6 @@ The %{name}-gui package contains the Qt based GUI for %{name}.
|
||||
# We cannot use backups with patches to Modules as they end up being installed
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1 -b .format
|
||||
|
||||
%if %{with python3}
|
||||
echo '#!%{__python3}' > %{name}.prov
|
||||
@ -403,6 +400,9 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Mar 20 2017 Orion Poplawski <orion@cora.nwra.com> - 3.8.0-0.1.rc2
|
||||
- Update to 3.8.0-rc2
|
||||
|
||||
* Mon Feb 27 2017 Rex Dieter <rdieter@fedoraproject.org> - 3.7.2-4
|
||||
- Add patch to handle gcc format option changes
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (cmake-3.7.2.tar.gz) = b2ed0192e12267de19eb178c2dedc69d06fc33dfadd47efbe0ccf6969ad72d290fa4bff02861c379a8752337d67d2485d7e1ba947cb219f2e4041a53a195e88d
|
||||
SHA512 (cmake-3.8.0-rc2.tar.gz) = 4ca4ea7f941e3fa9c80614e9873044425b9b5970e94885deace6750d3e0eb19c4e6b82c6d82e3c666971e523311584814e95d0787c978238b17b3d8138aaa3ee
|
||||
|
Loading…
Reference in New Issue
Block a user