Update to 3.12.0 (#1584925)
fixes libuv-related FTBFS (#1603661) use %_metainfodir
This commit is contained in:
parent
dada3cb546
commit
923181cba4
41
.gitignore
vendored
41
.gitignore
vendored
@ -1,45 +1,6 @@
|
||||
/cmake-3.2.2.tar.gz
|
||||
/cmake-3.2.3.tar.gz
|
||||
/cmake-3.3.0-rc1.tar.gz
|
||||
/cmake-3.3.0-rc2.tar.gz
|
||||
/cmake-3.3.0-rc3.tar.gz
|
||||
/cmake-3.3.0.tar.gz
|
||||
/cmake-3.3.1.tar.gz
|
||||
/cmake-3.3.2.tar.gz
|
||||
/cmake-3.4.0-rc1.tar.gz
|
||||
/cmake-3.4.0-rc2.tar.gz
|
||||
/cmake-3.4.0-rc3.tar.gz
|
||||
/cmake-3.4.0.tar.gz
|
||||
/cmake-3.4.1.tar.gz
|
||||
/cmake-3.4.2.tar.gz
|
||||
/cmake-3.4.3.tar.gz
|
||||
/cmake-3.5.0-rc2.tar.gz
|
||||
/cmake-3.5.0-rc3.tar.gz
|
||||
/cmake-3.5.0.tar.gz
|
||||
/cmake-3.5.1.tar.gz
|
||||
/cmake-3.5.2.tar.gz
|
||||
/cmake-3.6.0-rc4.tar.gz
|
||||
/cmake-3.6.0.tar.gz
|
||||
/cmake-3.6.1.tar.gz
|
||||
/cmake-3.6.2.tar.gz
|
||||
/cmake-3.7.0-rc1.tar.gz
|
||||
/cmake-3.7.0-rc2.tar.gz
|
||||
/cmake-3.7.0-rc3.tar.gz
|
||||
/cmake-3.7.0.tar.gz
|
||||
/cmake-3.7.1.tar.gz
|
||||
/cmake-3.7.2.tar.gz
|
||||
/cmake-3.8.0-rc2.tar.gz
|
||||
/cmake-3.8.0-rc3.tar.gz
|
||||
/cmake-3.8.0.tar.gz
|
||||
/cmake-3.8.1.tar.gz
|
||||
/cmake-3.8.2.tar.gz
|
||||
/cmake-3.9.0.tar.gz
|
||||
/cmake-3.9.1.tar.gz
|
||||
/cmake-3.9.3.tar.gz
|
||||
/cmake-3.9.5.tar.gz
|
||||
/cmake-3.9.6.tar.gz
|
||||
/cmake-3.10.0.tar.gz
|
||||
/cmake-3.10.1.tar.gz
|
||||
/cmake-3.10.2.tar.gz
|
||||
/cmake-3.11.0.tar.gz
|
||||
/cmake-3.11.2.tar.gz
|
||||
/cmake-3.12.0.tar.gz
|
||||
|
@ -1,13 +1,7 @@
|
||||
commit b247220ae5a91d8057fd57b5f6e50c93b168dc17
|
||||
Author: Björn Esser <besser82@fedoraproject.org>
|
||||
Date: Mon Jul 24 01:52:06 2017 +0200
|
||||
|
||||
Set optimization for RELEASE to Fedora default
|
||||
|
||||
Index: cmake-3.10.0/Modules/Compiler/Absoft-Fortran.cmake
|
||||
===================================================================
|
||||
--- cmake-3.10.0.orig/Modules/Compiler/Absoft-Fortran.cmake
|
||||
+++ cmake-3.10.0/Modules/Compiler/Absoft-Fortran.cmake
|
||||
diff -up cmake-3.12.0/.fedora_flag_release.orig cmake-3.12.0/.fedora_flag_release
|
||||
diff -up cmake-3.12.0/Modules/Compiler/Absoft-Fortran.cmake.orig cmake-3.12.0/Modules/Compiler/Absoft-Fortran.cmake
|
||||
--- cmake-3.12.0/Modules/Compiler/Absoft-Fortran.cmake.orig 2018-07-17 06:29:00.000000000 -0500
|
||||
+++ cmake-3.12.0/Modules/Compiler/Absoft-Fortran.cmake 2018-07-27 08:51:37.486583595 -0500
|
||||
@@ -1,7 +1,7 @@
|
||||
string(APPEND CMAKE_Fortran_FLAGS_INIT " ")
|
||||
string(APPEND CMAKE_Fortran_FLAGS_DEBUG_INIT " -g")
|
||||
@ -17,10 +11,9 @@ Index: cmake-3.10.0/Modules/Compiler/Absoft-Fortran.cmake
|
||||
string(APPEND CMAKE_Fortran_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
||||
set(CMAKE_Fortran_MODDIR_FLAG "-YMOD_OUT_DIR=")
|
||||
set(CMAKE_Fortran_MODPATH_FLAG "-p")
|
||||
Index: cmake-3.10.0/Modules/Compiler/G95-Fortran.cmake
|
||||
===================================================================
|
||||
--- cmake-3.10.0.orig/Modules/Compiler/G95-Fortran.cmake
|
||||
+++ cmake-3.10.0/Modules/Compiler/G95-Fortran.cmake
|
||||
diff -up cmake-3.12.0/Modules/Compiler/G95-Fortran.cmake.orig cmake-3.12.0/Modules/Compiler/G95-Fortran.cmake
|
||||
--- cmake-3.12.0/Modules/Compiler/G95-Fortran.cmake.orig 2018-07-17 06:29:00.000000000 -0500
|
||||
+++ cmake-3.12.0/Modules/Compiler/G95-Fortran.cmake 2018-07-27 08:51:37.487583601 -0500
|
||||
@@ -1,7 +1,7 @@
|
||||
string(APPEND CMAKE_Fortran_FLAGS_INIT " ")
|
||||
string(APPEND CMAKE_Fortran_FLAGS_DEBUG_INIT " -g")
|
||||
@ -30,23 +23,9 @@ Index: cmake-3.10.0/Modules/Compiler/G95-Fortran.cmake
|
||||
string(APPEND CMAKE_Fortran_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
||||
set(CMAKE_Fortran_MODDIR_FLAG "-fmod=")
|
||||
set(CMAKE_Fortran_VERBOSE_FLAG "-v")
|
||||
Index: cmake-3.10.0/Modules/Compiler/GNU-Fortran.cmake
|
||||
===================================================================
|
||||
--- cmake-3.10.0.orig/Modules/Compiler/GNU-Fortran.cmake
|
||||
+++ cmake-3.10.0/Modules/Compiler/GNU-Fortran.cmake
|
||||
@@ -11,7 +11,7 @@ set(CMAKE_Fortran_POSTPROCESS_FLAG "-fpr
|
||||
|
||||
# No -DNDEBUG for Fortran.
|
||||
string(APPEND CMAKE_Fortran_FLAGS_MINSIZEREL_INIT " -Os")
|
||||
-string(APPEND CMAKE_Fortran_FLAGS_RELEASE_INIT " -O3")
|
||||
+string(APPEND CMAKE_Fortran_FLAGS_RELEASE_INIT " -O2")
|
||||
|
||||
# No -isystem for Fortran because it will not find .mod files.
|
||||
unset(CMAKE_INCLUDE_SYSTEM_FLAG_Fortran)
|
||||
Index: cmake-3.10.0/Modules/Compiler/GNU.cmake
|
||||
===================================================================
|
||||
--- cmake-3.10.0.orig/Modules/Compiler/GNU.cmake
|
||||
+++ cmake-3.10.0/Modules/Compiler/GNU.cmake
|
||||
diff -up cmake-3.12.0/Modules/Compiler/GNU.cmake.orig cmake-3.12.0/Modules/Compiler/GNU.cmake
|
||||
--- cmake-3.12.0/Modules/Compiler/GNU.cmake.orig 2018-07-17 06:29:00.000000000 -0500
|
||||
+++ cmake-3.12.0/Modules/Compiler/GNU.cmake 2018-07-27 08:51:37.488583607 -0500
|
||||
@@ -40,7 +40,7 @@ macro(__compiler_gnu lang)
|
||||
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
||||
@ -56,10 +35,21 @@ Index: cmake-3.10.0/Modules/Compiler/GNU.cmake
|
||||
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g -DNDEBUG")
|
||||
set(CMAKE_${lang}_CREATE_PREPROCESSED_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <INCLUDES> <FLAGS> -E <SOURCE> > <PREPROCESSED_SOURCE>")
|
||||
set(CMAKE_${lang}_CREATE_ASSEMBLY_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <INCLUDES> <FLAGS> -S <SOURCE> -o <ASSEMBLY_SOURCE>")
|
||||
Index: cmake-3.10.0/Modules/Compiler/Intel.cmake
|
||||
===================================================================
|
||||
--- cmake-3.10.0.orig/Modules/Compiler/Intel.cmake
|
||||
+++ cmake-3.10.0/Modules/Compiler/Intel.cmake
|
||||
diff -up cmake-3.12.0/Modules/Compiler/GNU-Fortran.cmake.orig cmake-3.12.0/Modules/Compiler/GNU-Fortran.cmake
|
||||
--- cmake-3.12.0/Modules/Compiler/GNU-Fortran.cmake.orig 2018-07-17 06:29:00.000000000 -0500
|
||||
+++ cmake-3.12.0/Modules/Compiler/GNU-Fortran.cmake 2018-07-27 08:51:37.487583601 -0500
|
||||
@@ -11,7 +11,7 @@ set(CMAKE_Fortran_POSTPROCESS_FLAG "-fpr
|
||||
|
||||
# No -DNDEBUG for Fortran.
|
||||
string(APPEND CMAKE_Fortran_FLAGS_MINSIZEREL_INIT " -Os")
|
||||
-string(APPEND CMAKE_Fortran_FLAGS_RELEASE_INIT " -O3")
|
||||
+string(APPEND CMAKE_Fortran_FLAGS_RELEASE_INIT " -O2")
|
||||
|
||||
# No -isystem for Fortran because it will not find .mod files.
|
||||
unset(CMAKE_INCLUDE_SYSTEM_FLAG_Fortran)
|
||||
diff -up cmake-3.12.0/Modules/Compiler/Intel.cmake.orig cmake-3.12.0/Modules/Compiler/Intel.cmake
|
||||
--- cmake-3.12.0/Modules/Compiler/Intel.cmake.orig 2018-07-17 06:29:00.000000000 -0500
|
||||
+++ cmake-3.12.0/Modules/Compiler/Intel.cmake 2018-07-27 08:51:37.489583613 -0500
|
||||
@@ -22,7 +22,7 @@ else()
|
||||
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
||||
@ -69,10 +59,9 @@ Index: cmake-3.10.0/Modules/Compiler/Intel.cmake
|
||||
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
||||
|
||||
set(CMAKE_${lang}_COMPILER_PREDEFINES_COMMAND "${CMAKE_${lang}_COMPILER}" "-QdM" "-P" "-Za" "${CMAKE_ROOT}/Modules/CMakeCXXCompilerABI.cpp")
|
||||
Index: cmake-3.10.0/Modules/Compiler/NVIDIA-CUDA.cmake
|
||||
===================================================================
|
||||
--- cmake-3.10.0.orig/Modules/Compiler/NVIDIA-CUDA.cmake
|
||||
+++ cmake-3.10.0/Modules/Compiler/NVIDIA-CUDA.cmake
|
||||
diff -up cmake-3.12.0/Modules/Compiler/NVIDIA-CUDA.cmake.orig cmake-3.12.0/Modules/Compiler/NVIDIA-CUDA.cmake
|
||||
--- cmake-3.12.0/Modules/Compiler/NVIDIA-CUDA.cmake.orig 2018-07-17 06:29:00.000000000 -0500
|
||||
+++ cmake-3.12.0/Modules/Compiler/NVIDIA-CUDA.cmake 2018-07-27 08:51:37.490583619 -0500
|
||||
@@ -9,7 +9,7 @@ if(NOT "x${CMAKE_CUDA_SIMULATE_ID}" STRE
|
||||
set(CMAKE_SHARED_LIBRARY_CUDA_FLAGS -fPIC)
|
||||
string(APPEND CMAKE_CUDA_FLAGS_INIT " ")
|
||||
@ -82,10 +71,9 @@ Index: cmake-3.10.0/Modules/Compiler/NVIDIA-CUDA.cmake
|
||||
string(APPEND CMAKE_CUDA_FLAGS_MINSIZEREL_INIT " -O1 -DNDEBUG")
|
||||
string(APPEND CMAKE_CUDA_FLAGS_RELWITHDEBINFO_INIT " -O2 -g -DNDEBUG")
|
||||
endif()
|
||||
Index: cmake-3.10.0/Modules/Compiler/PathScale.cmake
|
||||
===================================================================
|
||||
--- cmake-3.10.0.orig/Modules/Compiler/PathScale.cmake
|
||||
+++ cmake-3.10.0/Modules/Compiler/PathScale.cmake
|
||||
diff -up cmake-3.12.0/Modules/Compiler/PathScale.cmake.orig cmake-3.12.0/Modules/Compiler/PathScale.cmake
|
||||
--- cmake-3.12.0/Modules/Compiler/PathScale.cmake.orig 2018-07-17 06:29:00.000000000 -0500
|
||||
+++ cmake-3.12.0/Modules/Compiler/PathScale.cmake 2018-07-27 08:51:37.490583619 -0500
|
||||
@@ -16,6 +16,6 @@ macro(__compiler_pathscale lang)
|
||||
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g -O0")
|
||||
@ -94,36 +82,9 @@ Index: cmake-3.10.0/Modules/Compiler/PathScale.cmake
|
||||
+ string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O2")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -g -O2")
|
||||
endmacro()
|
||||
Index: cmake-3.10.0/Modules/Platform/IRIX.cmake
|
||||
===================================================================
|
||||
--- cmake-3.10.0.orig/Modules/Platform/IRIX.cmake
|
||||
+++ cmake-3.10.0/Modules/Platform/IRIX.cmake
|
||||
@@ -7,7 +7,7 @@ if(NOT CMAKE_COMPILER_IS_GNUCXX)
|
||||
"<CMAKE_CXX_COMPILER> -ar -o <TARGET> <OBJECTS>")
|
||||
set (CMAKE_CXX_FLAGS_INIT "")
|
||||
set (CMAKE_CXX_FLAGS_DEBUG_INIT "-g")
|
||||
- set (CMAKE_CXX_FLAGS_MINSIZEREL_INIT "-O3 -DNDEBUG")
|
||||
+ set (CMAKE_CXX_FLAGS_MINSIZEREL_INIT "-O2 -DNDEBUG")
|
||||
set (CMAKE_CXX_FLAGS_RELEASE_INIT "-O2 -DNDEBUG")
|
||||
set (CMAKE_CXX_FLAGS_RELWITHDEBINFO_INIT "-O2")
|
||||
set (CMAKE_C_FLAGS_INIT "")
|
||||
Index: cmake-3.10.0/Modules/Platform/IRIX64.cmake
|
||||
===================================================================
|
||||
--- cmake-3.10.0.orig/Modules/Platform/IRIX64.cmake
|
||||
+++ cmake-3.10.0/Modules/Platform/IRIX64.cmake
|
||||
@@ -37,7 +37,7 @@ if(NOT CMAKE_COMPILER_IS_GNUCC)
|
||||
set(CMAKE_CXX_CREATE_STATIC_LIBRARY
|
||||
"<CMAKE_CXX_COMPILER> -ar -o <TARGET> <OBJECTS>")
|
||||
set (CMAKE_CXX_FLAGS_DEBUG_INIT "-g")
|
||||
- set (CMAKE_CXX_FLAGS_MINSIZEREL_INIT "-O3 -DNDEBUG")
|
||||
+ set (CMAKE_CXX_FLAGS_MINSIZEREL_INIT "-O2 -DNDEBUG")
|
||||
set (CMAKE_CXX_FLAGS_RELEASE_INIT "-O2 -DNDEBUG")
|
||||
set (CMAKE_CXX_FLAGS_RELWITHDEBINFO_INIT "-O2")
|
||||
endif()
|
||||
Index: cmake-3.10.0/Modules/Compiler/PGI.cmake
|
||||
===================================================================
|
||||
--- cmake-3.10.0.orig/Modules/Compiler/PGI.cmake
|
||||
+++ cmake-3.10.0/Modules/Compiler/PGI.cmake
|
||||
diff -up cmake-3.12.0/Modules/Compiler/PGI.cmake.orig cmake-3.12.0/Modules/Compiler/PGI.cmake
|
||||
--- cmake-3.12.0/Modules/Compiler/PGI.cmake.orig 2018-07-17 06:29:00.000000000 -0500
|
||||
+++ cmake-3.12.0/Modules/Compiler/PGI.cmake 2018-07-27 08:51:37.492583631 -0500
|
||||
@@ -18,7 +18,7 @@ macro(__compiler_pgi lang)
|
||||
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g -O0")
|
||||
@ -133,10 +94,9 @@ Index: cmake-3.10.0/Modules/Compiler/PGI.cmake
|
||||
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -gopt")
|
||||
|
||||
if(CMAKE_HOST_WIN32)
|
||||
Index: cmake-3.10.0/Modules/Compiler/SunPro-ASM.cmake
|
||||
===================================================================
|
||||
--- cmake-3.10.0.orig/Modules/Compiler/SunPro-ASM.cmake
|
||||
+++ cmake-3.10.0/Modules/Compiler/SunPro-ASM.cmake
|
||||
diff -up cmake-3.12.0/Modules/Compiler/SunPro-ASM.cmake.orig cmake-3.12.0/Modules/Compiler/SunPro-ASM.cmake
|
||||
--- cmake-3.12.0/Modules/Compiler/SunPro-ASM.cmake.orig 2018-07-17 06:29:00.000000000 -0500
|
||||
+++ cmake-3.12.0/Modules/Compiler/SunPro-ASM.cmake 2018-07-27 08:51:37.492583631 -0500
|
||||
@@ -11,7 +11,7 @@ set(CMAKE_SHARED_LIBRARY_SONAME_ASM_FLAG
|
||||
string(APPEND CMAKE_ASM_FLAGS_INIT " ")
|
||||
string(APPEND CMAKE_ASM_FLAGS_DEBUG_INIT " -g")
|
||||
@ -146,10 +106,9 @@ Index: cmake-3.10.0/Modules/Compiler/SunPro-ASM.cmake
|
||||
string(APPEND CMAKE_ASM_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
||||
|
||||
# Initialize ASM link type selection flags. These flags are used when
|
||||
Index: cmake-3.10.0/Modules/Compiler/SunPro-C.cmake
|
||||
===================================================================
|
||||
--- cmake-3.10.0.orig/Modules/Compiler/SunPro-C.cmake
|
||||
+++ cmake-3.10.0/Modules/Compiler/SunPro-C.cmake
|
||||
diff -up cmake-3.12.0/Modules/Compiler/SunPro-C.cmake.orig cmake-3.12.0/Modules/Compiler/SunPro-C.cmake
|
||||
--- cmake-3.12.0/Modules/Compiler/SunPro-C.cmake.orig 2018-07-17 06:29:00.000000000 -0500
|
||||
+++ cmake-3.12.0/Modules/Compiler/SunPro-C.cmake 2018-07-27 08:51:37.492583631 -0500
|
||||
@@ -15,7 +15,7 @@ set(CMAKE_SHARED_LIBRARY_SONAME_C_FLAG "
|
||||
string(APPEND CMAKE_C_FLAGS_INIT " ")
|
||||
string(APPEND CMAKE_C_FLAGS_DEBUG_INIT " -g")
|
||||
@ -158,11 +117,10 @@ Index: cmake-3.10.0/Modules/Compiler/SunPro-C.cmake
|
||||
+string(APPEND CMAKE_C_FLAGS_RELEASE_INIT " -xO2 -DNDEBUG")
|
||||
string(APPEND CMAKE_C_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
||||
|
||||
# Initialize C link type selection flags. These flags are used when
|
||||
Index: cmake-3.10.0/Modules/Compiler/SunPro-CXX.cmake
|
||||
===================================================================
|
||||
--- cmake-3.10.0.orig/Modules/Compiler/SunPro-CXX.cmake
|
||||
+++ cmake-3.10.0/Modules/Compiler/SunPro-CXX.cmake
|
||||
set(CMAKE_DEPFILE_FLAGS_C "-xMD -xMF <DEPFILE>")
|
||||
diff -up cmake-3.12.0/Modules/Compiler/SunPro-CXX.cmake.orig cmake-3.12.0/Modules/Compiler/SunPro-CXX.cmake
|
||||
--- cmake-3.12.0/Modules/Compiler/SunPro-CXX.cmake.orig 2018-07-17 06:29:00.000000000 -0500
|
||||
+++ cmake-3.12.0/Modules/Compiler/SunPro-CXX.cmake 2018-07-27 08:51:37.493583637 -0500
|
||||
@@ -15,7 +15,7 @@ set(CMAKE_SHARED_LIBRARY_SONAME_CXX_FLAG
|
||||
string(APPEND CMAKE_CXX_FLAGS_INIT " ")
|
||||
string(APPEND CMAKE_CXX_FLAGS_DEBUG_INIT " -g")
|
||||
@ -171,11 +129,10 @@ Index: cmake-3.10.0/Modules/Compiler/SunPro-CXX.cmake
|
||||
+string(APPEND CMAKE_CXX_FLAGS_RELEASE_INIT " -xO2 -DNDEBUG")
|
||||
string(APPEND CMAKE_CXX_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
||||
|
||||
# Initialize C link type selection flags. These flags are used when
|
||||
Index: cmake-3.10.0/Modules/Compiler/SunPro-Fortran.cmake
|
||||
===================================================================
|
||||
--- cmake-3.10.0.orig/Modules/Compiler/SunPro-Fortran.cmake
|
||||
+++ cmake-3.10.0/Modules/Compiler/SunPro-Fortran.cmake
|
||||
set(CMAKE_DEPFILE_FLAGS_CXX "-xMD -xMF <DEPFILE>")
|
||||
diff -up cmake-3.12.0/Modules/Compiler/SunPro-Fortran.cmake.orig cmake-3.12.0/Modules/Compiler/SunPro-Fortran.cmake
|
||||
--- cmake-3.12.0/Modules/Compiler/SunPro-Fortran.cmake.orig 2018-07-17 06:29:00.000000000 -0500
|
||||
+++ cmake-3.12.0/Modules/Compiler/SunPro-Fortran.cmake 2018-07-27 08:51:37.493583637 -0500
|
||||
@@ -13,7 +13,7 @@ set(CMAKE_EXECUTABLE_RUNTIME_Fortran_FLA
|
||||
string(APPEND CMAKE_Fortran_FLAGS_INIT " ")
|
||||
string(APPEND CMAKE_Fortran_FLAGS_DEBUG_INIT " -g")
|
||||
@ -185,3 +142,27 @@ Index: cmake-3.10.0/Modules/Compiler/SunPro-Fortran.cmake
|
||||
string(APPEND CMAKE_Fortran_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
||||
set(CMAKE_Fortran_MODDIR_FLAG "-moddir=")
|
||||
set(CMAKE_Fortran_MODPATH_FLAG "-M")
|
||||
diff -up cmake-3.12.0/Modules/Platform/IRIX64.cmake.orig cmake-3.12.0/Modules/Platform/IRIX64.cmake
|
||||
--- cmake-3.12.0/Modules/Platform/IRIX64.cmake.orig 2018-07-17 06:29:00.000000000 -0500
|
||||
+++ cmake-3.12.0/Modules/Platform/IRIX64.cmake 2018-07-27 08:51:37.492583631 -0500
|
||||
@@ -37,7 +37,7 @@ if(NOT CMAKE_COMPILER_IS_GNUCC)
|
||||
set(CMAKE_CXX_CREATE_STATIC_LIBRARY
|
||||
"<CMAKE_CXX_COMPILER> -ar -o <TARGET> <OBJECTS>")
|
||||
set (CMAKE_CXX_FLAGS_DEBUG_INIT "-g")
|
||||
- set (CMAKE_CXX_FLAGS_MINSIZEREL_INIT "-O3 -DNDEBUG")
|
||||
+ set (CMAKE_CXX_FLAGS_MINSIZEREL_INIT "-O2 -DNDEBUG")
|
||||
set (CMAKE_CXX_FLAGS_RELEASE_INIT "-O2 -DNDEBUG")
|
||||
set (CMAKE_CXX_FLAGS_RELWITHDEBINFO_INIT "-O2")
|
||||
endif()
|
||||
diff -up cmake-3.12.0/Modules/Platform/IRIX.cmake.orig cmake-3.12.0/Modules/Platform/IRIX.cmake
|
||||
--- cmake-3.12.0/Modules/Platform/IRIX.cmake.orig 2018-07-17 06:29:00.000000000 -0500
|
||||
+++ cmake-3.12.0/Modules/Platform/IRIX.cmake 2018-07-27 08:51:37.491583625 -0500
|
||||
@@ -7,7 +7,7 @@ if(NOT CMAKE_COMPILER_IS_GNUCXX)
|
||||
"<CMAKE_CXX_COMPILER> -ar -o <TARGET> <OBJECTS>")
|
||||
set (CMAKE_CXX_FLAGS_INIT "")
|
||||
set (CMAKE_CXX_FLAGS_DEBUG_INIT "-g")
|
||||
- set (CMAKE_CXX_FLAGS_MINSIZEREL_INIT "-O3 -DNDEBUG")
|
||||
+ set (CMAKE_CXX_FLAGS_MINSIZEREL_INIT "-O2 -DNDEBUG")
|
||||
set (CMAKE_CXX_FLAGS_RELEASE_INIT "-O2 -DNDEBUG")
|
||||
set (CMAKE_CXX_FLAGS_RELWITHDEBINFO_INIT "-O2")
|
||||
set (CMAKE_C_FLAGS_INIT "")
|
||||
|
18
cmake.spec
18
cmake.spec
@ -1,4 +1,5 @@
|
||||
# Do we add appdata-files?
|
||||
# consider conditional on whether %%_metainfodir is defined or not instead -- rex
|
||||
%if 0%{?fedora} || 0%{?rhel} > 7
|
||||
%bcond_without appdata
|
||||
%else
|
||||
@ -51,7 +52,7 @@
|
||||
%{!?_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||
|
||||
%global major_version 3
|
||||
%global minor_version 11
|
||||
%global minor_version 12
|
||||
# Set to RC version if building RC, else %%{nil}
|
||||
#global rcsuf rc3
|
||||
%{?rcsuf:%global relsuf .%{rcsuf}}
|
||||
@ -62,8 +63,8 @@
|
||||
%global orig_name cmake
|
||||
|
||||
Name: %{orig_name}%{?name_suffix}
|
||||
Version: %{major_version}.%{minor_version}.2
|
||||
Release: 3%{?relsuf}%{?dist}
|
||||
Version: %{major_version}.%{minor_version}.0
|
||||
Release: 1%{?relsuf}%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
# most sources are BSD
|
||||
@ -349,8 +350,8 @@ desktop-file-install --delete-original \
|
||||
#
|
||||
# See http://www.freedesktop.org/software/appstream/docs/ for more details.
|
||||
#
|
||||
mkdir -p %{buildroot}%{_datadir}/appdata
|
||||
cat > %{buildroot}%{_datadir}/appdata/cmake-gui.appdata.xml <<EOF
|
||||
mkdir -p %{buildroot}%{_metainfodir}
|
||||
cat > %{buildroot}%{_metainfodir}/cmake-gui.appdata.xml <<EOF
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!-- Copyright 2014 Ryan Lerch <rlerch@redhat.com> -->
|
||||
<!--
|
||||
@ -478,7 +479,7 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
%files gui
|
||||
%{_bindir}/%{name}-gui
|
||||
%if %{with appdata}
|
||||
%{_datadir}/appdata/*.appdata.xml
|
||||
%{_metainfodir}/*.appdata.xml
|
||||
%endif
|
||||
%{_datadir}/applications/%{name}-gui.desktop
|
||||
%{_datadir}/mime/packages
|
||||
@ -499,6 +500,11 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jul 27 2018 Rex Dieter <rdieter@fedoraproject.org> - 3.12.0-1
|
||||
- Update to 3.12.0 (#1584925)
|
||||
- fixes libuv-related FTBFS (#1603661)
|
||||
- use %%_metainfodir
|
||||
|
||||
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.11.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (cmake-3.11.2.tar.gz) = c8ffa0885778ea942eb2533dab72da8719f67a212a33883913af047717c87368cb58e1d6c578b542d96d7dcc85d126abe81686214366c32174fd5553b399b69e
|
||||
SHA512 (cmake-3.12.0.tar.gz) = e1d5764023d6c8dd4e8d087614e0329a097f1bc587c08c7d22ce7600867bcd7f6750d513458c7c4042570a9526060b89778243e6ea6137efb1727e409ca031ab
|
||||
|
Loading…
Reference in New Issue
Block a user