Update to 3.7.0-rc1
- Drop gui, findjni, and riscv patches applied upstream
This commit is contained in:
parent
72da9d7a8d
commit
8e2a2daaf8
1
.gitignore
vendored
1
.gitignore
vendored
@ -22,3 +22,4 @@
|
||||
/cmake-3.6.0.tar.gz
|
||||
/cmake-3.6.1.tar.gz
|
||||
/cmake-3.6.2.tar.gz
|
||||
/cmake-3.7.0-rc1.tar.gz
|
||||
|
@ -1,15 +0,0 @@
|
||||
diff -ur cmake-3.6.1.old/Utilities/KWIML/include/kwiml/abi.h cmake-3.6.1.riscv/Utilities/KWIML/include/kwiml/abi.h
|
||||
--- cmake-3.6.1.old/Utilities/KWIML/include/kwiml/abi.h 2016-07-22 14:50:23.000000000 +0100
|
||||
+++ cmake-3.6.1.riscv/Utilities/KWIML/include/kwiml/abi.h 2016-09-07 17:59:15.929447366 +0100
|
||||
@@ -467,6 +467,10 @@
|
||||
#elif defined(__XTENSA_EL__)
|
||||
# define KWIML_ABI_ENDIAN_ID KWIML_ABI_ENDIAN_ID_LITTLE
|
||||
|
||||
+/* RISC-V */
|
||||
+#elif defined(__riscv__)
|
||||
+# define KWIML_ABI_ENDIAN_ID KWIML_ABI_ENDIAN_ID_LITTLE
|
||||
+
|
||||
/* Unknown CPU */
|
||||
#elif !defined(KWIML_ABI_NO_ERROR_ENDIAN)
|
||||
# error "Byte order of target CPU unknown."
|
||||
Only in cmake-3.6.1.riscv/Utilities/KWIML/include/kwiml: abi.h~
|
@ -1,13 +1,12 @@
|
||||
diff -up cmake-3.5.2/Modules/Compiler/GNU.cmake.than cmake-3.5.2/Modules/Compiler/GNU.cmake
|
||||
--- cmake-3.5.2/Modules/Compiler/GNU.cmake.than 2016-06-02 13:42:38.186383915 +0200
|
||||
+++ cmake-3.5.2/Modules/Compiler/GNU.cmake 2016-06-02 14:00:26.256271135 +0200
|
||||
@@ -48,7 +48,7 @@ macro(__compiler_gnu lang)
|
||||
set(CMAKE_${lang}_FLAGS_INIT "")
|
||||
set(CMAKE_${lang}_FLAGS_DEBUG_INIT "-g")
|
||||
set(CMAKE_${lang}_FLAGS_MINSIZEREL_INIT "-Os -DNDEBUG")
|
||||
- set(CMAKE_${lang}_FLAGS_RELEASE_INIT "-O3 -DNDEBUG")
|
||||
+ set(CMAKE_${lang}_FLAGS_RELEASE_INIT "-O2 -DNDEBUG")
|
||||
set(CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT "-O2 -g -DNDEBUG")
|
||||
diff -up cmake-3.7.0-rc1/Modules/Compiler/GNU.cmake.orig cmake-3.7.0-rc1/Modules/Compiler/GNU.cmake
|
||||
--- cmake-3.7.0-rc1/Modules/Compiler/GNU.cmake.orig 2016-10-06 15:23:57.198332664 -0600
|
||||
+++ cmake-3.7.0-rc1/Modules/Compiler/GNU.cmake 2016-10-06 15:24:28.062177278 -0600
|
||||
@@ -38,7 +38,7 @@ macro(__compiler_gnu lang)
|
||||
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_MINSIZEREL_INIT " -Os -DNDEBUG")
|
||||
- string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O3 -DNDEBUG")
|
||||
+ string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O2 -DNDEBUG")
|
||||
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g -DNDEBUG")
|
||||
set(CMAKE_${lang}_CREATE_PREPROCESSED_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <INCLUDES> <FLAGS> -E <SOURCE> > <PREPROCESSED_SOURCE>")
|
||||
set(CMAKE_${lang}_CREATE_ASSEMBLY_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <INCLUDES> <FLAGS> -S <SOURCE> -o <ASSEMBLY_SOURCE>")
|
||||
diff -up cmake-3.5.2/Modules/Platform/GNU.cmake.than cmake-3.5.2/Modules/Platform/GNU.cmake
|
||||
|
@ -1,6 +1,7 @@
|
||||
--- cmake-3.1.0-rc1/Modules/FindRuby.cmake.orig 2014-10-27 08:40:56.000000000 -0600
|
||||
+++ cmake-3.1.0-rc1/Modules/FindRuby.cmake 2014-10-29 20:37:15.832502515 -0600
|
||||
@@ -117,14 +117,8 @@
|
||||
diff -up cmake-3.7.0-rc1/Modules/FindRuby.cmake.orig cmake-3.7.0-rc1/Modules/FindRuby.cmake
|
||||
--- cmake-3.7.0-rc1/Modules/FindRuby.cmake.orig 2016-10-04 07:54:11.000000000 -0600
|
||||
+++ cmake-3.7.0-rc1/Modules/FindRuby.cmake 2016-10-06 15:23:57.195332679 -0600
|
||||
@@ -106,14 +106,8 @@ if(RUBY_EXECUTABLE AND NOT RUBY_VERSIO
|
||||
_RUBY_CONFIG_VAR("sitearchdir" RUBY_SITEARCH_DIR)
|
||||
_RUBY_CONFIG_VAR("sitelibdir" RUBY_SITELIB_DIR)
|
||||
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up cmake-3.6.2/Modules/FindJNI.cmake.than cmake-3.6.2/Modules/FindJNI.cmake
|
||||
--- cmake-3.6.2/Modules/FindJNI.cmake.than 2016-09-26 16:07:43.486195741 +0200
|
||||
+++ cmake-3.6.2/Modules/FindJNI.cmake 2016-09-26 16:08:53.239573692 +0200
|
||||
@@ -53,7 +53,7 @@ macro(java_append_library_directories _v
|
||||
set(_java_libarch "alpha")
|
||||
elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "^arm")
|
||||
# Subdir is "arm" for both big-endian (arm) and little-endian (armel).
|
||||
- set(_java_libarch "arm")
|
||||
+ set(_java_libarch "arm" "aarch32")
|
||||
elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "^mips")
|
||||
# mips* machines are bi-endian mostly so processor does not tell
|
||||
# endianess of the underlying system.
|
@ -1,32 +0,0 @@
|
||||
From 48624b3cb85a6e1854eff0ef45996ef75b5aa9e9 Mon Sep 17 00:00:00 2001
|
||||
From: Clinton Stimpson <clinton@elemtech.com>
|
||||
Date: Thu, 22 Sep 2016 13:13:38 -0600
|
||||
Subject: [PATCH] cmake-gui: Do not remove library paths for Qt5 plugins.
|
||||
|
||||
Not removing library paths is necessary for QFileDialog to function correctly
|
||||
on Linux when using Qt5.
|
||||
---
|
||||
Source/QtDialog/CMakeSetup.cxx | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/Source/QtDialog/CMakeSetup.cxx b/Source/QtDialog/CMakeSetup.cxx
|
||||
index c849d52..61c4d7b 100644
|
||||
--- a/Source/QtDialog/CMakeSetup.cxx
|
||||
+++ b/Source/QtDialog/CMakeSetup.cxx
|
||||
@@ -101,11 +101,13 @@ int main(int argc, char** argv)
|
||||
QTextCodec::setCodecForLocale(utf8_codec);
|
||||
#endif
|
||||
|
||||
+#if QT_VERSION < 0x050000
|
||||
// clean out standard Qt paths for plugins, which we don't use anyway
|
||||
// when creating Mac bundles, it potentially causes problems
|
||||
foreach (QString p, QApplication::libraryPaths()) {
|
||||
QApplication::removeLibraryPath(p);
|
||||
}
|
||||
+#endif
|
||||
|
||||
// tell the cmake library where cmake is
|
||||
QDir cmExecDir(QApplication::applicationDirPath());
|
||||
--
|
||||
1.7.10.4
|
||||
|
25
cmake.spec
25
cmake.spec
@ -33,17 +33,17 @@
|
||||
%{!?_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||
|
||||
%global major_version 3
|
||||
%global minor_version 6
|
||||
%global minor_version 7
|
||||
# Set to RC version if building RC, else %{nil}
|
||||
#global rcver rc1
|
||||
%global rcver rc1
|
||||
|
||||
# Uncomment if building for EPEL
|
||||
#global name_suffix %{major_version}
|
||||
%global orig_name cmake
|
||||
|
||||
Name: %{orig_name}%{?name_suffix}
|
||||
Version: %{major_version}.%{minor_version}.2
|
||||
Release: 6%{?dist}
|
||||
Version: %{major_version}.%{minor_version}.0
|
||||
Release: 0.1.rc1%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
# most sources are BSD
|
||||
@ -60,21 +60,12 @@ Source2: macros.%{name}
|
||||
Source3: %{name}.attr
|
||||
Source4: %{name}.prov
|
||||
|
||||
# Upstream patch to fix cmake-gui with Qt5
|
||||
# https://cmake.org/gitweb?p=cmake.git;a=commit;h=48624b3c
|
||||
Patch0: cmake.git-48624b3c.patch
|
||||
# Patch to fix RindRuby vendor settings
|
||||
# http://public.kitware.com/Bug/view.php?id=12965
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=822796
|
||||
Patch2: %{name}-findruby.patch
|
||||
# replace release flag -O3 with -O2 for fedora
|
||||
Patch3: %{name}-fedora-flag_release.patch
|
||||
# add extra aarch32 to libarch for arm platform
|
||||
Patch4: %{name}-libarch-arm-findjni.patch
|
||||
|
||||
# Upstream patch which adds RISC-V support.
|
||||
# https://gitlab.kitware.com/utils/kwiml/commit/12f000d5b7b4c8394b16282da50126bccd4d4819
|
||||
Patch5: %{name}-3.6.1-riscv.patch
|
||||
|
||||
# Patch for renaming on EPEL
|
||||
%if 0%{?name_suffix:1}
|
||||
@ -96,6 +87,7 @@ BuildRequires: /usr/bin/sphinx-build
|
||||
%else
|
||||
BuildRequires: libarchive3-devel
|
||||
%endif
|
||||
BuildRequires: libuv-devel
|
||||
BuildRequires: xz-devel
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: emacs
|
||||
@ -174,7 +166,6 @@ The %{name}-gui package contains the Qt based GUI for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -qn %{orig_name}-%{version}%{?rcver:-%rcver}
|
||||
%patch0 -p1
|
||||
|
||||
# Apply renaming on EPEL before all other patches
|
||||
%if 0%{?name_suffix:1}
|
||||
@ -187,8 +178,6 @@ The %{name}-gui package contains the Qt based GUI for %{name}.
|
||||
# We cannot use backups with patches to Modules as they end up being installed
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
|
||||
%if %{with python3}
|
||||
echo '#!%{__python3}' > %{name}.prov
|
||||
@ -410,6 +399,10 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Oct 6 2016 Orion Poplawski <orion@cora.nwra.com> - 3.7.0-0.1.rc1
|
||||
- Update to 3.7.0-rc1
|
||||
- Drop gui, findjni, and riscv patches applied upstream
|
||||
|
||||
* Mon Oct 03 2016 Björn Esser <fedora@besser82.io> - 3.6.2-6
|
||||
- Rebuilt with gui enabled
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user