- Update to 2.8.0 RC 1
This commit is contained in:
parent
4a777e4934
commit
886d5a2242
@ -1 +1 @@
|
|||||||
cmake-2.6.4.tar.gz
|
cmake-2.8.0-rc1.tar.gz
|
||||||
|
@ -1,9 +1,11 @@
|
|||||||
--- cmake-2.6.4/Modules/FindVTK.cmake.vtk64 2009-04-28 14:22:59.000000000 -0600
|
--- cmake-2.8.0-rc1/Modules/FindVTK.cmake.vtk64 2009-09-25 12:29:20.000000000 -0600
|
||||||
+++ cmake-2.6.4/Modules/FindVTK.cmake 2009-06-03 10:01:25.580512670 -0600
|
+++ cmake-2.8.0-rc1/Modules/FindVTK.cmake 2009-09-29 10:33:20.506713352 -0600
|
||||||
@@ -45,9 +45,13 @@
|
@@ -45,10 +45,15 @@
|
||||||
SET(VTK_DIR_SEARCH "")
|
SET(VTK_DIR_SEARCH "")
|
||||||
FOREACH(dir ${VTK_DIR_SEARCH2})
|
FOREACH(dir ${VTK_DIR_SEARCH2})
|
||||||
SET(VTK_DIR_SEARCH ${VTK_DIR_SEARCH}
|
SET(VTK_DIR_SEARCH ${VTK_DIR_SEARCH}
|
||||||
|
+ ${dir}/../lib64/vtk-5.4
|
||||||
|
${dir}/../lib/vtk-5.4
|
||||||
+ ${dir}/../lib64/vtk-5.2
|
+ ${dir}/../lib64/vtk-5.2
|
||||||
${dir}/../lib/vtk-5.2
|
${dir}/../lib/vtk-5.2
|
||||||
+ ${dir}/../lib64/vtk-5.1
|
+ ${dir}/../lib64/vtk-5.1
|
15
cmake.spec
15
cmake.spec
@ -4,21 +4,21 @@
|
|||||||
# Set to bcond_with or use --without gui to disable qt4 gui build
|
# Set to bcond_with or use --without gui to disable qt4 gui build
|
||||||
%bcond_without gui
|
%bcond_without gui
|
||||||
# Set to RC version if building RC, else %{nil}
|
# Set to RC version if building RC, else %{nil}
|
||||||
%define rcver %{nil}
|
%define rcver -rc1
|
||||||
|
|
||||||
Name: cmake
|
Name: cmake
|
||||||
Version: 2.6.4
|
Version: 2.8.0
|
||||||
Release: 4%{?dist}
|
Release: 0.1.rc1%{?dist}
|
||||||
Summary: Cross-platform make system
|
Summary: Cross-platform make system
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://www.cmake.org
|
URL: http://www.cmake.org
|
||||||
Source0: http://www.cmake.org/files/v2.6/cmake-%{version}%{rcver}.tar.gz
|
Source0: http://www.cmake.org/files/v2.8/cmake-%{version}%{?rcver}.tar.gz
|
||||||
Source2: macros.cmake
|
Source2: macros.cmake
|
||||||
#Find UseVTK.cmake in /usr/lib64/vtk-* on 64-bit machines
|
#Find UseVTK.cmake in /usr/lib64/vtk-* on 64-bit machines
|
||||||
#http://public.kitware.com/mantis/view.php?id=9105
|
#http://public.kitware.com/mantis/view.php?id=9105
|
||||||
Patch0: cmake-2.6.4-vtk64.patch
|
Patch0: cmake-2.8.0-vtk64.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: ncurses-devel, libX11-devel
|
BuildRequires: ncurses-devel, libX11-devel
|
||||||
@ -52,7 +52,7 @@ The %{name}-gui package contains the Qt based GUI for CMake.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}%{rcver}
|
%setup -q -n %{name}-%{version}%{?rcver}
|
||||||
%patch0 -p1 -b .vtk64
|
%patch0 -p1 -b .vtk64
|
||||||
# Fixup permissions
|
# Fixup permissions
|
||||||
find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
|
find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
|
||||||
@ -132,6 +132,9 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 29 2009 Orion Poplawski <orion@cora.nwra.com> - 2.8.0-0.1.rc1
|
||||||
|
- Update to 2.8.0 RC 1
|
||||||
|
|
||||||
* Thu Sep 17 2009 Rex Dieter <rdieter@fedoraproject.org> - 2.6.4-4
|
* Thu Sep 17 2009 Rex Dieter <rdieter@fedoraproject.org> - 2.6.4-4
|
||||||
- macro.cmake: prefixes cmake with the package being builts bindir (#523878)
|
- macro.cmake: prefixes cmake with the package being builts bindir (#523878)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user