cmake-3.28.2
This commit is contained in:
parent
ceb582021b
commit
815f5fcb16
@ -1,83 +0,0 @@
|
||||
Improve C compatibility of LoadCommand tests
|
||||
|
||||
The previous code used char ** and const char ** types as if they were
|
||||
the same. But they are distinct types in C, so when passing these
|
||||
pointers as function arguments, their types have to match. Future C
|
||||
compilers will treat this as an error, similar to what C++ compilers
|
||||
do today.
|
||||
|
||||
Submitted upstream:
|
||||
|
||||
<https://gitlab.kitware.com/cmake/cmake/-/merge_requests/9002>
|
||||
|
||||
diff --git a/Tests/LoadCommand/CMakeCommands/cmTestCommand.c b/Tests/LoadCommand/CMakeCommands/cmTestCommand.c
|
||||
index 7176ebe9d4bd3c4e..ba13727d2b83a051 100644
|
||||
--- a/Tests/LoadCommand/CMakeCommands/cmTestCommand.c
|
||||
+++ b/Tests/LoadCommand/CMakeCommands/cmTestCommand.c
|
||||
@@ -16,14 +16,14 @@ static int CCONV InitialPass(void* inf, void* mf, int argc, char* argv[])
|
||||
{
|
||||
char* file;
|
||||
char* str;
|
||||
- char* srcs;
|
||||
+ const char* srcs;
|
||||
const char* cstr;
|
||||
char buffer[1024];
|
||||
void* source_file;
|
||||
char* args[2];
|
||||
- char* ccArgs[4];
|
||||
- char* ccDep[1];
|
||||
- char* ccOut[1];
|
||||
+ const char* ccArgs[4];
|
||||
+ const char* ccDep[1];
|
||||
+ const char* ccOut[1];
|
||||
cmLoadedCommandInfo* info = (cmLoadedCommandInfo*)inf;
|
||||
|
||||
cmVTKWrapTclData* cdata =
|
||||
@@ -148,7 +148,10 @@ static int CCONV InitialPass(void* inf, void* mf, int argc, char* argv[])
|
||||
if (info->CAPI->GetTotalArgumentSize(2, args) != 13) {
|
||||
return 0;
|
||||
}
|
||||
- info->CAPI->ExecuteCommand(mf, "SET", 2, args);
|
||||
+
|
||||
+ ccArgs[0] = "TEST_EXEC";
|
||||
+ ccArgs[1] = "TRUE";
|
||||
+ info->CAPI->ExecuteCommand(mf, "SET", 2, ccArgs);
|
||||
|
||||
/* make sure we can find the source file */
|
||||
if (!info->CAPI->GetSource(mf, argv[1])) {
|
||||
diff --git a/Tests/LoadCommandOneConfig/CMakeCommands/cmTestCommand.c b/Tests/LoadCommandOneConfig/CMakeCommands/cmTestCommand.c
|
||||
index 7176ebe9d4bd3c4e..e3b332c1aa9d9108 100644
|
||||
--- a/Tests/LoadCommandOneConfig/CMakeCommands/cmTestCommand.c
|
||||
+++ b/Tests/LoadCommandOneConfig/CMakeCommands/cmTestCommand.c
|
||||
@@ -16,14 +16,14 @@ static int CCONV InitialPass(void* inf, void* mf, int argc, char* argv[])
|
||||
{
|
||||
char* file;
|
||||
char* str;
|
||||
- char* srcs;
|
||||
- const char* cstr;
|
||||
+ const char* srcs;
|
||||
+ char* cstr;
|
||||
char buffer[1024];
|
||||
void* source_file;
|
||||
char* args[2];
|
||||
- char* ccArgs[4];
|
||||
- char* ccDep[1];
|
||||
- char* ccOut[1];
|
||||
+ const char* ccArgs[4];
|
||||
+ const char* ccDep[1];
|
||||
+ const char* ccOut[1];
|
||||
cmLoadedCommandInfo* info = (cmLoadedCommandInfo*)inf;
|
||||
|
||||
cmVTKWrapTclData* cdata =
|
||||
@@ -148,7 +148,10 @@ static int CCONV InitialPass(void* inf, void* mf, int argc, char* argv[])
|
||||
if (info->CAPI->GetTotalArgumentSize(2, args) != 13) {
|
||||
return 0;
|
||||
}
|
||||
- info->CAPI->ExecuteCommand(mf, "SET", 2, args);
|
||||
+
|
||||
+ ccArgs[0] = "TEST_EXEC";
|
||||
+ ccArgs[1] = "TRUE";
|
||||
+ info->CAPI->ExecuteCommand(mf, "SET", 2, ccArgs);
|
||||
|
||||
/* make sure we can find the source file */
|
||||
if (!info->CAPI->GetSource(mf, argv[1])) {
|
10
cmake.spec
10
cmake.spec
@ -69,13 +69,13 @@
|
||||
|
||||
%global major_version 3
|
||||
%global minor_version 28
|
||||
%global patch_version 0
|
||||
%global patch_version 2
|
||||
|
||||
# For handling bump release by rpmdev-bumpspec and mass rebuild
|
||||
%global baserelease 4
|
||||
%global baserelease 1
|
||||
|
||||
# Set to RC version if building RC, else comment out.
|
||||
%global rcsuf rc3
|
||||
#%%global rcsuf rc3
|
||||
|
||||
%if 0%{?rcsuf:1}
|
||||
%global pkg_version %{major_version}.%{minor_version}.%{patch_version}~%{rcsuf}
|
||||
@ -117,7 +117,6 @@ Source5: %{name}.req
|
||||
# http://public.kitware.com/Bug/view.php?id=12965
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=822796
|
||||
Patch100: %{name}-findruby.patch
|
||||
Patch101: cmake-c99.patch
|
||||
|
||||
# Patch for renaming on EPEL
|
||||
%if 0%{?name_suffix:1}
|
||||
@ -550,6 +549,9 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Feb 01 2024 Frantisek Zatloukal <fzatlouk@redhat.com> - 3.28.2-1
|
||||
- cmake-3.28.2 (fixes RHBZ#2261037 and RHBZ#2243343)
|
||||
|
||||
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 3.28.0~rc3-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (cmake-3.28.0-rc3.tar.gz) = 3090eaa0c747ad4978a43066a29e6b2f3d2c98dffea0e9f0354a5d18aea6f695dfe0850fcc414e32a23de2cab297af34389bb8182926048bbe6b0dd28572e2bc
|
||||
SHA512 (cmake-3.28.2.tar.gz) = 225f6d3eb56d41c449a32f7c3e0f8f3ffafbbf45474e29ad86e965a87f8d95e55e87affc62ef0a7b25c9fb070c6fca08e9838539e5f7011dc3ee83787025151b
|
||||
|
Loading…
Reference in New Issue
Block a user