- Update to 2.8.12-rc1
- Drop ImageMagick patch - not needed
This commit is contained in:
parent
a96004dd80
commit
8059b972fd
1
.gitignore
vendored
1
.gitignore
vendored
@ -9,3 +9,4 @@
|
||||
/cmake-2.8.11.1.tar.gz
|
||||
/cmake-2.8.11.2.tar.gz
|
||||
/cmake-*/
|
||||
/cmake-2.8.12-rc1.tar.gz
|
||||
|
@ -1,38 +0,0 @@
|
||||
diff -up cmake-2.8.11-rc1/Modules/FindImageMagick.cmake.IM_pkgconfig_hints cmake-2.8.11-rc1/Modules/FindImageMagick.cmake
|
||||
--- cmake-2.8.11-rc1/Modules/FindImageMagick.cmake.IM_pkgconfig_hints 2013-03-14 13:10:40.000000000 -0500
|
||||
+++ cmake-2.8.11-rc1/Modules/FindImageMagick.cmake 2013-03-18 09:18:09.453420248 -0500
|
||||
@@ -69,17 +69,24 @@
|
||||
# (To distribute this file outside of CMake, substitute the full
|
||||
# License text for the above reference.)
|
||||
|
||||
+find_package(PkgConfig QUIET)
|
||||
+
|
||||
#---------------------------------------------------------------------
|
||||
# Helper functions
|
||||
#---------------------------------------------------------------------
|
||||
function(FIND_IMAGEMAGICK_API component header)
|
||||
set(ImageMagick_${component}_FOUND FALSE PARENT_SCOPE)
|
||||
|
||||
+ pkg_check_modules(PC_${component} QUIET ${component})
|
||||
+
|
||||
find_path(ImageMagick_${component}_INCLUDE_DIR
|
||||
NAMES ${header}
|
||||
PATHS
|
||||
${ImageMagick_INCLUDE_DIRS}
|
||||
"[HKEY_LOCAL_MACHINE\\SOFTWARE\\ImageMagick\\Current;BinPath]/include"
|
||||
+ HINTS
|
||||
+ ${PC_${component}_INCLUDEDIR}
|
||||
+ ${PC_${component}_INCLUDE_DIRS}
|
||||
PATH_SUFFIXES
|
||||
ImageMagick
|
||||
DOC "Path to the ImageMagick include dir."
|
||||
@@ -88,6 +95,9 @@ function(FIND_IMAGEMAGICK_API component
|
||||
NAMES ${ARGN}
|
||||
PATHS
|
||||
"[HKEY_LOCAL_MACHINE\\SOFTWARE\\ImageMagick\\Current;BinPath]/lib"
|
||||
+ HINTS
|
||||
+ ${PC_${component}_LIBDIR}
|
||||
+ ${PC_${component}_LIB_DIRS}
|
||||
DOC "Path to the ImageMagick Magick++ library."
|
||||
)
|
||||
|
14
cmake.spec
14
cmake.spec
@ -4,7 +4,7 @@
|
||||
# Set to bcond_with or use --without gui to disable qt4 gui build
|
||||
%bcond_without gui
|
||||
# Set to RC version if building RC, else %{nil}
|
||||
%define rcver %{nil}
|
||||
%define rcver -rc1
|
||||
|
||||
%define rpm_macros_dir %{_sysconfdir}/rpm
|
||||
%if 0%{?fedora} > 18
|
||||
@ -12,8 +12,8 @@
|
||||
%endif
|
||||
|
||||
Name: cmake
|
||||
Version: 2.8.11.2
|
||||
Release: 4%{?dist}
|
||||
Version: 2.8.12
|
||||
Release: 0.1.rc1%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
Group: Development/Tools
|
||||
@ -38,9 +38,6 @@ Patch2: cmake-findruby.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=828467
|
||||
# http://public.kitware.com/Bug/view.php?id=13378
|
||||
Patch3: cmake-FindPostgreSQL.patch
|
||||
# Patch FindImageMagick.cmake for newer ImageMagick versions
|
||||
# http://public.kitware.com/Bug/view.php?id=14012
|
||||
Patch4: cmake-2.8.11-rc1-IM_pkgconfig_hints.patch
|
||||
# Add FindLua52.cmake
|
||||
Patch5: cmake-2.8.11-rc4-lua-5.2.patch
|
||||
# Add -fno-strict-aliasing when compiling cm_sha2.c
|
||||
@ -101,7 +98,6 @@ The %{name}-gui package contains the Qt based GUI for CMake.
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
@ -201,6 +197,10 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 26 2013 Orion Poplawski <orion@cora.nwra.com> - 2.8.12-0.1.rc1
|
||||
- Update to 2.8.12-rc1
|
||||
- Drop ImageMagick patch - not needed
|
||||
|
||||
* Fri Jul 26 2013 Orion Poplawski <orion@cora.nwra.com> - 2.8.11.2-4
|
||||
- Use version-less docdir
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user