Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/cmake.git#ec77e26a430f453cc58eb33fc5a7b593d88e6e81
This commit is contained in:
parent
2aadb74014
commit
695195bdbd
@ -1,74 +0,0 @@
|
||||
From 82930647607d23b118c84194afc3c70d6d8e79e3 Mon Sep 17 00:00:00 2001
|
||||
From: Brad King <brad.king@kitware.com>
|
||||
Date: Wed, 3 Feb 2021 12:07:49 -0500
|
||||
Subject: [PATCH 572/590] FindBoost: Add support for Boost 1.75
|
||||
|
||||
Update the list of known versions.
|
||||
|
||||
Run the command
|
||||
|
||||
cmake -DBOOST_DIR=/path/to/boost_1_75_0 \
|
||||
-P Utilities/Scripts/BoostScanDeps.cmake
|
||||
|
||||
to extract dependencies from the 1.75.0 source tree.
|
||||
They differ from 1.74's dependencies by the addition of
|
||||
dependencies of the json component, so add a new version
|
||||
block to FindBoost.
|
||||
|
||||
Fixes: #21773
|
||||
---
|
||||
Modules/FindBoost.cmake | 19 +++++++++++++++++--
|
||||
1 file changed, 17 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Modules/FindBoost.cmake b/Modules/FindBoost.cmake
|
||||
index 00e4ff1d21..54d9593ca7 100644
|
||||
--- a/Modules/FindBoost.cmake
|
||||
+++ b/Modules/FindBoost.cmake
|
||||
@@ -1186,11 +1186,26 @@ function(_Boost_COMPONENT_DEPENDENCIES component _ret)
|
||||
set(_Boost_TIMER_DEPENDENCIES chrono)
|
||||
set(_Boost_WAVE_DEPENDENCIES filesystem serialization thread chrono date_time atomic)
|
||||
set(_Boost_WSERIALIZATION_DEPENDENCIES serialization)
|
||||
+ elseif(Boost_VERSION_STRING VERSION_LESS 1.75.0)
|
||||
+ set(_Boost_CONTRACT_DEPENDENCIES thread chrono date_time)
|
||||
+ set(_Boost_COROUTINE_DEPENDENCIES context)
|
||||
+ set(_Boost_FIBER_DEPENDENCIES context)
|
||||
+ set(_Boost_IOSTREAMS_DEPENDENCIES regex)
|
||||
+ set(_Boost_LOG_DEPENDENCIES date_time log_setup filesystem thread regex chrono atomic)
|
||||
+ set(_Boost_MATH_DEPENDENCIES math_c99 math_c99f math_c99l math_tr1 math_tr1f math_tr1l atomic)
|
||||
+ set(_Boost_MPI_DEPENDENCIES serialization)
|
||||
+ set(_Boost_MPI_PYTHON_DEPENDENCIES python${component_python_version} mpi serialization)
|
||||
+ set(_Boost_NUMPY_DEPENDENCIES python${component_python_version})
|
||||
+ set(_Boost_THREAD_DEPENDENCIES chrono date_time atomic)
|
||||
+ set(_Boost_TIMER_DEPENDENCIES chrono)
|
||||
+ set(_Boost_WAVE_DEPENDENCIES filesystem serialization thread chrono date_time atomic)
|
||||
+ set(_Boost_WSERIALIZATION_DEPENDENCIES serialization)
|
||||
else()
|
||||
set(_Boost_CONTRACT_DEPENDENCIES thread chrono date_time)
|
||||
set(_Boost_COROUTINE_DEPENDENCIES context)
|
||||
set(_Boost_FIBER_DEPENDENCIES context)
|
||||
set(_Boost_IOSTREAMS_DEPENDENCIES regex)
|
||||
+ set(_Boost_JSON_DEPENDENCIES container)
|
||||
set(_Boost_LOG_DEPENDENCIES date_time log_setup filesystem thread regex chrono atomic)
|
||||
set(_Boost_MATH_DEPENDENCIES math_c99 math_c99f math_c99l math_tr1 math_tr1f math_tr1l atomic)
|
||||
set(_Boost_MPI_DEPENDENCIES serialization)
|
||||
@@ -1200,7 +1215,7 @@ function(_Boost_COMPONENT_DEPENDENCIES component _ret)
|
||||
set(_Boost_TIMER_DEPENDENCIES chrono)
|
||||
set(_Boost_WAVE_DEPENDENCIES filesystem serialization thread chrono date_time atomic)
|
||||
set(_Boost_WSERIALIZATION_DEPENDENCIES serialization)
|
||||
- if(Boost_VERSION_STRING VERSION_GREATER_EQUAL 1.75.0)
|
||||
+ if(Boost_VERSION_STRING VERSION_GREATER_EQUAL 1.76.0)
|
||||
message(WARNING "New Boost version may have incorrect or missing dependencies and imported targets")
|
||||
endif()
|
||||
endif()
|
||||
@@ -1472,7 +1487,7 @@ else()
|
||||
# _Boost_COMPONENT_HEADERS. See the instructions at the top of
|
||||
# _Boost_COMPONENT_DEPENDENCIES.
|
||||
set(_Boost_KNOWN_VERSIONS ${Boost_ADDITIONAL_VERSIONS}
|
||||
- "1.74.0" "1.74"
|
||||
+ "1.75.0" "1.75" "1.74.0" "1.74"
|
||||
"1.73.0" "1.73" "1.72.0" "1.72" "1.71.0" "1.71" "1.70.0" "1.70" "1.69.0" "1.69"
|
||||
"1.68.0" "1.68" "1.67.0" "1.67" "1.66.0" "1.66" "1.65.1" "1.65.0" "1.65"
|
||||
"1.64.0" "1.64" "1.63.0" "1.63" "1.62.0" "1.62" "1.61.0" "1.61" "1.60.0" "1.60"
|
||||
--
|
||||
2.29.2
|
||||
|
12
cmake.spec
12
cmake.spec
@ -70,14 +70,14 @@
|
||||
%{?rcsuf:%global versuf -%{rcsuf}}
|
||||
|
||||
# For handling bump release by rpmdev-bumpspec and mass rebuild
|
||||
%global baserelease 2
|
||||
%global baserelease 1
|
||||
|
||||
# Uncomment if building for EPEL
|
||||
#global name_suffix %%{major_version}
|
||||
%global orig_name cmake
|
||||
|
||||
Name: %{orig_name}%{?name_suffix}
|
||||
Version: %{major_version}.%{minor_version}.4
|
||||
Version: %{major_version}.%{minor_version}.7
|
||||
Release: %{baserelease}%{?relsuf}%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
@ -112,8 +112,6 @@ Patch102: %{name}-mingw-dl.patch
|
||||
# memory-hungry tests when building on koji builders with *lots* of cores
|
||||
# so limit it to some reasonable number (4)
|
||||
Patch103: cmake-3.19-CPACK_ARCHIVE_THREADS.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1925355
|
||||
Patch104: 0572-FindBoost-Add-support-for-Boost-1.75.patch
|
||||
|
||||
# Patch for renaming on EPEL
|
||||
%if 0%{?name_suffix:1}
|
||||
@ -535,6 +533,12 @@ mv -f Modules/FindLibArchive.disabled Modules/FindLibArchive.cmake
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Mar 15 2021 Rex Dieter <rdieter@fedoraproject.org> - 3.19.7-1
|
||||
- cmake-3.19.7
|
||||
|
||||
* Thu Feb 25 2021 Rex Dieter <rdieter@fedoraproject.org> - 3.19.6-2
|
||||
- cmake-3.19.6
|
||||
|
||||
* Sat Feb 06 2021 Rex Dieter <rdieter@fedoraproject.org> - 3.19.4-2
|
||||
- CMake warning when searching for Boost 1.75 (#1925355)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (cmake-3.19.4.tar.gz) = e2781479d2185f8f927439b795120a0f4957e9da7730804ff8ec06d6bbe75a0069e49d95e642706179520a7229ae82e53bab891fa8cfd859913c0cb5fd4e843f
|
||||
SHA512 (cmake-3.19.7.tar.gz) = 6af1fe3ea41906324d4c29f5f982281d92145d086f4a47fa2220b93483bc65d59b1e23f5b51d82305c630690be7c552827bb795560674b03620763e0917bf14a
|
||||
|
Loading…
Reference in New Issue
Block a user