Update to version 3.26.5
Resolves: RHEL-7396 Resolves: RHEL-7398 Resolves: RHEL-14385 Resolves: RHEL-14863 Resolves: RHEL-14864
This commit is contained in:
parent
801143c7b1
commit
613a26b7bc
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
SOURCES/cmake-3.20.2.tar.gz
|
||||
/cmake-3.20.2.tar.gz
|
||||
/cmake-3.26.5.tar.gz
|
||||
|
@ -1,41 +0,0 @@
|
||||
From f72734ff7712d6aae837f940a45d6e7508bb182c Mon Sep 17 00:00:00 2001
|
||||
From: Brad King <brad.king@kitware.com>
|
||||
Date: Thu, 20 Oct 2022 13:38:20 -0400
|
||||
Subject: [PATCH] Tests: Explicitly allow usage of git file-based protocol in
|
||||
test cases
|
||||
|
||||
Due to CVE-2022-39253, Git 2.30.6 sets `protocol.file.allow=user` by
|
||||
default. The change has also been backported to other Git versions by
|
||||
distros. This breaks some of our test cases that use the file-based
|
||||
protocol locally to simulate real workflows without requiring network
|
||||
access. In these cases the file protocol is safe, so explicitly enable
|
||||
it in the tests.
|
||||
|
||||
(cherry picked from commit 79ce0f434e916684d734e136b92e14f472a9d14a)
|
||||
---
|
||||
Tests/CMakeLists.txt | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
|
||||
index 8e7c04fbd0..d011020f99 100644
|
||||
--- a/Tests/CMakeLists.txt
|
||||
+++ b/Tests/CMakeLists.txt
|
||||
@@ -1540,6 +1540,7 @@ if(BUILD_TESTING)
|
||||
)
|
||||
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/ExternalProject")
|
||||
set_tests_properties(ExternalProject PROPERTIES
|
||||
+ ENVIRONMENT GIT_ALLOW_PROTOCOL=file
|
||||
RUN_SERIAL 1
|
||||
TIMEOUT ${CMAKE_LONG_TEST_TIMEOUT})
|
||||
|
||||
@@ -2653,6 +2654,7 @@ if(BUILD_TESTING)
|
||||
-P "${CMake_BINARY_DIR}/Tests/CTestUpdateGIT.cmake"
|
||||
)
|
||||
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/${CTestUpdateGIT_DIR}")
|
||||
+ set_property(TEST CTest.UpdateGIT PROPERTY ENVIRONMENT GIT_ALLOW_PROTOCOL=file)
|
||||
endif()
|
||||
|
||||
# Test CTest Update with HG
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff -up cmake-3.20.0/Tests/RunCMake/CPack/tests/THREADED_ALL/test.cmake.CPACK_THREADS cmake-3.20.0/Tests/RunCMake/CPack/tests/THREADED_ALL/test.cmake
|
||||
--- cmake-3.20.0/Tests/RunCMake/CPack/tests/THREADED_ALL/test.cmake.CPACK_THREADS 2021-03-23 10:43:17.000000000 -0500
|
||||
+++ cmake-3.20.0/Tests/RunCMake/CPack/tests/THREADED_ALL/test.cmake 2021-03-23 13:29:14.539434722 -0500
|
||||
@@ -1,6 +1,6 @@
|
||||
install(FILES CMakeLists.txt DESTINATION foo COMPONENT test)
|
||||
|
||||
-set(CPACK_THREADS 0)
|
||||
+set(CPACK_THREADS 4)
|
||||
|
||||
if(PACKAGING_TYPE STREQUAL "COMPONENT")
|
||||
set(CPACK_COMPONENTS_ALL test)
|
@ -1,16 +0,0 @@
|
||||
diff -Naur cmake-3.18.2.orig/Modules/Platform/Windows-GNU.cmake cmake-3.18.2/Modules/Platform/Windows-GNU.cmake
|
||||
--- cmake-3.18.2.orig/Modules/Platform/Windows-GNU.cmake 2020-09-08 13:30:51.186087690 +0000
|
||||
+++ cmake-3.18.2/Modules/Platform/Windows-GNU.cmake 2020-09-10 07:42:22.458698539 +0000
|
||||
@@ -28,9 +28,11 @@
|
||||
set(CMAKE_FIND_LIBRARY_SUFFIXES ".dll.a" ".a" ".lib")
|
||||
set(CMAKE_C_STANDARD_LIBRARIES_INIT "-lkernel32 -luser32 -lgdi32 -lwinspool -lshell32 -lole32 -loleaut32 -luuid -lcomdlg32 -ladvapi32")
|
||||
set(CMAKE_CXX_STANDARD_LIBRARIES_INIT "${CMAKE_C_STANDARD_LIBRARIES_INIT}")
|
||||
+ set(CMAKE_DL_LIBS "dl")
|
||||
+else()
|
||||
+ set(CMAKE_DL_LIBS "")
|
||||
endif()
|
||||
|
||||
-set(CMAKE_DL_LIBS "")
|
||||
set(CMAKE_LIBRARY_PATH_FLAG "-L")
|
||||
set(CMAKE_LINK_LIBRARY_FLAG "-l")
|
||||
set(CMAKE_LINK_DEF_FILE_FLAG "") # Empty string: passing the file is enough
|
18
cmake.spec
18
cmake.spec
@ -58,21 +58,21 @@
|
||||
%{!?_vpath_builddir:%global _vpath_builddir %{_target_platform}}
|
||||
|
||||
%global major_version 3
|
||||
%global minor_version 20
|
||||
%global minor_version 26
|
||||
# Set to RC version if building RC, else %%{nil}
|
||||
#global rcsuf rc1
|
||||
%{?rcsuf:%global relsuf .%{rcsuf}}
|
||||
%{?rcsuf:%global versuf -%{rcsuf}}
|
||||
|
||||
# For handling bump release by rpmdev-bumpspec and mass rebuild
|
||||
%global baserelease 5
|
||||
%global baserelease 1
|
||||
|
||||
# Uncomment if building for EPEL
|
||||
#global name_suffix %%{major_version}
|
||||
%global orig_name cmake
|
||||
|
||||
Name: %{orig_name}%{?name_suffix}
|
||||
Version: %{major_version}.%{minor_version}.2
|
||||
Version: %{major_version}.%{minor_version}.5
|
||||
Release: %{baserelease}%{?relsuf}%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
@ -103,15 +103,6 @@ Patch100: %{name}-findruby.patch
|
||||
%if 0%{?fedora} && 0%{?fedora} < 34
|
||||
Patch101: %{name}-fedora-flag_release.patch
|
||||
%endif
|
||||
# Add dl to CMAKE_DL_LIBS on MINGW
|
||||
# https://gitlab.kitware.com/cmake/cmake/issues/17600
|
||||
Patch102: %{name}-mingw-dl.patch
|
||||
# memory-hungry tests when building on koji builders with *lots* of cores
|
||||
# so limit it to some reasonable number (4)
|
||||
Patch103: cmake-3.20-CPACK_THREADS.patch
|
||||
|
||||
# rhbz#2162696
|
||||
Patch105: 0001-Tests-Explicitly-allow-usage-of-git-file-based-proto.patch
|
||||
|
||||
# Patch for renaming on EPEL
|
||||
%if 0%{?name_suffix:1}
|
||||
@ -532,6 +523,9 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Oct 26 2023 Tom Stellard <tstellar@redhat.com> - 3.26.5-1
|
||||
- Update to version 3.26.5-1
|
||||
|
||||
* Tue Jan 31 2023 Tom Stellard <tstellar@redhat.com> - 3.20.2-5
|
||||
- Fix test case broken by git fix for CVE-2022-39253
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (cmake-3.20.2.tar.gz) = 675a92f84b437169aee86dbfa59715671b9195ddeffc6fea83c7803a70abe3116106ad0a627b9e4bef326bfb2a10fdf624ad341fd9d3d08e3d8a69c271cd2b32
|
||||
SHA512 (cmake-3.26.5.tar.gz) = 43c17e00d6f326b96ea47c62bbffd19409281641b297b2362e4ed6a696e7e618d2ff265a213634bfa4c1200c3f581531fde6507f282a9460ab65af6c7bab61de
|
||||
|
Loading…
Reference in New Issue
Block a user