Update to 3.10.0 (#1515793)
This commit is contained in:
parent
df5452a402
commit
51cbbee01a
1
.gitignore
vendored
1
.gitignore
vendored
@ -38,3 +38,4 @@
|
|||||||
/cmake-3.9.3.tar.gz
|
/cmake-3.9.3.tar.gz
|
||||||
/cmake-3.9.5.tar.gz
|
/cmake-3.9.5.tar.gz
|
||||||
/cmake-3.9.6.tar.gz
|
/cmake-3.9.6.tar.gz
|
||||||
|
/cmake-3.10.0.tar.gz
|
||||||
|
@ -1,42 +0,0 @@
|
|||||||
From 0d1e152ef9c622b1f6203822b1c88cc3c48857ac Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
|
|
||||||
Date: Mon, 31 Jul 2017 16:10:34 +0200
|
|
||||||
Subject: [PATCH] Restore old style debuginfo creation for rpm >= 4.14
|
|
||||||
|
|
||||||
---
|
|
||||||
Modules/CPackRPM.cmake | 12 ++++++++++--
|
|
||||||
1 file changed, 10 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Modules/CPackRPM.cmake b/Modules/CPackRPM.cmake
|
|
||||||
index fa2a6e409..391349494 100644
|
|
||||||
--- a/Modules/CPackRPM.cmake
|
|
||||||
+++ b/Modules/CPackRPM.cmake
|
|
||||||
@@ -2422,7 +2422,11 @@ mv *.rpm %_rpmdir"
|
|
||||||
set(RPMBUILD_FLAGS "-bs")
|
|
||||||
|
|
||||||
file(WRITE ${CPACK_RPM_BINARY_SPECFILE}.in
|
|
||||||
- "# -*- rpm-spec -*-
|
|
||||||
+ "# Restore old style debuginfo creation for rpm >= 4.14.
|
|
||||||
+%undefine _debugsource_packages
|
|
||||||
+%undefine _debuginfo_subpackages
|
|
||||||
+
|
|
||||||
+# -*- rpm-spec -*-
|
|
||||||
BuildRoot: %_topdir/\@CPACK_PACKAGE_FILE_NAME\@
|
|
||||||
Summary: \@CPACK_RPM_PACKAGE_SUMMARY\@
|
|
||||||
Name: \@CPACK_RPM_PACKAGE_NAME\@
|
|
||||||
@@ -2527,7 +2531,11 @@ Vendor: \@CPACK_RPM_PACKAGE_VENDOR\@
|
|
||||||
if(CPACK_RPM_GENERATE_USER_BINARY_SPECFILE_TEMPLATE OR NOT CPACK_RPM_USER_BINARY_SPECFILE)
|
|
||||||
|
|
||||||
file(WRITE ${CPACK_RPM_BINARY_SPECFILE}.in
|
|
||||||
- "# -*- rpm-spec -*-
|
|
||||||
+ "# Restore old style debuginfo creation for rpm >= 4.14.
|
|
||||||
+%undefine _debugsource_packages
|
|
||||||
+%undefine _debuginfo_subpackages
|
|
||||||
+
|
|
||||||
+# -*- rpm-spec -*-
|
|
||||||
BuildRoot: %_topdir/\@CPACK_PACKAGE_FILE_NAME\@\@CPACK_RPM_PACKAGE_COMPONENT_PART_PATH\@
|
|
||||||
Summary: \@CPACK_RPM_PACKAGE_SUMMARY\@
|
|
||||||
Name: \@CPACK_RPM_PACKAGE_NAME\@
|
|
||||||
--
|
|
||||||
2.13.4
|
|
||||||
|
|
@ -4,10 +4,10 @@ Date: Mon Jul 24 01:52:06 2017 +0200
|
|||||||
|
|
||||||
Set optimization for RELEASE to Fedora default
|
Set optimization for RELEASE to Fedora default
|
||||||
|
|
||||||
diff --git a/Modules/Compiler/Absoft-Fortran.cmake b/Modules/Compiler/Absoft-Fortran.cmake
|
Index: cmake-3.10.0/Modules/Compiler/Absoft-Fortran.cmake
|
||||||
index da1fc80d4..5339c17e1 100644
|
===================================================================
|
||||||
--- a/Modules/Compiler/Absoft-Fortran.cmake
|
--- cmake-3.10.0.orig/Modules/Compiler/Absoft-Fortran.cmake
|
||||||
+++ b/Modules/Compiler/Absoft-Fortran.cmake
|
+++ cmake-3.10.0/Modules/Compiler/Absoft-Fortran.cmake
|
||||||
@@ -1,7 +1,7 @@
|
@@ -1,7 +1,7 @@
|
||||||
string(APPEND CMAKE_Fortran_FLAGS_INIT " ")
|
string(APPEND CMAKE_Fortran_FLAGS_INIT " ")
|
||||||
string(APPEND CMAKE_Fortran_FLAGS_DEBUG_INIT " -g")
|
string(APPEND CMAKE_Fortran_FLAGS_DEBUG_INIT " -g")
|
||||||
@ -17,10 +17,10 @@ index da1fc80d4..5339c17e1 100644
|
|||||||
string(APPEND CMAKE_Fortran_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
string(APPEND CMAKE_Fortran_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
||||||
set(CMAKE_Fortran_MODDIR_FLAG "-YMOD_OUT_DIR=")
|
set(CMAKE_Fortran_MODDIR_FLAG "-YMOD_OUT_DIR=")
|
||||||
set(CMAKE_Fortran_MODPATH_FLAG "-p")
|
set(CMAKE_Fortran_MODPATH_FLAG "-p")
|
||||||
diff --git a/Modules/Compiler/G95-Fortran.cmake b/Modules/Compiler/G95-Fortran.cmake
|
Index: cmake-3.10.0/Modules/Compiler/G95-Fortran.cmake
|
||||||
index 2c83fb8fc..55e0a83a6 100644
|
===================================================================
|
||||||
--- a/Modules/Compiler/G95-Fortran.cmake
|
--- cmake-3.10.0.orig/Modules/Compiler/G95-Fortran.cmake
|
||||||
+++ b/Modules/Compiler/G95-Fortran.cmake
|
+++ cmake-3.10.0/Modules/Compiler/G95-Fortran.cmake
|
||||||
@@ -1,7 +1,7 @@
|
@@ -1,7 +1,7 @@
|
||||||
string(APPEND CMAKE_Fortran_FLAGS_INIT " ")
|
string(APPEND CMAKE_Fortran_FLAGS_INIT " ")
|
||||||
string(APPEND CMAKE_Fortran_FLAGS_DEBUG_INIT " -g")
|
string(APPEND CMAKE_Fortran_FLAGS_DEBUG_INIT " -g")
|
||||||
@ -30,11 +30,11 @@ index 2c83fb8fc..55e0a83a6 100644
|
|||||||
string(APPEND CMAKE_Fortran_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
string(APPEND CMAKE_Fortran_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
||||||
set(CMAKE_Fortran_MODDIR_FLAG "-fmod=")
|
set(CMAKE_Fortran_MODDIR_FLAG "-fmod=")
|
||||||
set(CMAKE_Fortran_VERBOSE_FLAG "-v")
|
set(CMAKE_Fortran_VERBOSE_FLAG "-v")
|
||||||
diff --git a/Modules/Compiler/GNU-Fortran.cmake b/Modules/Compiler/GNU-Fortran.cmake
|
Index: cmake-3.10.0/Modules/Compiler/GNU-Fortran.cmake
|
||||||
index 94dc2755a..31774d3c5 100644
|
===================================================================
|
||||||
--- a/Modules/Compiler/GNU-Fortran.cmake
|
--- cmake-3.10.0.orig/Modules/Compiler/GNU-Fortran.cmake
|
||||||
+++ b/Modules/Compiler/GNU-Fortran.cmake
|
+++ cmake-3.10.0/Modules/Compiler/GNU-Fortran.cmake
|
||||||
@@ -9,7 +9,7 @@ set(CMAKE_Fortran_FORMAT_FREE_FLAG "-ffree-form")
|
@@ -11,7 +11,7 @@ set(CMAKE_Fortran_POSTPROCESS_FLAG "-fpr
|
||||||
|
|
||||||
# No -DNDEBUG for Fortran.
|
# No -DNDEBUG for Fortran.
|
||||||
string(APPEND CMAKE_Fortran_FLAGS_MINSIZEREL_INIT " -Os")
|
string(APPEND CMAKE_Fortran_FLAGS_MINSIZEREL_INIT " -Os")
|
||||||
@ -43,10 +43,10 @@ index 94dc2755a..31774d3c5 100644
|
|||||||
|
|
||||||
# No -isystem for Fortran because it will not find .mod files.
|
# No -isystem for Fortran because it will not find .mod files.
|
||||||
unset(CMAKE_INCLUDE_SYSTEM_FLAG_Fortran)
|
unset(CMAKE_INCLUDE_SYSTEM_FLAG_Fortran)
|
||||||
diff --git a/Modules/Compiler/GNU.cmake b/Modules/Compiler/GNU.cmake
|
Index: cmake-3.10.0/Modules/Compiler/GNU.cmake
|
||||||
index 675e50534..235e8ddc6 100644
|
===================================================================
|
||||||
--- a/Modules/Compiler/GNU.cmake
|
--- cmake-3.10.0.orig/Modules/Compiler/GNU.cmake
|
||||||
+++ b/Modules/Compiler/GNU.cmake
|
+++ cmake-3.10.0/Modules/Compiler/GNU.cmake
|
||||||
@@ -40,7 +40,7 @@ macro(__compiler_gnu lang)
|
@@ -40,7 +40,7 @@ macro(__compiler_gnu lang)
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
||||||
@ -56,10 +56,10 @@ index 675e50534..235e8ddc6 100644
|
|||||||
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g -DNDEBUG")
|
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g -DNDEBUG")
|
||||||
set(CMAKE_${lang}_CREATE_PREPROCESSED_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <INCLUDES> <FLAGS> -E <SOURCE> > <PREPROCESSED_SOURCE>")
|
set(CMAKE_${lang}_CREATE_PREPROCESSED_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <INCLUDES> <FLAGS> -E <SOURCE> > <PREPROCESSED_SOURCE>")
|
||||||
set(CMAKE_${lang}_CREATE_ASSEMBLY_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <INCLUDES> <FLAGS> -S <SOURCE> -o <ASSEMBLY_SOURCE>")
|
set(CMAKE_${lang}_CREATE_ASSEMBLY_SOURCE "<CMAKE_${lang}_COMPILER> <DEFINES> <INCLUDES> <FLAGS> -S <SOURCE> -o <ASSEMBLY_SOURCE>")
|
||||||
diff --git a/Modules/Compiler/Intel.cmake b/Modules/Compiler/Intel.cmake
|
Index: cmake-3.10.0/Modules/Compiler/Intel.cmake
|
||||||
index 635ac4d3c..3ae419e46 100644
|
===================================================================
|
||||||
--- a/Modules/Compiler/Intel.cmake
|
--- cmake-3.10.0.orig/Modules/Compiler/Intel.cmake
|
||||||
+++ b/Modules/Compiler/Intel.cmake
|
+++ cmake-3.10.0/Modules/Compiler/Intel.cmake
|
||||||
@@ -22,7 +22,7 @@ else()
|
@@ -22,7 +22,7 @@ else()
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g")
|
||||||
@ -69,11 +69,11 @@ index 635ac4d3c..3ae419e46 100644
|
|||||||
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -g")
|
||||||
|
|
||||||
set(CMAKE_${lang}_COMPILER_PREDEFINES_COMMAND "${CMAKE_${lang}_COMPILER}" "-QdM" "-P" "-Za" "${CMAKE_ROOT}/Modules/CMakeCXXCompilerABI.cpp")
|
set(CMAKE_${lang}_COMPILER_PREDEFINES_COMMAND "${CMAKE_${lang}_COMPILER}" "-QdM" "-P" "-Za" "${CMAKE_ROOT}/Modules/CMakeCXXCompilerABI.cpp")
|
||||||
diff --git a/Modules/Compiler/NVIDIA-CUDA.cmake b/Modules/Compiler/NVIDIA-CUDA.cmake
|
Index: cmake-3.10.0/Modules/Compiler/NVIDIA-CUDA.cmake
|
||||||
index 785e26998..8c098051f 100644
|
===================================================================
|
||||||
--- a/Modules/Compiler/NVIDIA-CUDA.cmake
|
--- cmake-3.10.0.orig/Modules/Compiler/NVIDIA-CUDA.cmake
|
||||||
+++ b/Modules/Compiler/NVIDIA-CUDA.cmake
|
+++ cmake-3.10.0/Modules/Compiler/NVIDIA-CUDA.cmake
|
||||||
@@ -9,7 +9,7 @@ if(NOT "x${CMAKE_CUDA_SIMULATE_ID}" STREQUAL "xMSVC")
|
@@ -9,7 +9,7 @@ if(NOT "x${CMAKE_CUDA_SIMULATE_ID}" STRE
|
||||||
set(CMAKE_SHARED_LIBRARY_CUDA_FLAGS -fPIC)
|
set(CMAKE_SHARED_LIBRARY_CUDA_FLAGS -fPIC)
|
||||||
string(APPEND CMAKE_CUDA_FLAGS_INIT " ")
|
string(APPEND CMAKE_CUDA_FLAGS_INIT " ")
|
||||||
string(APPEND CMAKE_CUDA_FLAGS_DEBUG_INIT " -g")
|
string(APPEND CMAKE_CUDA_FLAGS_DEBUG_INIT " -g")
|
||||||
@ -82,23 +82,10 @@ index 785e26998..8c098051f 100644
|
|||||||
string(APPEND CMAKE_CUDA_FLAGS_MINSIZEREL_INIT " -O1 -DNDEBUG")
|
string(APPEND CMAKE_CUDA_FLAGS_MINSIZEREL_INIT " -O1 -DNDEBUG")
|
||||||
string(APPEND CMAKE_CUDA_FLAGS_RELWITHDEBINFO_INIT " -O2 -g -DNDEBUG")
|
string(APPEND CMAKE_CUDA_FLAGS_RELWITHDEBINFO_INIT " -O2 -g -DNDEBUG")
|
||||||
endif()
|
endif()
|
||||||
diff --git a/Modules/Compiler/PGI.cmake b/Modules/Compiler/PGI.cmake
|
Index: cmake-3.10.0/Modules/Compiler/PathScale.cmake
|
||||||
index 0cbfd8a0b..22a63103d 100644
|
===================================================================
|
||||||
--- a/Modules/Compiler/PGI.cmake
|
--- cmake-3.10.0.orig/Modules/Compiler/PathScale.cmake
|
||||||
+++ b/Modules/Compiler/PGI.cmake
|
+++ cmake-3.10.0/Modules/Compiler/PathScale.cmake
|
||||||
@@ -18,7 +18,7 @@ macro(__compiler_pgi lang)
|
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g -O0")
|
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_MINSIZEREL_INIT " -O2 -s")
|
|
||||||
- string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -fast -O3")
|
|
||||||
+ string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -fast -O2")
|
|
||||||
# -Mipa was dropped with PGI 16.3 from Windows versions
|
|
||||||
if(NOT CMAKE_HOST_WIN32 OR CMAKE_${lang}_COMPILER_VERSION VERSION_LESS 16.3)
|
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -Mipa=fast")
|
|
||||||
diff --git a/Modules/Compiler/PathScale.cmake b/Modules/Compiler/PathScale.cmake
|
|
||||||
index d5f8cb12b..dd9bf1b92 100644
|
|
||||||
--- a/Modules/Compiler/PathScale.cmake
|
|
||||||
+++ b/Modules/Compiler/PathScale.cmake
|
|
||||||
@@ -16,6 +16,6 @@ macro(__compiler_pathscale lang)
|
@@ -16,6 +16,6 @@ macro(__compiler_pathscale lang)
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g -O0")
|
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g -O0")
|
||||||
@ -107,10 +94,10 @@ index d5f8cb12b..dd9bf1b92 100644
|
|||||||
+ string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O2")
|
+ string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -O2")
|
||||||
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -g -O2")
|
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -g -O2")
|
||||||
endmacro()
|
endmacro()
|
||||||
diff --git a/Modules/Platform/IRIX.cmake b/Modules/Platform/IRIX.cmake
|
Index: cmake-3.10.0/Modules/Platform/IRIX.cmake
|
||||||
index 12b0f3774..1f300fb14 100644
|
===================================================================
|
||||||
--- a/Modules/Platform/IRIX.cmake
|
--- cmake-3.10.0.orig/Modules/Platform/IRIX.cmake
|
||||||
+++ b/Modules/Platform/IRIX.cmake
|
+++ cmake-3.10.0/Modules/Platform/IRIX.cmake
|
||||||
@@ -7,7 +7,7 @@ if(NOT CMAKE_COMPILER_IS_GNUCXX)
|
@@ -7,7 +7,7 @@ if(NOT CMAKE_COMPILER_IS_GNUCXX)
|
||||||
"<CMAKE_CXX_COMPILER> -ar -o <TARGET> <OBJECTS>")
|
"<CMAKE_CXX_COMPILER> -ar -o <TARGET> <OBJECTS>")
|
||||||
set (CMAKE_CXX_FLAGS_INIT "")
|
set (CMAKE_CXX_FLAGS_INIT "")
|
||||||
@ -120,10 +107,10 @@ index 12b0f3774..1f300fb14 100644
|
|||||||
set (CMAKE_CXX_FLAGS_RELEASE_INIT "-O2 -DNDEBUG")
|
set (CMAKE_CXX_FLAGS_RELEASE_INIT "-O2 -DNDEBUG")
|
||||||
set (CMAKE_CXX_FLAGS_RELWITHDEBINFO_INIT "-O2")
|
set (CMAKE_CXX_FLAGS_RELWITHDEBINFO_INIT "-O2")
|
||||||
set (CMAKE_C_FLAGS_INIT "")
|
set (CMAKE_C_FLAGS_INIT "")
|
||||||
diff --git a/Modules/Platform/IRIX64.cmake b/Modules/Platform/IRIX64.cmake
|
Index: cmake-3.10.0/Modules/Platform/IRIX64.cmake
|
||||||
index ee9b96e89..82e5bdee9 100644
|
===================================================================
|
||||||
--- a/Modules/Platform/IRIX64.cmake
|
--- cmake-3.10.0.orig/Modules/Platform/IRIX64.cmake
|
||||||
+++ b/Modules/Platform/IRIX64.cmake
|
+++ cmake-3.10.0/Modules/Platform/IRIX64.cmake
|
||||||
@@ -37,7 +37,7 @@ if(NOT CMAKE_COMPILER_IS_GNUCC)
|
@@ -37,7 +37,7 @@ if(NOT CMAKE_COMPILER_IS_GNUCC)
|
||||||
set(CMAKE_CXX_CREATE_STATIC_LIBRARY
|
set(CMAKE_CXX_CREATE_STATIC_LIBRARY
|
||||||
"<CMAKE_CXX_COMPILER> -ar -o <TARGET> <OBJECTS>")
|
"<CMAKE_CXX_COMPILER> -ar -o <TARGET> <OBJECTS>")
|
||||||
@ -133,3 +120,68 @@ index ee9b96e89..82e5bdee9 100644
|
|||||||
set (CMAKE_CXX_FLAGS_RELEASE_INIT "-O2 -DNDEBUG")
|
set (CMAKE_CXX_FLAGS_RELEASE_INIT "-O2 -DNDEBUG")
|
||||||
set (CMAKE_CXX_FLAGS_RELWITHDEBINFO_INIT "-O2")
|
set (CMAKE_CXX_FLAGS_RELWITHDEBINFO_INIT "-O2")
|
||||||
endif()
|
endif()
|
||||||
|
Index: cmake-3.10.0/Modules/Compiler/PGI.cmake
|
||||||
|
===================================================================
|
||||||
|
--- cmake-3.10.0.orig/Modules/Compiler/PGI.cmake
|
||||||
|
+++ cmake-3.10.0/Modules/Compiler/PGI.cmake
|
||||||
|
@@ -18,7 +18,7 @@ macro(__compiler_pgi lang)
|
||||||
|
string(APPEND CMAKE_${lang}_FLAGS_INIT " ")
|
||||||
|
string(APPEND CMAKE_${lang}_FLAGS_DEBUG_INIT " -g -O0")
|
||||||
|
string(APPEND CMAKE_${lang}_FLAGS_MINSIZEREL_INIT " -O2 -s")
|
||||||
|
- string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -fast -O3")
|
||||||
|
+ string(APPEND CMAKE_${lang}_FLAGS_RELEASE_INIT " -fast -O2")
|
||||||
|
string(APPEND CMAKE_${lang}_FLAGS_RELWITHDEBINFO_INIT " -O2 -gopt")
|
||||||
|
|
||||||
|
if(CMAKE_HOST_WIN32)
|
||||||
|
Index: cmake-3.10.0/Modules/Compiler/SunPro-ASM.cmake
|
||||||
|
===================================================================
|
||||||
|
--- cmake-3.10.0.orig/Modules/Compiler/SunPro-ASM.cmake
|
||||||
|
+++ cmake-3.10.0/Modules/Compiler/SunPro-ASM.cmake
|
||||||
|
@@ -11,7 +11,7 @@ set(CMAKE_SHARED_LIBRARY_SONAME_ASM_FLAG
|
||||||
|
string(APPEND CMAKE_ASM_FLAGS_INIT " ")
|
||||||
|
string(APPEND CMAKE_ASM_FLAGS_DEBUG_INIT " -g")
|
||||||
|
string(APPEND CMAKE_ASM_FLAGS_MINSIZEREL_INIT " -xO2 -xspace -DNDEBUG")
|
||||||
|
-string(APPEND CMAKE_ASM_FLAGS_RELEASE_INIT " -xO3 -DNDEBUG")
|
||||||
|
+string(APPEND CMAKE_ASM_FLAGS_RELEASE_INIT " -xO2 -DNDEBUG")
|
||||||
|
string(APPEND CMAKE_ASM_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
||||||
|
|
||||||
|
# Initialize ASM link type selection flags. These flags are used when
|
||||||
|
Index: cmake-3.10.0/Modules/Compiler/SunPro-C.cmake
|
||||||
|
===================================================================
|
||||||
|
--- cmake-3.10.0.orig/Modules/Compiler/SunPro-C.cmake
|
||||||
|
+++ cmake-3.10.0/Modules/Compiler/SunPro-C.cmake
|
||||||
|
@@ -15,7 +15,7 @@ set(CMAKE_SHARED_LIBRARY_SONAME_C_FLAG "
|
||||||
|
string(APPEND CMAKE_C_FLAGS_INIT " ")
|
||||||
|
string(APPEND CMAKE_C_FLAGS_DEBUG_INIT " -g")
|
||||||
|
string(APPEND CMAKE_C_FLAGS_MINSIZEREL_INIT " -xO2 -xspace -DNDEBUG")
|
||||||
|
-string(APPEND CMAKE_C_FLAGS_RELEASE_INIT " -xO3 -DNDEBUG")
|
||||||
|
+string(APPEND CMAKE_C_FLAGS_RELEASE_INIT " -xO2 -DNDEBUG")
|
||||||
|
string(APPEND CMAKE_C_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
||||||
|
|
||||||
|
# Initialize C link type selection flags. These flags are used when
|
||||||
|
Index: cmake-3.10.0/Modules/Compiler/SunPro-CXX.cmake
|
||||||
|
===================================================================
|
||||||
|
--- cmake-3.10.0.orig/Modules/Compiler/SunPro-CXX.cmake
|
||||||
|
+++ cmake-3.10.0/Modules/Compiler/SunPro-CXX.cmake
|
||||||
|
@@ -15,7 +15,7 @@ set(CMAKE_SHARED_LIBRARY_SONAME_CXX_FLAG
|
||||||
|
string(APPEND CMAKE_CXX_FLAGS_INIT " ")
|
||||||
|
string(APPEND CMAKE_CXX_FLAGS_DEBUG_INIT " -g")
|
||||||
|
string(APPEND CMAKE_CXX_FLAGS_MINSIZEREL_INIT " -xO2 -xspace -DNDEBUG")
|
||||||
|
-string(APPEND CMAKE_CXX_FLAGS_RELEASE_INIT " -xO3 -DNDEBUG")
|
||||||
|
+string(APPEND CMAKE_CXX_FLAGS_RELEASE_INIT " -xO2 -DNDEBUG")
|
||||||
|
string(APPEND CMAKE_CXX_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
||||||
|
|
||||||
|
# Initialize C link type selection flags. These flags are used when
|
||||||
|
Index: cmake-3.10.0/Modules/Compiler/SunPro-Fortran.cmake
|
||||||
|
===================================================================
|
||||||
|
--- cmake-3.10.0.orig/Modules/Compiler/SunPro-Fortran.cmake
|
||||||
|
+++ cmake-3.10.0/Modules/Compiler/SunPro-Fortran.cmake
|
||||||
|
@@ -13,7 +13,7 @@ set(CMAKE_EXECUTABLE_RUNTIME_Fortran_FLA
|
||||||
|
string(APPEND CMAKE_Fortran_FLAGS_INIT " ")
|
||||||
|
string(APPEND CMAKE_Fortran_FLAGS_DEBUG_INIT " -g")
|
||||||
|
string(APPEND CMAKE_Fortran_FLAGS_MINSIZEREL_INIT " -xO2 -xspace -DNDEBUG")
|
||||||
|
-string(APPEND CMAKE_Fortran_FLAGS_RELEASE_INIT " -xO3 -DNDEBUG")
|
||||||
|
+string(APPEND CMAKE_Fortran_FLAGS_RELEASE_INIT " -xO2 -DNDEBUG")
|
||||||
|
string(APPEND CMAKE_Fortran_FLAGS_RELWITHDEBINFO_INIT " -g -xO2 -DNDEBUG")
|
||||||
|
set(CMAKE_Fortran_MODDIR_FLAG "-moddir=")
|
||||||
|
set(CMAKE_Fortran_MODPATH_FLAG "-M")
|
||||||
|
@ -1,6 +1,7 @@
|
|||||||
diff -up cmake-3.7.0-rc1/Modules/FindRuby.cmake.orig cmake-3.7.0-rc1/Modules/FindRuby.cmake
|
Index: cmake-3.10.0/Modules/FindRuby.cmake
|
||||||
--- cmake-3.7.0-rc1/Modules/FindRuby.cmake.orig 2016-10-04 07:54:11.000000000 -0600
|
===================================================================
|
||||||
+++ cmake-3.7.0-rc1/Modules/FindRuby.cmake 2016-10-06 15:23:57.195332679 -0600
|
--- cmake-3.10.0.orig/Modules/FindRuby.cmake
|
||||||
|
+++ cmake-3.10.0/Modules/FindRuby.cmake
|
||||||
@@ -106,14 +106,8 @@ if(RUBY_EXECUTABLE AND NOT RUBY_VERSIO
|
@@ -106,14 +106,8 @@ if(RUBY_EXECUTABLE AND NOT RUBY_VERSIO
|
||||||
_RUBY_CONFIG_VAR("sitearchdir" RUBY_SITEARCH_DIR)
|
_RUBY_CONFIG_VAR("sitearchdir" RUBY_SITEARCH_DIR)
|
||||||
_RUBY_CONFIG_VAR("sitelibdir" RUBY_SITELIB_DIR)
|
_RUBY_CONFIG_VAR("sitelibdir" RUBY_SITELIB_DIR)
|
||||||
|
10
cmake.spec
10
cmake.spec
@ -54,7 +54,7 @@
|
|||||||
%{!?_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
%{!?_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||||
|
|
||||||
%global major_version 3
|
%global major_version 3
|
||||||
%global minor_version 9
|
%global minor_version 10
|
||||||
# Set to RC version if building RC, else %%{nil}
|
# Set to RC version if building RC, else %%{nil}
|
||||||
#global rcsuf rc3
|
#global rcsuf rc3
|
||||||
%{?rcsuf:%global relsuf .%{rcsuf}}
|
%{?rcsuf:%global relsuf .%{rcsuf}}
|
||||||
@ -65,7 +65,7 @@
|
|||||||
%global orig_name cmake
|
%global orig_name cmake
|
||||||
|
|
||||||
Name: %{orig_name}%{?name_suffix}
|
Name: %{orig_name}%{?name_suffix}
|
||||||
Version: %{major_version}.%{minor_version}.6
|
Version: %{major_version}.%{minor_version}.0
|
||||||
Release: 1%{?relsuf}%{?dist}
|
Release: 1%{?relsuf}%{?dist}
|
||||||
Summary: Cross-platform make system
|
Summary: Cross-platform make system
|
||||||
|
|
||||||
@ -94,9 +94,6 @@ Source5: %{name}.req
|
|||||||
Patch100: %{name}-findruby.patch
|
Patch100: %{name}-findruby.patch
|
||||||
# replace release flag -O3 with -O2 for fedora
|
# replace release flag -O3 with -O2 for fedora
|
||||||
Patch101: %{name}-fedora-flag_release.patch
|
Patch101: %{name}-fedora-flag_release.patch
|
||||||
# restore old style debuginfo creation for rpm >= 4.14 in CPackRPM
|
|
||||||
# https://gitlab.kitware.com/cmake/cmake/merge_requests/1099
|
|
||||||
Patch102: https://gitlab.kitware.com/cmake/cmake/merge_requests/1099.patch#/%{name}-CPackRPM_rpm_4_14_old_debuginfo.patch
|
|
||||||
|
|
||||||
# Patch for renaming on EPEL
|
# Patch for renaming on EPEL
|
||||||
%if 0%{?name_suffix:1}
|
%if 0%{?name_suffix:1}
|
||||||
@ -495,6 +492,9 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Nov 23 2017 Björn Esser <besser82@fedoraproject.org> - 3.10.0-1
|
||||||
|
- Update to 3.10.0 (#1515793)
|
||||||
|
|
||||||
* Fri Nov 10 2017 Rex Dieter <rdieter@fedoraproject.org> - 3.9.6-1
|
* Fri Nov 10 2017 Rex Dieter <rdieter@fedoraproject.org> - 3.9.6-1
|
||||||
- Update to 3.9.6
|
- Update to 3.9.6
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (cmake-3.9.6.tar.gz) = 9fda2c9ac054ef8fb1bf3885fbdec02c518da89ade220eba06b5502ac3ff300f635ec0922e61f3b2d090644fb743b8f71a04c532ab66b2d890a180cc7da54e6c
|
SHA512 (cmake-3.10.0.tar.gz) = 0bf05f5aacb17007d5beb0909263e31717102b685701eef45c20408895cc9dfd54c96ebc8eee148845c8ffb1d3db687e68a58d4e08395425e14ca0413ee84765
|
||||||
|
Loading…
Reference in New Issue
Block a user