- attempt to patch logic error, crasher
This commit is contained in:
parent
6791c88397
commit
3d57928da9
25
cmake-2.6.1-parens.patch
Normal file
25
cmake-2.6.1-parens.patch
Normal file
@ -0,0 +1,25 @@
|
||||
diff -up cmake-2.6.1/Source/cmELF.cxx.parens cmake-2.6.1/Source/cmELF.cxx
|
||||
--- cmake-2.6.1/Source/cmELF.cxx.parens 2008-08-01 10:34:52.000000000 -0500
|
||||
+++ cmake-2.6.1/Source/cmELF.cxx 2008-08-26 14:58:23.000000000 -0500
|
||||
@@ -884,8 +884,8 @@ cmELF::StringEntry const* cmELF::GetSONa
|
||||
cmELF::StringEntry const* cmELF::GetRPath()
|
||||
{
|
||||
if(this->Valid() &&
|
||||
- this->Internal->GetFileType() == cmELF::FileTypeExecutable ||
|
||||
- this->Internal->GetFileType() == cmELF::FileTypeSharedLibrary)
|
||||
+ (this->Internal->GetFileType() == cmELF::FileTypeExecutable ||
|
||||
+ this->Internal->GetFileType() == cmELF::FileTypeSharedLibrary) )
|
||||
{
|
||||
return this->Internal->GetRPath();
|
||||
}
|
||||
@@ -899,8 +899,8 @@ cmELF::StringEntry const* cmELF::GetRPat
|
||||
cmELF::StringEntry const* cmELF::GetRunPath()
|
||||
{
|
||||
if(this->Valid() &&
|
||||
- this->Internal->GetFileType() == cmELF::FileTypeExecutable ||
|
||||
- this->Internal->GetFileType() == cmELF::FileTypeSharedLibrary)
|
||||
+ (this->Internal->GetFileType() == cmELF::FileTypeExecutable ||
|
||||
+ this->Internal->GetFileType() == cmELF::FileTypeSharedLibrary) )
|
||||
{
|
||||
return this->Internal->GetRunPath();
|
||||
}
|
15
cmake.spec
15
cmake.spec
@ -4,7 +4,7 @@
|
||||
|
||||
Name: cmake
|
||||
Version: 2.6.1
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
Group: Development/Tools
|
||||
@ -16,6 +16,11 @@ Source2: macros.cmake
|
||||
#Submitted upstream: http://public.kitware.com/Bug/view.php?id=7333
|
||||
Patch0: cmake-2.6.0-jni.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
# fix a crasher, see
|
||||
# http://www.redhat.com/archives/fedora-devel-list/2008-August/msg01145.html
|
||||
Patch1: cmake-2.6.1-parens.patch
|
||||
|
||||
BuildRequires: ncurses-devel, libX11-devel
|
||||
BuildRequires: qt4-devel, desktop-file-utils
|
||||
BuildRequires: curl-devel, expat-devel, zlib-devel
|
||||
@ -43,7 +48,10 @@ The %{name}-gui package contains the Qt based GUI for CMake.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch -p1 -b .jni
|
||||
|
||||
%patch0 -p1 -b .jni
|
||||
%patch1 -p1 -b .parens
|
||||
|
||||
# Fixup permissions
|
||||
find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
|
||||
|
||||
@ -114,6 +122,9 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> - 2.6.1-2
|
||||
- attempt to patch logic error, crasher
|
||||
|
||||
* Tue Aug 5 2008 Orion Poplawski <orion@cora.nwra.com> - 2.6.1-1
|
||||
- Update to 2.6.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user