cmake-3.25.2
Fixes rhbz#2162459
This commit is contained in:
parent
069fdb1d8c
commit
20cb796f3f
@ -1,52 +0,0 @@
|
||||
From a97032c4e7b1efb4c5535e5f705ef8ffd5fc2dd3 Mon Sep 17 00:00:00 2001
|
||||
From: leha-bot <leha-bot@yandex.ru>
|
||||
Date: Tue, 27 Dec 2022 18:25:38 +0300
|
||||
Subject: [PATCH] FindBoost: Add Boost 1.81 support
|
||||
|
||||
Update the list of known versions.
|
||||
|
||||
There is a new header-only library, Boost.URL. It has no
|
||||
dependencies and has a core header `<boost/url.hpp>`.
|
||||
|
||||
Run the command
|
||||
|
||||
cmake -DBOOST_DIR=/path/to/boost_1_81_0 \
|
||||
-P Utilities/Scripts/BoostScanDeps.cmake
|
||||
|
||||
to extract dependencies from the 1.81.0 source tree.
|
||||
They are the same as 1.80's dependencies, so just update
|
||||
the version check for warning about newer versions.
|
||||
---
|
||||
Modules/FindBoost.cmake | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Modules/FindBoost.cmake b/Modules/FindBoost.cmake
|
||||
index 0cea239ac95..72a9a4c1923 100644
|
||||
--- a/Modules/FindBoost.cmake
|
||||
+++ b/Modules/FindBoost.cmake
|
||||
@@ -1380,7 +1380,7 @@ function(_Boost_COMPONENT_DEPENDENCIES component _ret)
|
||||
set(_Boost_TIMER_DEPENDENCIES chrono)
|
||||
set(_Boost_WAVE_DEPENDENCIES filesystem serialization thread chrono atomic)
|
||||
set(_Boost_WSERIALIZATION_DEPENDENCIES serialization)
|
||||
- if(Boost_VERSION_STRING VERSION_GREATER_EQUAL 1.81.0 AND NOT Boost_NO_WARN_NEW_VERSIONS)
|
||||
+ if(Boost_VERSION_STRING VERSION_GREATER_EQUAL 1.82.0 AND NOT Boost_NO_WARN_NEW_VERSIONS)
|
||||
message(WARNING "New Boost version may have incorrect or missing dependencies and imported targets")
|
||||
endif()
|
||||
endif()
|
||||
@@ -1466,6 +1466,7 @@ function(_Boost_COMPONENT_HEADERS component _hdrs)
|
||||
set(_Boost_TIMER_HEADERS "boost/timer.hpp")
|
||||
set(_Boost_TYPE_ERASURE_HEADERS "boost/type_erasure/config.hpp")
|
||||
set(_Boost_UNIT_TEST_FRAMEWORK_HEADERS "boost/test/framework.hpp")
|
||||
+ set(_Boost_URL_HEADERS "boost/url.hpp")
|
||||
set(_Boost_WAVE_HEADERS "boost/wave.hpp")
|
||||
set(_Boost_WSERIALIZATION_HEADERS "boost/archive/text_wiarchive.hpp")
|
||||
set(_Boost_BZIP2_HEADERS "boost/iostreams/filter/bzip2.hpp")
|
||||
@@ -1653,7 +1654,7 @@ else()
|
||||
# _Boost_COMPONENT_HEADERS. See the instructions at the top of
|
||||
# _Boost_COMPONENT_DEPENDENCIES.
|
||||
set(_Boost_KNOWN_VERSIONS ${Boost_ADDITIONAL_VERSIONS}
|
||||
- "1.80.0" "1.80" "1.79.0" "1.79"
|
||||
+ "1.81.0" "1.81" "1.80.0" "1.80" "1.79.0" "1.79"
|
||||
"1.78.0" "1.78" "1.77.0" "1.77" "1.76.0" "1.76" "1.75.0" "1.75" "1.74.0" "1.74"
|
||||
"1.73.0" "1.73" "1.72.0" "1.72" "1.71.0" "1.71" "1.70.0" "1.70" "1.69.0" "1.69"
|
||||
"1.68.0" "1.68" "1.67.0" "1.67" "1.66.0" "1.66" "1.65.1" "1.65.0" "1.65"
|
12
cmake.spec
12
cmake.spec
@ -68,14 +68,14 @@
|
||||
%{?rcsuf:%global versuf -%{rcsuf}}
|
||||
|
||||
# For handling bump release by rpmdev-bumpspec and mass rebuild
|
||||
%global baserelease 4
|
||||
%global baserelease 1
|
||||
|
||||
# Uncomment if building for EPEL
|
||||
#global name_suffix %%{major_version}
|
||||
%global orig_name cmake
|
||||
|
||||
Name: %{orig_name}%{?name_suffix}
|
||||
Version: %{major_version}.%{minor_version}.1
|
||||
Version: %{major_version}.%{minor_version}.2
|
||||
Release: %{baserelease}%{?relsuf}%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
@ -112,10 +112,6 @@ Patch101: %{name}-fedora-flag_release.patch
|
||||
Patch102: %{name}-mingw-dl.patch
|
||||
%endif
|
||||
|
||||
# FindBoost: Add Boost 1.81 support.
|
||||
# https://github.com/Kitware/CMake/commit/a97032c4e7b1efb4c5535e5f705ef8ffd5fc2dd3
|
||||
Patch200: https://github.com/Kitware/CMake/commit/a97032c4e7b1efb4c5535e5f705ef8ffd5fc2dd3.patch#/%{name}-3.25.1-Boost_181.patch
|
||||
|
||||
# Patch for renaming on EPEL
|
||||
%if 0%{?name_suffix:1}
|
||||
Patch1: %{name}-rename.patch
|
||||
@ -529,6 +525,10 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jan 19 2023 Björn Esser <besser82@fedoraproject.org> - 3.25.2-1
|
||||
- cmake-3.25.2
|
||||
Fixes rhbz#2162459
|
||||
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 3.25.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (cmake-3.25.1.tar.gz) = ec4203cac569e3c340bf6535d193d9ccff9c4e4d59a7a7ae5b9156172f647d9f9212bdc37b3c12cbd676b1351b9a64364c563aaa968a2f41e0f402410ed78d57
|
||||
SHA512 (cmake-3.25.2.tar.gz) = 20146d06a1722c36249192944a58e4780aad334d2bc5ce2a3d8c4f24656630c5b71ca0ae7ed53587e3d46f488bd773452fa60c3fc7045fe54db2dbc6ffd86390
|
||||
|
Loading…
Reference in New Issue
Block a user