Update to 2.8.5 RC 2
Add patch from upstream to fix FindSWIG
This commit is contained in:
parent
d8388c9662
commit
19a5770efc
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@ cmake-2.8.2.tar.gz
|
||||
/cmake-2.8.4-rc2.tar.gz
|
||||
/cmake-2.8.4.tar.gz
|
||||
/cmake-2.8.5-rc1.tar.gz
|
||||
/cmake-2.8.5-rc2.tar.gz
|
||||
|
11
cmake-swig.patch
Normal file
11
cmake-swig.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- cmake-2.8.5-rc2/Modules/FindSWIG.cmake.swig 2011-06-15 09:18:34.000000000 -0600
|
||||
+++ cmake-2.8.5-rc2/Modules/FindSWIG.cmake 2011-06-20 09:24:51.200421179 -0600
|
||||
@@ -27,7 +27,7 @@
|
||||
# (To distribute this file outside of CMake, substitute the full
|
||||
# License text for the above reference.)
|
||||
|
||||
-FIND_PROGRAM(SWIG_EXECUTABLE swig2.0 swig)
|
||||
+FIND_PROGRAM(SWIG_EXECUTABLE NAMES swig2.0 swig)
|
||||
|
||||
IF(SWIG_EXECUTABLE)
|
||||
EXECUTE_PROCESS(COMMAND ${SWIG_EXECUTABLE} -swiglib
|
11
cmake.spec
11
cmake.spec
@ -4,11 +4,11 @@
|
||||
# Set to bcond_with or use --without gui to disable qt4 gui build
|
||||
%bcond_without gui
|
||||
# Set to RC version if building RC, else %{nil}
|
||||
%define rcver -rc1
|
||||
%define rcver -rc2
|
||||
|
||||
Name: cmake
|
||||
Version: 2.8.5
|
||||
Release: 0.1.rc1%{?dist}
|
||||
Release: 0.2.rc2%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
Group: Development/Tools
|
||||
@ -16,6 +16,8 @@ License: BSD
|
||||
URL: http://www.cmake.org
|
||||
Source0: http://www.cmake.org/files/v2.8/cmake-%{version}%{?rcver}.tar.gz
|
||||
Source2: macros.cmake
|
||||
# http://public.kitware.com/Bug/view.php?id=12280 - Fix finding swig executable
|
||||
Patch0: cmake-swig.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -56,6 +58,7 @@ The %{name}-gui package contains the Qt based GUI for CMake.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}%{?rcver}
|
||||
%patch0 -p1 -b .swig
|
||||
|
||||
|
||||
%build
|
||||
@ -156,6 +159,10 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jun 20 2011 Orion Poplawski <orion@cora.nwra.com> - 2.8.5-0.2.rc2
|
||||
- Update to 2.8.5 RC 2
|
||||
- Add patch from upstream to fix FindSWIG
|
||||
|
||||
* Tue May 31 2011 Orion Poplawski <orion@cora.nwra.com> - 2.8.5-0.1.rc1
|
||||
- Update to 2.8.5 RC 1
|
||||
- Disable CTestTestUpload test, needs internet access
|
||||
|
Loading…
Reference in New Issue
Block a user