Update to 3.10.2
Add patch to fix test failure with gcc 8
This commit is contained in:
parent
807c1a2de6
commit
18f7a632ed
1
.gitignore
vendored
1
.gitignore
vendored
@ -40,3 +40,4 @@
|
||||
/cmake-3.9.6.tar.gz
|
||||
/cmake-3.10.0.tar.gz
|
||||
/cmake-3.10.1.tar.gz
|
||||
/cmake-3.10.2.tar.gz
|
||||
|
30
1785.patch
Normal file
30
1785.patch
Normal file
@ -0,0 +1,30 @@
|
||||
From 972f7caad354e0bb04d338446601d391e4b0efbd Mon Sep 17 00:00:00 2001
|
||||
From: Brad King <brad.king@kitware.com>
|
||||
Date: Wed, 21 Feb 2018 14:34:56 -0500
|
||||
Subject: [PATCH] Tests: Make CompileFeatures C dialect check consistent with
|
||||
impl
|
||||
|
||||
`Modules/CMakeCCompilerId.c.in` will report the C dialect as 11 whenever
|
||||
`__STDC_VERSION__` indicates *at least* C 11. Make the test consistent
|
||||
with this. We already do this for the C++ case.
|
||||
|
||||
Fixes: #17740
|
||||
---
|
||||
Tests/CompileFeatures/default_dialect.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Tests/CompileFeatures/default_dialect.c b/Tests/CompileFeatures/default_dialect.c
|
||||
index 4debd9410c..2b4627ca46 100644
|
||||
--- a/Tests/CompileFeatures/default_dialect.c
|
||||
+++ b/Tests/CompileFeatures/default_dialect.c
|
||||
@@ -1,6 +1,6 @@
|
||||
|
||||
#if DEFAULT_C11
|
||||
-#if __STDC_VERSION__ != 201112L
|
||||
+#if __STDC_VERSION__ < 201112L
|
||||
#error Unexpected value for __STDC_VERSION__.
|
||||
#endif
|
||||
#elif DEFAULT_C99
|
||||
--
|
||||
2.14.3
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- cmake-3.10.1/Utilities/KWIML/include/kwiml/abi.h.old 2017-12-30 06:41:48.775310791 +0000
|
||||
+++ cmake-3.10.1/Utilities/KWIML/include/kwiml/abi.h 2017-12-30 06:41:56.332310127 +0000
|
||||
@@ -468,7 +468,7 @@
|
||||
# define KWIML_ABI_ENDIAN_ID KWIML_ABI_ENDIAN_ID_LITTLE
|
||||
|
||||
/* RISC-V */
|
||||
-#elif defined(__riscv__)
|
||||
+#elif defined(__riscv)
|
||||
# define KWIML_ABI_ENDIAN_ID KWIML_ABI_ENDIAN_ID_LITTLE
|
||||
|
||||
/* Unknown CPU */
|
14
cmake.spec
14
cmake.spec
@ -62,8 +62,8 @@
|
||||
%global orig_name cmake
|
||||
|
||||
Name: %{orig_name}%{?name_suffix}
|
||||
Version: %{major_version}.%{minor_version}.1
|
||||
Release: 13%{?relsuf}%{?dist}
|
||||
Version: %{major_version}.%{minor_version}.2
|
||||
Release: 1%{?relsuf}%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
# most sources are BSD
|
||||
@ -91,10 +91,8 @@ Source5: %{name}.req
|
||||
Patch100: %{name}-findruby.patch
|
||||
# replace release flag -O3 with -O2 for fedora
|
||||
Patch101: %{name}-fedora-flag_release.patch
|
||||
|
||||
# Patch to fix RISC-V support. Sent upstream 2017-12-30.
|
||||
Patch102: cmake-3.10.1-fix-riscv.patch
|
||||
|
||||
# Fix C17 handling
|
||||
Patch102: https://gitlab.kitware.com/cmake/cmake/merge_requests/1785.patch
|
||||
# Add dl to CMAKE_DL_LIBS on MINGW
|
||||
# https://gitlab.kitware.com/cmake/cmake/issues/17600
|
||||
Patch103: cmake-mingw-dl.patch
|
||||
@ -503,6 +501,10 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Feb 22 2018 Orion Poplawski <orion@nwra.com> - 3.10.2-1
|
||||
- Update to 3.10.2
|
||||
- Add patch to fix test failure with gcc 8
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.10.1-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (cmake-3.10.1.tar.gz) = 14e9a7f01747b369cad3c4e4e83bc777c0c98ce69209456f60d086d2471302f66dc1c1d22fd04e11dcb64de4bfc7dacd9aca70ee0e5f006abd1df79ef642eeed
|
||||
SHA512 (cmake-3.10.2.tar.gz) = f58fdd025285c9ff5396c0bd0d9573fc8a498fcbe5c11b336cb8ad6154ca6bc875c1a5e22d6654ba98596791ecf89ae8adffb83450839fa1275756b0af5bf82b
|
||||
|
Loading…
Reference in New Issue
Block a user