Add patch to fix FindRuby (bug 822796)
This commit is contained in:
parent
5d94a100b3
commit
0cf590138b
20
cmake-findruby.patch
Normal file
20
cmake-findruby.patch
Normal file
@ -0,0 +1,20 @@
|
||||
diff -up cmake-2.8.8/Modules/FindRuby.cmake.findruby cmake-2.8.8/Modules/FindRuby.cmake
|
||||
--- cmake-2.8.8/Modules/FindRuby.cmake.findruby 2012-04-18 12:10:54.000000000 -0600
|
||||
+++ cmake-2.8.8/Modules/FindRuby.cmake 2012-05-21 10:36:19.206076083 -0600
|
||||
@@ -92,14 +92,8 @@ IF(RUBY_EXECUTABLE AND NOT RUBY_VERSIO
|
||||
_RUBY_CONFIG_VAR("sitearchdir" RUBY_SITEARCH_DIR)
|
||||
_RUBY_CONFIG_VAR("sitelibdir" RUBY_SITELIB_DIR)
|
||||
|
||||
- # vendor_ruby available ?
|
||||
- EXECUTE_PROCESS(COMMAND ${RUBY_EXECUTABLE} -r vendor-specific -e "print 'true'"
|
||||
- OUTPUT_VARIABLE RUBY_HAS_VENDOR_RUBY ERROR_QUIET)
|
||||
-
|
||||
- IF(RUBY_HAS_VENDOR_RUBY)
|
||||
- _RUBY_CONFIG_VAR("vendorlibdir" RUBY_VENDORLIB_DIR)
|
||||
- _RUBY_CONFIG_VAR("vendorarchdir" RUBY_VENDORARCH_DIR)
|
||||
- ENDIF(RUBY_HAS_VENDOR_RUBY)
|
||||
+ _RUBY_CONFIG_VAR("vendorlibdir" RUBY_VENDORLIB_DIR)
|
||||
+ _RUBY_CONFIG_VAR("vendorarchdir" RUBY_VENDORARCH_DIR)
|
||||
|
||||
# save the results in the cache so we don't have to run ruby the next time again
|
||||
SET(RUBY_VERSION_MAJOR ${RUBY_VERSION_MAJOR} CACHE PATH "The Ruby major version" FORCE)
|
10
cmake.spec
10
cmake.spec
@ -8,7 +8,7 @@
|
||||
|
||||
Name: cmake
|
||||
Version: 2.8.8
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
Group: Development/Tools
|
||||
@ -24,6 +24,10 @@ Source2: macros.cmake
|
||||
Patch0: cmake-dcmtk.patch
|
||||
# (modified) Upstream patch to fix setting PKG_CONFIG_FOUND (bug #812188)
|
||||
Patch1: cmake-pkgconfig.patch
|
||||
# Patch to fix RindRuby vendor settings
|
||||
# http://public.kitware.com/Bug/view.php?id=12965
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=822796
|
||||
Patch2: cmake-findruby.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: gcc-gfortran
|
||||
@ -74,6 +78,7 @@ The %{name}-gui package contains the Qt based GUI for CMake.
|
||||
%setup -q -n %{name}-%{version}%{?rcver}
|
||||
%patch0 -p1 -b .dcmtk
|
||||
%patch1 -p1 -b .pkgconfig
|
||||
%patch2 -p1 -b .findruby
|
||||
|
||||
|
||||
%build
|
||||
@ -170,6 +175,9 @@ update-mime-database %{_datadir}/mime &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon May 21 2012 Orion Poplawski <orion@cora.nwra.com> 2.8.8-4
|
||||
- Add patch to fix FindRuby (bug 822796)
|
||||
|
||||
* Thu May 10 2012 Rex Dieter <rdieter@fedoraproject.org> 2.8.8-3
|
||||
- Incorrect license tag in spec file (#820334)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user