Update to 3.6.0-rc4
This commit is contained in:
parent
215439aebc
commit
08e14f95d5
1
.gitignore
vendored
1
.gitignore
vendored
@ -18,3 +18,4 @@
|
||||
/cmake-3.5.0.tar.gz
|
||||
/cmake-3.5.1.tar.gz
|
||||
/cmake-3.5.2.tar.gz
|
||||
/cmake-3.6.0-rc4.tar.gz
|
||||
|
@ -1,36 +0,0 @@
|
||||
From 92c47b8786fdd41f4b9d882386b7acf585f1c00a Mon Sep 17 00:00:00 2001
|
||||
From: Orion Poplawski <orion@cora.nwra.com>
|
||||
Date: Fri, 3 Jun 2016 09:37:03 -0600
|
||||
Subject: [PATCH] Support libarchive 3.2 version string format
|
||||
|
||||
---
|
||||
Modules/FindLibArchive.cmake | 9 +++++----
|
||||
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/Modules/FindLibArchive.cmake b/Modules/FindLibArchive.cmake
|
||||
index 471a4f1..dd93041 100644
|
||||
--- a/Modules/FindLibArchive.cmake
|
||||
+++ b/Modules/FindLibArchive.cmake
|
||||
@@ -42,14 +42,15 @@ mark_as_advanced(LibArchive_INCLUDE_DIR LibArchive_LIBRARY)
|
||||
|
||||
# Extract the version number from the header.
|
||||
if(LibArchive_INCLUDE_DIR AND EXISTS "${LibArchive_INCLUDE_DIR}/archive.h")
|
||||
- # The version string appears in one of two known formats in the header:
|
||||
+ # The version string appears in one of three known formats in the header:
|
||||
# #define ARCHIVE_LIBRARY_VERSION "libarchive 2.4.12"
|
||||
# #define ARCHIVE_VERSION_STRING "libarchive 2.8.4"
|
||||
- # Match either format.
|
||||
- set(_LibArchive_VERSION_REGEX "^#define[ \t]+ARCHIVE[_A-Z]+VERSION[_A-Z]*[ \t]+\"libarchive +([0-9]+)\\.([0-9]+)\\.([0-9]+)[^\"]*\".*$")
|
||||
+ # #define ARCHIVE_VERSION_ONLY_STRING "3.2.0"
|
||||
+ # Match any format.
|
||||
+ set(_LibArchive_VERSION_REGEX "^#define[ \t]+ARCHIVE[_A-Z]+VERSION[_A-Z]*[ \t]+\"(libarchive +)?([0-9]+)\\.([0-9]+)\\.([0-9]+)[^\"]*\".*$")
|
||||
file(STRINGS "${LibArchive_INCLUDE_DIR}/archive.h" _LibArchive_VERSION_STRING LIMIT_COUNT 1 REGEX "${_LibArchive_VERSION_REGEX}")
|
||||
if(_LibArchive_VERSION_STRING)
|
||||
- string(REGEX REPLACE "${_LibArchive_VERSION_REGEX}" "\\1.\\2.\\3" LibArchive_VERSION "${_LibArchive_VERSION_STRING}")
|
||||
+ string(REGEX REPLACE "${_LibArchive_VERSION_REGEX}" "\\2.\\3.\\4" LibArchive_VERSION "${_LibArchive_VERSION_STRING}")
|
||||
endif()
|
||||
unset(_LibArchive_VERSION_REGEX)
|
||||
unset(_LibArchive_VERSION_STRING)
|
||||
--
|
||||
1.8.3.1
|
||||
|
16
cmake.spec
16
cmake.spec
@ -33,15 +33,15 @@
|
||||
%{!?_pkgdocdir:%global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||
|
||||
# Set to RC version if building RC, else %{nil}
|
||||
%global rcver %{nil}
|
||||
%global rcver rc4
|
||||
|
||||
# Uncomment if building for EPEL
|
||||
#global name_suffix 3
|
||||
%global orig_name cmake
|
||||
|
||||
Name: %{orig_name}%{?name_suffix}
|
||||
Version: 3.5.2
|
||||
Release: 3%{?dist}
|
||||
Version: 3.6.0
|
||||
Release: 0.1.%{rcver}%{?dist}
|
||||
Summary: Cross-platform make system
|
||||
|
||||
# most sources are BSD
|
||||
@ -51,7 +51,7 @@ Summary: Cross-platform make system
|
||||
# exception granting redistribution under terms of your choice
|
||||
License: BSD and MIT and zlib
|
||||
URL: http://www.cmake.org
|
||||
Source0: http://www.cmake.org/files/v3.5/%{orig_name}-%{version}%{?rcver}.tar.gz
|
||||
Source0: http://www.cmake.org/files/v3.6/%{orig_name}-%{version}%{?rcver:-%rcver}.tar.gz
|
||||
Source1: %{name}-init.el
|
||||
Source2: macros.%{name}
|
||||
# See https://bugzilla.redhat.com/show_bug.cgi?id=1202899
|
||||
@ -64,8 +64,6 @@ Source4: %{name}.prov
|
||||
Patch2: %{name}-findruby.patch
|
||||
# replace release flag -O3 with -O2 for fedora
|
||||
Patch3: %{name}-fedora-flag_release.patch
|
||||
# Support libarchive 3.2
|
||||
Patch4: %{name}-libarchive.patch
|
||||
|
||||
# Patch for renaming on EPEL
|
||||
%if 0%{?name_suffix:1}
|
||||
@ -161,7 +159,7 @@ The %{name}-gui package contains the Qt based GUI for %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -qn %{orig_name}-%{version}%{?rcver}
|
||||
%setup -qn %{orig_name}-%{version}%{?rcver:-%rcver}
|
||||
|
||||
# Apply renaming on EPEL before all other patches
|
||||
%if 0%{?name_suffix:1}
|
||||
@ -174,7 +172,6 @@ The %{name}-gui package contains the Qt based GUI for %{name}.
|
||||
# We cannot use backups with patches to Modules as they end up being installed
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
|
||||
%if %{with python3}
|
||||
echo '#!%{__python3}' > %{name}.prov
|
||||
@ -384,6 +381,9 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jun 29 2016 Orion Poplawski <orion@cora.nwra.com> - 3.6.0-0.1.rc4
|
||||
- Update to 3.6.0-rc4
|
||||
|
||||
* Fri Jun 03 2016 Orion Poplawski <orion@cora.nwra.com> - 3.5.2-3
|
||||
- Add patch to support libarchive 3.2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user