Update to 3.3.2
This commit is contained in:
parent
4ccb585d3f
commit
0375260458
1
.gitignore
vendored
1
.gitignore
vendored
@ -40,3 +40,4 @@
|
|||||||
/cmake-3.3.0-rc3.tar.gz
|
/cmake-3.3.0-rc3.tar.gz
|
||||||
/cmake-3.3.0.tar.gz
|
/cmake-3.3.0.tar.gz
|
||||||
/cmake-3.3.1.tar.gz
|
/cmake-3.3.1.tar.gz
|
||||||
|
/cmake-3.3.2.tar.gz
|
||||||
|
@ -1,35 +0,0 @@
|
|||||||
From 371fe92e82ecadede532a211c1ec36f7039268d7 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Brad King <brad.king@kitware.com>
|
|
||||||
Date: Thu, 27 Aug 2015 16:41:34 -0400
|
|
||||||
Subject: [PATCH] Makefile: Print color escapes only when necessary
|
|
||||||
|
|
||||||
Teach cmSystemTools::MakefileColorEcho to use the color printing API
|
|
||||||
only when we actually have a color to print. This avoids printing
|
|
||||||
escape sequences that do not change the text attributes.
|
|
||||||
|
|
||||||
Since commit v3.3.0-rc1~480^2~4 (Makefile: Fix output during parallel
|
|
||||||
builds, 2015-02-05) we always use this code path to print progress and
|
|
||||||
rule messages even when color is disabled (e.g. in a try_compile). It
|
|
||||||
is important to avoid printing escapes when there is no color because on
|
|
||||||
MSYS we have no isatty and so assume that vt100 escapes are supported,
|
|
||||||
but we do not want to print them when capturing try_compile output.
|
|
||||||
---
|
|
||||||
Source/cmSystemTools.cxx | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/Source/cmSystemTools.cxx b/Source/cmSystemTools.cxx
|
|
||||||
index e2adabe..b440a17 100644
|
|
||||||
--- a/Source/cmSystemTools.cxx
|
|
||||||
+++ b/Source/cmSystemTools.cxx
|
|
||||||
@@ -2331,7 +2331,7 @@ void cmSystemTools::MakefileColorEcho(int color, const char* message,
|
|
||||||
assumeTTY = 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
- if(enabled)
|
|
||||||
+ if(enabled && color != cmsysTerminal_Color_Normal)
|
|
||||||
{
|
|
||||||
// Print with color. Delay the newline until later so that
|
|
||||||
// all color restore sequences appear before it.
|
|
||||||
--
|
|
||||||
1.7.10.4
|
|
||||||
|
|
11
cmake.spec
11
cmake.spec
@ -12,8 +12,8 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: cmake
|
Name: cmake
|
||||||
Version: 3.3.1
|
Version: 3.3.2
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Cross-platform make system
|
Summary: Cross-platform make system
|
||||||
|
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -31,9 +31,6 @@ Source3: cmake.attr
|
|||||||
Source4: cmake.prov
|
Source4: cmake.prov
|
||||||
# Patch to find DCMTK in Fedora (bug #720140)
|
# Patch to find DCMTK in Fedora (bug #720140)
|
||||||
Patch0: cmake-dcmtk.patch
|
Patch0: cmake-dcmtk.patch
|
||||||
# Patch to fix trycompile output
|
|
||||||
# http://www.cmake.org/gitweb?p=cmake.git;a=patch;h=371fe92e
|
|
||||||
Patch1: cmake.git-371fe92e.patch
|
|
||||||
# Patch to fix RindRuby vendor settings
|
# Patch to fix RindRuby vendor settings
|
||||||
# http://public.kitware.com/Bug/view.php?id=12965
|
# http://public.kitware.com/Bug/view.php?id=12965
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=822796
|
# https://bugzilla.redhat.com/show_bug.cgi?id=822796
|
||||||
@ -113,7 +110,6 @@ The %{name}-gui package contains the Qt based GUI for CMake.
|
|||||||
%setup -q -n %{name}-%{version}%{?rcver}
|
%setup -q -n %{name}-%{version}%{?rcver}
|
||||||
# We cannot use backups with patches to Modules as they end up being installed
|
# We cannot use backups with patches to Modules as they end up being installed
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
%patch624 -p1
|
%patch624 -p1
|
||||||
@ -290,6 +286,9 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 17 2015 Orion Poplawski <orion@cora.nwra.com> - 3.3.2-1
|
||||||
|
- Update to 3.3.2
|
||||||
|
|
||||||
* Fri Sep 11 2015 Orion Poplawski <orion@cora.nwra.com> - 3.3.1-5
|
* Fri Sep 11 2015 Orion Poplawski <orion@cora.nwra.com> - 3.3.1-5
|
||||||
- Apply upstream patch to fix Fortran linker detection with redhat-hardened-ld
|
- Apply upstream patch to fix Fortran linker detection with redhat-hardened-ld
|
||||||
(bug #1260490)
|
(bug #1260490)
|
||||||
|
Loading…
Reference in New Issue
Block a user