Prefer the X11 backend to the Wayland one, and enable wayland
This commit is contained in:
parent
5b492ecd79
commit
b6cb8d74ef
@ -1,65 +0,0 @@
|
|||||||
From b58a1d66816c19eda079a1bd7cecd1ad03644e69 Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Jasper St. Pierre" <jstpierre@mecheye.net>
|
|
||||||
Date: Wed, 23 Jan 2013 17:09:59 -0500
|
|
||||||
Subject: [PATCH] x11: Always request XI2.2
|
|
||||||
|
|
||||||
The X server should fill in the minor version that it supports in the
|
|
||||||
case where it only supports the older version. We should not get a
|
|
||||||
BadRequest or fail the version check if we pass something higher.
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=692466
|
|
||||||
---
|
|
||||||
clutter/x11/clutter-backend-x11.c | 5 -----
|
|
||||||
1 file changed, 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/clutter/x11/clutter-backend-x11.c b/clutter/x11/clutter-backend-x11.c
|
|
||||||
index 2d8f4ba..26f9581 100644
|
|
||||||
--- a/clutter/x11/clutter-backend-x11.c
|
|
||||||
+++ b/clutter/x11/clutter-backend-x11.c
|
|
||||||
@@ -239,12 +239,7 @@ clutter_backend_x11_create_device_manager (ClutterBackendX11 *backend_x11)
|
|
||||||
{
|
|
||||||
#ifdef HAVE_XINPUT_2
|
|
||||||
int major = 2;
|
|
||||||
-
|
|
||||||
-#ifdef HAVE_XINPUT_2_2
|
|
||||||
int minor = 2;
|
|
||||||
-#else
|
|
||||||
- int minor = 0;
|
|
||||||
-#endif /* HAVE_XINPUT_2_2 */
|
|
||||||
|
|
||||||
if (XIQueryVersion (backend_x11->xdpy, &major, &minor) != BadRequest)
|
|
||||||
{
|
|
||||||
--
|
|
||||||
1.8.1.2
|
|
||||||
|
|
||||||
From 3e1450ba17fce90a8034cc525c67a87ff3cdd53d Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Jasper St. Pierre" <jstpierre@mecheye.net>
|
|
||||||
Date: Wed, 23 Jan 2013 14:49:26 -0500
|
|
||||||
Subject: [PATCH] clutter-backend: Request XI2.3
|
|
||||||
|
|
||||||
Since XIQueryVersion, the bad API that it is, chooses the first client
|
|
||||||
version that it gets, we need to ensure that we pass XIQueryVersion the
|
|
||||||
new XI2.3 version, knowing fully well that Clutter won't be confused
|
|
||||||
by the new features.
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=692466
|
|
||||||
---
|
|
||||||
clutter/x11/clutter-backend-x11.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/clutter/x11/clutter-backend-x11.c b/clutter/x11/clutter-backend-x11.c
|
|
||||||
index 26f9581..1015f4c 100644
|
|
||||||
--- a/clutter/x11/clutter-backend-x11.c
|
|
||||||
+++ b/clutter/x11/clutter-backend-x11.c
|
|
||||||
@@ -239,7 +239,7 @@ clutter_backend_x11_create_device_manager (ClutterBackendX11 *backend_x11)
|
|
||||||
{
|
|
||||||
#ifdef HAVE_XINPUT_2
|
|
||||||
int major = 2;
|
|
||||||
- int minor = 2;
|
|
||||||
+ int minor = 3;
|
|
||||||
|
|
||||||
if (XIQueryVersion (backend_x11->xdpy, &major, &minor) != BadRequest)
|
|
||||||
{
|
|
||||||
--
|
|
||||||
1.8.1.2
|
|
||||||
|
|
@ -1,26 +0,0 @@
|
|||||||
diff --git a/clutter/x11/clutter-device-manager-xi2.c b/clutter/x11/clutter-device-manager-xi2.c
|
|
||||||
index 73e99af..b5bf2e4 100644
|
|
||||||
--- a/clutter/x11/clutter-device-manager-xi2.c
|
|
||||||
+++ b/clutter/x11/clutter-device-manager-xi2.c
|
|
||||||
@@ -733,12 +733,15 @@ clutter_device_manager_xi2_translate_event (ClutterEventTranslator *translator,
|
|
||||||
|
|
||||||
device = g_hash_table_lookup (manager_xi2->devices_by_id,
|
|
||||||
GINT_TO_POINTER (xev->deviceid));
|
|
||||||
- _clutter_input_device_reset_axes (device);
|
|
||||||
- _clutter_input_device_reset_scroll_info (device);
|
|
||||||
- translate_device_classes (backend_x11->xdpy,
|
|
||||||
- device,
|
|
||||||
- xev->classes,
|
|
||||||
- xev->num_classes);
|
|
||||||
+ if (device)
|
|
||||||
+ {
|
|
||||||
+ _clutter_input_device_reset_axes (device);
|
|
||||||
+ _clutter_input_device_reset_scroll_info (device);
|
|
||||||
+ translate_device_classes (backend_x11->xdpy,
|
|
||||||
+ device,
|
|
||||||
+ xev->classes,
|
|
||||||
+ xev->num_classes);
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
retval = CLUTTER_TRANSLATE_REMOVE;
|
|
||||||
break;
|
|
11
clutter.spec
11
clutter.spec
@ -1,10 +1,10 @@
|
|||||||
%if 0%{?fedora}
|
%if 0%{?fedora}
|
||||||
%global with_wayland 0
|
%global with_wayland 1
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: clutter
|
Name: clutter
|
||||||
Version: 1.13.8
|
Version: 1.13.8
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: Open Source software library for creating rich graphical user interfaces
|
Summary: Open Source software library for creating rich graphical user interfaces
|
||||||
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -12,6 +12,9 @@ License: LGPLv2+
|
|||||||
URL: http://www.clutter-project.org/
|
URL: http://www.clutter-project.org/
|
||||||
Source0: http://download.gnome.org/sources/clutter/1.13/clutter-%{version}.tar.xz
|
Source0: http://download.gnome.org/sources/clutter/1.13/clutter-%{version}.tar.xz
|
||||||
|
|
||||||
|
# https://bugzilla.gnome.org/show_bug.cgi?id=695838
|
||||||
|
Patch0: 0001-clutter-Prefer-the-X11-backend-to-the-Wayland-one.patch
|
||||||
|
|
||||||
BuildRequires: glib2-devel mesa-libGL-devel pkgconfig pango-devel
|
BuildRequires: glib2-devel mesa-libGL-devel pkgconfig pango-devel
|
||||||
BuildRequires: cairo-gobject-devel gdk-pixbuf2-devel atk-devel
|
BuildRequires: cairo-gobject-devel gdk-pixbuf2-devel atk-devel
|
||||||
BuildRequires: cogl-devel >= 1.13.4
|
BuildRequires: cogl-devel >= 1.13.4
|
||||||
@ -74,6 +77,7 @@ This package contains documentation for clutter.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
|
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
|
||||||
@ -122,6 +126,9 @@ find %{buildroot} -name '*.la' -exec rm -f {} ';'
|
|||||||
%{_datadir}/gtk-doc/html/cally
|
%{_datadir}/gtk-doc/html/cally
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 14 2013 Bastien Nocera <bnocera@redhat.com> 1.13.8-4
|
||||||
|
- Prefer the X11 backend to the Wayland one, and enable wayland
|
||||||
|
|
||||||
* Thu Mar 14 2013 Matthias Clasen <mclasen@redhat.com> 1.13.8-3
|
* Thu Mar 14 2013 Matthias Clasen <mclasen@redhat.com> 1.13.8-3
|
||||||
- Enabling Wayland broke the login screen, so disable for now
|
- Enabling Wayland broke the login screen, so disable for now
|
||||||
|
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
From d5604be9e5a148ced73dee2ede49b38f97119baf Mon Sep 17 00:00:00 2001
|
|
||||||
From: Yanko Kaneti <yaneti@declera.com>
|
|
||||||
Date: Mon, 28 Jan 2013 15:49:51 +0200
|
|
||||||
Subject: [PATCH] xi2: Fix access beyond array boundaries
|
|
||||||
|
|
||||||
---
|
|
||||||
clutter/x11/clutter-device-manager-xi2.c | 6 +++---
|
|
||||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/clutter/x11/clutter-device-manager-xi2.c b/clutter/x11/clutter-device-manager-xi2.c
|
|
||||||
index 616dee7..bd9473e 100644
|
|
||||||
--- a/clutter/x11/clutter-device-manager-xi2.c
|
|
||||||
+++ b/clutter/x11/clutter-device-manager-xi2.c
|
|
||||||
@@ -94,13 +94,13 @@ translate_valuator_class (Display *xdisplay,
|
|
||||||
atoms_initialized = TRUE;
|
|
||||||
}
|
|
||||||
|
|
||||||
- for (i = CLUTTER_INPUT_AXIS_IGNORE;
|
|
||||||
- i < CLUTTER_INPUT_AXIS_LAST;
|
|
||||||
+ for (i = 0;
|
|
||||||
+ i < N_AXIS_ATOMS;
|
|
||||||
i += 1)
|
|
||||||
{
|
|
||||||
if (clutter_input_axis_atoms[i] == class->label)
|
|
||||||
{
|
|
||||||
- axis = i;
|
|
||||||
+ axis = i + 1;
|
|
||||||
break;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
--
|
|
||||||
1.8.1
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user