Update to 1.23.2
This commit is contained in:
parent
7bf71e230e
commit
4cfddcf59e
@ -1,35 +0,0 @@
|
||||
From a4aad807d5cc6842043e12897cfac3a516825c0f Mon Sep 17 00:00:00 2001
|
||||
From: Rui Matos <tiagomatos@gmail.com>
|
||||
Date: Sun, 17 May 2015 00:50:56 +0200
|
||||
Subject: [PATCH] x11: Fix touchpad detection
|
||||
|
||||
Commit 79849ef1d5fff9acd310cd68d59df0c7cf2cb28f had a typo in the
|
||||
device property format check. This property is formated in 8-bit
|
||||
items, not 32-bit.
|
||||
|
||||
This went unnoticed till now because some touchpads were still being
|
||||
detected as such due to a second check below:
|
||||
|
||||
else if (strstr (name, "touchpad") != NULL)
|
||||
source = CLUTTER_TOUCHPAD_DEVICE;
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=749482
|
||||
---
|
||||
clutter/x11/clutter-device-manager-xi2.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/clutter/x11/clutter-device-manager-xi2.c b/clutter/x11/clutter-device-manager-xi2.c
|
||||
index 17c491e..1b101c4 100644
|
||||
--- a/clutter/x11/clutter-device-manager-xi2.c
|
||||
+++ b/clutter/x11/clutter-device-manager-xi2.c
|
||||
@@ -242,7 +242,7 @@ is_touchpad_device (ClutterBackendX11 *backend_x11,
|
||||
/* We don't care about the data */
|
||||
XFree (data);
|
||||
|
||||
- if (rc != Success || type != XA_INTEGER || format != 32 || nitems != 1)
|
||||
+ if (rc != Success || type != XA_INTEGER || format != 8 || nitems != 1)
|
||||
return FALSE;
|
||||
|
||||
return TRUE;
|
||||
--
|
||||
2.4.0
|
13
clutter.spec
13
clutter.spec
@ -7,16 +7,14 @@
|
||||
%global with_tests 1
|
||||
|
||||
Name: clutter
|
||||
Version: 1.22.2
|
||||
Release: 3%{?dist}
|
||||
Version: 1.23.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Open Source software library for creating rich graphical user interfaces
|
||||
|
||||
Group: Development/Libraries
|
||||
License: LGPLv2+
|
||||
URL: http://www.clutter-project.org/
|
||||
Source0: http://download.gnome.org/sources/clutter/1.22/clutter-%{version}.tar.xz
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=749482
|
||||
Patch0: 0001-x11-Fix-touchpad-detection.patch
|
||||
Source0: http://download.gnome.org/sources/clutter/1.23/clutter-%{version}.tar.xz
|
||||
|
||||
BuildRequires: glib2-devel mesa-libGL-devel pkgconfig pango-devel
|
||||
BuildRequires: cairo-gobject-devel gdk-pixbuf2-devel atk-devel
|
||||
@ -80,7 +78,6 @@ the functionality of the installed clutter package.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
@ -123,7 +120,6 @@ find %{buildroot} -name '*.la' -delete
|
||||
|
||||
%files doc
|
||||
%{_datadir}/gtk-doc/html/clutter
|
||||
%{_datadir}/gtk-doc/html/cally
|
||||
|
||||
%if 0%{?with_tests}
|
||||
%files tests
|
||||
@ -132,6 +128,9 @@ find %{buildroot} -name '*.la' -delete
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jun 29 2015 Kalev Lember <klember@redhat.com> - 1.23.2-1
|
||||
- Update to 1.23.2
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.22.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user