Update to 1.15.96
This commit is contained in:
parent
dddc1af407
commit
4b120b57ba
11
clutter.spec
11
clutter.spec
@ -5,8 +5,8 @@
|
||||
%endif
|
||||
|
||||
Name: clutter
|
||||
Version: 1.15.94
|
||||
Release: 2%{?dist}
|
||||
Version: 1.15.96
|
||||
Release: 1%{?dist}
|
||||
Summary: Open Source software library for creating rich graphical user interfaces
|
||||
|
||||
Group: Development/Libraries
|
||||
@ -14,9 +14,6 @@ License: LGPLv2+
|
||||
URL: http://www.clutter-project.org/
|
||||
Source0: http://download.gnome.org/sources/clutter/1.15/clutter-%{version}.tar.xz
|
||||
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=708439
|
||||
Patch0: no-stage-crash.patch
|
||||
|
||||
BuildRequires: glib2-devel mesa-libGL-devel pkgconfig pango-devel
|
||||
BuildRequires: cairo-gobject-devel gdk-pixbuf2-devel atk-devel
|
||||
BuildRequires: cogl-devel >= 1.15.1
|
||||
@ -82,7 +79,6 @@ This package contains documentation for clutter.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
|
||||
@ -134,6 +130,9 @@ find %{buildroot} -name '*.la' -exec rm -f {} ';'
|
||||
%{_datadir}/gtk-doc/html/cally
|
||||
|
||||
%changelog
|
||||
* Fri Sep 20 2013 Kalev Lember <kalevlember@gmail.com> - 1.15.96-1
|
||||
- Update to 1.15.96
|
||||
|
||||
* Fri Sep 20 2013 Matthias Clasen <mclasen@redhat.com> - 1.15.94-2
|
||||
- Fix a shell crash
|
||||
|
||||
|
@ -1,32 +0,0 @@
|
||||
From 2f90e355310801f78a1be48515c8cf740f3291af Mon Sep 17 00:00:00 2001
|
||||
From: Giovanni Campagna <gcampagn@redhat.com>
|
||||
Date: Fri, 20 Sep 2013 10:24:42 +0200
|
||||
Subject: [PATCH] clutter-xi2: don't access the stage if we don't have one
|
||||
|
||||
For DeviceChanged and HierarchyChanged events we don't have the
|
||||
stage, so we can't access the scale factor on it.
|
||||
Fixes hotplugging of devices which would happen when switching VTs.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=708439
|
||||
---
|
||||
clutter/x11/clutter-device-manager-xi2.c | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/clutter/x11/clutter-device-manager-xi2.c b/clutter/x11/clutter-device-manager-xi2.c
|
||||
index 8f9133f..67f4ce5 100644
|
||||
--- a/clutter/x11/clutter-device-manager-xi2.c
|
||||
+++ b/clutter/x11/clutter-device-manager-xi2.c
|
||||
@@ -774,7 +774,10 @@ clutter_device_manager_xi2_translate_event (ClutterEventTranslator *translator,
|
||||
|
||||
event->any.stage = stage;
|
||||
|
||||
- window_scale = stage_x11->scale_factor;
|
||||
+ if (stage_x11)
|
||||
+ window_scale = stage_x11->scale_factor;
|
||||
+ else
|
||||
+ window_scale = 0;
|
||||
|
||||
switch (xi_event->evtype)
|
||||
{
|
||||
--
|
||||
1.8.3.1
|
Loading…
Reference in New Issue
Block a user