34 lines
1.2 KiB
Diff
34 lines
1.2 KiB
Diff
From 88d74c56612773dc350efde57eff97f461f438e6 Mon Sep 17 00:00:00 2001
|
|
From: Lionel Landwerlin <llandwerlin@gmail.com>
|
|
Date: Mon, 29 Aug 2016 19:36:48 +0100
|
|
Subject: [PATCH] embed: remove non double buffer setting
|
|
|
|
This started causing problems with Gtk+ 3.21. As the documentation explains,
|
|
disabling double buffering might trigger rendering issues.
|
|
|
|
https://bugzilla.gnome.org/show_bug.cgi?id=769097
|
|
---
|
|
clutter-gtk/gtk-clutter-embed.c | 5 -----
|
|
configure.ac | 2 +-
|
|
2 files changed, 1 insertion(+), 6 deletions(-)
|
|
|
|
diff --git a/clutter-gtk/gtk-clutter-embed.c b/clutter-gtk/gtk-clutter-embed.c
|
|
index 9a01b9e..521afc9 100644
|
|
--- a/clutter-gtk/gtk-clutter-embed.c
|
|
+++ b/clutter-gtk/gtk-clutter-embed.c
|
|
@@ -1153,11 +1153,6 @@ gtk_clutter_embed_init (GtkClutterEmbed *embed)
|
|
/* we accept key focus */
|
|
gtk_widget_set_can_focus (widget, TRUE);
|
|
|
|
- G_GNUC_BEGIN_IGNORE_DEPRECATIONS
|
|
- /* disable double-buffering: it's automatically provided by OpenGL */
|
|
- gtk_widget_set_double_buffered (widget, FALSE);
|
|
- G_GNUC_END_IGNORE_DEPRECATIONS
|
|
-
|
|
/* we own the whole drawing of this widget, including the background */
|
|
gtk_widget_set_app_paintable (widget, TRUE);
|
|
|
|
--
|
|
2.7.4
|
|
|