This commit is contained in:
Peter Robinson 2010-10-10 16:21:15 +01:00
parent 941ff8400e
commit 279bcd0be3
6 changed files with 7 additions and 116 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
clutter-gtk-0.10.4.tar.bz2
/clutter-gtk-0.90.2.tar.bz2
/clutter-gtk-0.91.2.tar.bz2

View File

@ -1,33 +0,0 @@
From c1e51ff81d0958ab86e11248339360b579a08b42 Mon Sep 17 00:00:00 2001
From: Lucas Rocha <lucasr@litl.com>
Date: Fri, 10 Sep 2010 16:22:09 +0000
Subject: Remove GDK_DISPLAY() usage
It has been removed from GDK 3.0.
http://bugzilla.clutter-project.org/show_bug.cgi?id=2308
---
diff --git a/clutter-gtk/gtk-clutter-util.c b/clutter-gtk/gtk-clutter-util.c
index 6d49b8f..1533247 100644
--- a/clutter-gtk/gtk-clutter-util.c
+++ b/clutter-gtk/gtk-clutter-util.c
@@ -588,7 +588,7 @@ post_parse_hook (GOptionContext *context,
{
#if defined(GDK_WINDOWING_X11)
/* share the X11 Display with GTK+ */
- clutter_x11_set_display (GDK_DISPLAY());
+ clutter_x11_set_display (GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()));
/* let GTK+ in charge of the event handling */
clutter_x11_disable_event_retrieval ();
@@ -681,7 +681,7 @@ gtk_clutter_init (int *argc,
# endif
/* share the X11 Display with GTK+ */
- clutter_x11_set_display (GDK_DISPLAY());
+ clutter_x11_set_display (GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()));
/* let GTK+ in charge of the event handling */
clutter_x11_disable_event_retrieval ();
--
cgit v0.8.3.1-30-gff3a

View File

@ -1,24 +0,0 @@
From 39f437eb79d61cdba3e4fda773a4e849cf3aa73e Mon Sep 17 00:00:00 2001
From: Lucas Rocha <lucasr@litl.com>
Date: Fri, 10 Sep 2010 16:21:01 +0000
Subject: Use new --identifier-prefix flag in g-ir-scanner
The --strip-prefix option has been removed in latest g-ir-scanner.
http://bugzilla.clutter-project.org/show_bug.cgi?id=2308
---
diff --git a/clutter-gtk/Makefile.am b/clutter-gtk/Makefile.am
index 0f13aa0..60f2b58 100644
--- a/clutter-gtk/Makefile.am
+++ b/clutter-gtk/Makefile.am
@@ -68,7 +68,7 @@ INTROSPECTION_GIRS = GtkClutter-1.0.gir
GtkClutter-1.0.gir: libclutter-gtk-@CLUTTER_GTK_API_VERSION@.la $(INTROSPECTION_SCANNER) Makefile
-GtkClutter_1_0_gir_SCANNERFLAGS = --strip-prefix=GtkClutter --add-include-path=$(top_builddir)
+GtkClutter_1_0_gir_SCANNERFLAGS = --identifier-prefix=GtkClutter --add-include-path=$(top_builddir)
GtkClutter_1_0_gir_NAMESPACE = GtkClutter
GtkClutter_1_0_gir_VERSION = 1.0
GtkClutter_1_0_gir_INCLUDES = Gtk-3.0 Clutter-1.0
--
cgit v0.8.3.1-30-gff3a

View File

@ -1,49 +0,0 @@
From 29d4536122174a3495e49727200da3e4315527de Mon Sep 17 00:00:00 2001
From: Emmanuele Bassi <ebassi@linux.intel.com>
Date: Wed, 11 Aug 2010 12:50:31 +0000
Subject: build: Re-sync the introspection.m4 file
---
diff --git a/build/autotools/introspection.m4 b/build/autotools/introspection.m4
index bb3a0da..589721c 100644
--- a/build/autotools/introspection.m4
+++ b/build/autotools/introspection.m4
@@ -21,7 +21,7 @@ m4_define([_GOBJECT_INTROSPECTION_CHECK_INTERNAL],
],[dnl
AC_ARG_ENABLE(introspection,
AS_HELP_STRING([--enable-introspection[=@<:@no/auto/yes@:>@]],
- [Enable introspection for this build]),,
+ [Enable introspection for this build]),,
[enable_introspection=auto])
])dnl
@@ -42,7 +42,7 @@ m4_define([_GOBJECT_INTROSPECTION_CHECK_INTERNAL],
[auto],[dnl
PKG_CHECK_EXISTS([gobject-introspection-1.0 >= $1], found_introspection=yes, found_introspection=no)
],dnl
- [dnl
+ [dnl
AC_MSG_ERROR([invalid argument passed to --enable-introspection, should be one of @<:@no/auto/yes@:>@])
])dnl
@@ -59,12 +59,18 @@ m4_define([_GOBJECT_INTROSPECTION_CHECK_INTERNAL],
INTROSPECTION_GENERATE=`$PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0`
INTROSPECTION_GIRDIR=`$PKG_CONFIG --variable=girdir gobject-introspection-1.0`
INTROSPECTION_TYPELIBDIR="$($PKG_CONFIG --variable=typelibdir gobject-introspection-1.0)"
+ INTROSPECTION_CFLAGS=`$PKG_CONFIG --cflags gobject-introspection-1.0`
+ INTROSPECTION_LIBS=`$PKG_CONFIG --libs gobject-introspection-1.0`
+ INTROSPECTION_MAKEFILE=`$PKG_CONFIG --variable=datadir gobject-introspection-1.0`/gobject-introspection-1.0/Makefile.introspection
fi
AC_SUBST(INTROSPECTION_SCANNER)
AC_SUBST(INTROSPECTION_COMPILER)
AC_SUBST(INTROSPECTION_GENERATE)
AC_SUBST(INTROSPECTION_GIRDIR)
AC_SUBST(INTROSPECTION_TYPELIBDIR)
+ AC_SUBST(INTROSPECTION_CFLAGS)
+ AC_SUBST(INTROSPECTION_LIBS)
+ AC_SUBST(INTROSPECTION_MAKEFILE)
AM_CONDITIONAL(HAVE_INTROSPECTION, test "x$found_introspection" = "xyes")
])
--
cgit v0.8.3.1-30-gff3a

View File

@ -1,8 +1,8 @@
%define clutter_version 1.0
Name: clutter-gtk
Version: 0.90.2
Release: 3%{?dist}
Version: 0.91.2
Release: 1%{?dist}
Summary: A basic GTK clutter widget
Group: Development/Languages
@ -10,10 +10,6 @@ License: LGPLv2+
URL: http://www.clutter-project.org
Source0: http://www.clutter-project.org/sources/%{name}/%{clutter_version}/%{name}-%{version}.tar.bz2
Patch0: clutter-gtk-gir.patch
Patch1: clutter-gtk-intro.patch
Patch2: clutter-gtk-gdk.patch
BuildRequires: gtk3-devel
BuildRequires: clutter-devel
BuildRequires: gobject-introspection-devel
@ -36,9 +32,6 @@ clutter-gtk
%prep
%setup -q
%patch0 -p1 -b .gir
%patch1 -p1 -b .intro
%patch2 -p1 -b .gdk
%build
@ -75,6 +68,9 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/gtk-doc/html/clutter-gtk
%changelog
* Sun Oct 10 2010 Peter Robinson <pbrobinson@gmail.com> 0.91.2-1
- Update to 0.91.2
* Wed Sep 29 2010 Peter Robinson <pbrobinson@gmail.com> 0.90.2-3
- Add upstream patches to compile with latest gobject-introspection

View File

@ -1 +1 @@
77b6bd3c6f69ba096a1eff18e67c0ada clutter-gtk-0.90.2.tar.bz2
3bba16d26981ce94550c93cad66a8d5f clutter-gtk-0.91.2.tar.bz2