2.3.3.4-14.20130812.e8e3d20git
- 20130812 git snapshot - fix tests - %prep: explicitly delete bundled boost,zlib
This commit is contained in:
parent
b4add81f3f
commit
3693cab5ba
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
clucene-core-0.9.21b.tar.bz2
|
clucene-core-0.9.21b.tar.bz2
|
||||||
/clucene-core-2.3.3.4.tar.gz
|
/clucene-core-2.3.3.4.tar.gz
|
||||||
|
/clucene-core-2.3.3.4-e8e3d20.tar.xz
|
||||||
|
14
clucene-core-2.3.3.4-CLuceneConfig.patch
Normal file
14
clucene-core-2.3.3.4-CLuceneConfig.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -up clucene-core-2.3.3.4/src/core/CMakeLists.txt.CLuceneConfig.cmake clucene-core-2.3.3.4/src/core/CMakeLists.txt
|
||||||
|
--- clucene-core-2.3.3.4/src/core/CMakeLists.txt.CLuceneConfig.cmake 2011-03-16 19:21:07.000000000 -0500
|
||||||
|
+++ clucene-core-2.3.3.4/src/core/CMakeLists.txt 2014-10-07 19:32:17.042894690 -0500
|
||||||
|
@@ -251,8 +251,8 @@ file(WRITE "${CMAKE_CURRENT_BINARY_DIR}/
|
||||||
|
set(CLUCENE_VERSION ${CLUCENE_VERSION})
|
||||||
|
set(CLUCENE_SOVERSION ${CLUCENE_SOVERSION})
|
||||||
|
")
|
||||||
|
-install(FILES "${CMAKE_CURRENT_BINARY_DIR}/CLuceneConfig.cmake"
|
||||||
|
- DESTINATION ${LIB_DESTINATION}/CLuceneConfig.cmake)
|
||||||
|
+#install(FILES "${CMAKE_CURRENT_BINARY_DIR}/CLuceneConfig.cmake"
|
||||||
|
+# DESTINATION ${LIB_DESTINATION}/CLuceneConfig.cmake)
|
||||||
|
|
||||||
|
# install pkg-config file
|
||||||
|
IF(NOT WIN32)
|
11
clucene-core-2.3.3.4-usleep.patch
Normal file
11
clucene-core-2.3.3.4-usleep.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -up clucene-core-2.3.3.4/src/test/search/TestIndexSearcher.cpp.usleep clucene-core-2.3.3.4/src/test/search/TestIndexSearcher.cpp
|
||||||
|
--- clucene-core-2.3.3.4/src/test/search/TestIndexSearcher.cpp.usleep 2011-03-16 19:21:07.000000000 -0500
|
||||||
|
+++ clucene-core-2.3.3.4/src/test/search/TestIndexSearcher.cpp 2014-10-07 19:35:20.854480798 -0500
|
||||||
|
@@ -4,6 +4,7 @@
|
||||||
|
* Distributable under the terms of either the Apache License (Version 2.0) or
|
||||||
|
* the GNU Lesser General Public License, as specified in the COPYING file.
|
||||||
|
------------------------------------------------------------------------------*/
|
||||||
|
+#include <unistd.h>
|
||||||
|
#include "test.h"
|
||||||
|
|
||||||
|
DEFINE_MUTEX(searchMutex);
|
49
clucene.spec
49
clucene.spec
@ -1,12 +1,27 @@
|
|||||||
|
|
||||||
|
%define git_long e8e3d20f20da5ee3e37d347207b01890829a5475
|
||||||
|
%define git_short e8e3d20
|
||||||
|
%define snap 20130812
|
||||||
|
|
||||||
Summary: A C++ port of Lucene
|
Summary: A C++ port of Lucene
|
||||||
Name: clucene
|
Name: clucene
|
||||||
Version: 2.3.3.4
|
Version: 2.3.3.4
|
||||||
Release: 13%{?dist}
|
Release: 14.%{snap}.%{git_short}git%{?dist}
|
||||||
License: LGPLv2+ or ASL 2.0
|
License: LGPLv2+ or ASL 2.0
|
||||||
Group: Development/System
|
Group: Development/System
|
||||||
URL: http://www.sourceforge.net/projects/clucene
|
URL: http://www.sourceforge.net/projects/clucene
|
||||||
|
%if 0%{?snap}
|
||||||
|
# git archive e8e3d20f20da5ee3e37d347207b01890829a5475 --prefix=clucene-core-2.3.3.4/ | xz -9 > ../clucene-core-2.3.3.4-e8e3d20.tar.xz
|
||||||
|
Source0: clucene-core-2.3.3.4-%{git_short}.tar.xz
|
||||||
|
|
||||||
|
%else
|
||||||
Source0: http://downloads.sourceforge.net/clucene/clucene-core-%{version}.tar.gz
|
Source0: http://downloads.sourceforge.net/clucene/clucene-core-%{version}.tar.gz
|
||||||
BuildRequires: gawk cmake zlib-devel boost-devel
|
%endif
|
||||||
|
|
||||||
|
BuildRequires: boost-devel
|
||||||
|
BuildRequires: cmake
|
||||||
|
BuildRequires: gawk
|
||||||
|
BuildRequires: zlib-devel
|
||||||
|
|
||||||
## upstreamable patches
|
## upstreamable patches
|
||||||
# include LUCENE_SYS_INCLUDES in pkgconfig --cflags output
|
# include LUCENE_SYS_INCLUDES in pkgconfig --cflags output
|
||||||
@ -19,6 +34,10 @@ Patch50: clucene-core-2.3.3.4-pkgconfig.patch
|
|||||||
# https://sourceforge.net/tracker/index.php?func=detail&aid=3392466&group_id=80013&atid=558446
|
# https://sourceforge.net/tracker/index.php?func=detail&aid=3392466&group_id=80013&atid=558446
|
||||||
# contribs-lib is not built and installed even with config
|
# contribs-lib is not built and installed even with config
|
||||||
Patch51: clucene-core-2.3.3.4-install_contribs_lib.patch
|
Patch51: clucene-core-2.3.3.4-install_contribs_lib.patch
|
||||||
|
# Don't install CLuceneConfig.cmake twice
|
||||||
|
Patch52: clucene-core-2.3.3.4-CLuceneConfig.patch
|
||||||
|
# Fix tests for undefined usleep
|
||||||
|
Patch53: clucene-core-2.3.3.4-usleep.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
CLucene is a C++ port of the popular Apache Lucene search engine
|
CLucene is a C++ port of the popular Apache Lucene search engine
|
||||||
@ -61,6 +80,11 @@ Requires: %{name}-core%{?_isa} = %{version}-%{release}
|
|||||||
|
|
||||||
%patch50 -p1 -b .pkgconfig
|
%patch50 -p1 -b .pkgconfig
|
||||||
%patch51 -p1 -b .install_contribs_lib
|
%patch51 -p1 -b .install_contribs_lib
|
||||||
|
%patch52 -p1 -b .CLuceneConfig
|
||||||
|
%patch53 -p1 -b .usleep
|
||||||
|
|
||||||
|
# nuke bundled code
|
||||||
|
rm -rfv src/ext/{boost/,zlib/}
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -79,17 +103,15 @@ make %{?_smp_mflags} -C %{_target_platform}
|
|||||||
%install
|
%install
|
||||||
make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
|
make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
|
||||||
|
|
||||||
rm -rf %{buildroot}%{_libdir}/CLuceneConfig.cmake
|
|
||||||
|
|
||||||
|
|
||||||
%check
|
%check
|
||||||
# FIXME: do not run tests for ppc and s390 (big endian 32 bit archs) until
|
export PKG_CONFIG_PATH=%{buildroot}%{_libdir}/pkgconfig
|
||||||
# we have a proper fix
|
test "$(pkg-config --modversion libclucene-core)" = "%{version}"
|
||||||
%ifnarch ppc s390
|
# FIXME: make tests non-fatal for ppc and s390 (big endian 32 bit archs) until we have a proper fix
|
||||||
# Fails on all arches at the moment so temporaily disable
|
#ifnarch ppc s390
|
||||||
#make cl_test -C %{_target_platform}
|
export CTEST_OUTPUT_ON_FAILURE=1
|
||||||
#make test -C %{_target_platform}
|
time make -C %{_target_platform} test ARGS="--timeout 300 --output-on-failure" ||:
|
||||||
%endif
|
#endif
|
||||||
|
|
||||||
|
|
||||||
%post core -p /sbin/ldconfig
|
%post core -p /sbin/ldconfig
|
||||||
@ -123,6 +145,11 @@ rm -rf %{buildroot}%{_libdir}/CLuceneConfig.cmake
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 07 2014 Rex Dieter <rdieter@fedoraproject.org> - 2.3.3.4-14.20130812.e8e3d20git
|
||||||
|
- 20130812 git snapshot
|
||||||
|
- fix tests
|
||||||
|
- %%prep: explicitly delete bundled boost,zlib
|
||||||
|
|
||||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.3.4-13
|
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.3.4-13
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user