da2ae0160a
The most major problem is that it no longer seems possible to define a user via the user-defined cloud-config data and have that user get an SSH authorized_keys correctly installed, when the SSH key comes from the Ec2 datasource. This is a regression from the version shipped in F17 AFAICS, and it's fixed upstream[1]. There are a number of other F18 related fixes upstream which would be valuable, including: - Improved hostname handling (doesn't truncate hostnames containing ".")[2] - Fedora locale, hostname and tz related fixes[3] - Fedora systemd, blkid and sysconfig fixes (rev 809)[3] [1] https://bugs.launchpad.net/cloud-init/+bug/1100920 [2] https://bugs.launchpad.net/heat/+bug/1164400 [3] http://bazaar.launchpad.net/~gpadgett/cloud-init/ovirt/revision/802
34 lines
1.4 KiB
Diff
34 lines
1.4 KiB
Diff
diff -uNr cloud-init.orig/cloudinit/config/cc_keys_to_console.py cloud-init/cloudinit/config/cc_keys_to_console.py
|
|
--- cloud-init.orig/cloudinit/config/cc_keys_to_console.py 2013-04-12 14:03:11.049761648 +0100
|
|
+++ cloud-init/cloudinit/config/cc_keys_to_console.py 2013-04-12 14:13:09.660280218 +0100
|
|
@@ -26,7 +26,7 @@
|
|
frequency = PER_INSTANCE
|
|
|
|
# This is a tool that cloud init provides
|
|
-HELPER_TOOL = '/usr/lib/cloud-init/write-ssh-key-fingerprints'
|
|
+HELPER_TOOL = '/usr/libexec/cloud-init/write-ssh-key-fingerprints'
|
|
|
|
|
|
def handle(name, cfg, _cloud, log, _args):
|
|
diff -uNr cloud-init.orig/setup.py cloud-init/setup.py
|
|
--- cloud-init.orig/setup.py 2013-04-12 14:03:11.052761671 +0100
|
|
+++ cloud-init/setup.py 2013-04-12 14:08:12.828042068 +0100
|
|
@@ -45,7 +45,7 @@
|
|
INITSYS_ROOTS = {
|
|
'sysvinit': '/etc/rc.d/init.d',
|
|
'sysvinit_deb': '/etc/init.d',
|
|
- 'systemd': '/etc/systemd/system/',
|
|
+ 'systemd': '/usr/lib/systemd/system/',
|
|
'upstart': '/etc/init/',
|
|
}
|
|
INITSYS_TYPES = sorted(list(INITSYS_ROOTS.keys()))
|
|
@@ -123,7 +123,7 @@
|
|
('/etc/cloud/cloud.cfg.d', glob('config/cloud.cfg.d/*')),
|
|
('/etc/cloud/templates', glob('templates/*')),
|
|
('/usr/share/cloud-init', []),
|
|
- ('/usr/lib/cloud-init',
|
|
+ ('/usr/libexec/cloud-init',
|
|
['tools/uncloud-init',
|
|
'tools/write-ssh-key-fingerprints']),
|
|
('/usr/share/doc/cloud-init',
|