Add missed patch, remove unused patches
This commit is contained in:
parent
44c9fcdf12
commit
e95c4d9d2b
40
Move-helper-tools-to-usr-lib.patch
Normal file
40
Move-helper-tools-to-usr-lib.patch
Normal file
@ -0,0 +1,40 @@
|
|||||||
|
From 08c53df33fba378116ae4cf61e107407537ed761 Mon Sep 17 00:00:00 2001
|
||||||
|
From: rpm-build <rpm-build>
|
||||||
|
Date: Fri, 14 Nov 2014 13:45:22 -0500
|
||||||
|
Subject: [PATCH] Move helper tools to usr/lib
|
||||||
|
|
||||||
|
This is more in line with the Fedora filesystem standards.
|
||||||
|
---
|
||||||
|
cloudinit/config/cc_keys_to_console.py | 2 +-
|
||||||
|
setup.py | 2 +-
|
||||||
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/cloudinit/config/cc_keys_to_console.py b/cloudinit/config/cc_keys_to_console.py
|
||||||
|
index ed7af69..e8bc33a 100644
|
||||||
|
--- a/cloudinit/config/cc_keys_to_console.py
|
||||||
|
+++ b/cloudinit/config/cc_keys_to_console.py
|
||||||
|
@@ -26,7 +26,7 @@ from cloudinit import util
|
||||||
|
frequency = PER_INSTANCE
|
||||||
|
|
||||||
|
# This is a tool that cloud init provides
|
||||||
|
-HELPER_TOOL = '/usr/lib/cloud-init/write-ssh-key-fingerprints'
|
||||||
|
+HELPER_TOOL = '/usr/libexec/cloud-init/write-ssh-key-fingerprints'
|
||||||
|
|
||||||
|
|
||||||
|
def handle(name, cfg, _cloud, log, _args):
|
||||||
|
diff --git a/setup.py b/setup.py
|
||||||
|
index bd41bc9..dbc9105 100755
|
||||||
|
--- a/setup.py
|
||||||
|
+++ b/setup.py
|
||||||
|
@@ -149,7 +149,7 @@ setuptools.setup(name='cloud-init',
|
||||||
|
data_files=[(ETC + '/cloud', glob('config/*.cfg')),
|
||||||
|
(ETC + '/cloud/cloud.cfg.d', glob('config/cloud.cfg.d/*')),
|
||||||
|
(ETC + '/cloud/templates', glob('templates/*')),
|
||||||
|
- (USR + '/lib/cloud-init',
|
||||||
|
+ (USR + '/libexec/cloud-init',
|
||||||
|
['tools/uncloud-init',
|
||||||
|
'tools/write-ssh-key-fingerprints']),
|
||||||
|
(USR + '/share/doc/cloud-init',
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
@ -1,33 +0,0 @@
|
|||||||
diff -uNr cloud-init.orig/cloudinit/config/cc_keys_to_console.py cloud-init/cloudinit/config/cc_keys_to_console.py
|
|
||||||
--- cloud-init.orig/cloudinit/config/cc_keys_to_console.py 2013-04-12 14:03:11.049761648 +0100
|
|
||||||
+++ cloud-init/cloudinit/config/cc_keys_to_console.py 2013-04-12 14:13:09.660280218 +0100
|
|
||||||
@@ -26,7 +26,7 @@
|
|
||||||
frequency = PER_INSTANCE
|
|
||||||
|
|
||||||
# This is a tool that cloud init provides
|
|
||||||
-HELPER_TOOL = '/usr/lib/cloud-init/write-ssh-key-fingerprints'
|
|
||||||
+HELPER_TOOL = '/usr/libexec/cloud-init/write-ssh-key-fingerprints'
|
|
||||||
|
|
||||||
|
|
||||||
def handle(name, cfg, _cloud, log, _args):
|
|
||||||
diff -uNr cloud-init.orig/setup.py cloud-init/setup.py
|
|
||||||
--- cloud-init.orig/setup.py 2013-04-12 14:03:11.052761671 +0100
|
|
||||||
+++ cloud-init/setup.py 2013-04-12 14:08:12.828042068 +0100
|
|
||||||
@@ -45,7 +45,7 @@
|
|
||||||
INITSYS_ROOTS = {
|
|
||||||
'sysvinit': '/etc/rc.d/init.d',
|
|
||||||
'sysvinit_deb': '/etc/init.d',
|
|
||||||
- 'systemd': '/etc/systemd/system/',
|
|
||||||
+ 'systemd': '/usr/lib/systemd/system/',
|
|
||||||
'upstart': '/etc/init/',
|
|
||||||
}
|
|
||||||
INITSYS_TYPES = sorted(list(INITSYS_ROOTS.keys()))
|
|
||||||
@@ -123,7 +123,7 @@
|
|
||||||
('/etc/cloud/cloud.cfg.d', glob('config/cloud.cfg.d/*')),
|
|
||||||
('/etc/cloud/templates', glob('templates/*')),
|
|
||||||
('/usr/share/cloud-init', []),
|
|
||||||
- ('/usr/lib/cloud-init',
|
|
||||||
+ ('/usr/libexec/cloud-init',
|
|
||||||
['tools/uncloud-init',
|
|
||||||
'tools/write-ssh-key-fingerprints']),
|
|
||||||
('/usr/share/doc/cloud-init',
|
|
@ -1,11 +0,0 @@
|
|||||||
--- cloud-init-0.7.5/cloudinit/settings.py.orig 2014-06-12 19:45:29.132522989 -0500
|
|
||||||
+++ cloud-init-0.7.5/cloudinit/settings.py 2014-06-12 19:45:40.670481588 -0500
|
|
||||||
@@ -37,7 +37,7 @@
|
|
||||||
'OVF',
|
|
||||||
'MAAS',
|
|
||||||
'GCE',
|
|
||||||
- 'OpenStack'
|
|
||||||
+ 'OpenStack',
|
|
||||||
'Ec2',
|
|
||||||
'CloudSigma',
|
|
||||||
'CloudStack',
|
|
Loading…
Reference in New Issue
Block a user