update to upstream revision 809 to fix various issues
The most major problem is that it no longer seems possible to define a user via the user-defined cloud-config data and have that user get an SSH authorized_keys correctly installed, when the SSH key comes from the Ec2 datasource. This is a regression from the version shipped in F17 AFAICS, and it's fixed upstream[1]. There are a number of other F18 related fixes upstream which would be valuable, including: - Improved hostname handling (doesn't truncate hostnames containing ".")[2] - Fedora locale, hostname and tz related fixes[3] - Fedora systemd, blkid and sysconfig fixes (rev 809)[3] [1] https://bugs.launchpad.net/cloud-init/+bug/1100920 [2] https://bugs.launchpad.net/heat/+bug/1164400 [3] http://bazaar.launchpad.net/~gpadgett/cloud-init/ovirt/revision/802
This commit is contained in:
parent
3eb2ef9003
commit
da2ae0160a
@ -1,8 +1,7 @@
|
||||
Index: cloud-init/cloudinit/config/cc_keys_to_console.py
|
||||
===================================================================
|
||||
--- cloud-init.orig/cloudinit/config/cc_keys_to_console.py
|
||||
+++ cloud-init/cloudinit/config/cc_keys_to_console.py
|
||||
@@ -26,7 +26,7 @@ from cloudinit import util
|
||||
diff -uNr cloud-init.orig/cloudinit/config/cc_keys_to_console.py cloud-init/cloudinit/config/cc_keys_to_console.py
|
||||
--- cloud-init.orig/cloudinit/config/cc_keys_to_console.py 2013-04-12 14:03:11.049761648 +0100
|
||||
+++ cloud-init/cloudinit/config/cc_keys_to_console.py 2013-04-12 14:13:09.660280218 +0100
|
||||
@@ -26,7 +26,7 @@
|
||||
frequency = PER_INSTANCE
|
||||
|
||||
# This is a tool that cloud init provides
|
||||
@ -11,20 +10,19 @@ Index: cloud-init/cloudinit/config/cc_keys_to_console.py
|
||||
|
||||
|
||||
def handle(name, cfg, _cloud, log, _args):
|
||||
Index: cloud-init/setup.py
|
||||
===================================================================
|
||||
--- cloud-init.orig/setup.py
|
||||
+++ cloud-init/setup.py
|
||||
@@ -43,7 +43,7 @@ INITSYS_FILES = {
|
||||
}
|
||||
diff -uNr cloud-init.orig/setup.py cloud-init/setup.py
|
||||
--- cloud-init.orig/setup.py 2013-04-12 14:03:11.052761671 +0100
|
||||
+++ cloud-init/setup.py 2013-04-12 14:08:12.828042068 +0100
|
||||
@@ -45,7 +45,7 @@
|
||||
INITSYS_ROOTS = {
|
||||
'sysvinit': '/etc/rc.d/init.d',
|
||||
'sysvinit_deb': '/etc/init.d',
|
||||
- 'systemd': '/etc/systemd/system/',
|
||||
+ 'systemd': '/usr/lib/systemd/system/',
|
||||
'upstart': '/etc/init/',
|
||||
}
|
||||
INITSYS_TYPES = sorted(list(INITSYS_ROOTS.keys()))
|
||||
@@ -120,7 +120,7 @@ setuptools.setup(name='cloud-init',
|
||||
@@ -123,7 +123,7 @@
|
||||
('/etc/cloud/cloud.cfg.d', glob('config/cloud.cfg.d/*')),
|
||||
('/etc/cloud/templates', glob('templates/*')),
|
||||
('/usr/share/cloud-init', []),
|
@ -1,24 +1,17 @@
|
||||
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||
|
||||
Name: cloud-init
|
||||
Version: 0.7.1
|
||||
Release: 4%{?dist}
|
||||
Version: 0.7.2
|
||||
Release: 0.1.bzr809%{?dist}
|
||||
Summary: Cloud instance init scripts
|
||||
|
||||
Group: System Environment/Base
|
||||
License: GPLv3
|
||||
URL: http://launchpad.net/cloud-init
|
||||
Source0: https://launchpad.net/cloud-init/trunk/0.7.1/+download/cloud-init-0.7.1.tar.gz
|
||||
Source0: http://bazaar.launchpad.net/~cloud-init-dev/cloud-init/trunk/tarball/809?/cloud-init-0.7.2-bzr809.tar.gz
|
||||
Source1: cloud-init-fedora.cfg
|
||||
Source2: cloud-init-README.fedora
|
||||
Patch0: cloud-init-0.7.0-fedora.patch
|
||||
# Fix broken sudoers file generation
|
||||
# http://bazaar.launchpad.net/~cloud-init-dev/cloud-init/trunk/revision/740
|
||||
Patch1: cloud-init-0.7.1-sudo-iterstr.patch
|
||||
# Fix "resize_root: noblock"
|
||||
# https://launchpad.net/bugs/1080985
|
||||
# http://bazaar.launchpad.net/~cloud-init-dev/cloud-init/trunk/revision/743
|
||||
Patch2: cloud-init-0.7.1-noblock.patch
|
||||
Patch0: cloud-init-0.7.2-fedora.patch
|
||||
|
||||
BuildArch: noarch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -53,9 +46,8 @@ ssh keys and to let the user run various scripts.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%setup -q -n %{name}-%{version}-bzr809
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
cp -p %{SOURCE2} README.fedora
|
||||
|
||||
@ -136,6 +128,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu May 02 2013 Steven Hardy <shardy@redhat.com> - 0.7.2-0.1.bzr809
|
||||
- Rebased against upstream rev 809, fixes several F18 related issues
|
||||
|
||||
* Sat Apr 6 2013 Orion Poplawski <orion@cora.nwra.com> - 0.7.1-4
|
||||
- Don't ship tests
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user