diff --git a/ci-fix-Add-subnet-ipv4-ipv6-to-network-schema-5191.patch b/ci-fix-Add-subnet-ipv4-ipv6-to-network-schema-5191.patch
new file mode 100644
index 0000000..4c75da5
--- /dev/null
+++ b/ci-fix-Add-subnet-ipv4-ipv6-to-network-schema-5191.patch
@@ -0,0 +1,45 @@
+From 6a61ce0f0cde11551bfe92835d0b33c7b1022b68 Mon Sep 17 00:00:00 2001
+From: James Falcon <james.falcon@canonical.com>
+Date: Thu, 18 Apr 2024 20:27:27 -0500
+Subject: [PATCH] fix: Add subnet ipv4/ipv6  to network schema (#5191)
+
+RH-Author: Ani Sinha <anisinha@redhat.com>
+RH-MergeRequest: 109: fix: Add subnet ipv4/ipv6  to network schema (#5191)
+RH-Jira: RHEL-54686
+RH-Acked-by: Emanuele Giuseppe Esposito <eesposit@redhat.com>
+RH-Acked-by: Cathy Avery <cavery@redhat.com>
+RH-Commit: [1/1] 83692fac8f9af1831970091bdf7c43d0e59f314c (anisinha/cloud-init)
+
+These are used by our openstack network_data.json parsing code and
+get used by the sysconfig renderer.
+
+Fixes GH-4911
+
+(cherry picked from commit 0b1ca174095e3ad685e6d6649bb08aafb19a95b9)
+Signed-off-by: Ani Sinha <anisinha@redhat.com>
+---
+ cloudinit/config/schemas/schema-network-config-v1.json | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/cloudinit/config/schemas/schema-network-config-v1.json b/cloudinit/config/schemas/schema-network-config-v1.json
+index 64c492a4..f485c784 100644
+--- a/cloudinit/config/schemas/schema-network-config-v1.json
++++ b/cloudinit/config/schemas/schema-network-config-v1.json
+@@ -523,6 +523,14 @@
+           "items": {
+             "$ref": "#/$defs/anyOf_type_route"
+           }
++        },
++        "ipv4": {
++          "type": "boolean",
++          "description": "Indicate if the subnet is IPv4. If not specified, it will be inferred from the subnet type or address. This exists for compatibility with OpenStack's ``network_data.json`` when rendered through sysconfig."
++        },
++        "ipv6": {
++          "type": "boolean",
++          "description": "Indicate if the subnet is IPv6. If not specified, it will be inferred from the subnet type or address. This is exists for compatibility with OpenStack's ``network_data.json`` when rendered through sysconfig."
+         }
+       }
+     },
+-- 
+2.39.3
+
diff --git a/cloud-init.spec b/cloud-init.spec
index 27fc0ca..8d4764d 100644
--- a/cloud-init.spec
+++ b/cloud-init.spec
@@ -1,6 +1,6 @@
 Name:           cloud-init
 Version:        23.4
-Release:        18%{?dist}
+Release:        19%{?dist}
 Summary:        Cloud instance init scripts
 License:        ASL 2.0 or GPLv3
 URL:            http://launchpad.net/cloud-init
@@ -65,6 +65,8 @@ Patch31: ci-fix-Clean-cache-if-no-datasource-fallback-5499.patch
 Patch32: ci-Support-setting-mirrorlist-in-yum-repository-config-.patch
 # For RHEL-54373 - [RHEL9]Revert "fix(vmware): Set IPv6 to dhcp when there is no IPv6 addr (#5471)"
 Patch33: ci-Revert-fix-vmware-Set-IPv6-to-dhcp-when-there-is-no-.patch
+# For RHEL-54686 - [RHEL-9.5] cloud-init schema validation fails.
+Patch34: ci-fix-Add-subnet-ipv4-ipv6-to-network-schema-5191.patch
 
 BuildArch:      noarch
 
@@ -279,6 +281,11 @@ fi
 %config(noreplace) %{_sysconfdir}/rsyslog.d/21-cloudinit.conf
 
 %changelog
+* Mon Aug 26 2024 Miroslav Rezanina <mrezanin@redhat.com> - 23.4-19
+- ci-fix-Add-subnet-ipv4-ipv6-to-network-schema-5191.patch [RHEL-54686]
+- Resolves: RHEL-54686
+  ([RHEL-9.5] cloud-init schema validation fails.)
+
 * Mon Aug 19 2024 Miroslav Rezanina <mrezanin@redhat.com> - 23.4-18
 - ci-Revert-fix-vmware-Set-IPv6-to-dhcp-when-there-is-no-.patch [RHEL-54373]
 - Resolves: RHEL-54373