Auto sync2gitlab import of cloud-init-22.1-4.el8.src.rpm
This commit is contained in:
parent
0680461e5e
commit
aa61624c50
57
ci-setup.py-adjust-udev-rules-default-path-1513.patch
Normal file
57
ci-setup.py-adjust-udev-rules-default-path-1513.patch
Normal file
@ -0,0 +1,57 @@
|
|||||||
|
From ed7060ac1d5003f70fc3da4d6006a1a958a47b04 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Emanuele Giuseppe Esposito <eesposit@redhat.com>
|
||||||
|
Date: Mon, 20 Jun 2022 10:31:14 +0200
|
||||||
|
Subject: [PATCH 2/2] setup.py: adjust udev/rules default path (#1513)
|
||||||
|
|
||||||
|
RH-Author: Emanuele Giuseppe Esposito <eesposit@redhat.com>
|
||||||
|
RH-MergeRequest: 80: setup.py: adjust udev/rules default path (#1513)
|
||||||
|
RH-Commit: [2/2] 2cb64b004acbe1b6a30f943b0da51d2d1f2f0d50 (eesposit/cloud-init)
|
||||||
|
RH-Bugzilla: 2096269
|
||||||
|
RH-Acked-by: Vitaly Kuznetsov <vkuznets@redhat.com>
|
||||||
|
RH-Acked-by: Mohamed Gamal Morsy <mmorsy@redhat.com>
|
||||||
|
|
||||||
|
commit 70715125f3af118ae242770e61064c24f41e9a02
|
||||||
|
Author: Emanuele Giuseppe Esposito <eesposit@redhat.com>
|
||||||
|
Date: Thu Jun 16 20:39:42 2022 +0200
|
||||||
|
|
||||||
|
setup.py: adjust udev/rules default path (#1513)
|
||||||
|
|
||||||
|
RHEL must put cloudinit .rules files in /usr/lib/udev/rules.d
|
||||||
|
This place is a rhel standard and since it is used by all packages
|
||||||
|
cannot be modified.
|
||||||
|
|
||||||
|
Signed-off-by: Emanuele Giuseppe Esposito <eesposit@redhat.com>
|
||||||
|
|
||||||
|
Signed-off-by: Emanuele Giuseppe Esposito <eesposit@redhat.com>
|
||||||
|
---
|
||||||
|
setup.py | 7 ++++++-
|
||||||
|
1 file changed, 6 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/setup.py b/setup.py
|
||||||
|
index a9132d2c..fdf27cd7 100755
|
||||||
|
--- a/setup.py
|
||||||
|
+++ b/setup.py
|
||||||
|
@@ -302,6 +302,11 @@ data_files = [
|
||||||
|
),
|
||||||
|
]
|
||||||
|
if not platform.system().endswith("BSD"):
|
||||||
|
+
|
||||||
|
+ RULES_PATH = LIB
|
||||||
|
+ if os.path.isfile("/etc/redhat-release"):
|
||||||
|
+ RULES_PATH = "/usr/lib"
|
||||||
|
+
|
||||||
|
data_files.extend(
|
||||||
|
[
|
||||||
|
(
|
||||||
|
@@ -309,7 +314,7 @@ if not platform.system().endswith("BSD"):
|
||||||
|
["tools/hook-network-manager"],
|
||||||
|
),
|
||||||
|
(ETC + "/dhcp/dhclient-exit-hooks.d/", ["tools/hook-dhclient"]),
|
||||||
|
- (LIB + "/udev/rules.d", [f for f in glob("udev/*.rules")]),
|
||||||
|
+ (RULES_PATH + "/udev/rules.d", [f for f in glob("udev/*.rules")]),
|
||||||
|
(
|
||||||
|
ETC + "/systemd/system/sshd-keygen@.service.d/",
|
||||||
|
["systemd/disable-sshd-keygen-if-cloud-init-active.conf"],
|
||||||
|
--
|
||||||
|
2.31.1
|
||||||
|
|
@ -6,7 +6,7 @@
|
|||||||
|
|
||||||
Name: cloud-init
|
Name: cloud-init
|
||||||
Version: 22.1
|
Version: 22.1
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: Cloud instance init scripts
|
Summary: Cloud instance init scripts
|
||||||
|
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -31,6 +31,8 @@ Patch9: ci-Align-rhel-custom-files-with-upstream-1431.patch
|
|||||||
Patch10: ci-Remove-rhel-specific-files.patch
|
Patch10: ci-Remove-rhel-specific-files.patch
|
||||||
# For bz#2082686 - [cloud][init] Add support for reading tags from instance metadata
|
# For bz#2082686 - [cloud][init] Add support for reading tags from instance metadata
|
||||||
Patch11: ci-Support-EC2-tags-in-instance-metadata-1309.patch
|
Patch11: ci-Support-EC2-tags-in-instance-metadata-1309.patch
|
||||||
|
# For bz#2096269 - Adjust udev/rules default path[RHEL-8]
|
||||||
|
Patch12: ci-setup.py-adjust-udev-rules-default-path-1513.patch
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
@ -205,7 +207,7 @@ fi
|
|||||||
%dir /var/lib/cloud
|
%dir /var/lib/cloud
|
||||||
/etc/NetworkManager/dispatcher.d/cloud-init-azure-hook
|
/etc/NetworkManager/dispatcher.d/cloud-init-azure-hook
|
||||||
/etc/dhcp/dhclient-exit-hooks.d/hook-dhclient
|
/etc/dhcp/dhclient-exit-hooks.d/hook-dhclient
|
||||||
/lib/udev/rules.d/66-azure-ephemeral.rules
|
%{_udevrulesdir}/66-azure-ephemeral.rules
|
||||||
%{_datadir}/bash-completion/completions/cloud-init
|
%{_datadir}/bash-completion/completions/cloud-init
|
||||||
%{_bindir}/cloud-id
|
%{_bindir}/cloud-id
|
||||||
/usr/lib/systemd/system-generators/cloud-init-generator
|
/usr/lib/systemd/system-generators/cloud-init-generator
|
||||||
@ -216,6 +218,12 @@ fi
|
|||||||
%config(noreplace) %{_sysconfdir}/rsyslog.d/21-cloudinit.conf
|
%config(noreplace) %{_sysconfdir}/rsyslog.d/21-cloudinit.conf
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 12 2022 Miroslav Rezanina <mrezanin@redhat.com> - 22.1-4
|
||||||
|
- ci-cloud-init.spec-adjust-path-for-66-azure-ephemeral.r.patch [bz#2096269]
|
||||||
|
- ci-setup.py-adjust-udev-rules-default-path-1513.patch [bz#2096269]
|
||||||
|
- Resolves: bz#2096269
|
||||||
|
(Adjust udev/rules default path[RHEL-8])
|
||||||
|
|
||||||
* Thu Jun 23 2022 Jon Maloy <jmaloy@redhat.com> - 22.1-3
|
* Thu Jun 23 2022 Jon Maloy <jmaloy@redhat.com> - 22.1-3
|
||||||
- ci-Support-EC2-tags-in-instance-metadata-1309.patch [bz#2082686]
|
- ci-Support-EC2-tags-in-instance-metadata-1309.patch [bz#2082686]
|
||||||
- Resolves: bz#2082686
|
- Resolves: bz#2082686
|
||||||
|
Loading…
Reference in New Issue
Block a user