Remove old patches for the 0.7.2 series
This commit is contained in:
parent
729a213e1b
commit
a1649cd763
@ -1,33 +0,0 @@
|
||||
diff -uNr cloud-init.orig/cloudinit/config/cc_keys_to_console.py cloud-init/cloudinit/config/cc_keys_to_console.py
|
||||
--- cloud-init.orig/cloudinit/config/cc_keys_to_console.py 2013-04-12 14:03:11.049761648 +0100
|
||||
+++ cloud-init/cloudinit/config/cc_keys_to_console.py 2013-04-12 14:13:09.660280218 +0100
|
||||
@@ -26,7 +26,7 @@
|
||||
frequency = PER_INSTANCE
|
||||
|
||||
# This is a tool that cloud init provides
|
||||
-HELPER_TOOL = '/usr/lib/cloud-init/write-ssh-key-fingerprints'
|
||||
+HELPER_TOOL = '/usr/libexec/cloud-init/write-ssh-key-fingerprints'
|
||||
|
||||
|
||||
def handle(name, cfg, _cloud, log, _args):
|
||||
diff -uNr cloud-init.orig/setup.py cloud-init/setup.py
|
||||
--- cloud-init.orig/setup.py 2013-04-12 14:03:11.052761671 +0100
|
||||
+++ cloud-init/setup.py 2013-04-12 14:08:12.828042068 +0100
|
||||
@@ -45,7 +45,7 @@
|
||||
INITSYS_ROOTS = {
|
||||
'sysvinit': '/etc/rc.d/init.d',
|
||||
'sysvinit_deb': '/etc/init.d',
|
||||
- 'systemd': '/etc/systemd/system/',
|
||||
+ 'systemd': '/usr/lib/systemd/system/',
|
||||
'upstart': '/etc/init/',
|
||||
}
|
||||
INITSYS_TYPES = sorted(list(INITSYS_ROOTS.keys()))
|
||||
@@ -123,7 +123,7 @@
|
||||
('/etc/cloud/cloud.cfg.d', glob('config/cloud.cfg.d/*')),
|
||||
('/etc/cloud/templates', glob('templates/*')),
|
||||
('/usr/share/cloud-init', []),
|
||||
- ('/usr/lib/cloud-init',
|
||||
+ ('/usr/libexec/cloud-init',
|
||||
['tools/uncloud-init',
|
||||
'tools/write-ssh-key-fingerprints']),
|
||||
('/usr/share/doc/cloud-init',
|
@ -1,73 +0,0 @@
|
||||
Index: cloud-init-0.7.2/cloudinit/util.py
|
||||
===================================================================
|
||||
--- cloud-init-0.7.2.orig/cloudinit/util.py
|
||||
+++ cloud-init-0.7.2/cloudinit/util.py
|
||||
@@ -361,11 +361,11 @@ def multi_log(text, console=True, stderr
|
||||
if stderr:
|
||||
sys.stderr.write(text)
|
||||
if console:
|
||||
- # Don't use the write_file since
|
||||
- # this might be 'sensitive' info (not debug worthy?)
|
||||
- with open('/dev/console', 'wb') as wfh:
|
||||
- wfh.write(text)
|
||||
- wfh.flush()
|
||||
+ # Some containers lack /dev/console, so we send output to
|
||||
+ # stdout and configure upstart with "console output" and
|
||||
+ # systemd with "journal+console" and let them take care of
|
||||
+ # getting output to the console.
|
||||
+ print text
|
||||
if log:
|
||||
if text[-1] == "\n":
|
||||
log.log(log_level, text[:-1])
|
||||
Index: cloud-init-0.7.2/systemd/cloud-config.service
|
||||
===================================================================
|
||||
--- cloud-init-0.7.2.orig/systemd/cloud-config.service
|
||||
+++ cloud-init-0.7.2/systemd/cloud-config.service
|
||||
@@ -11,7 +11,7 @@ RemainAfterExit=yes
|
||||
TimeoutSec=0
|
||||
|
||||
# Output needs to appear in instance console output
|
||||
-StandardOutput=tty
|
||||
+StandardOutput=journal+console
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
||||
Index: cloud-init-0.7.2/systemd/cloud-final.service
|
||||
===================================================================
|
||||
--- cloud-init-0.7.2.orig/systemd/cloud-final.service
|
||||
+++ cloud-init-0.7.2/systemd/cloud-final.service
|
||||
@@ -11,7 +11,7 @@ RemainAfterExit=yes
|
||||
TimeoutSec=0
|
||||
|
||||
# Output needs to appear in instance console output
|
||||
-StandardOutput=tty
|
||||
+StandardOutput=journal+console
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
||||
Index: cloud-init-0.7.2/systemd/cloud-init-local.service
|
||||
===================================================================
|
||||
--- cloud-init-0.7.2.orig/systemd/cloud-init-local.service
|
||||
+++ cloud-init-0.7.2/systemd/cloud-init-local.service
|
||||
@@ -10,7 +10,7 @@ RemainAfterExit=yes
|
||||
TimeoutSec=0
|
||||
|
||||
# Output needs to appear in instance console output
|
||||
-StandardOutput=tty
|
||||
+StandardOutput=journal+console
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
||||
Index: cloud-init-0.7.2/systemd/cloud-init.service
|
||||
===================================================================
|
||||
--- cloud-init-0.7.2.orig/systemd/cloud-init.service
|
||||
+++ cloud-init-0.7.2/systemd/cloud-init.service
|
||||
@@ -11,7 +11,7 @@ RemainAfterExit=yes
|
||||
TimeoutSec=0
|
||||
|
||||
# Output needs to appear in instance console output
|
||||
-StandardOutput=tty
|
||||
+StandardOutput=journal+console
|
||||
|
||||
[Install]
|
||||
WantedBy=multi-user.target
|
@ -1,19 +0,0 @@
|
||||
Index: cloud-init-0.7.2/cloudinit/config/cc_puppet.py
|
||||
===================================================================
|
||||
--- cloud-init-0.7.2.orig/cloudinit/config/cc_puppet.py
|
||||
+++ cloud-init-0.7.2/cloudinit/config/cc_puppet.py
|
||||
@@ -39,7 +39,7 @@ def _autostart_puppet(log):
|
||||
'-e', 's/^START=.*/START=yes/',
|
||||
'/etc/default/puppet'], capture=False)
|
||||
elif os.path.exists('/bin/systemctl'):
|
||||
- util.subp(['/bin/systemctl', 'enable', 'puppet.service'],
|
||||
+ util.subp(['/bin/systemctl', 'enable', 'puppetagent.service'],
|
||||
capture=False)
|
||||
elif os.path.exists('/sbin/chkconfig'):
|
||||
util.subp(['/sbin/chkconfig', 'puppet', 'on'], capture=False)
|
||||
@@ -115,4 +115,4 @@ def handle(name, cfg, cloud, log, _args)
|
||||
_autostart_puppet(log)
|
||||
|
||||
# Start puppetd
|
||||
- util.subp(['service', 'puppet', 'start'], capture=False)
|
||||
+ util.subp(['service', 'puppetagent', 'start'], capture=False)
|
@ -1,11 +0,0 @@
|
||||
Index: cloud-init-0.7.2/tools/21-cloudinit.conf
|
||||
===================================================================
|
||||
--- cloud-init-0.7.2.orig/tools/21-cloudinit.conf
|
||||
+++ cloud-init-0.7.2/tools/21-cloudinit.conf
|
||||
@@ -1,5 +1,5 @@
|
||||
# Log cloudinit generated log messages to file
|
||||
-:syslogtag, isequal, "[CLOUDINIT]" /var/log/cloud-init.log
|
||||
+:programname, isequal, "cloud-init" /var/log/cloud-init.log
|
||||
|
||||
# comment out the following line to allow CLOUDINIT messages through.
|
||||
# Doing so means you'll also get CLOUDINIT messages in /var/log/syslog
|
@ -1,20 +0,0 @@
|
||||
Index: cloud-init-0.7.2/cloudinit/util.py
|
||||
===================================================================
|
||||
--- cloud-init-0.7.2.orig/cloudinit/util.py
|
||||
+++ cloud-init-0.7.2/cloudinit/util.py
|
||||
@@ -161,13 +161,13 @@ class SeLinuxGuard(object):
|
||||
self.recursive = recursive
|
||||
|
||||
def __enter__(self):
|
||||
- if self.selinux:
|
||||
+ if self.selinux and self.selinux.is_selinux_enabled():
|
||||
return True
|
||||
else:
|
||||
return False
|
||||
|
||||
def __exit__(self, excp_type, excp_value, excp_traceback):
|
||||
- if self.selinux:
|
||||
+ if self.selinux and self.selinux.is_selinux_enabled():
|
||||
path = os.path.realpath(os.path.expanduser(self.path))
|
||||
do_restore = False
|
||||
try:
|
Loading…
Reference in New Issue
Block a user