Update to 0.7.5 and rename associate patches
Removing unnecessary patches will be in a subsequent commit.
This commit is contained in:
parent
063a33c0ad
commit
729a213e1b
33
cloud-init-0.7.5-fedora.patch
Normal file
33
cloud-init-0.7.5-fedora.patch
Normal file
@ -0,0 +1,33 @@
|
||||
diff -uNr cloud-init.orig/cloudinit/config/cc_keys_to_console.py cloud-init/cloudinit/config/cc_keys_to_console.py
|
||||
--- cloud-init.orig/cloudinit/config/cc_keys_to_console.py 2013-04-12 14:03:11.049761648 +0100
|
||||
+++ cloud-init/cloudinit/config/cc_keys_to_console.py 2013-04-12 14:13:09.660280218 +0100
|
||||
@@ -26,7 +26,7 @@
|
||||
frequency = PER_INSTANCE
|
||||
|
||||
# This is a tool that cloud init provides
|
||||
-HELPER_TOOL = '/usr/lib/cloud-init/write-ssh-key-fingerprints'
|
||||
+HELPER_TOOL = '/usr/libexec/cloud-init/write-ssh-key-fingerprints'
|
||||
|
||||
|
||||
def handle(name, cfg, _cloud, log, _args):
|
||||
diff -uNr cloud-init.orig/setup.py cloud-init/setup.py
|
||||
--- cloud-init.orig/setup.py 2013-04-12 14:03:11.052761671 +0100
|
||||
+++ cloud-init/setup.py 2013-04-12 14:08:12.828042068 +0100
|
||||
@@ -45,7 +45,7 @@
|
||||
INITSYS_ROOTS = {
|
||||
'sysvinit': '/etc/rc.d/init.d',
|
||||
'sysvinit_deb': '/etc/init.d',
|
||||
- 'systemd': '/etc/systemd/system/',
|
||||
+ 'systemd': '/usr/lib/systemd/system/',
|
||||
'upstart': '/etc/init/',
|
||||
}
|
||||
INITSYS_TYPES = sorted(list(INITSYS_ROOTS.keys()))
|
||||
@@ -123,7 +123,7 @@
|
||||
('/etc/cloud/cloud.cfg.d', glob('config/cloud.cfg.d/*')),
|
||||
('/etc/cloud/templates', glob('templates/*')),
|
||||
('/usr/share/cloud-init', []),
|
||||
- ('/usr/lib/cloud-init',
|
||||
+ ('/usr/libexec/cloud-init',
|
||||
['tools/uncloud-init',
|
||||
'tools/write-ssh-key-fingerprints']),
|
||||
('/usr/share/doc/cloud-init',
|
11
cloud-init-0.7.5-rsyslog-programname.patch
Normal file
11
cloud-init-0.7.5-rsyslog-programname.patch
Normal file
@ -0,0 +1,11 @@
|
||||
Index: cloud-init-0.7.2/tools/21-cloudinit.conf
|
||||
===================================================================
|
||||
--- cloud-init-0.7.2.orig/tools/21-cloudinit.conf
|
||||
+++ cloud-init-0.7.2/tools/21-cloudinit.conf
|
||||
@@ -1,5 +1,5 @@
|
||||
# Log cloudinit generated log messages to file
|
||||
-:syslogtag, isequal, "[CLOUDINIT]" /var/log/cloud-init.log
|
||||
+:programname, isequal, "cloud-init" /var/log/cloud-init.log
|
||||
|
||||
# comment out the following line to allow CLOUDINIT messages through.
|
||||
# Doing so means you'll also get CLOUDINIT messages in /var/log/syslog
|
@ -1,8 +1,8 @@
|
||||
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||
|
||||
Name: cloud-init
|
||||
Version: 0.7.2
|
||||
Release: 8%{?dist}
|
||||
Version: 0.7.5
|
||||
Release: 1%{?dist}
|
||||
Summary: Cloud instance init scripts
|
||||
|
||||
Group: System Environment/Base
|
||||
@ -13,23 +13,11 @@ Source1: cloud-init-fedora.cfg
|
||||
Source2: cloud-init-README.fedora
|
||||
|
||||
# Deal with Fedora/Ubuntu path differences
|
||||
Patch0: cloud-init-0.7.2-fedora.patch
|
||||
|
||||
# Send text to stdout instead of /dev/console, then tell systemd to send
|
||||
# stdout to journal+console. Code that sends directly to syslog remains
|
||||
# unchanged.
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=977952
|
||||
# https://bugs.launchpad.net/bugs/1228434
|
||||
Patch1: cloud-init-0.7.2-nodevconsole.patch
|
||||
|
||||
# Fix restorecon failure when SELinux is disabled
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=967002
|
||||
# https://bugs.launchpad.net/bugs/1228441
|
||||
Patch2: cloud-init-0.7.2-selinux-enabled.patch
|
||||
Patch0: cloud-init-0.7.5-fedora.patch
|
||||
|
||||
# Fix rsyslog log filtering
|
||||
# https://code.launchpad.net/~gholms/cloud-init/rsyslog-programname/+merge/186906
|
||||
Patch3: cloud-init-0.7.2-rsyslog-programname.patch
|
||||
Patch1: cloud-init-0.7.5-rsyslog-programname.patch
|
||||
|
||||
|
||||
BuildArch: noarch
|
||||
@ -68,8 +56,6 @@ ssh keys and to let the user run various scripts.
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
cp -p %{SOURCE2} README.fedora
|
||||
|
||||
@ -150,6 +136,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Apr 29 2014 Sam Kottler <skottler@fedoraproject.org> - 0.7.5-1
|
||||
- Update to 0.7.5 and remove patches which landed in the release
|
||||
|
||||
* Sat Jan 25 2014 Sam Kottler <skottler@fedoraproject.org> - 0.7.2-8
|
||||
- Remove patch to the Puppet service unit nane [RH:1057860]
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user