Update to 0.7.8

This commit is contained in:
Garrett Holmstrom 2016-09-29 17:55:32 -07:00
parent 1508f89def
commit 090f91029a
7 changed files with 113 additions and 36 deletions

View File

@ -1,12 +0,0 @@
Index: cloud-init-0.7.6-bzr1245/setup.py
===================================================================
--- cloud-init-0.7.6-bzr1245.orig/setup.py
+++ cloud-init-0.7.6-bzr1245/setup.py
@@ -207,7 +207,6 @@ setuptools.setup(
scripts=['tools/cloud-init-per'],
license='GPLv3',
data_files=data_files,
- install_requires=requirements,
cmdclass=cmdclass,
entry_points={
'console_scripts': [

View File

@ -0,0 +1,14 @@
Index: cloud-init-0.7.8/tests/unittests/test_handler/test_handler_apt_source_v3.py
===================================================================
--- cloud-init-0.7.8.orig/tests/unittests/test_handler/test_handler_apt_source_v3.py
+++ cloud-init-0.7.8/tests/unittests/test_handler/test_handler_apt_source_v3.py
@@ -947,6 +947,9 @@ deb http://ubuntu.com/ubuntu/ xenial-pro
self.assertEqual(
orig, cc_apt_configure.disable_suites(["proposed"], orig, rel))
+ # https://bugs.launchpad.net/cloud-init/+bug/1629149
+ import unittest
+ @unittest.skip('module not used on Fedora; test is env-sensitive')
def test_apt_v3_mirror_search_dns(self):
"""test_apt_v3_mirror_search_dns - Test searching dns patterns"""
pmir = "phit"

View File

@ -1,7 +1,7 @@
Index: cloud-init-0.7.6/cloudinit/distros/rhel.py
Index: cloud-init-0.7.8/cloudinit/distros/rhel.py
===================================================================
--- cloud-init-0.7.6.orig/cloudinit/distros/rhel.py
+++ cloud-init-0.7.6/cloudinit/distros/rhel.py
--- cloud-init-0.7.8.orig/cloudinit/distros/rhel.py
+++ cloud-init-0.7.8/cloudinit/distros/rhel.py
@@ -20,6 +20,8 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
@ -11,7 +11,7 @@ Index: cloud-init-0.7.6/cloudinit/distros/rhel.py
from cloudinit import distros
from cloudinit import helpers
from cloudinit import log as logging
@@ -181,13 +183,12 @@ class Distro(distros.Distro):
@@ -201,13 +203,12 @@ class Distro(distros.Distro):
if pkgs is None:
pkgs = []
@ -26,7 +26,7 @@ Index: cloud-init-0.7.6/cloudinit/distros/rhel.py
+ LOG.debug('Using DNF for package management')
+ cmd = ['dnf']
+ else:
+ LOG.debug('Using DNF for package management')
+ LOG.debug('Using YUM for package management')
+ cmd = ['yum', '-t']
# Determines whether or not yum prompts for confirmation
# of critical actions. We don't want to prompt...

View File

@ -0,0 +1,43 @@
Index: cloud-init-0.7.8/setup.py
===================================================================
--- cloud-init-0.7.8.orig/setup.py
+++ cloud-init-0.7.8/setup.py
@@ -179,7 +179,6 @@ else:
(ETC + '/cloud/cloud.cfg.d', glob('config/cloud.cfg.d/*')),
(ETC + '/cloud/templates', glob('templates/*')),
(ETC + '/NetworkManager/dispatcher.d/', ['tools/hook-network-manager']),
- (ETC + '/dhcp/dhclient-exit-hooks.d/', ['tools/hook-dhclient']),
(USR_LIB_EXEC + '/cloud-init', ['tools/uncloud-init',
'tools/write-ssh-key-fingerprints']),
(USR + '/share/doc/cloud-init', [f for f in glob('doc/*') if is_f(f)]),
@@ -211,7 +210,6 @@ setuptools.setup(
scripts=['tools/cloud-init-per'],
license='GPLv3',
data_files=data_files,
- install_requires=requirements,
cmdclass=cmdclass,
entry_points={
'console_scripts': [
Index: cloud-init-0.7.8/cloudinit/settings.py
===================================================================
--- cloud-init-0.7.8.orig/cloudinit/settings.py
+++ cloud-init-0.7.8/cloudinit/settings.py
@@ -48,13 +48,16 @@ CFG_BUILTIN = {
],
'def_log_file': '/var/log/cloud-init.log',
'log_cfgs': [],
- 'syslog_fix_perms': ['syslog:adm', 'root:adm'],
+ 'mount_default_fields': [None, None, 'auto', 'defaults,nofail', '0', '2'],
+ 'ssh_deletekeys': False,
+ 'ssh_genkeytypes': [],
+ 'syslog_fix_perms': [],
'system_info': {
'paths': {
'cloud_dir': '/var/lib/cloud',
'templates_dir': '/etc/cloud/templates/',
},
- 'distro': 'ubuntu',
+ 'distro': 'fedora',
},
'vendor_data': {'enabled': True, 'prefix': []},
}

View File

@ -1,15 +1,32 @@
# The top level settings are used as module
# and system configuration.
# A set of users which may be applied and/or used by various modules
# when a 'default' entry is found it will reference the 'default_user'
# from the distro configuration specified below
users:
- default
disable_root: 1
ssh_pwauth: 0
# If this is set, 'root' will not be able to ssh in and they
# will get a message to login instead as the above user (fedora).
disable_root: true
# This will cause the set+update hostname module to not operate (if true)
preserve_hostname: false
mount_default_fields: [~, ~, 'auto', 'defaults,nofail', '0', '2']
resize_rootfs_tmp: /dev
ssh_deletekeys: 0
ssh_genkeytypes: ~
syslog_fix_perms: ~
# Example datasource config
# datasource:
# Ec2:
# metadata_urls: ['blah.com']
# timeout: 5 # (defaults to 50 seconds)
# max_wait: 10 # (defaults to 120 seconds)
# The modules that run in the 'init' stage
cloud_init_modules:
- migrator
- seed_random
@ -17,6 +34,8 @@ cloud_init_modules:
- write_files
- growpart
- resizefs
- disk_setup
- mounts
- set_hostname
- update_hostname
- update_etc_hosts
@ -24,22 +43,23 @@ cloud_init_modules:
- users-groups
- ssh
# The modules that run in the 'config' stage
cloud_config_modules:
- disk_setup
- mounts
- locale
- set-passwords
- yum-add-repo
- package-update-upgrade-install
- ntp
- timezone
- disable-ec2-metadata
- runcmd
# The modules that run in the 'final' stage
cloud_final_modules:
- package-update-upgrade-install
- puppet
- chef
- salt-minion
- mcollective
- disable-ec2-metadata
- runcmd
cloud_final_modules:
- rightscale_userdata
- scripts-vendor
- scripts-per-once
@ -52,15 +72,19 @@ cloud_final_modules:
- final-message
- power-state-change
# System and/or distro specific settings
# (not accessible to handlers/transforms)
system_info:
# This will affect which distro class gets used
distro: fedora
# Default user name + that default user's groups
default_user:
name: fedora
lock_passwd: true
gecos: Fedora Cloud User
gecos: Fedora
groups: [wheel, adm, systemd-journal]
sudo: ["ALL=(ALL) NOPASSWD:ALL"]
shell: /bin/bash
distro: fedora
paths:
cloud_dir: /var/lib/cloud
templates_dir: /etc/cloud/templates

View File

@ -1,5 +1,5 @@
Name: cloud-init
Version: 0.7.7
Version: 0.7.8
Release: 1%{?dist}
Summary: Cloud instance init scripts
@ -13,11 +13,11 @@ Source1: cloud-init-fedora.cfg
Source2: cloud-init-README.fedora
Source3: cloud-init-tmpfiles.conf
Patch0: cloud-init-0.7.6-bzr1245-fedora.patch
Patch0: cloud-init-0.7.8-fedora.patch
# Fix rsyslog log filtering
# https://code.launchpad.net/~gholms/cloud-init/rsyslog-programname/+merge/186906
Patch1: cloud-init-0.7.5-rsyslog-programname.patch
#Patch1: cloud-init-0.7.5-rsyslog-programname.patch
# Add 3 ecdsa-sha2-nistp* ssh key types now that they are standardized
# https://bugzilla.redhat.com/show_bug.cgi?id=1151824
@ -30,7 +30,11 @@ Patch4: cloud-init-0.7.6-bzr1245-groupadd-list.patch
# Use dnf instead of yum when available
# https://bugzilla.redhat.com/show_bug.cgi?id=1194451
Patch7: cloud-init-0.7.6-dnf.patch
Patch7: cloud-init-0.7.8-dnf.patch
# Skip apt-source tests that are sensitive to the system's hostname
# https://bugs.launchpad.net/cloud-init/+bug/1629149
Patch8: cloud-init-0.7.8-apt-dns-test.patch
BuildArch: noarch
@ -151,6 +155,9 @@ rm -rf $RPM_BUILD_ROOT
%doc %{_sysconfdir}/cloud/cloud.cfg.d/README
%dir %{_sysconfdir}/cloud/templates
%config(noreplace) %{_sysconfdir}/cloud/templates/*
%dir %{_sysconfdir}/rsyslog.d
%config(noreplace) %{_sysconfdir}/rsyslog.d/21-cloudinit.conf
%{_sysconfdir}/NetworkManager/dispatcher.d/hook-network-manager
/lib/udev/rules.d/66-azure-ephemeral.rules
%{_unitdir}/cloud-config.service
%{_unitdir}/cloud-final.service
@ -165,11 +172,12 @@ rm -rf $RPM_BUILD_ROOT
%{_bindir}/cloud-init*
%dir /run/cloud-init
%dir /var/lib/cloud
%dir %{_sysconfdir}/rsyslog.d
%config(noreplace) %{_sysconfdir}/rsyslog.d/21-cloudinit.conf
%changelog
* Thu Sep 29 2016 Garrett Holmstrom <gholms@fedoraproject.org> - 0.7.8-1
- Updated to 0.7.8
* Tue Aug 30 2016 Garrett Holmstrom <gholms@fedoraproject.org> - 0.7.7-1
- Updated to 0.7.7

View File

@ -1 +1 @@
7511a05ac2684465b42ba448e2bb5616 cloud-init-0.7.7.tar.gz
a522fc74f9b89200f821bda6c2ea44f1 cloud-init-0.7.8.tar.gz