Update to v18
Resolves: rhbz#1956760
This commit is contained in:
parent
9f3878a1ce
commit
d83e74b5a4
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@
|
||||
/clevis-14.tar.xz
|
||||
/clevis-15.tar.xz
|
||||
/clevis-16.tar.xz
|
||||
/clevis-18.tar.xz
|
||||
|
@ -1,52 +0,0 @@
|
||||
From a7d17dab6957b3036972575af04b55590c53b9ad Mon Sep 17 00:00:00 2001
|
||||
From: John Baublitz <jbaublitz@redhat.com>
|
||||
Date: Tue, 16 Mar 2021 09:36:46 -0400
|
||||
Subject: [PATCH] Fix for -t option in clevis luks bind (#297)
|
||||
|
||||
---
|
||||
src/luks/clevis-luks-bind | 2 +-
|
||||
src/luks/clevis-luks-common-functions.in | 2 +-
|
||||
src/luks/tests/bind-luks2 | 4 ++++
|
||||
3 files changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/luks/clevis-luks-bind b/src/luks/clevis-luks-bind
|
||||
index 9bea9b1..a0f3430 100755
|
||||
--- a/src/luks/clevis-luks-bind
|
||||
+++ b/src/luks/clevis-luks-bind
|
||||
@@ -119,7 +119,7 @@ if [ "${luks_type}" = "luks1" ] && ! luksmeta test -d "${DEV}"; then
|
||||
luksmeta init -d "${DEV}" ${FRC}
|
||||
fi
|
||||
|
||||
-if ! clevis_luks_do_bind "${DEV}" "${SLT}" "" \
|
||||
+if ! clevis_luks_do_bind "${DEV}" "${SLT}" "${TOKEN_ID}" \
|
||||
"${PIN}" "${CFG}" \
|
||||
"${YES}" "" \
|
||||
"${existing_key}" "${keyfile}"; then
|
||||
diff --git a/src/luks/clevis-luks-common-functions.in b/src/luks/clevis-luks-common-functions.in
|
||||
index 1bd7616..30fef56 100644
|
||||
--- a/src/luks/clevis-luks-common-functions.in
|
||||
+++ b/src/luks/clevis-luks-common-functions.in
|
||||
@@ -978,7 +978,7 @@ clevis_luks_do_bind() {
|
||||
return 1
|
||||
fi
|
||||
|
||||
- if ! clevis_luks_save_slot "${DEV}" "${SLT}" "${tkn_id}" \
|
||||
+ if ! clevis_luks_save_slot "${DEV}" "${SLT}" "${TKN_ID}" \
|
||||
"${jwe}" "${OVERWRITE}"; then
|
||||
echo "Unable to update metadata; operation cancelled" >&2
|
||||
clevis_luks_restore_dev "${CLEVIS_TMP_DIR}" || :
|
||||
diff --git a/src/luks/tests/bind-luks2 b/src/luks/tests/bind-luks2
|
||||
index 492db50..04c6b8e 100755
|
||||
--- a/src/luks/tests/bind-luks2
|
||||
+++ b/src/luks/tests/bind-luks2
|
||||
@@ -47,3 +47,7 @@ new_device "luks2" "${DEV}"
|
||||
if ! clevis luks bind -d "${DEV}" -t "$TOKEN_ID" tang "${CFG}" <<< "${DEFAULT_PASS}"; then
|
||||
error "${TEST}: Binding is expected to succeed when given a correct (${DEFAULT_PASS}) password." >&2
|
||||
fi
|
||||
+
|
||||
+if ! cryptsetup token export --token-id=5 "${DEV}"; then
|
||||
+ error "${TEST}: Clevis did not add the LUKS2 token to the correct slot." >&2
|
||||
+fi
|
||||
--
|
||||
2.30.2
|
||||
|
11
clevis.spec
11
clevis.spec
@ -1,6 +1,6 @@
|
||||
Name: clevis
|
||||
Version: 16
|
||||
Release: 3%{?dist}
|
||||
Version: 18
|
||||
Release: 1%{?dist}
|
||||
Summary: Automated decryption framework
|
||||
|
||||
License: GPLv3+
|
||||
@ -8,8 +8,6 @@ URL: https://github.com/latchset/%{name}
|
||||
Source0: https://github.com/latchset/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.xz
|
||||
Source1: clevis.sysusers
|
||||
|
||||
Patch0001: 0001-Fix-for-t-option-in-clevis-luks-bind-297.patch
|
||||
|
||||
BuildRequires: git-core
|
||||
BuildRequires: gcc
|
||||
BuildRequires: meson
|
||||
@ -45,7 +43,6 @@ Requires: curl
|
||||
Requires: jq
|
||||
Requires(pre): shadow-utils
|
||||
Recommends: cracklib-dicts
|
||||
Recommends: clevis-pin-tpm2
|
||||
|
||||
%description
|
||||
Clevis is a framework for automated decryption. It allows you to encrypt
|
||||
@ -194,6 +191,10 @@ exit 0
|
||||
%attr(4755, root, root) %{_libexecdir}/%{name}-luks-udisks2
|
||||
|
||||
%changelog
|
||||
* Tue May 04 2021 Sergio Correia <scorreia@redhat.com> - 18-1
|
||||
- Update to new clevis upstream release, v18
|
||||
Resolves: rhbz#1956760
|
||||
|
||||
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 16-3
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (clevis-16.tar.xz) = a474a0a4d17b65091a6447698a4f3e0e3bc45b61e686be76bc5d7b5d248e503803174ae40b958cfee8a72087089c1ac132b8684f2f913c5e8a9873ceae2aa5c3
|
||||
SHA512 (clevis-18.tar.xz) = 2385b49f63b8237d44b3790560cd74372d598fd3728945ac11278c09e1e1583bea279eeff43c4fd57b0530a66c532ebfa7eb7f11da9732a50da80389e45ed1d1
|
||||
|
Loading…
Reference in New Issue
Block a user