Update to latest upstream version, v15
This commit is contained in:
parent
6e9ce1a014
commit
c29e330dd8
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
|||||||
/clevis-12.tar.xz
|
/clevis-12.tar.xz
|
||||||
/clevis-13.tar.xz
|
/clevis-13.tar.xz
|
||||||
/clevis-14.tar.xz
|
/clevis-14.tar.xz
|
||||||
|
/clevis-15.tar.xz
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
From 6eba228a763ea319a8f0a9b9ba1e76e66cef733c Mon Sep 17 00:00:00 2001
|
|
||||||
From: Sergio Correia <scorreia@redhat.com>
|
|
||||||
Date: Sat, 5 Sep 2020 09:09:06 -0300
|
|
||||||
Subject: [PATCH] systemd: clevis-luks-askpass: exit cleanly with SIGTERM
|
|
||||||
|
|
||||||
Especially when running in early boot, clevis-luks-askpass may be
|
|
||||||
looping because e.g. we still have devices remaining to unlock, as
|
|
||||||
per crypttab, or we were unable to determine if there are any devices
|
|
||||||
left to be unlocked.
|
|
||||||
|
|
||||||
Eventually we may receive a SIGTERM, from e.g. systemd and we should
|
|
||||||
exit cleanly in this situation.
|
|
||||||
---
|
|
||||||
src/luks/systemd/clevis-luks-askpass | 3 +++
|
|
||||||
1 file changed, 3 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/luks/systemd/clevis-luks-askpass b/src/luks/systemd/clevis-luks-askpass
|
|
||||||
index d17d122..285bba4 100755
|
|
||||||
--- a/src/luks/systemd/clevis-luks-askpass
|
|
||||||
+++ b/src/luks/systemd/clevis-luks-askpass
|
|
||||||
@@ -22,6 +22,9 @@ set -eu
|
|
||||||
|
|
||||||
. clevis-luks-common-functions
|
|
||||||
|
|
||||||
+# Make sure to exit cleanly if SIGTERM is received.
|
|
||||||
+trap 'echo "Exiting due to SIGTERM" && exit 0' TERM
|
|
||||||
+
|
|
||||||
loop=
|
|
||||||
path=/run/systemd/ask-password
|
|
||||||
while getopts ":lp:" o; do
|
|
||||||
--
|
|
||||||
2.28.0
|
|
||||||
|
|
15
clevis.spec
15
clevis.spec
@ -1,14 +1,12 @@
|
|||||||
Name: clevis
|
Name: clevis
|
||||||
Version: 14
|
Version: 15
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Automated decryption framework
|
Summary: Automated decryption framework
|
||||||
|
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: https://github.com/latchset/%{name}
|
URL: https://github.com/latchset/%{name}
|
||||||
Source0: https://github.com/latchset/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.xz
|
Source0: https://github.com/latchset/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.xz
|
||||||
|
|
||||||
Patch0001: 0001-systemd-clevis-luks-askpass-exit-cleanly-with-SIGTER.patch
|
|
||||||
|
|
||||||
BuildRequires: git
|
BuildRequires: git
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: meson
|
BuildRequires: meson
|
||||||
@ -162,11 +160,17 @@ exit 0
|
|||||||
%{_mandir}/man1/%{name}-luks-unbind.1*
|
%{_mandir}/man1/%{name}-luks-unbind.1*
|
||||||
%{_mandir}/man1/%{name}-luks-bind.1*
|
%{_mandir}/man1/%{name}-luks-bind.1*
|
||||||
%{_mandir}/man1/%{name}-luks-list.1.*
|
%{_mandir}/man1/%{name}-luks-list.1.*
|
||||||
|
%{_mandir}/man1/%{name}-luks-edit.1.*
|
||||||
|
%{_mandir}/man1/%{name}-luks-regen.1.*
|
||||||
|
%{_mandir}/man1/%{name}-luks-report.1.*
|
||||||
%{_bindir}/%{name}-luks-unlock
|
%{_bindir}/%{name}-luks-unlock
|
||||||
%{_bindir}/%{name}-luks-unbind
|
%{_bindir}/%{name}-luks-unbind
|
||||||
%{_bindir}/%{name}-luks-bind
|
%{_bindir}/%{name}-luks-bind
|
||||||
%{_bindir}/%{name}-luks-common-functions
|
%{_bindir}/%{name}-luks-common-functions
|
||||||
%{_bindir}/%{name}-luks-list
|
%{_bindir}/%{name}-luks-list
|
||||||
|
%{_bindir}/%{name}-luks-edit
|
||||||
|
%{_bindir}/%{name}-luks-regen
|
||||||
|
%{_bindir}/%{name}-luks-report
|
||||||
|
|
||||||
%files systemd
|
%files systemd
|
||||||
%{_libexecdir}/%{name}-luks-askpass
|
%{_libexecdir}/%{name}-luks-askpass
|
||||||
@ -184,6 +188,9 @@ exit 0
|
|||||||
%attr(4755, root, root) %{_libexecdir}/%{name}-luks-udisks2
|
%attr(4755, root, root) %{_libexecdir}/%{name}-luks-udisks2
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 28 2020 Sergio Correia <scorreia@redhat.com> - 15-1
|
||||||
|
- Update to new clevis upstream release, v15.
|
||||||
|
|
||||||
* Tue Sep 08 2020 Sergio Correia <scorreia@redhat.com> - 14-5
|
* Tue Sep 08 2020 Sergio Correia <scorreia@redhat.com> - 14-5
|
||||||
- Suppress output in pre scriptlet when adjusting users/groups
|
- Suppress output in pre scriptlet when adjusting users/groups
|
||||||
Resolves: rhbz#1876729
|
Resolves: rhbz#1876729
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (clevis-14.tar.xz) = 4a71945c6a51f6b2d82cd031c1b5bad6981505191d6eade76cd495bd85e8494d2c704cedcb06c9801748fd507d16485d6e2a97f1892d22ac9fb5a574355e1f28
|
SHA512 (clevis-15.tar.xz) = 8a84b9e081d02742c2c718bdc8b2c834764da6ec9ad1ae5640e8af80a38c2a1ec83eeea5de7696f60f7dd8f165b3dc527290831621440b1a46459d2c8bd56918
|
||||||
|
Loading…
Reference in New Issue
Block a user