import clevis-18-102.el9
This commit is contained in:
parent
8eab70ade5
commit
44466347a0
@ -0,0 +1,49 @@
|
|||||||
|
From 76ad9b21b61627a728bc9499821cf8e09446725d Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Renaud=20M=C3=A9trich?= <rmetrich@redhat.com>
|
||||||
|
Date: Thu, 21 Oct 2021 13:58:52 +0200
|
||||||
|
Subject: [PATCH 4/4] luks: explicitly specify pbkdf iterations to cryptsetup
|
||||||
|
|
||||||
|
This fixes an Out of memory error when the system has not much memory,
|
||||||
|
such as a VM configured with 2GB currently being installed through the
|
||||||
|
network (hence having ~1GB free memory only).
|
||||||
|
See RHBZ #1979256 (https://bugzilla.redhat.com/show_bug.cgi?id=1979256).
|
||||||
|
---
|
||||||
|
src/luks/clevis-luks-common-functions.in | 7 ++++++-
|
||||||
|
1 file changed, 6 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/luks/clevis-luks-common-functions.in b/src/luks/clevis-luks-common-functions.in
|
||||||
|
index d53d2ab..360eb7e 100644
|
||||||
|
--- a/src/luks/clevis-luks-common-functions.in
|
||||||
|
+++ b/src/luks/clevis-luks-common-functions.in
|
||||||
|
@@ -760,10 +760,12 @@ clevis_luks_add_key() {
|
||||||
|
extra_args="$(printf -- '--key-file %s' "${KEYFILE}")"
|
||||||
|
input="$(printf '%s' "${NEWKEY}")"
|
||||||
|
fi
|
||||||
|
+ local pbkdf_args="--pbkdf pbkdf2 --pbkdf-force-iterations 1000"
|
||||||
|
|
||||||
|
printf '%s' "${input}" | cryptsetup luksAddKey --batch-mode \
|
||||||
|
--key-slot "${SLT}" \
|
||||||
|
"${DEV}" \
|
||||||
|
+ ${pbkdf_args} \
|
||||||
|
${extra_args}
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -792,11 +794,14 @@ clevis_luks_update_key() {
|
||||||
|
extra_args="$(printf -- '--key-file %s' "${KEYFILE}")"
|
||||||
|
input="$(printf '%s' "${NEWKEY}")"
|
||||||
|
fi
|
||||||
|
+ local pbkdf_args="--pbkdf pbkdf2 --pbkdf-force-iterations 1000"
|
||||||
|
|
||||||
|
if [ -n "${in_place}" ]; then
|
||||||
|
printf '%s' "${input}" | cryptsetup luksChangeKey "${DEV}" \
|
||||||
|
--key-slot "${SLT}" \
|
||||||
|
- --batch-mode ${extra_args}
|
||||||
|
+ --batch-mode \
|
||||||
|
+ ${pbkdf_args} \
|
||||||
|
+ ${extra_args}
|
||||||
|
return
|
||||||
|
fi
|
||||||
|
|
||||||
|
--
|
||||||
|
2.33.1
|
||||||
|
|
16
SOURCES/0005-tang-dump-url-on-error-communication.patch
Normal file
16
SOURCES/0005-tang-dump-url-on-error-communication.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
--- clevis-18.ori/src/pins/tang/clevis-decrypt-tang 2021-04-15 13:00:19.969067600 +0200
|
||||||
|
+++ clevis-18/src/pins/tang/clevis-decrypt-tang 2022-01-20 17:29:21.859897964 +0100
|
||||||
|
@@ -99,10 +99,10 @@
|
||||||
|
|
||||||
|
xfr="$(jose jwk exc -i '{"alg":"ECMR"}' -l- -r- <<< "$clt$eph")"
|
||||||
|
|
||||||
|
-url="$url/rec/$kid"
|
||||||
|
+rec_url="$url/rec/$kid"
|
||||||
|
ct="Content-Type: application/jwk+json"
|
||||||
|
-if ! rep="$(curl -sfg -X POST -H "$ct" --data-binary @- "$url" <<< "$xfr")"; then
|
||||||
|
- echo "Error communicating with the server!" >&2
|
||||||
|
+if ! rep="$(curl -sfg -X POST -H "$ct" --data-binary @- "$rec_url" <<< "$xfr")"; then
|
||||||
|
+ echo "Error communicating with the server $url" >&2
|
||||||
|
exit 1
|
||||||
|
fi
|
||||||
|
|
213
SOURCES/0006-feat-rename-the-test-pin-to-null-pin.patch
Normal file
213
SOURCES/0006-feat-rename-the-test-pin-to-null-pin.patch
Normal file
@ -0,0 +1,213 @@
|
|||||||
|
From f668840e22e45ac8b16d770072b4395a155d089c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Antonio Murdaca <runcom@linux.com>
|
||||||
|
Date: Wed, 1 Dec 2021 14:17:53 +0100
|
||||||
|
Subject: [PATCH 6/6] feat: rename the test pin to null pin
|
||||||
|
|
||||||
|
Signed-off-by: Antonio Murdaca <runcom@linux.com>
|
||||||
|
---
|
||||||
|
src/initramfs-tools/hooks/clevis.in | 1 +
|
||||||
|
.../dracut/clevis-pin-null/meson.build | 14 ++++++++++
|
||||||
|
.../dracut/clevis-pin-null/module-setup.sh.in | 28 +++++++++++++++++++
|
||||||
|
src/luks/systemd/dracut/meson.build | 1 +
|
||||||
|
...levis-decrypt-test => clevis-decrypt-null} | 4 +--
|
||||||
|
...levis-encrypt-test => clevis-encrypt-null} | 4 +--
|
||||||
|
src/pins/sss/meson.build | 5 +++-
|
||||||
|
src/pins/sss/{pin-test => pin-null} | 4 +--
|
||||||
|
src/pins/sss/pin-sss | 12 ++++----
|
||||||
|
9 files changed, 60 insertions(+), 13 deletions(-)
|
||||||
|
create mode 100644 src/luks/systemd/dracut/clevis-pin-null/meson.build
|
||||||
|
create mode 100755 src/luks/systemd/dracut/clevis-pin-null/module-setup.sh.in
|
||||||
|
rename src/pins/sss/{clevis-decrypt-test => clevis-decrypt-null} (88%)
|
||||||
|
rename src/pins/sss/{clevis-encrypt-test => clevis-encrypt-null} (90%)
|
||||||
|
rename src/pins/sss/{pin-test => pin-null} (53%)
|
||||||
|
|
||||||
|
diff --git a/src/initramfs-tools/hooks/clevis.in b/src/initramfs-tools/hooks/clevis.in
|
||||||
|
index 7e6d2b3..8d60d05 100755
|
||||||
|
--- a/src/initramfs-tools/hooks/clevis.in
|
||||||
|
+++ b/src/initramfs-tools/hooks/clevis.in
|
||||||
|
@@ -58,6 +58,7 @@ fi
|
||||||
|
|
||||||
|
copy_exec @bindir@/clevis-decrypt-tang || die 1 "@bindir@/clevis-decrypt-tang not found"
|
||||||
|
copy_exec @bindir@/clevis-decrypt-sss || die 1 "@bindir@/clevis-decrypt-sss not found"
|
||||||
|
+copy_exec @bindir@/clevis-decrypt-null || die 1 "@bindir@/clevis-decrypt-null not found"
|
||||||
|
copy_exec @bindir@/clevis-decrypt || die 1 "@bindir@/clevis-decrypt not found"
|
||||||
|
copy_exec @bindir@/clevis-luks-common-functions || die 1 "@bindir@/clevis-luks-common-functions not found"
|
||||||
|
copy_exec @bindir@/clevis-luks-list || die 1 "@bindir@/clevis-luks-list not found"
|
||||||
|
diff --git a/src/luks/systemd/dracut/clevis-pin-null/meson.build b/src/luks/systemd/dracut/clevis-pin-null/meson.build
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..107e3ba
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/src/luks/systemd/dracut/clevis-pin-null/meson.build
|
||||||
|
@@ -0,0 +1,14 @@
|
||||||
|
+dracut = dependency('dracut', required: false)
|
||||||
|
+
|
||||||
|
+if dracut.found()
|
||||||
|
+ dracutdir = dracut.get_pkgconfig_variable('dracutmodulesdir') + '/60' + meson.project_name() + '-pin-null'
|
||||||
|
+
|
||||||
|
+ configure_file(
|
||||||
|
+ input: 'module-setup.sh.in',
|
||||||
|
+ output: 'module-setup.sh',
|
||||||
|
+ install_dir: dracutdir,
|
||||||
|
+ configuration: data,
|
||||||
|
+ )
|
||||||
|
+else
|
||||||
|
+ warning('Will not install dracut module clevis-pin-null due to missing dependencies!')
|
||||||
|
+endif
|
||||||
|
diff --git a/src/luks/systemd/dracut/clevis-pin-null/module-setup.sh.in b/src/luks/systemd/dracut/clevis-pin-null/module-setup.sh.in
|
||||||
|
new file mode 100755
|
||||||
|
index 0000000..6a16078
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/src/luks/systemd/dracut/clevis-pin-null/module-setup.sh.in
|
||||||
|
@@ -0,0 +1,28 @@
|
||||||
|
+#!/bin/bash
|
||||||
|
+# vim: set tabstop=8 shiftwidth=4 softtabstop=4 expandtab smarttab colorcolumn=80:
|
||||||
|
+#
|
||||||
|
+# Copyright (c) 2016 Red Hat, Inc.
|
||||||
|
+# Author: Nathaniel McCallum <npmccallum@redhat.com>
|
||||||
|
+#
|
||||||
|
+# This program is free software: you can redistribute it and/or modify
|
||||||
|
+# it under the terms of the GNU General Public License as published by
|
||||||
|
+# the Free Software Foundation, either version 3 of the License, or
|
||||||
|
+# (at your option) any later version.
|
||||||
|
+#
|
||||||
|
+# This program is distributed in the hope that it will be useful,
|
||||||
|
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||||
|
+# GNU General Public License for more details.
|
||||||
|
+#
|
||||||
|
+# You should have received a copy of the GNU General Public License
|
||||||
|
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||||
|
+#
|
||||||
|
+
|
||||||
|
+depends() {
|
||||||
|
+ echo clevis
|
||||||
|
+ return 0
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+install() {
|
||||||
|
+ inst clevis-decrypt-null
|
||||||
|
+}
|
||||||
|
diff --git a/src/luks/systemd/dracut/meson.build b/src/luks/systemd/dracut/meson.build
|
||||||
|
index fdb264b..7ad5b14 100644
|
||||||
|
--- a/src/luks/systemd/dracut/meson.build
|
||||||
|
+++ b/src/luks/systemd/dracut/meson.build
|
||||||
|
@@ -2,3 +2,4 @@ subdir('clevis')
|
||||||
|
subdir('clevis-pin-tang')
|
||||||
|
subdir('clevis-pin-tpm2')
|
||||||
|
subdir('clevis-pin-sss')
|
||||||
|
+subdir('clevis-pin-null')
|
||||||
|
diff --git a/src/pins/sss/clevis-decrypt-test b/src/pins/sss/clevis-decrypt-null
|
||||||
|
similarity index 88%
|
||||||
|
rename from src/pins/sss/clevis-decrypt-test
|
||||||
|
rename to src/pins/sss/clevis-decrypt-null
|
||||||
|
index f0e9249..a6217ed 100755
|
||||||
|
--- a/src/pins/sss/clevis-decrypt-test
|
||||||
|
+++ b/src/pins/sss/clevis-decrypt-null
|
||||||
|
@@ -22,11 +22,11 @@
|
||||||
|
|
||||||
|
read -r -d . hdr
|
||||||
|
|
||||||
|
-if [ "$(jose fmt -q "$hdr" -SyOg clevis -g pin -u-)" != "test" ]; then
|
||||||
|
+if [ "$(jose fmt -q "$hdr" -SyOg clevis -g pin -u-)" != "null" ]; then
|
||||||
|
echo "JWE pin mismatch!" >&2
|
||||||
|
exit 1
|
||||||
|
fi
|
||||||
|
|
||||||
|
-jwk="$(jose fmt -q "$hdr" -SyOg clevis -g test -g jwk -Oo-)" || exit 1
|
||||||
|
+jwk="$(jose fmt -q "$hdr" -SyOg clevis -g null -g jwk -Oo-)" || exit 1
|
||||||
|
|
||||||
|
exec jose jwe dec -k- -i- < <(echo -n "$jwk$hdr."; /bin/cat)
|
||||||
|
diff --git a/src/pins/sss/clevis-encrypt-test b/src/pins/sss/clevis-encrypt-null
|
||||||
|
similarity index 90%
|
||||||
|
rename from src/pins/sss/clevis-encrypt-test
|
||||||
|
rename to src/pins/sss/clevis-encrypt-null
|
||||||
|
index bd2d6ec..af182a5 100755
|
||||||
|
--- a/src/pins/sss/clevis-encrypt-test
|
||||||
|
+++ b/src/pins/sss/clevis-encrypt-null
|
||||||
|
@@ -26,10 +26,10 @@ if ! cfg="$(jose fmt -j "$1" -Oo- 2>/dev/null)"; then
|
||||||
|
fi
|
||||||
|
|
||||||
|
jwk="$(jose jwk gen -i '{"alg":"A256GCM"}')"
|
||||||
|
-jwe='{"protected":{"clevis":{"pin":"test","test":{}}}}'
|
||||||
|
+jwe='{"protected":{"clevis":{"pin":"null","null":{}}}}'
|
||||||
|
|
||||||
|
if ! jose fmt -j "$cfg" -g fail -T; then
|
||||||
|
- jwe="$(jose fmt -j "$jwe" -Og protected -g clevis -g test -j "$jwk" -Os jwk -UUUUo-)"
|
||||||
|
+ jwe="$(jose fmt -j "$jwe" -Og protected -g clevis -g null -j "$jwk" -Os jwk -UUUUo-)"
|
||||||
|
fi
|
||||||
|
|
||||||
|
exec jose jwe enc -i- -k- -I- -c < <(echo -n "$jwe$jwk"; /bin/cat)
|
||||||
|
diff --git a/src/pins/sss/meson.build b/src/pins/sss/meson.build
|
||||||
|
index 7f20eea..2a5295a 100644
|
||||||
|
--- a/src/pins/sss/meson.build
|
||||||
|
+++ b/src/pins/sss/meson.build
|
||||||
|
@@ -28,8 +28,11 @@ if jansson.found() and libcrypto.found()
|
||||||
|
separator: ':'
|
||||||
|
)
|
||||||
|
|
||||||
|
+ bins += join_paths(meson.current_source_dir(), 'clevis-encrypt-null')
|
||||||
|
+ bins += join_paths(meson.current_source_dir(), 'clevis-decrypt-null')
|
||||||
|
+
|
||||||
|
test('pin-sss', find_program(join_paths(src, 'pin-sss')), env: env)
|
||||||
|
- test('pin-test', find_program(join_paths(src, 'pin-test')), env: env)
|
||||||
|
+ test('pin-null', find_program(join_paths(src, 'pin-null')), env: env)
|
||||||
|
else
|
||||||
|
warning('Will not install sss pin due to missing dependencies!')
|
||||||
|
endif
|
||||||
|
diff --git a/src/pins/sss/pin-test b/src/pins/sss/pin-null
|
||||||
|
similarity index 53%
|
||||||
|
rename from src/pins/sss/pin-test
|
||||||
|
rename to src/pins/sss/pin-null
|
||||||
|
index 50c8c67..b14ac63 100755
|
||||||
|
--- a/src/pins/sss/pin-test
|
||||||
|
+++ b/src/pins/sss/pin-null
|
||||||
|
@@ -2,9 +2,9 @@
|
||||||
|
|
||||||
|
trap 'exit' ERR
|
||||||
|
|
||||||
|
-e="$(echo -n hi | clevis encrypt test '{}')"
|
||||||
|
+e="$(echo -n hi | clevis encrypt null '{}')"
|
||||||
|
d="$(echo -n "$e" | clevis decrypt)"
|
||||||
|
test "$d" == "hi"
|
||||||
|
|
||||||
|
-e="$(echo -n hi | clevis encrypt test '{"fail":true}')"
|
||||||
|
+e="$(echo -n hi | clevis encrypt null '{"fail":true}')"
|
||||||
|
! echo "$e" | clevis decrypt
|
||||||
|
diff --git a/src/pins/sss/pin-sss b/src/pins/sss/pin-sss
|
||||||
|
index 5c0b8cf..24da052 100755
|
||||||
|
--- a/src/pins/sss/pin-sss
|
||||||
|
+++ b/src/pins/sss/pin-sss
|
||||||
|
@@ -1,24 +1,24 @@
|
||||||
|
#!/bin/bash -ex
|
||||||
|
|
||||||
|
-e="$(echo hi | clevis encrypt sss '{"t":1,"pins":{"test":[{},{}]}}')"
|
||||||
|
+e="$(echo hi | clevis encrypt sss '{"t":1,"pins":{"null":[{},{}]}}')"
|
||||||
|
d="$(echo "$e" | clevis decrypt)"
|
||||||
|
test "$d" == "hi"
|
||||||
|
|
||||||
|
-e="$(echo hi | clevis encrypt sss '{"t":1,"pins":{"test":[{},{"fail":true}]}}')"
|
||||||
|
+e="$(echo hi | clevis encrypt sss '{"t":1,"pins":{"null":[{},{"fail":true}]}}')"
|
||||||
|
d="$(echo "$e" | clevis decrypt)"
|
||||||
|
test "$d" == "hi"
|
||||||
|
|
||||||
|
-e="$(echo hi | clevis encrypt sss '{"t":1,"pins":{"test":[{"fail":true},{"fail":true}]}}')"
|
||||||
|
+e="$(echo hi | clevis encrypt sss '{"t":1,"pins":{"null":[{"fail":true},{"fail":true}]}}')"
|
||||||
|
! echo "$e" | clevis decrypt
|
||||||
|
|
||||||
|
-e="$(echo hi | clevis encrypt sss '{"t":2,"pins":{"test":[{},{}]}}')"
|
||||||
|
+e="$(echo hi | clevis encrypt sss '{"t":2,"pins":{"null":[{},{}]}}')"
|
||||||
|
d="$(echo "$e" | clevis decrypt)"
|
||||||
|
test "$d" == "hi"
|
||||||
|
|
||||||
|
-e="$(echo hi | clevis encrypt sss '{"t":2,"pins":{"test":[{},{"fail":true}]}}')"
|
||||||
|
+e="$(echo hi | clevis encrypt sss '{"t":2,"pins":{"null":[{},{"fail":true}]}}')"
|
||||||
|
! echo "$e" | clevis decrypt
|
||||||
|
|
||||||
|
-e="$(echo hi | clevis encrypt sss '{"t":2,"pins":{"test":[{"fail":true},{"fail":true}]}}')"
|
||||||
|
+e="$(echo hi | clevis encrypt sss '{"t":2,"pins":{"null":[{"fail":true},{"fail":true}]}}')"
|
||||||
|
! echo "$e" | clevis decrypt
|
||||||
|
|
||||||
|
! e="$(echo hi | clevis encrypt sss '{"t":1,"pins":{"tang":[{"url":"foo bar"}]}}')"
|
||||||
|
--
|
||||||
|
2.33.1
|
||||||
|
|
@ -1,6 +1,6 @@
|
|||||||
Name: clevis
|
Name: clevis
|
||||||
Version: 18
|
Version: 18
|
||||||
Release: 5%{?dist}
|
Release: 102%{?dist}
|
||||||
Summary: Automated decryption framework
|
Summary: Automated decryption framework
|
||||||
|
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
@ -10,6 +10,9 @@ Source1: clevis.sysusers
|
|||||||
|
|
||||||
Patch0001: 0001-sss-use-BN_set_word-x-0-instead-of-BN_zero.patch
|
Patch0001: 0001-sss-use-BN_set_word-x-0-instead-of-BN_zero.patch
|
||||||
Patch0002: 0002-systemd-account-for-unlocking-failures-in-clevis-luk.patch
|
Patch0002: 0002-systemd-account-for-unlocking-failures-in-clevis-luk.patch
|
||||||
|
Patch0004: 0004-luks-explicitly-specify-pbkdf-iterations-to-cryptset.patch
|
||||||
|
Patch0005: 0005-tang-dump-url-on-error-communication.patch
|
||||||
|
Patch0006: 0006-feat-rename-the-test-pin-to-null-pin.patch
|
||||||
|
|
||||||
BuildRequires: git-core
|
BuildRequires: git-core
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -146,10 +149,12 @@ exit 0
|
|||||||
%{_bindir}/%{name}-decrypt-tang
|
%{_bindir}/%{name}-decrypt-tang
|
||||||
%{_bindir}/%{name}-decrypt-tpm2
|
%{_bindir}/%{name}-decrypt-tpm2
|
||||||
%{_bindir}/%{name}-decrypt-sss
|
%{_bindir}/%{name}-decrypt-sss
|
||||||
|
%{_bindir}/%{name}-decrypt-null
|
||||||
%{_bindir}/%{name}-decrypt
|
%{_bindir}/%{name}-decrypt
|
||||||
%{_bindir}/%{name}-encrypt-tang
|
%{_bindir}/%{name}-encrypt-tang
|
||||||
%{_bindir}/%{name}-encrypt-tpm2
|
%{_bindir}/%{name}-encrypt-tpm2
|
||||||
%{_bindir}/%{name}-encrypt-sss
|
%{_bindir}/%{name}-encrypt-sss
|
||||||
|
%{_bindir}/%{name}-encrypt-null
|
||||||
%{_bindir}/%{name}
|
%{_bindir}/%{name}
|
||||||
%{_mandir}/man1/%{name}-encrypt-tang.1*
|
%{_mandir}/man1/%{name}-encrypt-tang.1*
|
||||||
%{_mandir}/man1/%{name}-encrypt-tpm2.1*
|
%{_mandir}/man1/%{name}-encrypt-tpm2.1*
|
||||||
@ -185,6 +190,7 @@ exit 0
|
|||||||
|
|
||||||
%files dracut
|
%files dracut
|
||||||
%{_prefix}/lib/dracut/modules.d/60%{name}
|
%{_prefix}/lib/dracut/modules.d/60%{name}
|
||||||
|
%{_prefix}/lib/dracut/modules.d/60%{name}-pin-null/module-setup.sh
|
||||||
%{_prefix}/lib/dracut/modules.d/60%{name}-pin-sss/module-setup.sh
|
%{_prefix}/lib/dracut/modules.d/60%{name}-pin-sss/module-setup.sh
|
||||||
%{_prefix}/lib/dracut/modules.d/60%{name}-pin-tang/module-setup.sh
|
%{_prefix}/lib/dracut/modules.d/60%{name}-pin-tang/module-setup.sh
|
||||||
%{_prefix}/lib/dracut/modules.d/60%{name}-pin-tpm2/module-setup.sh
|
%{_prefix}/lib/dracut/modules.d/60%{name}-pin-tpm2/module-setup.sh
|
||||||
@ -194,6 +200,26 @@ exit 0
|
|||||||
%attr(4755, root, root) %{_libexecdir}/%{name}-luks-udisks2
|
%attr(4755, root, root) %{_libexecdir}/%{name}-luks-udisks2
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 26 2022 Sergio Correia <scorreia@redhat.com> - 18-102
|
||||||
|
- Support a null pin
|
||||||
|
Resolves: rhbz#2028091
|
||||||
|
|
||||||
|
* Wed Jan 26 2022 Sergio Correia <scorreia@redhat.com> - 18-101
|
||||||
|
- Revert "Enable debugging in clevis scripts when rd.debug is set"
|
||||||
|
Related: rhbz#2022420
|
||||||
|
|
||||||
|
* Thu Jan 20 2022 Sergio Arroutbi <sarroutb@redhat.com> - 18-100
|
||||||
|
- Dump server information on server error communication
|
||||||
|
Resolves: rhbz#2022423
|
||||||
|
|
||||||
|
* Tue Jan 04 2022 Sergio Correia <scorreia@redhat.com> - 18-7
|
||||||
|
- Explicitly specify pbkdf iterations to cryptsetup
|
||||||
|
Resolves: rhbz#2022416
|
||||||
|
|
||||||
|
* Tue Jan 04 2022 Sergio Correia <scorreia@redhat.com> - 18-6
|
||||||
|
- Enable debugging in clevis scripts when rd.debug is set
|
||||||
|
Resolves: rhbz#2022420
|
||||||
|
|
||||||
* Wed Nov 17 2021 Sergio Correia <scorreia@redhat.com> - 18-5
|
* Wed Nov 17 2021 Sergio Correia <scorreia@redhat.com> - 18-5
|
||||||
- Account for unlocking failures in clevis-luks-askpass
|
- Account for unlocking failures in clevis-luks-askpass
|
||||||
Resolves: rhbz#2022421
|
Resolves: rhbz#2022421
|
||||||
|
Loading…
Reference in New Issue
Block a user