clang/0001-clang-tools-extra-Make-test-dependency-on-LLVMHello-.patch
Tulio Magno Quites Machado Filho b3669793eb Update to LLVM 17.0.0 RC 1
This is also a squashed merge commit from upstream-snapshot (commit ID
13b971d3fcbf82d2) into rawhide whose most important commits from
upstream-snapshot are:

Konrad Kleine (57):
      Prepare for snapshot build
      Fix patches by using them from the streamline branch
      Fixed E: specfile-error error: line 491: Unclosed %if
      Fix error: Bad file: /var/lib/copr-rpmbuild/workspace/workdir-0qjlioil/srcdir/0007-cmake-Allow-shared-li
braries-to-customize-the-soname.patch: No such file or directory
      Must have forgotten this newly added 'clang_version' global
      Disable LTO for anything older than Fedora 34
      Add recommonmark to build deps
      Use new llvm_snashot_changelog_entry macro
      Use llvm_snapshot_version_suffix
      Fix RPM packaging bug:
      Default to DWARFv4
      Revert "Default to DWARFv4"
      Compile with DWARFv4
      Merge remote-tracking branch 'upstream/rawhide' into upstream-snapshot
      Try to address https://reviews.llvm.org/D119199
      Update patches
      Fixup patches
      Patches rebased
      Separate clang-tools-extra patches
      Try to fix clang build
      Rebased patches to fix issue with patch
      Make %autopatch verbose
      Also rename patch tag
      Avoid ld error
      Rebased patches
      Rebased clang patches
      Rebased clang-tools-extra patches
      First try to default to DWARF4 by default
      Produce DWARF4 by default
      Added pgo_instrumented_build conditional
      Make clang use the llvm-snapshot-builder
      Use %{llvm_snapshot_extra_source_tags} macro
      Fix %changelog not in descending chronological order
      Rebase patches
      Bring back clang
      Rebased patches and added third-party and cmake sources
      Adjust to https://reviews.llvm.org/D130586
      Disable LTO
      Manually apply https://reviews.llvm.org/D141581
      adjust /lib/ to /%{_lib}/
      Remove third party stuff and use gtest patch
      Rebased D138472
      Trace configure output
      Rebase D138472
      Assist find_package(LLVMGTest by setting hint dir to LLVM_CMAKE_DIR
      Merge remote-tracking branch 'origin/rawhide' into upstream-snapshot
      Add back 0001-cmake-Allow-shared-libraries-to-customize-the-soname.patch
      Fixup 0001-cmake-Allow-shared-libraries-to-customize-the-soname.patch
      Rebased 0001-clang-tools-extra-Make-test-dependency-on-LLVMHello-.patch
      Rebased 0001-PATCH-clang-Make-funwind-tables-the-default-on-all-a.patch
      Dropping 0001-Take-into-account-Fedora-Specific-install-dir-for-li.patch
      D142506 landed already
      Fix for the IEEE 128-bit fp error
      Fix RPM install of includes
      Merge remote-tracking branch 'origin/rawhide' into upstream-snapshot
      Remove already landed patches D141581 and D143736
      Rebase 0001-PATCH-clang-Make-funwind-tables-the-default-on-all-a.patch

Nikita Popov (7):
      Rebase downstream patches
      Rebase clang-tools-extra patches
      Add clang-offload-packager to clang_tools_binaries
      Rebase downstream patches
      Rebase LLVMHello patch
      Remove fno-openmp-implicit-rpath patches
      Restore fno-openmp-implicit-rpath patches

Tom Stellard (25):
      Revert patches that added LLVMHello dependency to clang-tools-extra tests
      Remove accidentally committed changes from previous commit
      Add clang-linker-wrapper and clang-pseudo binaries
      Add test for building an rpm with -fopenmp
      Add a smaller patch for fixing clang-tools-extra standalone build
      Update test name
      Add link to upstream patch for clang-tools-extra
      Update DWARF-4 patch to fix a test failure
      Rebase patch
      Emit DWARF4 by default
      Fix test after switch to DWARF4 default
      Fix dwarf test again
      Add workaround for build failure on i386/f36
      Remove accidentally committed change
      Add back -fno-openmp-implicit-rpath option
      Fix patch
      Remove patch that was committed upstream
      Update  -fno-openmp-implicit-rpath patches
      Drop openmp changes from patch
      Add fix for test failures on AArch64/f38+rawhide
      Revert "Add fix for test failures on AArch64/f38+rawhide"
      Update OpenMP rpath patch
      copr: Install llvm-snapshot-builder from the local COPR project
      Remove %clang_resource_dir_readonly macro
      Move clang-resource-dir to /usr/lib

sergesanspaille (5):
      Rebased clang-tools-extra patches
      Rebased clang-tools-extra patches
      rebase downstream patches
      Rebase downstream patches
      Rebase downstream patch
2023-08-11 10:18:00 -03:00

86 lines
3.7 KiB
Diff

From 22d62b32cd3be5fb0ae10723b35a781e0f862b71 Mon Sep 17 00:00:00 2001
From: Tom Stellard <tstellar@redhat.com>
Date: Tue, 24 Jan 2023 22:46:25 +0000
Subject: [PATCH] clang-tools-extra: Make test dependency on LLVMHello optional
This fixes clang + clang-tools-extra standalone build after
36892727e4f19a60778e371d78f8fb09d8122c85.
---
clang-tools-extra/test/CMakeLists.txt | 10 +++++++++-
clang-tools-extra/test/clang-tidy/CTTestTidyModule.cpp | 2 +-
clang-tools-extra/test/lit.cfg.py | 3 +++
clang-tools-extra/test/lit.site.cfg.py.in | 1 +
4 files changed, 14 insertions(+), 2 deletions(-)
diff --git a/clang-tools-extra/test/CMakeLists.txt b/clang-tools-extra/test/CMakeLists.txt
index f4c529ee8af2..1cfb4dd529aa 100644
--- a/clang-tools-extra/test/CMakeLists.txt
+++ b/clang-tools-extra/test/CMakeLists.txt
@@ -7,10 +7,15 @@
set(CLANG_TOOLS_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/..")
set(CLANG_TOOLS_BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/..")
+if (TARGET LLVMHello)
+ set (LLVM_HAS_LLVM_HELLO 1)
+endif()
+
llvm_canonicalize_cmake_booleans(
CLANG_TIDY_ENABLE_STATIC_ANALYZER
CLANG_PLUGIN_SUPPORT
LLVM_INSTALL_TOOLCHAIN_ONLY
+ LLVM_HAS_LLVM_HELLO
)
configure_lit_site_cfg(
@@ -86,7 +91,10 @@ if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
endif()
if(TARGET CTTestTidyModule)
- list(APPEND CLANG_TOOLS_TEST_DEPS CTTestTidyModule LLVMHello)
+ list(APPEND CLANG_TOOLS_TEST_DEPS CTTestTidyModule)
+ if (TARGET LLVMHello)
+ list(APPEND CLANG_TOOLS_TEST_DEPS CTTestTidyModule)
+ endif()
target_include_directories(CTTestTidyModule PUBLIC BEFORE "${CLANG_TOOLS_SOURCE_DIR}")
if(CLANG_PLUGIN_SUPPORT AND (WIN32 OR CYGWIN))
set(LLVM_LINK_COMPONENTS
diff --git a/clang-tools-extra/test/clang-tidy/CTTestTidyModule.cpp b/clang-tools-extra/test/clang-tidy/CTTestTidyModule.cpp
index c66a94f458cf..b4e7a5d691e5 100644
--- a/clang-tools-extra/test/clang-tidy/CTTestTidyModule.cpp
+++ b/clang-tools-extra/test/clang-tidy/CTTestTidyModule.cpp
@@ -1,4 +1,4 @@
-// REQUIRES: plugins
+// REQUIRES: plugins, llvm-hello
// RUN: clang-tidy -checks='-*,mytest*' --list-checks -load %llvmshlibdir/CTTestTidyModule%pluginext -load %llvmshlibdir/LLVMHello%pluginext | FileCheck --check-prefix=CHECK-LIST %s
// CHECK-LIST: Enabled checks:
// CHECK-LIST-NEXT: mytest1
diff --git a/clang-tools-extra/test/lit.cfg.py b/clang-tools-extra/test/lit.cfg.py
index 9f64fd3d2ffa..1b258a00ddf9 100644
--- a/clang-tools-extra/test/lit.cfg.py
+++ b/clang-tools-extra/test/lit.cfg.py
@@ -75,6 +75,9 @@ config.substitutions.append(("%clang_tidy_headers", clang_tidy_headers))
if config.has_plugins and config.llvm_plugin_ext:
config.available_features.add("plugins")
+if config.has_llvm_hello:
+ config.available_features.add("llvm-hello")
+
# It is not realistically possible to account for all options that could
# possibly be present in system and user configuration files, so disable
# default configs for the test runs.
diff --git a/clang-tools-extra/test/lit.site.cfg.py.in b/clang-tools-extra/test/lit.site.cfg.py.in
index 4eb830a1baf1..6e5559348454 100644
--- a/clang-tools-extra/test/lit.site.cfg.py.in
+++ b/clang-tools-extra/test/lit.site.cfg.py.in
@@ -11,6 +11,7 @@ config.target_triple = "@LLVM_TARGET_TRIPLE@"
config.host_triple = "@LLVM_HOST_TRIPLE@"
config.clang_tidy_staticanalyzer = @CLANG_TIDY_ENABLE_STATIC_ANALYZER@
config.has_plugins = @CLANG_PLUGIN_SUPPORT@ & ~@LLVM_INSTALL_TOOLCHAIN_ONLY@
+config.has_llvm_hello = @LLVM_HAS_LLVM_HELLO@
# Support substitution of the tools and libs dirs with user parameters. This is
# used when we can't determine the tool dir at configuration time.
config.llvm_tools_dir = lit_config.substitute("@LLVM_TOOLS_DIR@")
--
2.40.1