Normalize some doc directory locations
Remove obsolete patch
This commit is contained in:
parent
1167eb14a2
commit
fd536b6e06
@ -1,41 +0,0 @@
|
|||||||
From 903c872b169dc88f434cf84c0aee32e429e1cc56 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Balazs Benics <benicsbalazs@gmail.com>
|
|
||||||
Date: Fri, 31 Jul 2020 10:28:14 +0200
|
|
||||||
Subject: [PATCH] [analyzer] Fix out-of-tree only clang build by not relaying
|
|
||||||
on private header
|
|
||||||
|
|
||||||
It turned out that the D78704 included a private LLVM header, which is excluded
|
|
||||||
from the LLVM install target.
|
|
||||||
I'm substituting that `#include` with the public one by moving the necessary
|
|
||||||
`#define` into that. There was a discussion about this at D78704 and on the
|
|
||||||
cfe-dev mailing list.
|
|
||||||
|
|
||||||
I'm also placing a note to remind others of this pitfall.
|
|
||||||
|
|
||||||
Reviewed By: mgorny
|
|
||||||
|
|
||||||
Differential Revision: https://reviews.llvm.org/D84929
|
|
||||||
|
|
||||||
(cherry picked from commit 63d3aeb529a7b0fb95c2092ca38ad21c1f5cfd74)
|
|
||||||
---
|
|
||||||
.../StaticAnalyzer/FalsePositiveRefutationBRVisitorTest.cpp | 2 +-
|
|
||||||
llvm/include/llvm/Config/config.h.cmake | 6 +++---
|
|
||||||
llvm/include/llvm/Config/llvm-config.h.cmake | 3 +++
|
|
||||||
3 files changed, 7 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/clang/unittests/StaticAnalyzer/FalsePositiveRefutationBRVisitorTest.cpp b/clang/unittests/StaticAnalyzer/FalsePositiveRefutationBRVisitorTest.cpp
|
|
||||||
index 7c151c18211..e67dcacca0a 100644
|
|
||||||
--- a/clang/unittests/StaticAnalyzer/FalsePositiveRefutationBRVisitorTest.cpp
|
|
||||||
+++ b/clang/unittests/StaticAnalyzer/FalsePositiveRefutationBRVisitorTest.cpp
|
|
||||||
@@ -16,7 +16,7 @@
|
|
||||||
#include "clang/StaticAnalyzer/Core/PathSensitive/CheckerContext.h"
|
|
||||||
#include "clang/StaticAnalyzer/Frontend/AnalysisConsumer.h"
|
|
||||||
#include "clang/StaticAnalyzer/Frontend/CheckerRegistry.h"
|
|
||||||
-#include "llvm/Config/config.h"
|
|
||||||
+#include "llvm/Config/llvm-config.h"
|
|
||||||
#include "gtest/gtest.h"
|
|
||||||
|
|
||||||
// FIXME: Use GTEST_SKIP() instead if GTest is updated to version 1.10.0
|
|
||||||
--
|
|
||||||
2.18.1
|
|
||||||
|
|
12
clang.spec
12
clang.spec
@ -87,8 +87,6 @@ Source4: https://prereleases.llvm.org/%{version}/hans-gpg-key.asc
|
|||||||
Patch4: 0002-gtest-reorg.patch
|
Patch4: 0002-gtest-reorg.patch
|
||||||
Patch11: 0001-ToolChain-Add-lgcc_s-to-the-linker-flags-when-using-.patch
|
Patch11: 0001-ToolChain-Add-lgcc_s-to-the-linker-flags-when-using-.patch
|
||||||
Patch13: 0001-Make-funwind-tables-the-default-for-all-archs.patch
|
Patch13: 0001-Make-funwind-tables-the-default-for-all-archs.patch
|
||||||
# This is already in the release/11.x branch and will be included in -rc2.
|
|
||||||
Patch14: 0001-analyzer-Fix-out-of-tree-only-clang-build-by-not-rel.patch
|
|
||||||
|
|
||||||
# Not Upstream
|
# Not Upstream
|
||||||
Patch15: 0001-clang-Don-t-install-static-libraries.patch
|
Patch15: 0001-clang-Don-t-install-static-libraries.patch
|
||||||
@ -260,7 +258,6 @@ pathfix.py -i %{__python3} -pn \
|
|||||||
%patch4 -p1 -b .gtest
|
%patch4 -p1 -b .gtest
|
||||||
%patch11 -p1 -b .libcxx-fix
|
%patch11 -p1 -b .libcxx-fix
|
||||||
%patch13 -p2 -b .unwind-all
|
%patch13 -p2 -b .unwind-all
|
||||||
%patch14 -p2 -b .test-fix
|
|
||||||
%patch15 -p2 -b .no-install-static
|
%patch15 -p2 -b .no-install-static
|
||||||
%patch16 -p2 -b .test-fix2
|
%patch16 -p2 -b .test-fix2
|
||||||
|
|
||||||
@ -380,9 +377,9 @@ rm -vf %{buildroot}%{_datadir}/clang/clang-format-bbedit.applescript
|
|||||||
rm -vf %{buildroot}%{_datadir}/clang/clang-format-sublime.py*
|
rm -vf %{buildroot}%{_datadir}/clang/clang-format-sublime.py*
|
||||||
|
|
||||||
# TODO: Package html docs
|
# TODO: Package html docs
|
||||||
rm -Rvf %{buildroot}%{_pkgdocdir}
|
rm -Rvf %{buildroot}%{_docdir}/clang/html
|
||||||
rm -Rvf %{buildroot}%{install_prefix}/share/clang/clang-doc-default-stylesheet.css
|
rm -Rvf %{buildroot}%{_datadir}/clang/clang-doc-default-stylesheet.css
|
||||||
rm -Rvf %{buildroot}%{install_prefix}/share/clang/index.js
|
rm -Rvf %{buildroot}%{_datadir}/clang/index.js
|
||||||
|
|
||||||
# TODO: What are the Fedora guidelines for packaging bash autocomplete files?
|
# TODO: What are the Fedora guidelines for packaging bash autocomplete files?
|
||||||
rm -vf %{buildroot}%{_datadir}/clang/bash-autocomplete.sh
|
rm -vf %{buildroot}%{_datadir}/clang/bash-autocomplete.sh
|
||||||
@ -496,6 +493,9 @@ false
|
|||||||
|
|
||||||
%endif
|
%endif
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 01 2020 sguelton@redhat.com - 11.0.0-0.2.rc2
|
||||||
|
- Normalize some doc directory locations
|
||||||
|
|
||||||
* Tue Sep 01 2020 sguelton@redhat.com - 11.0.0-0.1.rc2
|
* Tue Sep 01 2020 sguelton@redhat.com - 11.0.0-0.1.rc2
|
||||||
- 11.0.0-rc2 Release
|
- 11.0.0-rc2 Release
|
||||||
- Use %%license macro
|
- Use %%license macro
|
||||||
|
Loading…
Reference in New Issue
Block a user