Rename, cleanup and normalize patch serie
This commit is contained in:
parent
333b956fb4
commit
d803ebb6bc
@ -1,24 +0,0 @@
|
||||
diff -Naur clang-12.0.0rc1.src.orig/lib/Driver/ToolChain.cpp clang-12.0.0rc1.src/lib/Driver/ToolChain.cpp
|
||||
--- clang-12.0.0rc1.src.orig/lib/Driver/ToolChain.cpp 2021-02-15 21:40:55.000000000 +0100
|
||||
+++ clang-12.0.0rc1.src/lib/Driver/ToolChain.cpp 2021-02-16 07:35:01.000000000 +0100
|
||||
@@ -257,7 +257,7 @@
|
||||
}
|
||||
|
||||
bool ToolChain::IsUnwindTablesDefault(const ArgList &Args) const {
|
||||
- return false;
|
||||
+ return true;
|
||||
}
|
||||
|
||||
Tool *ToolChain::getClang() const {
|
||||
diff -Naur clang-12.0.0rc1.src.orig/lib/Driver/ToolChains/Gnu.cpp clang-12.0.0rc1.src/lib/Driver/ToolChains/Gnu.cpp
|
||||
--- clang-12.0.0rc1.src.orig/lib/Driver/ToolChains/Gnu.cpp 2021-02-15 21:40:55.000000000 +0100
|
||||
+++ clang-12.0.0rc1.src/lib/Driver/ToolChains/Gnu.cpp 2021-02-16 07:35:30.000000000 +0100
|
||||
@@ -2713,7 +2713,7 @@
|
||||
case llvm::Triple::x86_64:
|
||||
return true;
|
||||
default:
|
||||
- return false;
|
||||
+ return true;
|
||||
}
|
||||
}
|
||||
|
@ -1,7 +1,17 @@
|
||||
diff -Naur clang-12.0.0rc1.src.orig/CMakeLists.txt clang-12.0.0rc1.src/CMakeLists.txt
|
||||
--- clang-12.0.0rc1.src.orig/CMakeLists.txt 2021-02-14 21:40:31.000000000 +0100
|
||||
+++ clang-12.0.0rc1.src/CMakeLists.txt 2021-02-14 21:41:57.000000000 +0100
|
||||
@@ -153,12 +153,6 @@
|
||||
From 7475a5bacb2c9dee974199652740d1555eb36e56 Mon Sep 17 00:00:00 2001
|
||||
From: serge-sans-paille <sguelton@redhat.com>
|
||||
Date: Thu, 25 Feb 2021 14:04:52 +0100
|
||||
Subject: [PATCH 1/6] [PATCH][clang] Reorganize gtest integration
|
||||
|
||||
---
|
||||
clang/CMakeLists.txt | 12 +++++-------
|
||||
1 file changed, 5 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/clang/CMakeLists.txt b/clang/CMakeLists.txt
|
||||
index 9e74014..0185276 100644
|
||||
--- a/clang/CMakeLists.txt
|
||||
+++ b/clang/CMakeLists.txt
|
||||
@@ -153,12 +153,6 @@ if( CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR )
|
||||
set(LLVM_UTILS_PROVIDED ON)
|
||||
set(CLANG_TEST_DEPS FileCheck count not)
|
||||
endif()
|
||||
@ -14,7 +24,7 @@ diff -Naur clang-12.0.0rc1.src.orig/CMakeLists.txt clang-12.0.0rc1.src/CMakeList
|
||||
else()
|
||||
# Seek installed Lit.
|
||||
find_program(LLVM_LIT
|
||||
@@ -537,7 +531,11 @@
|
||||
@@ -537,7 +531,11 @@ endif()
|
||||
|
||||
|
||||
if( CLANG_INCLUDE_TESTS )
|
||||
@ -27,3 +37,6 @@ diff -Naur clang-12.0.0rc1.src.orig/CMakeLists.txt clang-12.0.0rc1.src/CMakeList
|
||||
add_subdirectory(unittests)
|
||||
list(APPEND CLANG_TEST_DEPS ClangUnitTests)
|
||||
list(APPEND CLANG_TEST_PARAMS
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -1,25 +0,0 @@
|
||||
From 5bfce60443b1c3f4066f506e47cbdc7c4263bb10 Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Tue, 11 Aug 2020 18:32:08 -0700
|
||||
Subject: [PATCH] clang: Fix spurious test failure
|
||||
|
||||
---
|
||||
clang/test/Driver/crash-report-modules.m | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/clang/test/Driver/crash-report-modules.m b/clang/test/Driver/crash-report-modules.m
|
||||
index e6d03353379..9519adf6f4b 100644
|
||||
--- a/clang/test/Driver/crash-report-modules.m
|
||||
+++ b/clang/test/Driver/crash-report-modules.m
|
||||
@@ -19,7 +19,7 @@
|
||||
@import simple;
|
||||
const int x = MODULE_MACRO;
|
||||
|
||||
-// CHECK: PLEASE submit a bug report to {{.*}} and include the crash backtrace, preprocessed source, and associated run script.
|
||||
+// CHECK: PLEASE submit a bug report to {{.*}}and include the crash backtrace, preprocessed source, and associated run script.
|
||||
// CHECK: Preprocessed source(s) and associated run script(s) are located at:
|
||||
// CHECK-NEXT: note: diagnostic msg: {{.*}}.m
|
||||
// CHECK-NEXT: note: diagnostic msg: {{.*}}.cache
|
||||
--
|
||||
2.18.1
|
||||
|
@ -1,7 +1,8 @@
|
||||
From 09ae3ef5710a89505318ec721c65b6c838147276 Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Thu, 7 Feb 2019 21:05:37 -0800
|
||||
Subject: [PATCH] ToolChain: Add -lgcc_s to the linker flags when using libc++
|
||||
From 27000b14439d22145487f55f8a85eb5f8cc98e30 Mon Sep 17 00:00:00 2001
|
||||
From: serge-sans-paille <sguelton@redhat.com>
|
||||
Date: Thu, 25 Feb 2021 14:08:28 +0100
|
||||
Subject: [PATCH 2/6] [PATCH][clang] ToolChain: Add -lgcc_s to the linker flags
|
||||
when using libc++
|
||||
|
||||
The libc++ build for Fedora does not include an implementation of
|
||||
libunwind, so we need to explicitly link against something that
|
||||
@ -11,11 +12,11 @@ provides this implementation.
|
||||
clang/test/Driver/netbsd.cpp | 4 ++--
|
||||
2 files changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/lib/Driver/ToolChain.cpp b/lib/Driver/ToolChain.cpp
|
||||
index 88a627e..cb99844 100644
|
||||
--- a/lib/Driver/ToolChain.cpp
|
||||
+++ b/lib/Driver/ToolChain.cpp
|
||||
@@ -767,6 +767,7 @@ void ToolChain::AddCXXStdlibLibArgs(const ArgList &Args,
|
||||
diff --git a/clang/lib/Driver/ToolChain.cpp b/clang/lib/Driver/ToolChain.cpp
|
||||
index b2ddef1..c4c71e1 100644
|
||||
--- a/clang/lib/Driver/ToolChain.cpp
|
||||
+++ b/clang/lib/Driver/ToolChain.cpp
|
||||
@@ -1014,6 +1014,7 @@ void ToolChain::AddCXXStdlibLibArgs(const ArgList &Args,
|
||||
switch (Type) {
|
||||
case ToolChain::CST_Libcxx:
|
||||
CmdArgs.push_back("-lc++");
|
||||
@ -23,10 +24,10 @@ index 88a627e..cb99844 100644
|
||||
break;
|
||||
|
||||
case ToolChain::CST_Libstdcxx:
|
||||
diff --git a/test/Driver/netbsd.cpp b/test/Driver/netbsd.cpp
|
||||
diff --git a/clang/test/Driver/netbsd.cpp b/clang/test/Driver/netbsd.cpp
|
||||
index 4af7d83..ff18c62 100644
|
||||
--- a/test/Driver/netbsd.cpp
|
||||
+++ b/test/Driver/netbsd.cpp
|
||||
--- a/clang/test/Driver/netbsd.cpp
|
||||
+++ b/clang/test/Driver/netbsd.cpp
|
||||
@@ -131,7 +131,7 @@
|
||||
// ARM-7: clang{{.*}}" "-cc1" "-triple" "armv5e-unknown-netbsd7.0.0-eabi"
|
||||
// ARM-7: ld{{.*}}" "--eh-frame-hdr" "-dynamic-linker" "/libexec/ld.elf_so"
|
@ -0,0 +1,40 @@
|
||||
From 1622f30ac9ece9171dccb25db8d596ac45b11eee Mon Sep 17 00:00:00 2001
|
||||
From: serge-sans-paille <sguelton@redhat.com>
|
||||
Date: Thu, 25 Feb 2021 14:09:29 +0100
|
||||
Subject: [PATCH 3/6] [PATCH][clang] Make -funwind-tables the default on all
|
||||
archs
|
||||
|
||||
---
|
||||
clang/lib/Driver/ToolChain.cpp | 2 +-
|
||||
clang/lib/Driver/ToolChains/Gnu.cpp | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/clang/lib/Driver/ToolChain.cpp b/clang/lib/Driver/ToolChain.cpp
|
||||
index c4c71e1..d237cc6 100644
|
||||
--- a/clang/lib/Driver/ToolChain.cpp
|
||||
+++ b/clang/lib/Driver/ToolChain.cpp
|
||||
@@ -257,7 +257,7 @@ std::string ToolChain::getInputFilename(const InputInfo &Input) const {
|
||||
}
|
||||
|
||||
bool ToolChain::IsUnwindTablesDefault(const ArgList &Args) const {
|
||||
- return false;
|
||||
+ return true;
|
||||
}
|
||||
|
||||
Tool *ToolChain::getClang() const {
|
||||
diff --git a/clang/lib/Driver/ToolChains/Gnu.cpp b/clang/lib/Driver/ToolChains/Gnu.cpp
|
||||
index 1d8a3cd..5deeb10 100644
|
||||
--- a/clang/lib/Driver/ToolChains/Gnu.cpp
|
||||
+++ b/clang/lib/Driver/ToolChains/Gnu.cpp
|
||||
@@ -2713,7 +2713,7 @@ bool Generic_GCC::IsUnwindTablesDefault(const ArgList &Args) const {
|
||||
case llvm::Triple::x86_64:
|
||||
return true;
|
||||
default:
|
||||
- return false;
|
||||
+ return true;
|
||||
}
|
||||
}
|
||||
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -1,14 +1,14 @@
|
||||
From 8097a9d4295dbc39cbd541ccace7bc5884852366 Mon Sep 17 00:00:00 2001
|
||||
From 4dbe9c671f4f15f5fb6bf80428505690e15b7c83 Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Fri, 31 Jan 2020 11:04:57 -0800
|
||||
Subject: [PATCH] clang: Don't install static libraries
|
||||
Subject: [PATCH 4/6] [PATCH][clang] Don't install static libraries
|
||||
|
||||
---
|
||||
clang/cmake/modules/AddClang.cmake | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/clang/cmake/modules/AddClang.cmake b/clang/cmake/modules/AddClang.cmake
|
||||
index 704278a0e93..1737b24a2bc 100644
|
||||
index 704278a..1737b24 100644
|
||||
--- a/clang/cmake/modules/AddClang.cmake
|
||||
+++ b/clang/cmake/modules/AddClang.cmake
|
||||
@@ -111,7 +111,7 @@ macro(add_clang_library name)
|
||||
@ -21,5 +21,5 @@ index 704278a0e93..1737b24a2bc 100644
|
||||
if(${lib} IN_LIST LLVM_DISTRIBUTION_COMPONENTS OR
|
||||
"clang-libraries" IN_LIST LLVM_DISTRIBUTION_COMPONENTS OR
|
||||
--
|
||||
2.18.1
|
||||
1.8.3.1
|
||||
|
@ -1,8 +1,8 @@
|
||||
From 67013ee5feecca0c1e1dd8a149b20779a9b6c12a Mon Sep 17 00:00:00 2001
|
||||
From 00bae317b3ae890a4baab8338696c3c9b0cdc114 Mon Sep 17 00:00:00 2001
|
||||
From: serge-sans-paille <sguelton@redhat.com>
|
||||
Date: Wed, 23 Sep 2020 12:47:30 +0000
|
||||
Subject: [PATCH] Driver: Prefer gcc toolchains with libgcc_s.so when not
|
||||
static linking libgcc
|
||||
Subject: [PATCH 5/6] [PATCH][clang] Prefer gcc toolchains with libgcc_s.so
|
||||
when not static linking libgcc
|
||||
|
||||
Fedora ships cross-compilers on all platforms, so a user could end up
|
||||
with a gcc x86_64 cross-compiler installed on an x86_64 system. clang
|
||||
@ -21,22 +21,22 @@ This patch fixes this by checking for the existence of libgcc_s.so
|
||||
when it is required and taking that into account when selecting a
|
||||
toolchain.
|
||||
---
|
||||
lib/Driver/ToolChains/Gnu.cpp | 16 ++++++++++++++--
|
||||
lib/Driver/ToolChains/Gnu.h | 4 +++-
|
||||
.../usr/lib/gcc/x86_64-linux-gnu/7/crtbegin.o | 0
|
||||
.../usr/lib/gcc/x86_64-redhat-linux/7/crtbegin.o | 0
|
||||
.../lib/gcc/x86_64-redhat-linux/7/libgcc_s.so | 0
|
||||
test/Driver/linux-ld.c | 12 ++++++++++++
|
||||
clang/lib/Driver/ToolChains/Gnu.cpp | 16 ++++++++++++++--
|
||||
clang/lib/Driver/ToolChains/Gnu.h | 4 +++-
|
||||
.../usr/lib/gcc/x86_64-linux-gnu/7/crtbegin.o | 0
|
||||
.../usr/lib/gcc/x86_64-redhat-linux/7/crtbegin.o | 0
|
||||
.../usr/lib/gcc/x86_64-redhat-linux/7/libgcc_s.so | 0
|
||||
clang/test/Driver/linux-ld.c | 12 ++++++++++++
|
||||
6 files changed, 29 insertions(+), 3 deletions(-)
|
||||
create mode 100644 test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-linux-gnu/7/crtbegin.o
|
||||
create mode 100644 test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/crtbegin.o
|
||||
create mode 100644 test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/libgcc_s.so
|
||||
create mode 100644 clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-linux-gnu/7/crtbegin.o
|
||||
create mode 100644 clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/crtbegin.o
|
||||
create mode 100644 clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/libgcc_s.so
|
||||
|
||||
diff --git a/lib/Driver/ToolChains/Gnu.cpp b/lib/Driver/ToolChains/Gnu.cpp
|
||||
index c8a7fce0..f28792b7 100644
|
||||
--- a/lib/Driver/ToolChains/Gnu.cpp
|
||||
+++ b/lib/Driver/ToolChains/Gnu.cpp
|
||||
@@ -2500,6 +2500,8 @@ void Generic_GCC::GCCInstallationDetector::ScanLibDirForGCCTriple(
|
||||
diff --git a/clang/lib/Driver/ToolChains/Gnu.cpp b/clang/lib/Driver/ToolChains/Gnu.cpp
|
||||
index 5deeb10..5d51517 100644
|
||||
--- a/clang/lib/Driver/ToolChains/Gnu.cpp
|
||||
+++ b/clang/lib/Driver/ToolChains/Gnu.cpp
|
||||
@@ -2539,6 +2539,8 @@ void Generic_GCC::GCCInstallationDetector::ScanLibDirForGCCTriple(
|
||||
(TargetArch == llvm::Triple::x86 &&
|
||||
TargetTriple.getOS() != llvm::Triple::Solaris)}};
|
||||
|
||||
@ -45,7 +45,7 @@ index c8a7fce0..f28792b7 100644
|
||||
for (auto &Suffix : Suffixes) {
|
||||
if (!Suffix.Active)
|
||||
continue;
|
||||
@@ -2517,8 +2519,17 @@ void Generic_GCC::GCCInstallationDetector::ScanLibDirForGCCTriple(
|
||||
@@ -2556,8 +2558,17 @@ void Generic_GCC::GCCInstallationDetector::ScanLibDirForGCCTriple(
|
||||
continue; // Saw this path before; no need to look at it again.
|
||||
if (CandidateVersion.isOlderThan(4, 1, 1))
|
||||
continue;
|
||||
@ -65,7 +65,7 @@ index c8a7fce0..f28792b7 100644
|
||||
|
||||
if (!ScanGCCForMultilibs(TargetTriple, Args, LI->path(),
|
||||
NeedsBiarchSuffix))
|
||||
@@ -2532,6 +2543,7 @@ void Generic_GCC::GCCInstallationDetector::ScanLibDirForGCCTriple(
|
||||
@@ -2571,6 +2582,7 @@ void Generic_GCC::GCCInstallationDetector::ScanLibDirForGCCTriple(
|
||||
GCCInstallPath = (LibDir + "/" + LibSuffix + "/" + VersionText).str();
|
||||
GCCParentLibPath = (GCCInstallPath + "/../" + Suffix.ReversePath).str();
|
||||
IsValid = true;
|
||||
@ -73,11 +73,11 @@ index c8a7fce0..f28792b7 100644
|
||||
}
|
||||
}
|
||||
}
|
||||
diff --git a/lib/Driver/ToolChains/Gnu.h b/lib/Driver/ToolChains/Gnu.h
|
||||
index 52690ab4..2a4452d9 100644
|
||||
--- a/lib/Driver/ToolChains/Gnu.h
|
||||
+++ b/lib/Driver/ToolChains/Gnu.h
|
||||
@@ -190,6 +190,7 @@
|
||||
diff --git a/clang/lib/Driver/ToolChains/Gnu.h b/clang/lib/Driver/ToolChains/Gnu.h
|
||||
index 90d3baf..9d0cea2 100644
|
||||
--- a/clang/lib/Driver/ToolChains/Gnu.h
|
||||
+++ b/clang/lib/Driver/ToolChains/Gnu.h
|
||||
@@ -190,6 +190,7 @@ public:
|
||||
/// Driver, and has logic for fuzzing that where appropriate.
|
||||
class GCCInstallationDetector {
|
||||
bool IsValid;
|
||||
@ -85,7 +85,7 @@ index 52690ab4..2a4452d9 100644
|
||||
llvm::Triple GCCTriple;
|
||||
const Driver &D;
|
||||
|
||||
@@ -216,7 +217,8 @@
|
||||
@@ -216,7 +217,8 @@ public:
|
||||
const std::string GentooConfigDir = "/etc/env.d/gcc";
|
||||
|
||||
public:
|
||||
@ -95,20 +95,19 @@ index 52690ab4..2a4452d9 100644
|
||||
void init(const llvm::Triple &TargetTriple, const llvm::opt::ArgList &Args,
|
||||
ArrayRef<std::string> ExtraTripleAliases = None);
|
||||
|
||||
|
||||
diff --git a/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-linux-gnu/7/crtbegin.o b/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-linux-gnu/7/crtbegin.o
|
||||
diff --git a/clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-linux-gnu/7/crtbegin.o b/clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-linux-gnu/7/crtbegin.o
|
||||
new file mode 100644
|
||||
index 00000000..e69de29b
|
||||
diff --git a/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/crtbegin.o b/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/crtbegin.o
|
||||
index 0000000..e69de29
|
||||
diff --git a/clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/crtbegin.o b/clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/crtbegin.o
|
||||
new file mode 100644
|
||||
index 00000000..e69de29b
|
||||
diff --git a/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/libgcc_s.so b/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/libgcc_s.so
|
||||
index 0000000..e69de29
|
||||
diff --git a/clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/libgcc_s.so b/clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/libgcc_s.so
|
||||
new file mode 100644
|
||||
index 00000000..e69de29b
|
||||
diff --git a/test/Driver/linux-ld.c b/test/Driver/linux-ld.c
|
||||
index ec539522..95725d5c 100644
|
||||
--- a/test/Driver/linux-ld.c
|
||||
+++ b/test/Driver/linux-ld.c
|
||||
index 0000000..e69de29
|
||||
diff --git a/clang/test/Driver/linux-ld.c b/clang/test/Driver/linux-ld.c
|
||||
index 24d3c78..071bb9b 100644
|
||||
--- a/clang/test/Driver/linux-ld.c
|
||||
+++ b/clang/test/Driver/linux-ld.c
|
||||
@@ -784,6 +784,18 @@
|
||||
// CHECK-FEDORA-31-RISCV64: "{{.*}}/usr/lib/gcc/riscv64-redhat-linux/9{{/|\\\\}}crtend.o"
|
||||
// CHECK-FEDORA-31-RISCV64: "{{.*}}/usr/lib/gcc/riscv64-redhat-linux/9{{/|\\\\}}crtn.o"
|
||||
@ -129,5 +128,5 @@ index ec539522..95725d5c 100644
|
||||
// RUN: --target=arm-unknown-linux-gnueabi -rtlib=platform \
|
||||
// RUN: --gcc-toolchain="" \
|
||||
--
|
||||
2.25.2
|
||||
1.8.3.1
|
||||
|
@ -1,8 +1,8 @@
|
||||
From 9d68d4554d903353a7d4599d2428bd479651eb40 Mon Sep 17 00:00:00 2001
|
||||
From 4e7dc19c77a609671b2dea81797d79dad1b688c3 Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Tue, 9 Feb 2021 13:35:43 -0800
|
||||
Subject: [PATCH] Partially Revert "scan-view: Remove Reporter.py and
|
||||
associated AppleScript files"
|
||||
Subject: [PATCH 6/6] [PATCH][clang] Partially Revert "scan-view: Remove
|
||||
Reporter.py and associated AppleScript files"
|
||||
|
||||
This reverts some of commit dbb01536f6f49fa428f170e34466072ef439b3e9.
|
||||
|
||||
@ -14,12 +14,12 @@ dbb01536f6f49fa428f170e34466072ef439b3e9.
|
||||
Differential Revision: https://reviews.llvm.org/D96367
|
||||
---
|
||||
clang/tools/scan-view/CMakeLists.txt | 1 +
|
||||
clang/tools/scan-view/share/Reporter.py | 183 ++++++++++++++++++++++++
|
||||
clang/tools/scan-view/share/Reporter.py | 183 ++++++++++++++++++++++++++++++++
|
||||
2 files changed, 184 insertions(+)
|
||||
create mode 100644 clang/tools/scan-view/share/Reporter.py
|
||||
|
||||
diff --git a/clang/tools/scan-view/CMakeLists.txt b/clang/tools/scan-view/CMakeLists.txt
|
||||
index dd3d33439299..eccc6b83195b 100644
|
||||
index dd3d334..eccc6b8 100644
|
||||
--- a/clang/tools/scan-view/CMakeLists.txt
|
||||
+++ b/clang/tools/scan-view/CMakeLists.txt
|
||||
@@ -5,6 +5,7 @@ set(BinFiles
|
||||
@ -32,7 +32,7 @@ index dd3d33439299..eccc6b83195b 100644
|
||||
|
||||
diff --git a/clang/tools/scan-view/share/Reporter.py b/clang/tools/scan-view/share/Reporter.py
|
||||
new file mode 100644
|
||||
index 000000000000..31a14fb0cf74
|
||||
index 0000000..31a14fb
|
||||
--- /dev/null
|
||||
+++ b/clang/tools/scan-view/share/Reporter.py
|
||||
@@ -0,0 +1,183 @@
|
||||
@ -220,5 +220,5 @@ index 000000000000..31a14fb0cf74
|
||||
+ return reporters
|
||||
+
|
||||
--
|
||||
2.27.0
|
||||
1.8.3.1
|
||||
|
21
clang.spec
21
clang.spec
@ -90,13 +90,12 @@ Source4: tstellar-gpg-key.asc
|
||||
Patch21: completion-model-cmake.patch
|
||||
%endif
|
||||
|
||||
# Not Upstream
|
||||
Patch4: 0002-gtest-reorg.patch
|
||||
Patch11: 0001-ToolChain-Add-lgcc_s-to-the-linker-flags-when-using-.patch
|
||||
Patch13: 0001-Make-funwind-tables-the-default-for-all-archs.patch
|
||||
Patch15: 0001-clang-Don-t-install-static-libraries.patch
|
||||
Patch17: 0001-Driver-Prefer-gcc-toolchains-with-libgcc_s.so-when-n.patch
|
||||
Patch19: 0001-Partially-Revert-scan-view-Remove-Reporter.py-and-as.patch
|
||||
Patch4: 0001-PATCH-clang-Reorganize-gtest-integration.patch
|
||||
Patch11: 0002-PATCH-clang-ToolChain-Add-lgcc_s-to-the-linker-flags.patch
|
||||
Patch13: 0003-PATCH-clang-Make-funwind-tables-the-default-on-all-a.patch
|
||||
Patch15: 0004-PATCH-clang-Don-t-install-static-libraries.patch
|
||||
Patch17: 0005-PATCH-clang-Prefer-gcc-toolchains-with-libgcc_s.so-w.patch
|
||||
Patch19: 0006-PATCH-clang-Partially-Revert-scan-view-Remove-Report.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
@ -277,11 +276,11 @@ pathfix.py -i %{__python3} -pn \
|
||||
|
||||
%setup -q -n %{clang_srcdir}
|
||||
|
||||
%patch4 -p1 -b .gtest
|
||||
%patch11 -p1 -b .libcxx-fix
|
||||
%patch13 -p1 -b .unwind-default
|
||||
%patch4 -p2 -b .gtest
|
||||
%patch11 -p2 -b .libcxx-fix
|
||||
%patch13 -p2 -b .unwind-default
|
||||
%patch15 -p2 -b .no-install-static
|
||||
%patch17 -p1 -b .check-gcc_s
|
||||
%patch17 -p2 -b .check-gcc_s
|
||||
%patch19 -p2 -b .scan-view-remove-files-fix
|
||||
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user