rebuilt with https://reviews.llvm.org/D94941 applied.
This commit is contained in:
parent
81f9d35924
commit
a60f8bc1c9
36
D94941.diff
Normal file
36
D94941.diff
Normal file
@ -0,0 +1,36 @@
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -509,7 +509,7 @@
|
||||
"${CLANG_VERSION_MAJOR}" CACHE STRING
|
||||
"Major version number that will be appended to the clang executable name")
|
||||
set(LIBCLANG_LIBRARY_VERSION
|
||||
- "${CLANG_VERSION_MAJOR}" CACHE STRING
|
||||
+ "${CLANG_VERSION_MAJOR}.${CLANG_VERSION_MINOR}" CACHE STRING
|
||||
"Major version number that will be appended to the libclang library")
|
||||
mark_as_advanced(CLANG_EXECUTABLE_VERSION LIBCLANG_LIBRARY_VERSION)
|
||||
|
||||
diff --git a/tools/clang-shlib/CMakeLists.txt b/tools/clang-shlib/CMakeLists.txt
|
||||
--- a/tools/clang-shlib/CMakeLists.txt
|
||||
+++ b/tools/clang-shlib/CMakeLists.txt
|
||||
@@ -48,3 +48,8 @@
|
||||
${_OBJECTS}
|
||||
LINK_LIBS
|
||||
${_DEPS})
|
||||
+
|
||||
+ set_target_properties(clang-cpp
|
||||
+ PROPERTIES
|
||||
+ VERSION ${LIBCLANG_LIBRARY_VERSION}
|
||||
+ SOVERSION ${LIBCLANG_LIBRARY_VERSION})
|
||||
diff --git a/tools/libclang/CMakeLists.txt b/tools/libclang/CMakeLists.txt
|
||||
--- a/tools/libclang/CMakeLists.txt
|
||||
+++ b/tools/libclang/CMakeLists.txt
|
||||
@@ -150,6 +150,7 @@
|
||||
else()
|
||||
set_target_properties(libclang
|
||||
PROPERTIES
|
||||
+ SOVERSION ${LIBCLANG_LIBRARY_VERSION}
|
||||
VERSION ${LIBCLANG_LIBRARY_VERSION}
|
||||
DEFINE_SYMBOL _CINDEX_LIB_)
|
||||
# FIXME: _CINDEX_LIB_ affects dllexport/dllimport on Win32.
|
||||
|
@ -4,7 +4,7 @@
|
||||
%global min_ver 1
|
||||
%global patch_ver 0
|
||||
%global rc_ver 1
|
||||
%global baserelease 1
|
||||
%global baserelease 2
|
||||
|
||||
%global clang_tools_binaries \
|
||||
%{_bindir}/clang-apply-replacements \
|
||||
@ -89,6 +89,9 @@ Patch4: 0002-gtest-reorg.patch
|
||||
Patch11: 0001-ToolChain-Add-lgcc_s-to-the-linker-flags-when-using-.patch
|
||||
Patch13: 0001-Make-funwind-tables-the-default-for-all-archs.patch
|
||||
|
||||
# Fix SONAME
|
||||
Patch5: D94941.diff
|
||||
|
||||
# Not Upstream
|
||||
Patch15: 0001-clang-Don-t-install-static-libraries.patch
|
||||
Patch16: 0001-clang-Fix-spurious-test-failure.patch
|
||||
@ -528,6 +531,9 @@ false
|
||||
|
||||
%endif
|
||||
%changelog
|
||||
* Wed Jan 20 2021 Serge Guelton - 11.1.0-0.2.rc1
|
||||
- rebuilt with https://reviews.llvm.org/D94941 applied.
|
||||
|
||||
* Thu Jan 14 2021 Serge Guelton - 11.1.0-0.1.rc1
|
||||
- 11.1.0-rc1 release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user