13.0.0-rc1 Release
This commit is contained in:
parent
f2a6113c88
commit
a5df6c712b
4
.gitignore
vendored
4
.gitignore
vendored
@ -179,3 +179,7 @@
|
|||||||
/clang-12.0.1.src.tar.xz.sig
|
/clang-12.0.1.src.tar.xz.sig
|
||||||
/clang-tools-extra-12.0.1.src.tar.xz
|
/clang-tools-extra-12.0.1.src.tar.xz
|
||||||
/clang-tools-extra-12.0.1.src.tar.xz.sig
|
/clang-tools-extra-12.0.1.src.tar.xz.sig
|
||||||
|
/clang-13.0.0rc1.src.tar.xz
|
||||||
|
/clang-13.0.0rc1.src.tar.xz.sig
|
||||||
|
/clang-tools-extra-13.0.0rc1.src.tar.xz
|
||||||
|
/clang-tools-extra-13.0.0rc1.src.tar.xz.sig
|
||||||
|
@ -0,0 +1,39 @@
|
|||||||
|
From 3dc5722d5c7673a879f2b4680369d3ac8b6b64b6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Tom Stellard <tstellar@redhat.com>
|
||||||
|
Date: Wed, 4 Aug 2021 14:05:38 -0700
|
||||||
|
Subject: [PATCH] cmake: Allow shared libraries to customize the soname using
|
||||||
|
LLVM_ABI_REVISION
|
||||||
|
|
||||||
|
The LLVM_ABI_REVISION variable is intended to be used for release
|
||||||
|
candidates which introduce an ABI change to a shared library. This
|
||||||
|
variable can be specified per library, so there is not one global value
|
||||||
|
for all of LLVM.
|
||||||
|
|
||||||
|
For example, if we LLVM X.0.0-rc2 introduces an ABI change for a library
|
||||||
|
compared with LLVM X.0.0-rc1, then the LLVM_ABI_REVISION number for
|
||||||
|
library will be incremented by 1.
|
||||||
|
|
||||||
|
In the main branch, LLVM_ABI_REVISION should always be 0, it is only
|
||||||
|
meant to be used in the release branch.
|
||||||
|
|
||||||
|
Differential Revision: https://reviews.llvm.org/D105594
|
||||||
|
---
|
||||||
|
clang/tools/clang-shlib/CMakeLists.txt | 5 +++++
|
||||||
|
3 files changed, 19 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/clang/tools/clang-shlib/CMakeLists.txt b/clang/tools/clang-shlib/CMakeLists.txt
|
||||||
|
index 9c1f8ea452b3..4d785924e4bb 100644
|
||||||
|
--- a/clang/tools/clang-shlib/CMakeLists.txt
|
||||||
|
+++ b/clang/tools/clang-shlib/CMakeLists.txt
|
||||||
|
@@ -1,3 +1,8 @@
|
||||||
|
+# In the main branch, LLVM_ABI_REVISION should always be 0. In the release
|
||||||
|
+# branches, this should be incremented before each release candidate every
|
||||||
|
+# time the ABI of libclang-cpp.so changes.
|
||||||
|
+set(LLVM_ABI_REVISION 0)
|
||||||
|
+
|
||||||
|
# Building libclang-cpp.so fails if LLVM_ENABLE_PIC=Off
|
||||||
|
if (NOT LLVM_ENABLE_PIC)
|
||||||
|
return()
|
||||||
|
--
|
||||||
|
2.27.0
|
||||||
|
|
@ -1,25 +1,25 @@
|
|||||||
From 2c6cd40d016f492d53e16f1c7424a0d9878ae7ec Mon Sep 17 00:00:00 2001
|
From 88704fc2eabb9dd19a9c3eb81a9b3dc37d95651c Mon Sep 17 00:00:00 2001
|
||||||
From: Tom Stellard <tstellar@redhat.com>
|
From: Tom Stellard <tstellar@redhat.com>
|
||||||
Date: Fri, 31 Jan 2020 11:04:57 -0800
|
Date: Fri, 31 Jan 2020 11:04:57 -0800
|
||||||
Subject: [PATCH 3/6] [PATCH][clang] Don't install static libraries
|
Subject: [PATCH][clang] Don't install static libraries
|
||||||
|
|
||||||
---
|
---
|
||||||
clang/cmake/modules/AddClang.cmake | 2 +-
|
clang/cmake/modules/AddClang.cmake | 2 +-
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/clang/cmake/modules/AddClang.cmake b/clang/cmake/modules/AddClang.cmake
|
diff --git a/clang/cmake/modules/AddClang.cmake b/clang/cmake/modules/AddClang.cmake
|
||||||
index 704278a..1737b24 100644
|
index 5752f4277444..0f52822d91f0 100644
|
||||||
--- a/clang/cmake/modules/AddClang.cmake
|
--- a/clang/cmake/modules/AddClang.cmake
|
||||||
+++ b/clang/cmake/modules/AddClang.cmake
|
+++ b/clang/cmake/modules/AddClang.cmake
|
||||||
@@ -111,7 +111,7 @@ macro(add_clang_library name)
|
@@ -113,7 +113,7 @@ macro(add_clang_library name)
|
||||||
if(TARGET ${lib})
|
if(TARGET ${lib})
|
||||||
target_link_libraries(${lib} INTERFACE ${LLVM_COMMON_LIBS})
|
target_link_libraries(${lib} INTERFACE ${LLVM_COMMON_LIBS})
|
||||||
|
|
||||||
- if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY OR ARG_INSTALL_WITH_TOOLCHAIN)
|
- if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY OR ARG_INSTALL_WITH_TOOLCHAIN)
|
||||||
+ if (ARG_SHARED AND (NOT LLVM_INSTALL_TOOLCHAIN_ONLY OR ARG_INSTALL_WITH_TOOLCHAIN))
|
+ if (ARG_SHARED AND (NOT LLVM_INSTALL_TOOLCHAIN_ONLY OR ARG_INSTALL_WITH_TOOLCHAIN))
|
||||||
set(export_to_clangtargets)
|
get_target_export_arg(${name} Clang export_to_clangtargets UMBRELLA clang-libraries)
|
||||||
if(${lib} IN_LIST LLVM_DISTRIBUTION_COMPONENTS OR
|
install(TARGETS ${lib}
|
||||||
"clang-libraries" IN_LIST LLVM_DISTRIBUTION_COMPONENTS OR
|
COMPONENT ${lib}
|
||||||
--
|
--
|
||||||
1.8.3.1
|
2.30.2
|
||||||
|
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
From d8af49687765744efaae7ba0f0c4c0fcd58a0e31 Mon Sep 17 00:00:00 2001
|
From b620ab11a339a4b8f3f0975fd016508483833f46 Mon Sep 17 00:00:00 2001
|
||||||
From: serge-sans-paille <sguelton@redhat.com>
|
From: serge-sans-paille <sguelton@redhat.com>
|
||||||
Date: Wed, 23 Sep 2020 12:47:30 +0000
|
Date: Wed, 23 Sep 2020 12:47:30 +0000
|
||||||
Subject: [PATCH 4/6] [PATCH][clang] Prefer gcc toolchains with libgcc_s.so
|
Subject: [PATCH][clang] Prefer gcc toolchains with libgcc_s.so when not static
|
||||||
when not static linking libgcc
|
linking libgcc
|
||||||
|
|
||||||
Fedora ships cross-compilers on all platforms, so a user could end up
|
Fedora ships cross-compilers on all platforms, so a user could end up
|
||||||
with a gcc x86_64 cross-compiler installed on an x86_64 system. clang
|
with a gcc x86_64 cross-compiler installed on an x86_64 system. clang
|
||||||
@ -21,31 +21,31 @@ This patch fixes this by checking for the existence of libgcc_s.so
|
|||||||
when it is required and taking that into account when selecting a
|
when it is required and taking that into account when selecting a
|
||||||
toolchain.
|
toolchain.
|
||||||
---
|
---
|
||||||
clang/lib/Driver/ToolChains/Gnu.cpp | 16 ++++++++++++++--
|
clang/lib/Driver/ToolChains/Gnu.cpp | 16 ++++++++++++++--
|
||||||
clang/lib/Driver/ToolChains/Gnu.h | 4 +++-
|
clang/lib/Driver/ToolChains/Gnu.h | 4 +++-
|
||||||
.../usr/lib/gcc/x86_64-linux-gnu/7/crtbegin.o | 0
|
.../usr/lib/gcc/x86_64-linux-gnu/7/crtbegin.o | 0
|
||||||
.../usr/lib/gcc/x86_64-redhat-linux/7/crtbegin.o | 0
|
.../usr/lib/gcc/x86_64-redhat-linux/7/crtbegin.o | 0
|
||||||
.../usr/lib/gcc/x86_64-redhat-linux/7/libgcc_s.so | 0
|
.../lib/gcc/x86_64-redhat-linux/7/libgcc_s.so | 0
|
||||||
clang/test/Driver/linux-ld.c | 12 ++++++++++++
|
clang/test/Driver/linux-ld.c | 12 ++++++++++++
|
||||||
6 files changed, 29 insertions(+), 3 deletions(-)
|
6 files changed, 29 insertions(+), 3 deletions(-)
|
||||||
create mode 100644 clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-linux-gnu/7/crtbegin.o
|
create mode 100644 clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-linux-gnu/7/crtbegin.o
|
||||||
create mode 100644 clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/crtbegin.o
|
create mode 100644 clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/crtbegin.o
|
||||||
create mode 100644 clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/libgcc_s.so
|
create mode 100644 clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/libgcc_s.so
|
||||||
|
|
||||||
diff --git a/clang/lib/Driver/ToolChains/Gnu.cpp b/clang/lib/Driver/ToolChains/Gnu.cpp
|
diff --git a/clang/lib/Driver/ToolChains/Gnu.cpp b/clang/lib/Driver/ToolChains/Gnu.cpp
|
||||||
index 5deeb10..5d51517 100644
|
index 6f431a1badae..11e1a8558556 100644
|
||||||
--- a/clang/lib/Driver/ToolChains/Gnu.cpp
|
--- a/clang/lib/Driver/ToolChains/Gnu.cpp
|
||||||
+++ b/clang/lib/Driver/ToolChains/Gnu.cpp
|
+++ b/clang/lib/Driver/ToolChains/Gnu.cpp
|
||||||
@@ -2539,6 +2539,8 @@ void Generic_GCC::GCCInstallationDetector::ScanLibDirForGCCTriple(
|
@@ -2537,6 +2537,8 @@ void Generic_GCC::GCCInstallationDetector::ScanLibDirForGCCTriple(
|
||||||
(TargetArch == llvm::Triple::x86 &&
|
TargetTriple.getVendor() == llvm::Triple::Freescale ||
|
||||||
TargetTriple.getOS() != llvm::Triple::Solaris)}};
|
TargetTriple.getVendor() == llvm::Triple::OpenEmbedded}};
|
||||||
|
|
||||||
+ bool NeedLibgccShared = !Args.hasArg(options::OPT_static_libgcc) &&
|
+ bool NeedLibgccShared = !Args.hasArg(options::OPT_static_libgcc) &&
|
||||||
+ !Args.hasArg(options::OPT_static);
|
+ !Args.hasArg(options::OPT_static);
|
||||||
for (auto &Suffix : Suffixes) {
|
for (auto &Suffix : Suffixes) {
|
||||||
if (!Suffix.Active)
|
if (!Suffix.Active)
|
||||||
continue;
|
continue;
|
||||||
@@ -2556,8 +2558,17 @@ void Generic_GCC::GCCInstallationDetector::ScanLibDirForGCCTriple(
|
@@ -2554,8 +2556,17 @@ void Generic_GCC::GCCInstallationDetector::ScanLibDirForGCCTriple(
|
||||||
continue; // Saw this path before; no need to look at it again.
|
continue; // Saw this path before; no need to look at it again.
|
||||||
if (CandidateVersion.isOlderThan(4, 1, 1))
|
if (CandidateVersion.isOlderThan(4, 1, 1))
|
||||||
continue;
|
continue;
|
||||||
@ -65,7 +65,7 @@ index 5deeb10..5d51517 100644
|
|||||||
|
|
||||||
if (!ScanGCCForMultilibs(TargetTriple, Args, LI->path(),
|
if (!ScanGCCForMultilibs(TargetTriple, Args, LI->path(),
|
||||||
NeedsBiarchSuffix))
|
NeedsBiarchSuffix))
|
||||||
@@ -2571,6 +2582,7 @@ void Generic_GCC::GCCInstallationDetector::ScanLibDirForGCCTriple(
|
@@ -2569,6 +2580,7 @@ void Generic_GCC::GCCInstallationDetector::ScanLibDirForGCCTriple(
|
||||||
GCCInstallPath = (LibDir + "/" + LibSuffix + "/" + VersionText).str();
|
GCCInstallPath = (LibDir + "/" + LibSuffix + "/" + VersionText).str();
|
||||||
GCCParentLibPath = (GCCInstallPath + "/../" + Suffix.ReversePath).str();
|
GCCParentLibPath = (GCCInstallPath + "/../" + Suffix.ReversePath).str();
|
||||||
IsValid = true;
|
IsValid = true;
|
||||||
@ -74,7 +74,7 @@ index 5deeb10..5d51517 100644
|
|||||||
}
|
}
|
||||||
}
|
}
|
||||||
diff --git a/clang/lib/Driver/ToolChains/Gnu.h b/clang/lib/Driver/ToolChains/Gnu.h
|
diff --git a/clang/lib/Driver/ToolChains/Gnu.h b/clang/lib/Driver/ToolChains/Gnu.h
|
||||||
index 90d3baf..9d0cea2 100644
|
index 40fd756a5653..0b103c1fc936 100644
|
||||||
--- a/clang/lib/Driver/ToolChains/Gnu.h
|
--- a/clang/lib/Driver/ToolChains/Gnu.h
|
||||||
+++ b/clang/lib/Driver/ToolChains/Gnu.h
|
+++ b/clang/lib/Driver/ToolChains/Gnu.h
|
||||||
@@ -190,6 +190,7 @@ public:
|
@@ -190,6 +190,7 @@ public:
|
||||||
@ -97,18 +97,18 @@ index 90d3baf..9d0cea2 100644
|
|||||||
|
|
||||||
diff --git a/clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-linux-gnu/7/crtbegin.o b/clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-linux-gnu/7/crtbegin.o
|
diff --git a/clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-linux-gnu/7/crtbegin.o b/clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-linux-gnu/7/crtbegin.o
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..e69de29
|
index 000000000000..e69de29bb2d1
|
||||||
diff --git a/clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/crtbegin.o b/clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/crtbegin.o
|
diff --git a/clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/crtbegin.o b/clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/crtbegin.o
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..e69de29
|
index 000000000000..e69de29bb2d1
|
||||||
diff --git a/clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/libgcc_s.so b/clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/libgcc_s.so
|
diff --git a/clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/libgcc_s.so b/clang/test/Driver/Inputs/fedora_28_tree/usr/lib/gcc/x86_64-redhat-linux/7/libgcc_s.so
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..e69de29
|
index 000000000000..e69de29bb2d1
|
||||||
diff --git a/clang/test/Driver/linux-ld.c b/clang/test/Driver/linux-ld.c
|
diff --git a/clang/test/Driver/linux-ld.c b/clang/test/Driver/linux-ld.c
|
||||||
index 24d3c78..071bb9b 100644
|
index cc505588331b..47c6352d333f 100644
|
||||||
--- a/clang/test/Driver/linux-ld.c
|
--- a/clang/test/Driver/linux-ld.c
|
||||||
+++ b/clang/test/Driver/linux-ld.c
|
+++ b/clang/test/Driver/linux-ld.c
|
||||||
@@ -784,6 +784,18 @@
|
@@ -681,6 +681,18 @@
|
||||||
// CHECK-FEDORA-31-RISCV64: "{{.*}}/usr/lib/gcc/riscv64-redhat-linux/9{{/|\\\\}}crtend.o"
|
// CHECK-FEDORA-31-RISCV64: "{{.*}}/usr/lib/gcc/riscv64-redhat-linux/9{{/|\\\\}}crtend.o"
|
||||||
// CHECK-FEDORA-31-RISCV64: "{{.*}}/usr/lib/gcc/riscv64-redhat-linux/9{{/|\\\\}}crtn.o"
|
// CHECK-FEDORA-31-RISCV64: "{{.*}}/usr/lib/gcc/riscv64-redhat-linux/9{{/|\\\\}}crtn.o"
|
||||||
//
|
//
|
||||||
@ -128,5 +128,5 @@ index 24d3c78..071bb9b 100644
|
|||||||
// RUN: --target=arm-unknown-linux-gnueabi -rtlib=platform \
|
// RUN: --target=arm-unknown-linux-gnueabi -rtlib=platform \
|
||||||
// RUN: --gcc-toolchain="" \
|
// RUN: --gcc-toolchain="" \
|
||||||
--
|
--
|
||||||
1.8.3.1
|
2.30.2
|
||||||
|
|
||||||
|
@ -1,77 +0,0 @@
|
|||||||
From 1ef1e91142ac48ecb826f33e1e7072c7402d9fe7 Mon Sep 17 00:00:00 2001
|
|
||||||
From: serge-sans-paille <sguelton@redhat.com>
|
|
||||||
Date: Wed, 3 Mar 2021 09:58:31 +0100
|
|
||||||
Subject: [PATCH 6/6] [PATCH][clang] Allow __ieee128 as an alias to __float128
|
|
||||||
on ppc
|
|
||||||
|
|
||||||
This matches gcc behavior.
|
|
||||||
|
|
||||||
Differential Revision: https://reviews.llvm.org/D97846
|
|
||||||
|
|
||||||
(cherry picked from commit 4aa510be78a75a4da82657fe433016f00dad0784)
|
|
||||||
---
|
|
||||||
clang/include/clang/Basic/LangOptions.def | 1 +
|
|
||||||
clang/lib/Basic/IdentifierTable.cpp | 3 +++
|
|
||||||
clang/lib/Basic/Targets/PPC.cpp | 1 +
|
|
||||||
clang/test/Sema/128bitfloat.cpp | 7 +++++++
|
|
||||||
4 files changed, 12 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/clang/include/clang/Basic/LangOptions.def b/clang/include/clang/Basic/LangOptions.def
|
|
||||||
index c01f0cc..3c22393e 100644
|
|
||||||
--- a/clang/include/clang/Basic/LangOptions.def
|
|
||||||
+++ b/clang/include/clang/Basic/LangOptions.def
|
|
||||||
@@ -107,6 +107,7 @@ LANGOPT(Bool , 1, 0, "bool, true, and false keywords")
|
|
||||||
LANGOPT(Half , 1, 0, "half keyword")
|
|
||||||
LANGOPT(WChar , 1, CPlusPlus, "wchar_t keyword")
|
|
||||||
LANGOPT(Char8 , 1, 0, "char8_t keyword")
|
|
||||||
+LANGOPT(IEEE128 , 1, 0, "__ieee128 keyword")
|
|
||||||
LANGOPT(DeclSpecKeyword , 1, 0, "__declspec keyword")
|
|
||||||
BENIGN_LANGOPT(DollarIdents , 1, 1, "'$' in identifiers")
|
|
||||||
BENIGN_LANGOPT(AsmPreprocessor, 1, 0, "preprocessor in asm mode")
|
|
||||||
diff --git a/clang/lib/Basic/IdentifierTable.cpp b/clang/lib/Basic/IdentifierTable.cpp
|
|
||||||
index 51c6e02..cedc94a 100644
|
|
||||||
--- a/clang/lib/Basic/IdentifierTable.cpp
|
|
||||||
+++ b/clang/lib/Basic/IdentifierTable.cpp
|
|
||||||
@@ -227,6 +227,9 @@ void IdentifierTable::AddKeywords(const LangOptions &LangOpts) {
|
|
||||||
if (LangOpts.DeclSpecKeyword)
|
|
||||||
AddKeyword("__declspec", tok::kw___declspec, KEYALL, LangOpts, *this);
|
|
||||||
|
|
||||||
+ if (LangOpts.IEEE128)
|
|
||||||
+ AddKeyword("__ieee128", tok::kw___float128, KEYALL, LangOpts, *this);
|
|
||||||
+
|
|
||||||
// Add the 'import' contextual keyword.
|
|
||||||
get("import").setModulesImport(true);
|
|
||||||
}
|
|
||||||
diff --git a/clang/lib/Basic/Targets/PPC.cpp b/clang/lib/Basic/Targets/PPC.cpp
|
|
||||||
index ff09c0f..38f286c 100644
|
|
||||||
--- a/clang/lib/Basic/Targets/PPC.cpp
|
|
||||||
+++ b/clang/lib/Basic/Targets/PPC.cpp
|
|
||||||
@@ -551,6 +551,7 @@ void PPCTargetInfo::adjust(LangOptions &Opts) {
|
|
||||||
LongDoubleFormat = Opts.PPCIEEELongDouble
|
|
||||||
? &llvm::APFloat::IEEEquad()
|
|
||||||
: &llvm::APFloat::PPCDoubleDouble();
|
|
||||||
+ Opts.IEEE128 = 1;
|
|
||||||
}
|
|
||||||
|
|
||||||
ArrayRef<Builtin::Info> PPCTargetInfo::getTargetBuiltins() const {
|
|
||||||
diff --git a/clang/test/Sema/128bitfloat.cpp b/clang/test/Sema/128bitfloat.cpp
|
|
||||||
index 4a826b4..6a9ae74 100644
|
|
||||||
--- a/clang/test/Sema/128bitfloat.cpp
|
|
||||||
+++ b/clang/test/Sema/128bitfloat.cpp
|
|
||||||
@@ -6,6 +6,13 @@
|
|
||||||
// RUN: %clang_cc1 -triple x86_64-windows-msvc -verify -std=c++11 %s
|
|
||||||
|
|
||||||
#if defined(__FLOAT128__) || defined(__SIZEOF_FLOAT128__)
|
|
||||||
+
|
|
||||||
+#if defined(__ppc__)
|
|
||||||
+template <typename> struct __is_float128 { static constexpr bool value = false; };
|
|
||||||
+template <> struct __is_float128<__float128> { static constexpr bool value = true; };
|
|
||||||
+static_assert(__is_float128<__ieee128>::value, "__ieee128 aliases to __float128");
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
__float128 f;
|
|
||||||
template<typename> struct __is_floating_point_helper {};
|
|
||||||
template<> struct __is_floating_point_helper<__float128> {};
|
|
||||||
--
|
|
||||||
1.8.3.1
|
|
||||||
|
|
39
clang.spec
39
clang.spec
@ -1,9 +1,9 @@
|
|||||||
%bcond_with compat_build
|
%bcond_with compat_build
|
||||||
|
|
||||||
%global maj_ver 12
|
%global maj_ver 13
|
||||||
%global min_ver 0
|
%global min_ver 0
|
||||||
%global patch_ver 1
|
%global patch_ver 0
|
||||||
#global rc_ver 3
|
%global rc_ver 1
|
||||||
%global clang_version %{maj_ver}.%{min_ver}.%{patch_ver}
|
%global clang_version %{maj_ver}.%{min_ver}.%{patch_ver}
|
||||||
|
|
||||||
%global clang_tools_binaries \
|
%global clang_tools_binaries \
|
||||||
@ -64,9 +64,11 @@
|
|||||||
%global clang_srcdir clang-%{clang_version}%{?rc_ver:rc%{rc_ver}}.src
|
%global clang_srcdir clang-%{clang_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
%global clang_tools_srcdir clang-tools-extra-%{clang_version}%{?rc_ver:rc%{rc_ver}}.src
|
%global clang_tools_srcdir clang-tools-extra-%{clang_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
|
|
||||||
|
%global abi_revision 0
|
||||||
|
|
||||||
Name: %pkg_name
|
Name: %pkg_name
|
||||||
Version: %{clang_version}%{?rc_ver:~rc%{rc_ver}}
|
Version: %{clang_version}%{?rc_ver:~rc%{rc_ver}}
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A C language family front-end for LLVM
|
Summary: A C language family front-end for LLVM
|
||||||
|
|
||||||
License: NCSA
|
License: NCSA
|
||||||
@ -84,7 +86,7 @@ Patch0: 0001-PATCH-clang-Reorganize-gtest-integration.patch
|
|||||||
Patch1: 0002-PATCH-clang-Make-funwind-tables-the-default-on-all-a.patch
|
Patch1: 0002-PATCH-clang-Make-funwind-tables-the-default-on-all-a.patch
|
||||||
Patch2: 0003-PATCH-clang-Don-t-install-static-libraries.patch
|
Patch2: 0003-PATCH-clang-Don-t-install-static-libraries.patch
|
||||||
Patch3: 0004-PATCH-clang-Prefer-gcc-toolchains-with-libgcc_s.so-w.patch
|
Patch3: 0004-PATCH-clang-Prefer-gcc-toolchains-with-libgcc_s.so-w.patch
|
||||||
Patch5: 0006-PATCH-clang-Allow-__ieee128-as-an-alias-to-__float12.patch
|
Patch4: 0001-cmake-Allow-shared-libraries-to-customize-the-soname.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
@ -275,7 +277,8 @@ pathfix.py -i %{__python3} -pn \
|
|||||||
tools/clang-format/git-clang-format \
|
tools/clang-format/git-clang-format \
|
||||||
utils/hmaptool/hmaptool \
|
utils/hmaptool/hmaptool \
|
||||||
tools/scan-view/bin/scan-view \
|
tools/scan-view/bin/scan-view \
|
||||||
tools/scan-build-py/bin/*
|
tools/scan-build-py/bin/* \
|
||||||
|
tools/scan-build-py/libexec/*
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -307,6 +310,9 @@ sed -i 's/\@FEDORA_LLVM_LIB_SUFFIX\@//g' test/lit.cfg.py
|
|||||||
# rpath of libraries and binaries. llvm will skip the manual setting
|
# rpath of libraries and binaries. llvm will skip the manual setting
|
||||||
# if CAMKE_INSTALL_RPATH is set to a value, but cmake interprets this value
|
# if CAMKE_INSTALL_RPATH is set to a value, but cmake interprets this value
|
||||||
# as nothing, so it sets the rpath to "" when installing.
|
# as nothing, so it sets the rpath to "" when installing.
|
||||||
|
|
||||||
|
# -DLLVM_ENABLE_NEW_PASS_MANAGER=ON can be removed once this patch is committed:
|
||||||
|
# https://reviews.llvm.org/D107628
|
||||||
%cmake -G Ninja \
|
%cmake -G Ninja \
|
||||||
-DLLVM_PARALLEL_LINK_JOBS=1 \
|
-DLLVM_PARALLEL_LINK_JOBS=1 \
|
||||||
-DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
|
-DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
|
||||||
@ -347,8 +353,10 @@ sed -i 's/\@FEDORA_LLVM_LIB_SUFFIX\@//g' test/lit.cfg.py
|
|||||||
-DLLVM_ENABLE_EH=ON \
|
-DLLVM_ENABLE_EH=ON \
|
||||||
-DLLVM_ENABLE_RTTI=ON \
|
-DLLVM_ENABLE_RTTI=ON \
|
||||||
-DLLVM_BUILD_DOCS=ON \
|
-DLLVM_BUILD_DOCS=ON \
|
||||||
|
-DLLVM_ENABLE_NEW_PASS_MANAGER=ON \
|
||||||
-DLLVM_ENABLE_SPHINX=ON \
|
-DLLVM_ENABLE_SPHINX=ON \
|
||||||
-DCLANG_LINK_CLANG_DYLIB=ON \
|
-DCLANG_LINK_CLANG_DYLIB=ON \
|
||||||
|
-DLLVM_ABI_REVISION=%{abi_revision} \
|
||||||
-DSPHINX_WARNINGS_AS_ERRORS=OFF \
|
-DSPHINX_WARNINGS_AS_ERRORS=OFF \
|
||||||
\
|
\
|
||||||
-DCLANG_BUILD_EXAMPLES:BOOL=OFF \
|
-DCLANG_BUILD_EXAMPLES:BOOL=OFF \
|
||||||
@ -376,6 +384,10 @@ mkdir -p %{buildroot}%{python3_sitelib}/clang/
|
|||||||
install -p -m644 bindings/python/clang/* %{buildroot}%{python3_sitelib}/clang/
|
install -p -m644 bindings/python/clang/* %{buildroot}%{python3_sitelib}/clang/
|
||||||
%py_byte_compile %{__python3} %{buildroot}%{python3_sitelib}/clang
|
%py_byte_compile %{__python3} %{buildroot}%{python3_sitelib}/clang
|
||||||
|
|
||||||
|
# install scanbuild-py to python sitelib.
|
||||||
|
mv %{buildroot}%{_prefix}/lib/{libear,libscanbuild} %{buildroot}%{python3_sitelib}
|
||||||
|
%py_byte_compile %{__python3} %{buildroot}%{python3_sitelib}/{libear,libscanbuild}
|
||||||
|
|
||||||
# multilib fix
|
# multilib fix
|
||||||
%multilib_fix_c_header --file %{_includedir}/clang/Config/config.h
|
%multilib_fix_c_header --file %{_includedir}/clang/Config/config.h
|
||||||
|
|
||||||
@ -493,11 +505,21 @@ false
|
|||||||
%files analyzer
|
%files analyzer
|
||||||
%{_bindir}/scan-view
|
%{_bindir}/scan-view
|
||||||
%{_bindir}/scan-build
|
%{_bindir}/scan-build
|
||||||
|
%{_bindir}/analyze-build
|
||||||
|
%{_bindir}/intercept-build
|
||||||
|
%{_bindir}/scan-build-py
|
||||||
%{_libexecdir}/ccc-analyzer
|
%{_libexecdir}/ccc-analyzer
|
||||||
%{_libexecdir}/c++-analyzer
|
%{_libexecdir}/c++-analyzer
|
||||||
|
%{_libexecdir}/analyze-c++
|
||||||
|
%{_libexecdir}/analyze-cc
|
||||||
|
%{_libexecdir}/intercept-c++
|
||||||
|
%{_libexecdir}/intercept-cc
|
||||||
%{_datadir}/scan-view/
|
%{_datadir}/scan-view/
|
||||||
%{_datadir}/scan-build/
|
%{_datadir}/scan-build/
|
||||||
%{_mandir}/man1/scan-build.1.*
|
%{_mandir}/man1/scan-build.1.*
|
||||||
|
%{python3_sitelib}/libear
|
||||||
|
%{python3_sitelib}/libscanbuild
|
||||||
|
|
||||||
|
|
||||||
%files tools-extra
|
%files tools-extra
|
||||||
%{clang_tools_binaries}
|
%{clang_tools_binaries}
|
||||||
@ -513,7 +535,7 @@ false
|
|||||||
%{_datadir}/clang/clang-format-diff.py*
|
%{_datadir}/clang/clang-format-diff.py*
|
||||||
%{_datadir}/clang/clang-include-fixer.py*
|
%{_datadir}/clang/clang-include-fixer.py*
|
||||||
%{_datadir}/clang/clang-tidy-diff.py*
|
%{_datadir}/clang/clang-tidy-diff.py*
|
||||||
%{_datadir}/clang/run-clang-tidy.py*
|
%{_bindir}/run-clang-tidy
|
||||||
%{_datadir}/clang/run-find-all-symbols.py*
|
%{_datadir}/clang/run-find-all-symbols.py*
|
||||||
%{_datadir}/clang/clang-rename.py*
|
%{_datadir}/clang/clang-rename.py*
|
||||||
|
|
||||||
@ -526,6 +548,9 @@ false
|
|||||||
|
|
||||||
%endif
|
%endif
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Aug 06 2021 Tom Stellard <tstellar@redhat.com> - 13.0.0~rc1-1
|
||||||
|
- 13.0.0-rc1 Release
|
||||||
|
|
||||||
* Thu Jul 22 2021 Tom Stellard <tstellar@redhat.com> - 12.0.1-3
|
* Thu Jul 22 2021 Tom Stellard <tstellar@redhat.com> - 12.0.1-3
|
||||||
- Fix compat build
|
- Fix compat build
|
||||||
|
|
||||||
|
8
sources
8
sources
@ -1,4 +1,4 @@
|
|||||||
SHA512 (clang-12.0.1.src.tar.xz) = 405011f0974b239427ca87c65e7485709c77705a9b7d51d679fe2abec79865f8c51c7ab085b4e6bf7aa4d0eade4b1438d88dd5feb56b434dc5d718ebf5715efa
|
SHA512 (clang-13.0.0rc1.src.tar.xz) = 88d47b9a467a9f41d2e3f49c0b7e68b01662400ed558a8fed8ebecc6c54523a685556c17a0a3d5867c2f0553cab53088e23fea50345f10f0a3aaceed892d55d5
|
||||||
SHA512 (clang-12.0.1.src.tar.xz.sig) = e8e87b84e0ea47afb9038c03327120deb8a785ce688fbe268658d4f8792e299ca4d5796c1077b745839226e4af211f37cc1b17348c59604fed6ab6ae0c2c3899
|
SHA512 (clang-13.0.0rc1.src.tar.xz.sig) = 8077d37176620f16c420dfb85ab974266368c41a83f4412d50301aaa852fd5c112dba4d28a252b46070cc4505d64c990ced267e4b6963c16ea9a017e5c0ee24d
|
||||||
SHA512 (clang-tools-extra-12.0.1.src.tar.xz) = be4975c81c83f98deb5f6e0cc170fb6740bc46396d5bd8f25b55270ed874bb099b6d6f0e413617396f5ab67182314735580f44be1913d9be44ae288cf8c4fd7c
|
SHA512 (clang-tools-extra-13.0.0rc1.src.tar.xz) = f7e0634eef1173d8815cc8137340103a59ae021613545c098670554014dcceae1843081d48fb8a4019d615989c7327fef910f369a9ceb079c8d49750747a837e
|
||||||
SHA512 (clang-tools-extra-12.0.1.src.tar.xz.sig) = ae418961ea307fcf65bf427d1d9e9ae966d3fbc48787c1683bc72bbb9019b1958880a39e39502dd1e45f7c42736377d35f1e0ae9ad013627313d58d82de9b41a
|
SHA512 (clang-tools-extra-13.0.0rc1.src.tar.xz.sig) = 570eb3de12057192201e40cda8fde6235e91ce28af0115c99a8ade4f45512cf49a702d75f6ed3aada502b37da6ce2fb1010a7ae049a8db62d37d990a5bc11488
|
||||||
|
Loading…
Reference in New Issue
Block a user