Update to LLVM 15.0.7
Resolves: rhbz#2118567 See also Bugzilla #2100122.
This commit is contained in:
parent
63f30e14dc
commit
89ce6231c4
4
.gitignore
vendored
4
.gitignore
vendored
@ -208,3 +208,7 @@
|
|||||||
/clang-15.0.6.src.tar.xz.sig
|
/clang-15.0.6.src.tar.xz.sig
|
||||||
/clang-tools-extra-15.0.6.src.tar.xz
|
/clang-tools-extra-15.0.6.src.tar.xz
|
||||||
/clang-tools-extra-15.0.6.src.tar.xz.sig
|
/clang-tools-extra-15.0.6.src.tar.xz.sig
|
||||||
|
/clang-15.0.7.src.tar.xz
|
||||||
|
/clang-15.0.7.src.tar.xz.sig
|
||||||
|
/clang-tools-extra-15.0.7.src.tar.xz
|
||||||
|
/clang-tools-extra-15.0.7.src.tar.xz.sig
|
||||||
|
@ -1,39 +0,0 @@
|
|||||||
From 7a37612c872ed2ce047adc85ef8eaa119ef6632f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tom Stellard <tstellar@redhat.com>
|
|
||||||
Date: Wed, 4 Aug 2021 14:05:38 -0700
|
|
||||||
Subject: cmake: Allow shared libraries to customize the soname using
|
|
||||||
LLVM_ABI_REVISION
|
|
||||||
|
|
||||||
The LLVM_ABI_REVISION variable is intended to be used for release
|
|
||||||
candidates which introduce an ABI change to a shared library. This
|
|
||||||
variable can be specified per library, so there is not one global value
|
|
||||||
for all of LLVM.
|
|
||||||
|
|
||||||
For example, if we LLVM X.0.0-rc2 introduces an ABI change for a library
|
|
||||||
compared with LLVM X.0.0-rc1, then the LLVM_ABI_REVISION number for
|
|
||||||
library will be incremented by 1.
|
|
||||||
|
|
||||||
In the main branch, LLVM_ABI_REVISION should always be 0, it is only
|
|
||||||
meant to be used in the release branch.
|
|
||||||
|
|
||||||
Differential Revision: https://reviews.llvm.org/D105594
|
|
||||||
---
|
|
||||||
clang/tools/clang-shlib/CMakeLists.txt | 5 +++++
|
|
||||||
1 file changed, 5 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/clang/tools/clang-shlib/CMakeLists.txt b/clang/tools/clang-shlib/CMakeLists.txt
|
|
||||||
index 9c1f8ea452b3..4d785924e4bb 100644
|
|
||||||
--- a/clang/tools/clang-shlib/CMakeLists.txt
|
|
||||||
+++ b/clang/tools/clang-shlib/CMakeLists.txt
|
|
||||||
@@ -1,3 +1,8 @@
|
|
||||||
+# In the main branch, LLVM_ABI_REVISION should always be 0. In the release
|
|
||||||
+# branches, this should be incremented before each release candidate every
|
|
||||||
+# time the ABI of libclang-cpp.so changes.
|
|
||||||
+set(LLVM_ABI_REVISION 0)
|
|
||||||
+
|
|
||||||
# Building libclang-cpp.so fails if LLVM_ENABLE_PIC=Off
|
|
||||||
if (NOT LLVM_ENABLE_PIC)
|
|
||||||
return()
|
|
||||||
--
|
|
||||||
2.37.1
|
|
||||||
|
|
23
clang.spec
23
clang.spec
@ -8,7 +8,7 @@
|
|||||||
|
|
||||||
%global maj_ver 15
|
%global maj_ver 15
|
||||||
%global min_ver 0
|
%global min_ver 0
|
||||||
%global patch_ver 6
|
%global patch_ver 7
|
||||||
%global clang_version %{maj_ver}.%{min_ver}.%{patch_ver}
|
%global clang_version %{maj_ver}.%{min_ver}.%{patch_ver}
|
||||||
|
|
||||||
%if %{with compat_build}
|
%if %{with compat_build}
|
||||||
@ -36,17 +36,13 @@
|
|||||||
|
|
||||||
|
|
||||||
%ifarch ppc64le aarch64
|
%ifarch ppc64le aarch64
|
||||||
# Too many threads on ppc64 systems causes OOM errors.
|
# Too many threads on ppc64 and aarch64 systems causes OOM errors.
|
||||||
%global _smp_mflags -j8
|
%global _smp_mflags -j8
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%global clang_srcdir clang-%{clang_version}%{?rc_ver:rc%{rc_ver}}.src
|
%global clang_srcdir clang-%{clang_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
%global clang_tools_srcdir clang-tools-extra-%{clang_version}%{?rc_ver:rc%{rc_ver}}.src
|
%global clang_tools_srcdir clang-tools-extra-%{clang_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
|
|
||||||
%if !%{maj_ver} && 0%{?rc_ver}
|
|
||||||
%global abi_revision 2
|
|
||||||
%endif
|
|
||||||
|
|
||||||
Name: %pkg_name
|
Name: %pkg_name
|
||||||
Version: %{clang_version}%{?rc_ver:~rc%{rc_ver}}
|
Version: %{clang_version}%{?rc_ver:~rc%{rc_ver}}
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
@ -74,7 +70,6 @@ Source10: macros.%{name}
|
|||||||
|
|
||||||
# Patches for clang
|
# Patches for clang
|
||||||
|
|
||||||
Patch1: 0001-cmake-Allow-shared-libraries-to-customize-the-soname.patch
|
|
||||||
Patch2: 0002-Driver-Add-a-gcc-equivalent-triple-to-the-list-of-tr.patch
|
Patch2: 0002-Driver-Add-a-gcc-equivalent-triple-to-the-list-of-tr.patch
|
||||||
# TODO: Can be dropped in LLVM 16: https://reviews.llvm.org/D133316
|
# TODO: Can be dropped in LLVM 16: https://reviews.llvm.org/D133316
|
||||||
Patch3: 0003-Mark-fopenmp-implicit-rpath-as-NoArgumentUnused.patch
|
Patch3: 0003-Mark-fopenmp-implicit-rpath-as-NoArgumentUnused.patch
|
||||||
@ -270,7 +265,7 @@ clang-format integration for git.
|
|||||||
|
|
||||||
%package -n python3-clang
|
%package -n python3-clang
|
||||||
Summary: Python3 bindings for clang
|
Summary: Python3 bindings for clang
|
||||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
|
||||||
Requires: python3
|
Requires: python3
|
||||||
%description -n python3-clang
|
%description -n python3-clang
|
||||||
%{summary}.
|
%{summary}.
|
||||||
@ -395,6 +390,7 @@ mv ../clang-%{compat_ver}.src ../clang
|
|||||||
-DLLVM_BUILD_UTILS:BOOL=ON \
|
-DLLVM_BUILD_UTILS:BOOL=ON \
|
||||||
-DLLVM_EXTERNAL_CLANG_TOOLS_EXTRA_SOURCE_DIR=../%{clang_tools_srcdir} \
|
-DLLVM_EXTERNAL_CLANG_TOOLS_EXTRA_SOURCE_DIR=../%{clang_tools_srcdir} \
|
||||||
-DLLVM_EXTERNAL_LIT=%{_bindir}/lit \
|
-DLLVM_EXTERNAL_LIT=%{_bindir}/lit \
|
||||||
|
-DLLVM_LIT_ARGS="-vv" \
|
||||||
-DLLVM_MAIN_SRC_DIR=%{_datadir}/llvm/src \
|
-DLLVM_MAIN_SRC_DIR=%{_datadir}/llvm/src \
|
||||||
%if 0%{?__isa_bits} == 64
|
%if 0%{?__isa_bits} == 64
|
||||||
-DLLVM_LIBDIR_SUFFIX=64 \
|
-DLLVM_LIBDIR_SUFFIX=64 \
|
||||||
@ -418,7 +414,6 @@ mv ../clang-%{compat_ver}.src ../clang
|
|||||||
-DLLVM_BUILD_DOCS=ON \
|
-DLLVM_BUILD_DOCS=ON \
|
||||||
-DLLVM_ENABLE_SPHINX=ON \
|
-DLLVM_ENABLE_SPHINX=ON \
|
||||||
-DCLANG_LINK_CLANG_DYLIB=ON \
|
-DCLANG_LINK_CLANG_DYLIB=ON \
|
||||||
%{?abi_revision:-DLLVM_ABI_REVISION=%{abi_revision}} \
|
|
||||||
-DSPHINX_WARNINGS_AS_ERRORS=OFF \
|
-DSPHINX_WARNINGS_AS_ERRORS=OFF \
|
||||||
\
|
\
|
||||||
-DCLANG_BUILD_EXAMPLES:BOOL=OFF \
|
-DCLANG_BUILD_EXAMPLES:BOOL=OFF \
|
||||||
@ -580,11 +575,11 @@ mv ./libclang-cpp.so.%{compat_maj_ver} "$compat_lib"
|
|||||||
|
|
||||||
%files libs
|
%files libs
|
||||||
%if %{without compat_build}
|
%if %{without compat_build}
|
||||||
%{_libdir}/clang/
|
%{_libdir}/clang/%{version}/include/*
|
||||||
%{_libdir}/*.so.*
|
%{_libdir}/*.so.*
|
||||||
%else
|
%else
|
||||||
%{pkg_libdir}/*.so.*
|
%{pkg_libdir}/*.so.*
|
||||||
%{pkg_libdir}/clang/%{version}
|
%{pkg_libdir}/clang/%{version}/include/*
|
||||||
%endif
|
%endif
|
||||||
%if %{with bundle_compat_lib}
|
%if %{with bundle_compat_lib}
|
||||||
%{_libdir}/libclang.so.%{compat_maj_ver}*
|
%{_libdir}/libclang.so.%{compat_maj_ver}*
|
||||||
@ -608,6 +603,7 @@ mv ./libclang-cpp.so.%{compat_maj_ver} "$compat_lib"
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%files resource-filesystem
|
%files resource-filesystem
|
||||||
|
%dir %{pkg_libdir}/clang/
|
||||||
%dir %{pkg_libdir}/clang/%{version}/
|
%dir %{pkg_libdir}/clang/%{version}/
|
||||||
%dir %{pkg_libdir}/clang/%{version}/include/
|
%dir %{pkg_libdir}/clang/%{version}/include/
|
||||||
%dir %{pkg_libdir}/clang/%{version}/lib/
|
%dir %{pkg_libdir}/clang/%{version}/lib/
|
||||||
@ -678,7 +674,7 @@ mv ./libclang-cpp.so.%{compat_maj_ver} "$compat_lib"
|
|||||||
%{_datadir}/clang/run-find-all-symbols.py*
|
%{_datadir}/clang/run-find-all-symbols.py*
|
||||||
%{_datadir}/clang/clang-rename.py*
|
%{_datadir}/clang/clang-rename.py*
|
||||||
|
|
||||||
%files tools-extra-devel
|
%files tools-extra-devel
|
||||||
%{_includedir}/clang-tidy/
|
%{_includedir}/clang-tidy/
|
||||||
|
|
||||||
%files -n git-clang-format
|
%files -n git-clang-format
|
||||||
@ -690,6 +686,9 @@ mv ./libclang-cpp.so.%{compat_maj_ver} "$compat_lib"
|
|||||||
|
|
||||||
%endif
|
%endif
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 16 2023 Konrad Kleine <kkleine|redhat.com> - 15.0.7
|
||||||
|
- Update to 15.0.7
|
||||||
|
|
||||||
* Thu Dec 08 2022 Konrad Kleine<kkleine@redhat.com> - 15.0.6-1
|
* Thu Dec 08 2022 Konrad Kleine<kkleine@redhat.com> - 15.0.6-1
|
||||||
- Update to 15.0.6
|
- Update to 15.0.6
|
||||||
|
|
||||||
|
8
sources
8
sources
@ -1,4 +1,4 @@
|
|||||||
SHA512 (clang-15.0.6.src.tar.xz) = 898e9793b27a17689150b8df99fce87037d7353e35b6f03449c64f131a8afb3780e45bf640af8c173362ddbf60bcf09f864a4316b523123899cdd19073ed5e48
|
SHA512 (clang-15.0.7.src.tar.xz) = 9fd2736a9f5993ddbb5b3c507fe497234a6def64f6f418f379d1ca56c9c361ad1ae9a5445ab938230fbc1671ec00b4f802a412b048569023863c20dc6bb46a1f
|
||||||
SHA512 (clang-15.0.6.src.tar.xz.sig) = 2a914cd9936e374ec493ebac677e5346513d6ae3dd9f2c72d80aeff81bfa78cbe346d2bbf78353067b0e89fcaf1578bf268701f607c0e864185b1c5e3ea1826b
|
SHA512 (clang-15.0.7.src.tar.xz.sig) = e1b41c5a6509c3554794bfa1b8d048f13268bc2234d7480f04f7700e27bd9d53e40bc1433885716a64da57458f3041c42a66639045476daefffc3f5d2e3d6efd
|
||||||
SHA512 (clang-tools-extra-15.0.6.src.tar.xz) = c9a36e7fa924351304af27e20e362f580d1d8585fdcd7973bd4c614f81c5c5e0ed313ae110c7662f8df8373a98c10f386352bce6fbfed568e7f879f07fd6a452
|
SHA512 (clang-tools-extra-15.0.7.src.tar.xz) = dd95d261d3a1618967b698e97ac0b41204d872d7479c0c832fcf5a91fe447af6a97fa794de07b3e271285867b30b905688f090e98f516b9df4cdfb3bad9defc6
|
||||||
SHA512 (clang-tools-extra-15.0.6.src.tar.xz.sig) = 722c5748cbeae73c6aaefa1c695dcae7b93bb3b12d10decd1f3ca713e95800341ccff7cbc4a9fb281eeb78b8d8de39f7c57d2cefa15aab322a79895e53b48787
|
SHA512 (clang-tools-extra-15.0.7.src.tar.xz.sig) = 10887b80d453d1ec826afbf5cfd937d5b671ed73f54691072b2b097da21f9358b8d6372df79200dc0694cbbc40b816c4139690b4e7033ba03a8a9b92611ee4ce
|
||||||
|
Loading…
Reference in New Issue
Block a user