16.0.0 Release
Resolves: rhbz#2178800
This commit is contained in:
parent
361076f838
commit
813dda472f
3
.gitignore
vendored
3
.gitignore
vendored
@ -4,3 +4,6 @@ SOURCES/release-keys.asc
|
||||
/clang-15.0.7.src.tar.xz
|
||||
/clang-tools-extra-15.0.7.src.tar.xz
|
||||
/release-keys.asc
|
||||
/clang-16.0.0.src.tar.xz
|
||||
/clang-tools-extra-16.0.0.src.tar.xz
|
||||
/cmake-16.0.0.src.tar.xz
|
||||
|
26
0001-PowerPC-clang-Fix-triple.patch
Normal file
26
0001-PowerPC-clang-Fix-triple.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From 701750a896a08d5841a7bc0d187bcddaa6c0f616 Mon Sep 17 00:00:00 2001
|
||||
From: Tulio Magno Quites Machado Filho <tuliom@redhat.com>
|
||||
Date: Thu, 16 Mar 2023 17:22:24 -0300
|
||||
Subject: [PATCH] [PowerPC][clang] Fix triple
|
||||
|
||||
Some Linux distributions use ppc64le instead of powerpc.
|
||||
---
|
||||
clang/test/CodeGenCoroutines/pr56329.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/clang/test/CodeGenCoroutines/pr56329.cpp b/clang/test/CodeGenCoroutines/pr56329.cpp
|
||||
index 31d4849af4e7..69e0f1d337cf 100644
|
||||
--- a/clang/test/CodeGenCoroutines/pr56329.cpp
|
||||
+++ b/clang/test/CodeGenCoroutines/pr56329.cpp
|
||||
@@ -2,7 +2,7 @@
|
||||
//
|
||||
// RUN: %clang_cc1 -triple %itanium_abi_triple -std=c++20 %s -O3 -S -emit-llvm -o - | FileCheck %s
|
||||
// This test is expected to fail on PowerPC.
|
||||
-// XFAIL: target=powerpc{{.*}}
|
||||
+// XFAIL: target={{(ppc|powerpc).*}}
|
||||
|
||||
#include "Inputs/coroutine.h"
|
||||
|
||||
--
|
||||
2.39.2
|
||||
|
@ -58,13 +58,16 @@ diff --git a/clang-tools-extra/test/lit.cfg.py b/clang-tools-extra/test/lit.cfg.
|
||||
index 9b99bfd93440..3fca9f25fb48 100644
|
||||
--- a/clang-tools-extra/test/lit.cfg.py
|
||||
+++ b/clang-tools-extra/test/lit.cfg.py
|
||||
@@ -59,3 +59,6 @@ config.substitutions.append(
|
||||
@@ -59,6 +59,9 @@ config.substitutions.append(
|
||||
# Plugins (loadable modules)
|
||||
if config.has_plugins and config.llvm_plugin_ext:
|
||||
config.available_features.add('plugins')
|
||||
+
|
||||
+if config.has_llvm_hello:
|
||||
+ config.available_features.add("llvm-hello")
|
||||
|
||||
# It is not realistically possible to account for all options that could
|
||||
# possibly be present in system and user configuration files, so disable
|
||||
diff --git a/clang-tools-extra/test/lit.site.cfg.py.in b/clang-tools-extra/test/lit.site.cfg.py.in
|
||||
index 4eb830a1baf1..6e5559348454 100644
|
||||
--- a/clang-tools-extra/test/lit.site.cfg.py.in
|
||||
|
@ -0,0 +1,28 @@
|
||||
From d95d3fbff661c0390072ed0bb4544d5e2aae5c9a Mon Sep 17 00:00:00 2001
|
||||
From: serge-sans-paille <sguelton@redhat.com>
|
||||
Date: Thu, 25 Feb 2021 14:09:29 +0100
|
||||
Subject: [PATCH] Make -funwind-tables the default on all archs
|
||||
|
||||
---
|
||||
clang/lib/Driver/ToolChains/Gnu.cpp | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/clang/lib/Driver/ToolChains/Gnu.cpp b/clang/lib/Driver/ToolChains/Gnu.cpp
|
||||
index c8006f3d8412..6ed03adb7702 100644
|
||||
--- a/clang/lib/Driver/ToolChains/Gnu.cpp
|
||||
+++ b/clang/lib/Driver/ToolChains/Gnu.cpp
|
||||
@@ -2863,6 +2863,11 @@ Generic_GCC::getDefaultUnwindTableLevel(const ArgList &Args) const {
|
||||
case llvm::Triple::ppc64le:
|
||||
case llvm::Triple::x86:
|
||||
case llvm::Triple::x86_64:
|
||||
+
|
||||
+ // Enable -funwind-tables on all architectures supported by Fedora:
|
||||
+ // rhbz#1655546
|
||||
+ case llvm::Triple::systemz:
|
||||
+ case llvm::Triple::arm:
|
||||
return UnwindTableLevel::Asynchronous;
|
||||
default:
|
||||
return UnwindTableLevel::None;
|
||||
--
|
||||
2.39.1
|
||||
|
@ -1,6 +1,6 @@
|
||||
From 1f68d73910ddee1beaf3582480b8a9738c941a43 Mon Sep 17 00:00:00 2001
|
||||
From 4ea62faaaac1aad0fe496cabe9674c809c91c49a Mon Sep 17 00:00:00 2001
|
||||
From: Konrad Kleine <kkleine@redhat.com>
|
||||
Date: Thu, 24 Mar 2022 09:44:21 +0100
|
||||
Date: Mon, 13 Feb 2023 17:11:00 -0300
|
||||
Subject: [PATCH] Produce DWARF4 by default
|
||||
|
||||
Have a look at the following commit to see when the move from DWARF 4 to 5 first happened upstream:
|
||||
@ -9,18 +9,19 @@ https://github.com/llvm/llvm-project/commit/d3b26dea16108c427b19b5480c9edc76edf8
|
||||
---
|
||||
clang/include/clang/Driver/ToolChain.h | 2 +-
|
||||
clang/test/CodeGen/dwarf-version.c | 4 ++--
|
||||
clang/test/Driver/as-options.s | 4 ++--
|
||||
clang/test/Driver/cl-options.c | 2 +-
|
||||
clang/test/Driver/clang-g-opts.c | 2 +-
|
||||
clang/test/Driver/ve-toolchain.c | 2 +-
|
||||
clang/test/Driver/ve-toolchain.cpp | 2 +-
|
||||
6 files changed, 7 insertions(+), 7 deletions(-)
|
||||
7 files changed, 9 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/clang/include/clang/Driver/ToolChain.h b/clang/include/clang/Driver/ToolChain.h
|
||||
index f20ab164531b..53c86ee82936 100644
|
||||
index f75f35dc9e65..a70ae2b17833 100644
|
||||
--- a/clang/include/clang/Driver/ToolChain.h
|
||||
+++ b/clang/include/clang/Driver/ToolChain.h
|
||||
@@ -535,7 +535,7 @@ public:
|
||||
|
||||
@@ -547,7 +547,7 @@ public:
|
||||
|
||||
// Return the DWARF version to emit, in the absence of arguments
|
||||
// to the contrary.
|
||||
- virtual unsigned GetDefaultDwarfVersion() const { return 5; }
|
||||
@ -43,19 +44,41 @@ index 0a6fa4768026..96f01749d0d8 100644
|
||||
|
||||
// The -isysroot is used as a hack to avoid LIT messing with the SDKROOT
|
||||
// environment variable which indirecty overrides the version in the target
|
||||
diff --git a/clang/test/Driver/as-options.s b/clang/test/Driver/as-options.s
|
||||
index 73d002c7ef7e..71d55f7fd537 100644
|
||||
--- a/clang/test/Driver/as-options.s
|
||||
+++ b/clang/test/Driver/as-options.s
|
||||
@@ -122,7 +122,7 @@
|
||||
// RUN: FileCheck --check-prefix=DEBUG %s
|
||||
// RUN: %clang --target=aarch64-linux-gnu -fno-integrated-as -g0 -g %s -### 2>&1 | \
|
||||
// RUN: FileCheck --check-prefix=DEBUG %s
|
||||
-// DEBUG: "-g" "-gdwarf-5"
|
||||
+// DEBUG: "-g" "-gdwarf-4"
|
||||
// RUN: %clang --target=aarch64-linux-gnu -fno-integrated-as -g -g0 %s -### 2>&1 | \
|
||||
// RUN: FileCheck --check-prefix=NODEBUG %s
|
||||
// RUN: %clang --target=aarch64-linux-gnu -fno-integrated-as -gdwarf-5 -g0 %s -### 2>&1 | \
|
||||
@@ -141,7 +141,7 @@
|
||||
// RUN: %clang --target=aarch64-linux-gnu -fno-integrated-as -gdwarf-2 %s -### 2>&1 | \
|
||||
// RUN: FileCheck --check-prefix=GDWARF2 %s
|
||||
// RUN: %clang --target=aarch64-linux-gnu -fno-integrated-as -gdwarf %s -### 2>&1 | \
|
||||
-// RUN: FileCheck --check-prefix=GDWARF5 %s
|
||||
+// RUN: FileCheck --check-prefix=GDWARF4 %s
|
||||
|
||||
// RUN: %clang --target=aarch64-linux-gnu -fno-integrated-as -gdwarf-5 %s -### 2>&1 | \
|
||||
// RUN: FileCheck --check-prefix=GDWARF5 %s
|
||||
diff --git a/clang/test/Driver/cl-options.c b/clang/test/Driver/cl-options.c
|
||||
index a2e350a0a835..01889ba0bf9b 100644
|
||||
index 1d588bdfc1b0..1ad57aedc3a4 100644
|
||||
--- a/clang/test/Driver/cl-options.c
|
||||
+++ b/clang/test/Driver/cl-options.c
|
||||
@@ -570,7 +570,7 @@
|
||||
@@ -575,7 +575,7 @@
|
||||
// RUN: %clang_cl /Z7 -gdwarf /c -### -- %s 2>&1 | FileCheck -check-prefix=Z7_gdwarf %s
|
||||
// Z7_gdwarf: "-gcodeview"
|
||||
// Z7_gdwarf: "-debug-info-kind=constructor"
|
||||
-// Z7_gdwarf: "-dwarf-version=
|
||||
+// Z7_gdwarf: "-dwarf-version=4
|
||||
|
||||
// RUN: %clang_cl -fmsc-version=1800 -TP -### -- %s 2>&1 | FileCheck -check-prefix=CXX11 %s
|
||||
// CXX11: -std=c++11
|
||||
// RUN: %clang_cl /ZH:MD5 /c -### -- %s 2>&1 | FileCheck -check-prefix=ZH_MD5 %s
|
||||
// ZH_MD5: "-gsrc-hash=md5"
|
||||
diff --git a/clang/test/Driver/clang-g-opts.c b/clang/test/Driver/clang-g-opts.c
|
||||
index d982b1070cae..bb129e75769c 100644
|
||||
--- a/clang/test/Driver/clang-g-opts.c
|
||||
@ -96,5 +119,5 @@ index 5a33d5eceb61..cedf895b36dc 100644
|
||||
///-----------------------------------------------------------------------------
|
||||
/// Checking include-path
|
||||
--
|
||||
2.37.1
|
||||
2.39.1
|
||||
|
||||
|
53
D138472.diff
Normal file
53
D138472.diff
Normal file
@ -0,0 +1,53 @@
|
||||
From 04b642c646048dd9df652eba05d45beaa13bc895 Mon Sep 17 00:00:00 2001
|
||||
From: Konrad Kleine <kkleine@redhat.com>
|
||||
Date: Mon, 23 Jan 2023 13:14:17 +0000
|
||||
Subject: [PATCH] Rebased D138472
|
||||
|
||||
---
|
||||
clang/CMakeLists.txt | 23 ++++++++++-------------
|
||||
1 file changed, 10 insertions(+), 13 deletions(-)
|
||||
|
||||
diff --git a/clang/CMakeLists.txt b/clang/CMakeLists.txt
|
||||
index 090cfa352078..f87838776c32 100644
|
||||
--- a/clang/CMakeLists.txt
|
||||
+++ b/clang/CMakeLists.txt
|
||||
@@ -118,12 +118,11 @@ if(CLANG_BUILT_STANDALONE)
|
||||
set(LLVM_UTILS_PROVIDED ON)
|
||||
set(CLANG_TEST_DEPS FileCheck count not)
|
||||
endif()
|
||||
- set(UNITTEST_DIR ${LLVM_THIRD_PARTY_DIR}/unittest)
|
||||
- if(EXISTS ${UNITTEST_DIR}/googletest/include/gtest/gtest.h
|
||||
- AND NOT EXISTS ${LLVM_LIBRARY_DIR}/${CMAKE_STATIC_LIBRARY_PREFIX}gtest${CMAKE_STATIC_LIBRARY_SUFFIX}
|
||||
- AND EXISTS ${UNITTEST_DIR}/CMakeLists.txt)
|
||||
- add_subdirectory(${UNITTEST_DIR} third-party/unittest)
|
||||
- endif()
|
||||
+ endif()
|
||||
+
|
||||
+ find_package(LLVMGTest HINTS "${LLVM_CMAKE_DIR}")
|
||||
+ if (NOT TARGET llvm_gtest)
|
||||
+ message(FATAL_ERROR "llvm-gtest not found. Please install llvm-gtest or disable tests with -DLLVM_INCLUDE_TESTS=OFF")
|
||||
endif()
|
||||
|
||||
if(LLVM_LIT)
|
||||
@@ -506,13 +505,11 @@ endif()
|
||||
|
||||
|
||||
if( CLANG_INCLUDE_TESTS )
|
||||
- if(EXISTS ${LLVM_THIRD_PARTY_DIR}/unittest/googletest/include/gtest/gtest.h)
|
||||
- add_subdirectory(unittests)
|
||||
- list(APPEND CLANG_TEST_DEPS ClangUnitTests)
|
||||
- list(APPEND CLANG_TEST_PARAMS
|
||||
- clang_unit_site_config=${CMAKE_CURRENT_BINARY_DIR}/test/Unit/lit.site.cfg
|
||||
- )
|
||||
- endif()
|
||||
+ add_subdirectory(unittests)
|
||||
+ list(APPEND CLANG_TEST_DEPS ClangUnitTests)
|
||||
+ list(APPEND CLANG_TEST_PARAMS
|
||||
+ clang_unit_site_config=${CMAKE_CURRENT_BINARY_DIR}/test/Unit/lit.site.cfg
|
||||
+ )
|
||||
add_subdirectory(test)
|
||||
add_subdirectory(bindings/python/tests)
|
||||
|
||||
--
|
||||
2.34.3
|
||||
|
25
D141581.diff
Normal file
25
D141581.diff
Normal file
@ -0,0 +1,25 @@
|
||||
diff --git a/clang/lib/Basic/CMakeLists.txt b/clang/lib/Basic/CMakeLists.txt
|
||||
--- a/clang/lib/Basic/CMakeLists.txt
|
||||
+++ b/clang/lib/Basic/CMakeLists.txt
|
||||
@@ -110,7 +110,7 @@
|
||||
|
||||
DEPENDS
|
||||
omp_gen
|
||||
- RISCVTargetParserTableGen
|
||||
+ LLVMTargetParser
|
||||
)
|
||||
|
||||
target_link_libraries(clangBasic
|
||||
diff --git a/clang/lib/Driver/CMakeLists.txt b/clang/lib/Driver/CMakeLists.txt
|
||||
--- a/clang/lib/Driver/CMakeLists.txt
|
||||
+++ b/clang/lib/Driver/CMakeLists.txt
|
||||
@@ -93,7 +93,7 @@
|
||||
|
||||
DEPENDS
|
||||
ClangDriverOptions
|
||||
- RISCVTargetParserTableGen
|
||||
+ LLVMTargetParser
|
||||
|
||||
LINK_LIBS
|
||||
clangBasic
|
||||
|
94
clang.spec
94
clang.spec
@ -1,9 +1,9 @@
|
||||
%bcond_with compat_build
|
||||
%bcond_without check
|
||||
|
||||
%global maj_ver 15
|
||||
%global maj_ver 16
|
||||
%global min_ver 0
|
||||
%global patch_ver 7
|
||||
%global patch_ver 0
|
||||
#global rc_ver 4
|
||||
%global clang_version %{maj_ver}.%{min_ver}.%{patch_ver}
|
||||
|
||||
@ -33,6 +33,7 @@
|
||||
%endif
|
||||
|
||||
%global clang_srcdir clang-%{clang_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
%global cmake_srcdir cmake-%{clang_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
%global clang_tools_srcdir clang-tools-extra-%{clang_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
%if !%{maj_ver} && 0%{?rc_ver}
|
||||
@ -52,21 +53,34 @@ Source3: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{clang_
|
||||
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{clang_version}%{?rc_ver:-rc%{rc_ver}}/%{clang_tools_srcdir}.tar.xz
|
||||
Source2: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{clang_version}%{?rc_ver:-rc%{rc_ver}}/%{clang_tools_srcdir}.tar.xz.sig
|
||||
%endif
|
||||
Source4: release-keys.asc
|
||||
%if !0%{?compat_build}
|
||||
Source5: macros.%{name}
|
||||
Source4: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{clang_version}%{?rc_ver:-rc%{rc_ver}}/%{cmake_srcdir}.tar.xz
|
||||
Source5: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{clang_version}%{?rc_ver:-rc%{rc_ver}}/%{cmake_srcdir}.tar.xz.sig
|
||||
Source6: release-keys.asc
|
||||
%if %{without compat_build}
|
||||
Source7: macros.%{name}
|
||||
%endif
|
||||
|
||||
# Patches for clang
|
||||
Patch0: 0001-PATCH-clang-Reorganize-gtest-integration.patch
|
||||
Patch1: 0002-PATCH-clang-Make-funwind-tables-the-default-on-all-a.patch
|
||||
Patch1: 0003-PATCH-Make-funwind-tables-the-default-on-all-archs.patch
|
||||
Patch2: 0003-PATCH-clang-Don-t-install-static-libraries.patch
|
||||
Patch3: 0001-Driver-Add-a-gcc-equivalent-triple-to-the-list-of-tr.patch
|
||||
Patch4: 0001-cmake-Allow-shared-libraries-to-customize-the-soname.patch
|
||||
# This patch can be dropped once gcc-12.0.1-0.5.fc36 is in the repo.
|
||||
Patch5: 0001-Work-around-gcc-miscompile.patch
|
||||
Patch7: 0010-PATCH-clang-Produce-DWARF4-by-default.patch
|
||||
Patch8: disable-recommonmark.patch
|
||||
# Drop the following patch after debugedit adds support to DWARF-5:
|
||||
# https://sourceware.org/bugzilla/show_bug.cgi?id=28728
|
||||
Patch5: 0010-PATCH-clang-Produce-DWARF4-by-default.patch
|
||||
# Fix a test based on the triple used on RHEL-based systems.
|
||||
Patch6: 0001-PowerPC-clang-Fix-triple.patch
|
||||
# Make clangBasic and clangDriver depend on LLVMTargetParser
|
||||
# See https://reviews.llvm.org/D141581
|
||||
Patch7: D141581.diff
|
||||
# clang/cmake: Use installed gtest libraries for stand-alone builds
|
||||
# See https://reviews.llvm.org/D138472
|
||||
Patch8: D138472.diff
|
||||
|
||||
Patch10: fix-ieee128-cross.diff
|
||||
|
||||
|
||||
|
||||
Patch100: disable-recommonmark.patch
|
||||
|
||||
|
||||
# Patches for clang-tools-extra
|
||||
@ -244,13 +258,20 @@ Requires: python3
|
||||
|
||||
|
||||
%prep
|
||||
%{gpgverify} --keyring='%{SOURCE4}' --signature='%{SOURCE3}' --data='%{SOURCE0}'
|
||||
%{gpgverify} --keyring='%{SOURCE6}' --signature='%{SOURCE3}' --data='%{SOURCE0}'
|
||||
%{gpgverify} --keyring='%{SOURCE6}' --signature='%{SOURCE5}' --data='%{SOURCE4}'
|
||||
|
||||
%setup -T -q -b 4 -n %{cmake_srcdir}
|
||||
# TODO: It would be more elegant to set -DLLVM_COMMON_CMAKE_UTILS=%{_builddir}/%{cmake_srcdir},
|
||||
# but this is not a CACHED variable, so we can't actually set it externally :(
|
||||
cd ..
|
||||
mv %{cmake_srcdir} cmake
|
||||
|
||||
%if %{with compat_build}
|
||||
%autosetup -n %{clang_srcdir} -p2
|
||||
%else
|
||||
|
||||
%{gpgverify} --keyring='%{SOURCE4}' --signature='%{SOURCE2}' --data='%{SOURCE1}'
|
||||
%{gpgverify} --keyring='%{SOURCE6}' --signature='%{SOURCE2}' --data='%{SOURCE1}'
|
||||
%setup -T -q -b 1 -n %{clang_tools_srcdir}
|
||||
%autopatch -m200 -p2
|
||||
|
||||
@ -398,7 +419,7 @@ rm -Rf %{buildroot}%{install_prefix}/lib/{libear,libscanbuild}
|
||||
# File in the macros file for other packages to use. We are not doing this
|
||||
# in the compat package, because the version macros would # conflict with
|
||||
# eachother if both clang and the clang compat package were installed together.
|
||||
install -p -m0644 -D %{SOURCE5} %{buildroot}%{_rpmmacrodir}/macros.%{name}
|
||||
install -p -m0644 -D %{SOURCE7} %{buildroot}%{_rpmmacrodir}/macros.%{name}
|
||||
sed -i -e "s|@@CLANG_MAJOR_VERSION@@|%{maj_ver}|" \
|
||||
-e "s|@@CLANG_MINOR_VERSION@@|%{min_ver}|" \
|
||||
-e "s|@@CLANG_PATCH_VERSION@@|%{patch_ver}|" \
|
||||
@ -410,7 +431,7 @@ install -p -m644 bindings/python/clang/* %{buildroot}%{python3_sitelib}/clang/
|
||||
%py_byte_compile %{__python3} %{buildroot}%{python3_sitelib}/clang
|
||||
|
||||
# install scanbuild-py to python sitelib.
|
||||
mv %{buildroot}%{_prefix}/lib/{libear,libscanbuild} %{buildroot}%{python3_sitelib}
|
||||
mv %{buildroot}%{_prefix}/%{_lib}/{libear,libscanbuild} %{buildroot}%{python3_sitelib}
|
||||
%py_byte_compile %{__python3} %{buildroot}%{python3_sitelib}/{libear,libscanbuild}
|
||||
|
||||
# Fix permissions of scan-view scripts
|
||||
@ -449,20 +470,11 @@ ln -s clang++ %{buildroot}%{_bindir}/clang++-%{maj_ver}
|
||||
# Fix permission
|
||||
chmod u-x %{buildroot}%{_mandir}/man1/scan-build.1*
|
||||
|
||||
# create a link to clang's resource directory that is "constant" across minor
|
||||
# version bumps
|
||||
# this is required for packages like ccls that hardcode the link to clang's
|
||||
# resource directory to not require rebuilds on minor version bumps
|
||||
# Fix for bugs like rhbz#1807574
|
||||
pushd %{buildroot}%{_libdir}/clang/
|
||||
ln -s %{version} %{maj_ver}
|
||||
popd
|
||||
|
||||
%endif
|
||||
|
||||
# Create sub-directories in the clang resource directory that will be
|
||||
# populated by other packages
|
||||
mkdir -p %{buildroot}%{pkg_libdir}/clang/%{version}/{include,lib,share}/
|
||||
mkdir -p %{buildroot}%{pkg_libdir}/clang/%{maj_ver}/{include,lib,share}/
|
||||
|
||||
|
||||
# Remove clang-tidy headers. We don't ship the libraries for these.
|
||||
@ -476,6 +488,12 @@ ln -s %{_datadir}/clang/clang-format-diff.py %{buildroot}%{_bindir}/clang-format
|
||||
%check
|
||||
%if %{without compat_build}
|
||||
%if %{with check}
|
||||
# Build test dependencies separately, to prevent invocations of host clang from being affected
|
||||
# by LD_LIBRARY_PATH below.
|
||||
pushd %{_vpath_builddir}
|
||||
%cmake_build --target clang-test-depends \
|
||||
ExtraToolsUnitTests ClangdUnitTests ClangIncludeCleanerUnitTests ClangPseudoUnitTests
|
||||
popd
|
||||
# requires lit.py from LLVM utilities
|
||||
# FIXME: Fix failing ARM tests
|
||||
LD_LIBRARY_PATH=%{buildroot}/%{_libdir} %{__ninja} %{_smp_mflags} check-all -C %{_vpath_builddir} || \
|
||||
@ -505,11 +523,11 @@ false
|
||||
|
||||
%files libs
|
||||
%if %{without compat_build}
|
||||
%{_libdir}/clang/
|
||||
%{_libdir}/clang/%{maj_ver}/include/*
|
||||
%{_libdir}/*.so.*
|
||||
%else
|
||||
%{pkg_libdir}/*.so.*
|
||||
%{pkg_libdir}/clang/%{version}
|
||||
%{pkg_libdir}/clang/%{maj_ver}/include/*
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
@ -528,13 +546,11 @@ false
|
||||
%endif
|
||||
|
||||
%files resource-filesystem
|
||||
%dir %{pkg_libdir}/clang/%{version}/
|
||||
%dir %{pkg_libdir}/clang/%{version}/include/
|
||||
%dir %{pkg_libdir}/clang/%{version}/lib/
|
||||
%dir %{pkg_libdir}/clang/%{version}/share/
|
||||
%if %{without compat_build}
|
||||
%{pkg_libdir}/clang/%{maj_ver}
|
||||
%endif
|
||||
%dir %{pkg_libdir}/clang/
|
||||
%dir %{pkg_libdir}/clang/%{maj_ver}/
|
||||
%dir %{pkg_libdir}/clang/%{maj_ver}/include/
|
||||
%dir %{pkg_libdir}/clang/%{maj_ver}/lib/
|
||||
%dir %{pkg_libdir}/clang/%{maj_ver}/share/
|
||||
|
||||
%if %{without compat_build}
|
||||
%files analyzer
|
||||
@ -557,19 +573,19 @@ false
|
||||
|
||||
|
||||
%files tools-extra
|
||||
%{_bindir}/amdgpu-arch
|
||||
%{_bindir}/clang-apply-replacements
|
||||
%{_bindir}/clang-change-namespace
|
||||
%{_bindir}/clang-check
|
||||
%{_bindir}/clang-doc
|
||||
%{_bindir}/clang-extdef-mapping
|
||||
%{_bindir}/clang-format
|
||||
%{_bindir}/clang-include-cleaner
|
||||
%{_bindir}/clang-include-fixer
|
||||
%{_bindir}/clang-move
|
||||
%{_bindir}/clang-offload-bundler
|
||||
%{_bindir}/clang-offload-packager
|
||||
%{_bindir}/clang-offload-wrapper
|
||||
%{_bindir}/clang-linker-wrapper
|
||||
%{_bindir}/clang-nvlink-wrapper
|
||||
%{_bindir}/clang-pseudo
|
||||
%{_bindir}/clang-query
|
||||
%{_bindir}/clang-refactor
|
||||
@ -581,6 +597,7 @@ false
|
||||
%{_bindir}/clangd
|
||||
%{_bindir}/diagtool
|
||||
%{_bindir}/hmaptool
|
||||
%{_bindir}/nvptx-arch
|
||||
%{_bindir}/pp-trace
|
||||
%{_bindir}/c-index-test
|
||||
%{_bindir}/find-all-symbols
|
||||
@ -607,6 +624,9 @@ false
|
||||
|
||||
%endif
|
||||
%changelog
|
||||
* Fri Apr 28 2023 Tom Stellard <tstelar@redhat.com> - 16.0.0-1
|
||||
- 16.0.0 Release
|
||||
|
||||
* Thu Jan 19 2023 Tom Stellard <tstellar@redhat.com> - 15.0.7-1
|
||||
- Update to LLVM 15.0.7
|
||||
|
||||
|
16
fix-ieee128-cross.diff
Normal file
16
fix-ieee128-cross.diff
Normal file
@ -0,0 +1,16 @@
|
||||
diff --git a/clang/test/Driver/ppc-float-abi-warning.cpp b/clang/test/Driver/ppc-float-abi-warning.cpp
|
||||
index e3baa9f4c059..87d6d87a3b31 100644
|
||||
--- a/clang/test/Driver/ppc-float-abi-warning.cpp
|
||||
+++ b/clang/test/Driver/ppc-float-abi-warning.cpp
|
||||
@@ -17,10 +17,12 @@
|
||||
// RUN: -mabi=ieeelongdouble -stdlib=libc++ -Wno-unsupported-abi 2>&1 | \
|
||||
// RUN: FileCheck %s --check-prefix=NOWARN
|
||||
// RUN: %clang -### --driver-mode=g++ -target powerpc64le-linux-gnu %s\
|
||||
+// RUN: --dyld-prefix=%S/Inputs/powerpc64le-linux-gnu-tree/gcc-12 \
|
||||
// RUN: -mabi=%if ppc_linux_default_ieeelongdouble %{ieeelongdouble%} \
|
||||
// RUN: %else %{ibmlongdouble%} -stdlib=libc++ 2>&1 | \
|
||||
// RUN: FileCheck %s --check-prefix=NOWARN
|
||||
// RUN: %clang -### --driver-mode=g++ -target powerpc64le-linux-gnu %s\
|
||||
+// RUN: --dyld-prefix=%S/Inputs/powerpc64le-linux-gnu-tree/gcc-12 \
|
||||
// RUN: -mabi=%if ppc_linux_default_ieeelongdouble %{ibmlongdouble%} \
|
||||
// RUN: %else %{ieeelongdouble%} -stdlib=libc++ 2>&1 | FileCheck %s
|
5
sources
5
sources
@ -1,3 +1,4 @@
|
||||
SHA512 (clang-15.0.7.src.tar.xz) = 9fd2736a9f5993ddbb5b3c507fe497234a6def64f6f418f379d1ca56c9c361ad1ae9a5445ab938230fbc1671ec00b4f802a412b048569023863c20dc6bb46a1f
|
||||
SHA512 (clang-tools-extra-15.0.7.src.tar.xz) = dd95d261d3a1618967b698e97ac0b41204d872d7479c0c832fcf5a91fe447af6a97fa794de07b3e271285867b30b905688f090e98f516b9df4cdfb3bad9defc6
|
||||
SHA512 (clang-16.0.0.src.tar.xz) = 2a6ff3b4d61b4e9fcb60a6d9dae451170cd91acc25f924a29c18c579ee78af76d2d5eebb2940d61676e2e791fb247ccf9f5377b5528f3a0fa7dd0ac8e72816ba
|
||||
SHA512 (clang-tools-extra-16.0.0.src.tar.xz) = a96498a3ce72cfa1be783455bbdbbde22ee3842652c584cabbae8ca0658ad394ede479cad1d8535bc1c5dc95a52551a059394e968d69b3e9745a95229aecdcc2
|
||||
SHA512 (release-keys.asc) = 08eab15cd40116bb1eea5ddcdd2822d248d6d7f5dce37868aa7152377aa0062567fe571909a1c9d3c3f8978ebcf5e0f6b0ab8fff13e3578c0548e21be3026462
|
||||
SHA512 (cmake-16.0.0.src.tar.xz) = 4f21461aa8165061dbea47dcda4f098957e16bd307484bcb66884cf5a0776197f69a74002d5601229c4630db53ac44049f3f2ce1e96a6bb16ba3df828d387932
|
||||
|
Loading…
Reference in New Issue
Block a user