import clang-12.0.1-1.module+el8.5.0+11871+08d0eab5
This commit is contained in:
parent
714ce1de72
commit
7673dc1744
@ -1,3 +1,3 @@
|
||||
51250856f368acef5ab335a16f994bf29ad3d115 SOURCES/clang-12.0.0.src.tar.xz
|
||||
5fe54db45be35b8f77acc32f08e01912f8e8b915 SOURCES/clang-tools-extra-12.0.0.src.tar.xz
|
||||
e3cdd3fb39c78a5bcb0a1d5706678cf8643a48f6 SOURCES/clang-12.0.1.src.tar.xz
|
||||
42f179bb59432c4d2785239952853ad6308d0863 SOURCES/clang-tools-extra-12.0.1.src.tar.xz
|
||||
b8d2648a01d36ed0186fd2c5af325fd28797f9a0 SOURCES/tstellar-gpg-key.asc
|
||||
|
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,3 +1,3 @@
|
||||
SOURCES/clang-12.0.0.src.tar.xz
|
||||
SOURCES/clang-tools-extra-12.0.0.src.tar.xz
|
||||
SOURCES/clang-12.0.1.src.tar.xz
|
||||
SOURCES/clang-tools-extra-12.0.1.src.tar.xz
|
||||
SOURCES/tstellar-gpg-key.asc
|
||||
|
@ -1,31 +0,0 @@
|
||||
From 84e4fe467f290c85b3d7d22c7333d192e1282054 Mon Sep 17 00:00:00 2001
|
||||
From: serge-sans-paille <sguelton@redhat.com>
|
||||
Date: Wed, 17 Mar 2021 08:32:56 +0100
|
||||
Subject: [PATCH] [PATCH][clang-tools-extra] Make clangd CompletionModel usable
|
||||
even with non-standard (but supported) layout
|
||||
|
||||
llvm supports specifying a non-standard layout where each project lies in its
|
||||
own place. Do not assume a fixed layout and use the appropriate cmake variable
|
||||
instead.
|
||||
---
|
||||
clang-tools-extra/clangd/quality/CompletionModel.cmake | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/clang-tools-extra/clangd/quality/CompletionModel.cmake b/clang-tools-extra/clangd/quality/CompletionModel.cmake
|
||||
index 60c6d2a..41bc2ed 100644
|
||||
--- a/clang-tools-extra/clangd/quality/CompletionModel.cmake
|
||||
+++ b/clang-tools-extra/clangd/quality/CompletionModel.cmake
|
||||
@@ -5,8 +5,8 @@
|
||||
# will define a C++ class called ${cpp_class} - which may be a
|
||||
# namespace-qualified class name.
|
||||
function(gen_decision_forest model filename cpp_class)
|
||||
- set(model_compiler ${CMAKE_SOURCE_DIR}/../clang-tools-extra/clangd/quality/CompletionModelCodegen.py)
|
||||
-
|
||||
+ set(model_compiler ${LLVM_EXTERNAL_CLANG_TOOLS_EXTRA_SOURCE_DIR}/clangd/quality/CompletionModelCodegen.py)
|
||||
+
|
||||
set(output_dir ${CMAKE_CURRENT_BINARY_DIR})
|
||||
set(header_file ${output_dir}/${filename}.h)
|
||||
set(cpp_file ${output_dir}/${filename}.cpp)
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -1,224 +0,0 @@
|
||||
From ea01f898fd74bae23d8be31f1a29b542e886e3a5 Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Tue, 9 Feb 2021 13:35:43 -0800
|
||||
Subject: [PATCH 5/6] [PATCH][clang] Partially Revert "scan-view: Remove
|
||||
Reporter.py and associated AppleScript files"
|
||||
|
||||
This reverts some of commit dbb01536f6f49fa428f170e34466072ef439b3e9.
|
||||
|
||||
The Reporter module was still being used by the ScanView.py module and deleting
|
||||
it caused scan-view to fail. This commit adds back Reporter.py but removes the
|
||||
code the references the AppleScript files which were removed in
|
||||
dbb01536f6f49fa428f170e34466072ef439b3e9.
|
||||
|
||||
Differential Revision: https://reviews.llvm.org/D96367
|
||||
---
|
||||
clang/tools/scan-view/CMakeLists.txt | 1 +
|
||||
clang/tools/scan-view/share/Reporter.py | 183 ++++++++++++++++++++++++++++++++
|
||||
2 files changed, 184 insertions(+)
|
||||
create mode 100644 clang/tools/scan-view/share/Reporter.py
|
||||
|
||||
diff --git a/clang/tools/scan-view/CMakeLists.txt b/clang/tools/scan-view/CMakeLists.txt
|
||||
index dd3d334..eccc6b8 100644
|
||||
--- a/clang/tools/scan-view/CMakeLists.txt
|
||||
+++ b/clang/tools/scan-view/CMakeLists.txt
|
||||
@@ -5,6 +5,7 @@ set(BinFiles
|
||||
|
||||
set(ShareFiles
|
||||
ScanView.py
|
||||
+ Reporter.py
|
||||
startfile.py
|
||||
bugcatcher.ico)
|
||||
|
||||
diff --git a/clang/tools/scan-view/share/Reporter.py b/clang/tools/scan-view/share/Reporter.py
|
||||
new file mode 100644
|
||||
index 0000000..31a14fb
|
||||
--- /dev/null
|
||||
+++ b/clang/tools/scan-view/share/Reporter.py
|
||||
@@ -0,0 +1,183 @@
|
||||
+#!/usr/bin/env python
|
||||
+# -*- coding: utf-8 -*-
|
||||
+
|
||||
+"""Methods for reporting bugs."""
|
||||
+
|
||||
+import subprocess, sys, os
|
||||
+
|
||||
+__all__ = ['ReportFailure', 'BugReport', 'getReporters']
|
||||
+
|
||||
+#
|
||||
+
|
||||
+class ReportFailure(Exception):
|
||||
+ """Generic exception for failures in bug reporting."""
|
||||
+ def __init__(self, value):
|
||||
+ self.value = value
|
||||
+
|
||||
+# Collect information about a bug.
|
||||
+
|
||||
+class BugReport(object):
|
||||
+ def __init__(self, title, description, files):
|
||||
+ self.title = title
|
||||
+ self.description = description
|
||||
+ self.files = files
|
||||
+
|
||||
+# Reporter interfaces.
|
||||
+
|
||||
+import os
|
||||
+
|
||||
+import email, mimetypes, smtplib
|
||||
+from email import encoders
|
||||
+from email.message import Message
|
||||
+from email.mime.base import MIMEBase
|
||||
+from email.mime.multipart import MIMEMultipart
|
||||
+from email.mime.text import MIMEText
|
||||
+
|
||||
+#===------------------------------------------------------------------------===#
|
||||
+# ReporterParameter
|
||||
+#===------------------------------------------------------------------------===#
|
||||
+
|
||||
+class ReporterParameter(object):
|
||||
+ def __init__(self, n):
|
||||
+ self.name = n
|
||||
+ def getName(self):
|
||||
+ return self.name
|
||||
+ def getValue(self,r,bugtype,getConfigOption):
|
||||
+ return getConfigOption(r.getName(),self.getName())
|
||||
+ def saveConfigValue(self):
|
||||
+ return True
|
||||
+
|
||||
+class TextParameter (ReporterParameter):
|
||||
+ def getHTML(self,r,bugtype,getConfigOption):
|
||||
+ return """\
|
||||
+<tr>
|
||||
+<td class="form_clabel">%s:</td>
|
||||
+<td class="form_value"><input type="text" name="%s_%s" value="%s"></td>
|
||||
+</tr>"""%(self.getName(),r.getName(),self.getName(),self.getValue(r,bugtype,getConfigOption))
|
||||
+
|
||||
+class SelectionParameter (ReporterParameter):
|
||||
+ def __init__(self, n, values):
|
||||
+ ReporterParameter.__init__(self,n)
|
||||
+ self.values = values
|
||||
+
|
||||
+ def getHTML(self,r,bugtype,getConfigOption):
|
||||
+ default = self.getValue(r,bugtype,getConfigOption)
|
||||
+ return """\
|
||||
+<tr>
|
||||
+<td class="form_clabel">%s:</td><td class="form_value"><select name="%s_%s">
|
||||
+%s
|
||||
+</select></td>"""%(self.getName(),r.getName(),self.getName(),'\n'.join(["""\
|
||||
+<option value="%s"%s>%s</option>"""%(o[0],
|
||||
+ o[0] == default and ' selected="selected"' or '',
|
||||
+ o[1]) for o in self.values]))
|
||||
+
|
||||
+#===------------------------------------------------------------------------===#
|
||||
+# Reporters
|
||||
+#===------------------------------------------------------------------------===#
|
||||
+
|
||||
+class EmailReporter(object):
|
||||
+ def getName(self):
|
||||
+ return 'Email'
|
||||
+
|
||||
+ def getParameters(self):
|
||||
+ return [TextParameter(x) for x in ['To', 'From', 'SMTP Server', 'SMTP Port']]
|
||||
+
|
||||
+ # Lifted from python email module examples.
|
||||
+ def attachFile(self, outer, path):
|
||||
+ # Guess the content type based on the file's extension. Encoding
|
||||
+ # will be ignored, although we should check for simple things like
|
||||
+ # gzip'd or compressed files.
|
||||
+ ctype, encoding = mimetypes.guess_type(path)
|
||||
+ if ctype is None or encoding is not None:
|
||||
+ # No guess could be made, or the file is encoded (compressed), so
|
||||
+ # use a generic bag-of-bits type.
|
||||
+ ctype = 'application/octet-stream'
|
||||
+ maintype, subtype = ctype.split('/', 1)
|
||||
+ if maintype == 'text':
|
||||
+ fp = open(path)
|
||||
+ # Note: we should handle calculating the charset
|
||||
+ msg = MIMEText(fp.read(), _subtype=subtype)
|
||||
+ fp.close()
|
||||
+ else:
|
||||
+ fp = open(path, 'rb')
|
||||
+ msg = MIMEBase(maintype, subtype)
|
||||
+ msg.set_payload(fp.read())
|
||||
+ fp.close()
|
||||
+ # Encode the payload using Base64
|
||||
+ encoders.encode_base64(msg)
|
||||
+ # Set the filename parameter
|
||||
+ msg.add_header('Content-Disposition', 'attachment', filename=os.path.basename(path))
|
||||
+ outer.attach(msg)
|
||||
+
|
||||
+ def fileReport(self, report, parameters):
|
||||
+ mainMsg = """\
|
||||
+BUG REPORT
|
||||
+---
|
||||
+Title: %s
|
||||
+Description: %s
|
||||
+"""%(report.title, report.description)
|
||||
+
|
||||
+ if not parameters.get('To'):
|
||||
+ raise ReportFailure('No "To" address specified.')
|
||||
+ if not parameters.get('From'):
|
||||
+ raise ReportFailure('No "From" address specified.')
|
||||
+
|
||||
+ msg = MIMEMultipart()
|
||||
+ msg['Subject'] = 'BUG REPORT: %s'%(report.title)
|
||||
+ # FIXME: Get config parameters
|
||||
+ msg['To'] = parameters.get('To')
|
||||
+ msg['From'] = parameters.get('From')
|
||||
+ msg.preamble = mainMsg
|
||||
+
|
||||
+ msg.attach(MIMEText(mainMsg, _subtype='text/plain'))
|
||||
+ for file in report.files:
|
||||
+ self.attachFile(msg, file)
|
||||
+
|
||||
+ try:
|
||||
+ s = smtplib.SMTP(host=parameters.get('SMTP Server'),
|
||||
+ port=parameters.get('SMTP Port'))
|
||||
+ s.sendmail(msg['From'], msg['To'], msg.as_string())
|
||||
+ s.close()
|
||||
+ except:
|
||||
+ raise ReportFailure('Unable to send message via SMTP.')
|
||||
+
|
||||
+ return "Message sent!"
|
||||
+
|
||||
+class BugzillaReporter(object):
|
||||
+ def getName(self):
|
||||
+ return 'Bugzilla'
|
||||
+
|
||||
+ def getParameters(self):
|
||||
+ return [TextParameter(x) for x in ['URL','Product']]
|
||||
+
|
||||
+ def fileReport(self, report, parameters):
|
||||
+ raise NotImplementedError
|
||||
+
|
||||
+
|
||||
+class RadarClassificationParameter(SelectionParameter):
|
||||
+ def __init__(self):
|
||||
+ SelectionParameter.__init__(self,"Classification",
|
||||
+ [['1', 'Security'], ['2', 'Crash/Hang/Data Loss'],
|
||||
+ ['3', 'Performance'], ['4', 'UI/Usability'],
|
||||
+ ['6', 'Serious Bug'], ['7', 'Other']])
|
||||
+
|
||||
+ def saveConfigValue(self):
|
||||
+ return False
|
||||
+
|
||||
+ def getValue(self,r,bugtype,getConfigOption):
|
||||
+ if bugtype.find("leak") != -1:
|
||||
+ return '3'
|
||||
+ elif bugtype.find("dereference") != -1:
|
||||
+ return '2'
|
||||
+ elif bugtype.find("missing ivar release") != -1:
|
||||
+ return '3'
|
||||
+ else:
|
||||
+ return '7'
|
||||
+
|
||||
+###
|
||||
+
|
||||
+def getReporters():
|
||||
+ reporters = []
|
||||
+ reporters.append(EmailReporter())
|
||||
+ return reporters
|
||||
+
|
||||
--
|
||||
1.8.3.1
|
||||
|
Binary file not shown.
BIN
SOURCES/clang-12.0.1.src.tar.xz.sig
Normal file
BIN
SOURCES/clang-12.0.1.src.tar.xz.sig
Normal file
Binary file not shown.
Binary file not shown.
BIN
SOURCES/clang-tools-extra-12.0.1.src.tar.xz.sig
Normal file
BIN
SOURCES/clang-tools-extra-12.0.1.src.tar.xz.sig
Normal file
Binary file not shown.
@ -2,7 +2,7 @@
|
||||
|
||||
%global maj_ver 12
|
||||
%global min_ver 0
|
||||
%global patch_ver 0
|
||||
%global patch_ver 1
|
||||
#%%global rc_ver 5
|
||||
|
||||
%global clang_tools_binaries \
|
||||
@ -86,12 +86,13 @@ Patch0: 0001-PATCH-clang-Reorganize-gtest-integration.patch
|
||||
Patch1: 0002-PATCH-clang-Make-funwind-tables-the-default-on-all-a.patch
|
||||
Patch2: 0003-PATCH-clang-Don-t-install-static-libraries.patch
|
||||
Patch3: 0004-PATCH-clang-Prefer-gcc-toolchains-with-libgcc_s.so-w.patch
|
||||
Patch4: 0005-PATCH-clang-Partially-Revert-scan-view-Remove-Report.patch
|
||||
Patch5: 0006-PATCH-clang-Allow-__ieee128-as-an-alias-to-__float12.patch
|
||||
|
||||
# Patches for clang-tools-extra
|
||||
%if !0%{?compat_build}
|
||||
Patch201: 0001-PATCH-clang-tools-extra-Make-clangd-CompletionModel-.patch
|
||||
%ifarch ix86
|
||||
Patch201 clangd-tests.patch
|
||||
%endif
|
||||
%endif
|
||||
|
||||
BuildRequires: gcc
|
||||
@ -540,6 +541,9 @@ false
|
||||
|
||||
%endif
|
||||
%changelog
|
||||
* Fri Jul 16 2021 sguelton@redhat.com - 12.0.1-1
|
||||
- 12.0.1 release
|
||||
|
||||
* Thu May 6 2021 sguelton@redhat.com - 12.0.0-1
|
||||
- 12.0.0 release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user