Update to LLVM 17.0.1
This commit is contained in:
parent
7ca2731b6f
commit
522fd69676
30
689.patch
30
689.patch
@ -1,30 +0,0 @@
|
|||||||
From b7d6e2b5308a7b53ce7b3bbfd6e8e38e28e036ec Mon Sep 17 00:00:00 2001
|
|
||||||
From: Sam James <sam@gentoo.org>
|
|
||||||
Date: Tue, 5 Sep 2023 16:02:04 +0100
|
|
||||||
Subject: [PATCH] [Clang] Fix JIT test on 32-bit systems
|
|
||||||
|
|
||||||
As reported by mgorny at https://reviews.llvm.org/D159115#4638037, the
|
|
||||||
unsigned long long cast fails on 32-bit systems at least with GCC.
|
|
||||||
|
|
||||||
It looks like a pointer provenance/aliasing issue rather than a bug in GCC.
|
|
||||||
|
|
||||||
Acked by Vassil Vassilev on the original revision.
|
|
||||||
|
|
||||||
(cherry picked from commit 3403686b72507e3fdbcd69f21fb9235ffa0ca169)
|
|
||||||
---
|
|
||||||
clang/unittests/Interpreter/InterpreterTest.cpp | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/clang/unittests/Interpreter/InterpreterTest.cpp b/clang/unittests/Interpreter/InterpreterTest.cpp
|
|
||||||
index abb8e6377aab..5f2911e9a7ad 100644
|
|
||||||
--- a/clang/unittests/Interpreter/InterpreterTest.cpp
|
|
||||||
+++ b/clang/unittests/Interpreter/InterpreterTest.cpp
|
|
||||||
@@ -244,7 +244,7 @@ TEST(IncrementalProcessing, FindMangledNameSymbol) {
|
|
||||||
|
|
||||||
// FIXME: Re-enable when we investigate the way we handle dllimports on Win.
|
|
||||||
#ifndef _WIN32
|
|
||||||
- EXPECT_EQ((unsigned long long)&printf, Addr->getValue());
|
|
||||||
+ EXPECT_EQ((uintptr_t)&printf, Addr->getValue());
|
|
||||||
#endif // _WIN32
|
|
||||||
}
|
|
||||||
|
|
14
clang.spec
14
clang.spec
@ -15,8 +15,8 @@
|
|||||||
|
|
||||||
%global maj_ver 17
|
%global maj_ver 17
|
||||||
%global min_ver 0
|
%global min_ver 0
|
||||||
%global patch_ver 0
|
%global patch_ver 1
|
||||||
%global rc_ver 4
|
#global rc_ver 4
|
||||||
|
|
||||||
%if %{with snapshot_build}
|
%if %{with snapshot_build}
|
||||||
%undefine rc_ver
|
%undefine rc_ver
|
||||||
@ -55,7 +55,7 @@
|
|||||||
|
|
||||||
Name: %pkg_name
|
Name: %pkg_name
|
||||||
Version: %{clang_version}%{?rc_ver:~rc%{rc_ver}}%{?llvm_snapshot_version_suffix:~%{llvm_snapshot_version_suffix}}
|
Version: %{clang_version}%{?rc_ver:~rc%{rc_ver}}%{?llvm_snapshot_version_suffix:~%{llvm_snapshot_version_suffix}}
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A C language family front-end for LLVM
|
Summary: A C language family front-end for LLVM
|
||||||
|
|
||||||
License: Apache-2.0 WITH LLVM-exception OR NCSA
|
License: Apache-2.0 WITH LLVM-exception OR NCSA
|
||||||
@ -85,12 +85,9 @@ Patch3: 0001-Driver-Add-a-gcc-equivalent-triple-to-the-list-of-tr.patch
|
|||||||
# Drop the following patch after debugedit adds support to DWARF-5:
|
# Drop the following patch after debugedit adds support to DWARF-5:
|
||||||
# https://sourceware.org/bugzilla/show_bug.cgi?id=28728
|
# https://sourceware.org/bugzilla/show_bug.cgi?id=28728
|
||||||
Patch4: 0001-Produce-DWARF4-by-default.patch
|
Patch4: 0001-Produce-DWARF4-by-default.patch
|
||||||
# Backport from LLVM 18:
|
|
||||||
# https://github.com/llvm/llvm-project-release-prs/pull/689
|
|
||||||
Patch5: 689.patch
|
|
||||||
# Workaround a bug in ORC on ppc64le.
|
# Workaround a bug in ORC on ppc64le.
|
||||||
# More info is available here: https://reviews.llvm.org/D159115#4641826
|
# More info is available here: https://reviews.llvm.org/D159115#4641826
|
||||||
Patch6: 0001-Workaround-a-bug-in-ORC-on-ppc64le.patch
|
Patch5: 0001-Workaround-a-bug-in-ORC-on-ppc64le.patch
|
||||||
|
|
||||||
# RHEL specific patches
|
# RHEL specific patches
|
||||||
# Avoid unwanted dependency on python-recommonmark
|
# Avoid unwanted dependency on python-recommonmark
|
||||||
@ -644,6 +641,9 @@ false
|
|||||||
%changelog
|
%changelog
|
||||||
%{?llvm_snapshot_changelog_entry}
|
%{?llvm_snapshot_changelog_entry}
|
||||||
|
|
||||||
|
* Sat Sep 23 2023 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 17.0.1-1
|
||||||
|
- Update to LLVM 17.0.1
|
||||||
|
|
||||||
* Tue Sep 19 2023 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 17.0.0~rc4-4
|
* Tue Sep 19 2023 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 17.0.0~rc4-4
|
||||||
- Re-add dwarf4 patch. Fix rhbz#2239619.
|
- Re-add dwarf4 patch. Fix rhbz#2239619.
|
||||||
|
|
||||||
|
8
sources
8
sources
@ -1,4 +1,4 @@
|
|||||||
SHA512 (clang-17.0.0rc4.src.tar.xz) = 97d9263fb56cbb20dfc70db31e375339b8ec490ba1a7b64b69a38738c2c4ea34b0bf8d38c7542be0a1eb68ead121dfc7cde4d76b08d916160cbbd81c3f1ea499
|
SHA512 (clang-17.0.1.src.tar.xz) = fe2a74f67d6f45cb53d25864643e5b8e98a7066c8f8862acdd76a73e3b5478fc7220d5f136558ba9dd4043e661d09a3d293e0ad689eedcd491feba0a201e0c51
|
||||||
SHA512 (clang-17.0.0rc4.src.tar.xz.sig) = 4c0f70b236430de358ed51dc640970c8fa5894542d4af22ec6c0d2a87a1cda24684d8f58a3102e7973c510618d19f4cfd77aab1ced50542e0d602f021a9c9744
|
SHA512 (clang-17.0.1.src.tar.xz.sig) = 40ebd4b4b2102f130734388c4368fa21d3c7dd3b88e6ef1bf167416d17dafc60a216ec80d87e13465b7b450349310d1cb44b56b9e6166d3bef41c96230a5cc32
|
||||||
SHA512 (clang-tools-extra-17.0.0rc4.src.tar.xz) = 3372b94d0eeafd838a1d9b75d4e69645a40632150cc5ba4d74494469fb4fe070da979f0140954ac7773d27b1bdadd0ae30a7571ae08b23f307ade23a167e6818
|
SHA512 (clang-tools-extra-17.0.1.src.tar.xz) = e4e1b3b39aba0d225312e6c504851cf98fba888cdcadd45a5f3ac6673b1d43e289e3febbd3e18cb0f44b522a6316651a400bb2c2e48e4c650ffa5dc8b4a46d74
|
||||||
SHA512 (clang-tools-extra-17.0.0rc4.src.tar.xz.sig) = 48e16589e37bafa98aec0de20ae6e5ac7abfb0d4405713c2b15ceca76dfce964949e36466affbdcad41c6889652a5dda40a6d5e17afa866eb208c404166909b3
|
SHA512 (clang-tools-extra-17.0.1.src.tar.xz.sig) = 9a08b574ced425ebe42790257afa42963483292c9866e2fcf114fe0aca1626e771ce97cf52196c070f0d26e695f17684c7da6937925175369e990aaf82aa8843
|
||||||
|
Loading…
Reference in New Issue
Block a user