Update to LLVM 16.0.6
Resolves: rhbz#2178796
This commit is contained in:
parent
9279f98d16
commit
4fcf8241b9
@ -1,26 +0,0 @@
|
||||
From 701750a896a08d5841a7bc0d187bcddaa6c0f616 Mon Sep 17 00:00:00 2001
|
||||
From: Tulio Magno Quites Machado Filho <tuliom@redhat.com>
|
||||
Date: Thu, 16 Mar 2023 17:22:24 -0300
|
||||
Subject: [PATCH] [PowerPC][clang] Fix triple
|
||||
|
||||
Some Linux distributions use ppc64le instead of powerpc.
|
||||
---
|
||||
clang/test/CodeGenCoroutines/pr56329.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/clang/test/CodeGenCoroutines/pr56329.cpp b/clang/test/CodeGenCoroutines/pr56329.cpp
|
||||
index 31d4849af4e7..69e0f1d337cf 100644
|
||||
--- a/clang/test/CodeGenCoroutines/pr56329.cpp
|
||||
+++ b/clang/test/CodeGenCoroutines/pr56329.cpp
|
||||
@@ -2,7 +2,7 @@
|
||||
//
|
||||
// RUN: %clang_cc1 -triple %itanium_abi_triple -std=c++20 %s -O3 -S -emit-llvm -o - | FileCheck %s
|
||||
// This test is expected to fail on PowerPC.
|
||||
-// XFAIL: target=powerpc{{.*}}
|
||||
+// XFAIL: target={{(ppc|powerpc).*}}
|
||||
|
||||
#include "Inputs/coroutine.h"
|
||||
|
||||
--
|
||||
2.39.2
|
||||
|
14
clang.spec
14
clang.spec
@ -5,12 +5,12 @@
|
||||
%global gts_version 13
|
||||
|
||||
%bcond_with compat_build
|
||||
%bcond_without bundle_compat_lib
|
||||
%bcond_with bundle_compat_lib
|
||||
%bcond_without check
|
||||
|
||||
%global maj_ver 16
|
||||
%global min_ver 0
|
||||
%global patch_ver 1
|
||||
%global patch_ver 6
|
||||
%global clang_version %{maj_ver}.%{min_ver}.%{patch_ver}
|
||||
|
||||
%if %{with compat_build}
|
||||
@ -47,7 +47,7 @@
|
||||
|
||||
Name: %pkg_name
|
||||
Version: %{clang_version}%{?rc_ver:~rc%{rc_ver}}
|
||||
Release: 7%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: A C language family front-end for LLVM
|
||||
|
||||
License: Apache-2.0 WITH LLVM-exception OR NCSA
|
||||
@ -77,8 +77,6 @@ Patch1: 0003-PATCH-Make-funwind-tables-the-default-on-all-archs.patch
|
||||
Patch2: 0006-Don-t-install-static-libraries.patch
|
||||
Patch3: 0002-Driver-Add-a-gcc-equivalent-triple-to-the-list-of-tr.patch
|
||||
Patch4: 0010-PATCH-clang-Produce-DWARF4-by-default.patch
|
||||
# Fix a test based on the triple used on RHEL-based systems.
|
||||
Patch6: 0001-PowerPC-clang-Fix-triple.patch
|
||||
# Make clangBasic and clangDriver depend on LLVMTargetParser
|
||||
# See https://reviews.llvm.org/D141581
|
||||
Patch7: D141581.diff
|
||||
@ -101,8 +99,7 @@ Patch201: 0001-clang-tools-extra-Make-test-dependency-on-LLVMHello-.patch
|
||||
%endif
|
||||
|
||||
# Required for 64-bit atomics on i686.
|
||||
# TODO: Update to gts_version on next clang build.
|
||||
BuildRequires: gcc-toolset-12-libatomic-devel
|
||||
BuildRequires: gcc-toolset-%{gts_version}-libatomic-devel
|
||||
# Required to handle LTO debuginfo.
|
||||
BuildRequires: gcc-toolset-%{gts_version}-gdb
|
||||
BuildRequires: clang
|
||||
@ -689,6 +686,9 @@ mv ./libclang-cpp.so.%{compat_maj_ver} "$compat_lib"
|
||||
|
||||
%endif
|
||||
%changelog
|
||||
* Wed Jul 05 2023 Nikita Popov <npopov@redhat.com> - 16.0.6-1
|
||||
- Update to LLVM 16.0.6
|
||||
|
||||
* Fri Jun 30 2023 Nikita Popov <npopov@redhat.com> - 16.0.1-7
|
||||
- Restore gcc-toolset-libatomic-devel requirement
|
||||
|
||||
|
14
sources
14
sources
@ -1,10 +1,4 @@
|
||||
SHA512 (clang-15.0.7.src.tar.xz) = 9fd2736a9f5993ddbb5b3c507fe497234a6def64f6f418f379d1ca56c9c361ad1ae9a5445ab938230fbc1671ec00b4f802a412b048569023863c20dc6bb46a1f
|
||||
SHA512 (clang-15.0.7.src.tar.xz.sig) = e1b41c5a6509c3554794bfa1b8d048f13268bc2234d7480f04f7700e27bd9d53e40bc1433885716a64da57458f3041c42a66639045476daefffc3f5d2e3d6efd
|
||||
SHA512 (llvm-15.0.7.src.tar.xz) = ed8d565515b1bc6164e4ff06d3388ba92e332850305496fd65db9adf1ec87bd9dd1bfde49dd41be5d5216289efc72bfd287cd7392f2bba80b740d4c314c749e5
|
||||
SHA512 (llvm-15.0.7.src.tar.xz.sig) = 79fc82dfabe397f7df4c139f75fa9a0a34c92b77d603543a4eb3e579e253a9d84d0e8314f7356ed77326977d6190997b42f074a6c910d0f932e6b21d09374bde
|
||||
SHA512 (cmake-15.0.7.src.tar.xz) = 85097a6eaee0df004567905f7e5ce8ca02e3b46c6fc66fa552fe99734642e6ee61685de4e5e6e8b505963334d7b91d98ecd9c5870e6bdd3f0018ee5b963ffa96
|
||||
SHA512 (cmake-15.0.7.src.tar.xz.sig) = 61d53c602bcb099426b8828a239628ba2fca9616afcdf67ce3c8c887146dce99a649ddb625df096e3d8aa9ede1ea9bb6933f88f3adec0192fd68faeca2488a1a
|
||||
SHA512 (clang-16.0.1.src.tar.xz) = c7ef4c386471850f30e194d0a8afe95fdd366c9182b1cdd7653342dcbf72a2b90970c0c4cc900314a26ba131163adec234eec00816207266fbe9c2259d01b61a
|
||||
SHA512 (clang-16.0.1.src.tar.xz.sig) = 31756b55641debde8e075819a3705c9fbf9a3e39d0f5da5a0e8421bd96eb19972ced6f22df0f66f918d48375089c06b5e499f0627dc81d22956421d9791e088e
|
||||
SHA512 (clang-tools-extra-16.0.1.src.tar.xz) = eb3a5656526db559fa331e4020305b6070a33e9c4e7a082f0ebe2b307ac43d542c989585e99c660fc749041774ff80dbad089678456318b40415e340654424c8
|
||||
SHA512 (clang-tools-extra-16.0.1.src.tar.xz.sig) = c661a454ddc27aa12fd82aa19f49e26982147519bb108580059042302dc010b351d99fef65dc51c854a3d06a89a9200ee22dd613a1777bcf35b5236fa75ba2af
|
||||
SHA512 (clang-16.0.6.src.tar.xz) = 92c65b882e1504f4a9b8a3f6b8a24061505987aaacc8bb835115b4e4d74ac3a8c98343a308567b07c6b42bb99877c300bce3c4a5a25ada77abe65606aa25188d
|
||||
SHA512 (clang-16.0.6.src.tar.xz.sig) = a3e68c07d61ce62dfe406464f1afce352f36480966ceaa3171889ac1f02441d9df48e938b3e81d6b73b5957dd6623171323a9915281dc052be0c5c7014e75f24
|
||||
SHA512 (clang-tools-extra-16.0.6.src.tar.xz) = ec1a0834f223e393d24c11586b744167a41cea6c39d1bb18c433d2fb736501950fdff42f1eb0caa13c75bcb8ef9ac309eb0687644307698ec0420ff8a769c710
|
||||
SHA512 (clang-tools-extra-16.0.6.src.tar.xz.sig) = ff94fe024399bb72da10752ad1c41d57dcf5094b11ef5abdb82189026db0d7016c7ede0f47b7841aaa823de75bd927f8a1ffdbc112c5a0f61dec878790b5e7e3
|
||||
|
Loading…
Reference in New Issue
Block a user