7.0.0-rc2 Release
This commit is contained in:
parent
f7f57849e2
commit
462b3d2eb2
3
.gitignore
vendored
3
.gitignore
vendored
@ -41,3 +41,6 @@
|
||||
/clang-tools-extra-7.0.0rc1.src.tar.xz
|
||||
/test-suite-7.0.0rc1.src.fedora.tar.gz
|
||||
/test-suite-7.0.0rc1.src.fedora.tar.xz
|
||||
/cfe-7.0.0rc2.src.tar.xz
|
||||
/clang-tools-extra-7.0.0rc2.src.tar.xz
|
||||
/test-suite-7.0.0rc2.src.fedora.tar.xz
|
||||
|
@ -1,25 +0,0 @@
|
||||
From 2ebadefad7d5b8d6770fc135f1ad48059a5ac3b5 Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Fri, 17 Aug 2018 20:12:53 -0700
|
||||
Subject: [PATCH] ABI-Testsuite: Force the old c++11 ABI in mangling/test.xpp
|
||||
|
||||
The check lines for this test assume the old c++11 ABI.
|
||||
---
|
||||
ABI-Testsuite/test/mangling/test.xpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/ABI-Testsuite/test/mangling/test.xpp b/ABI-Testsuite/test/mangling/test.xpp
|
||||
index e7f4e00..b39e284 100755
|
||||
--- a/ABI-Testsuite/test/mangling/test.xpp
|
||||
+++ b/ABI-Testsuite/test/mangling/test.xpp
|
||||
@@ -1,6 +1,6 @@
|
||||
// This file is distributed under the University of Illinois Open Source License.
|
||||
// See LICENSE.TXT for details.
|
||||
-// RUN: cxx_compiler cxx_11 -c %s -o %t.o
|
||||
+// RUN: cxx_compiler cxx_11 -D_GLIBCXX_USE_CXX11_ABI=0 -c %s -o %t.o
|
||||
// RUN: bindump %t.o | FileCheck -allow-deprecated-dag-overlap prefixes %s
|
||||
|
||||
#include <cstddef>
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -1,28 +0,0 @@
|
||||
From b997a61df6094d258db94393d378282e039ebe13 Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Fri, 17 Aug 2018 16:00:52 -0700
|
||||
Subject: [PATCH] Fix CLAMR build with newer libstdc++
|
||||
|
||||
---
|
||||
MultiSource/Benchmarks/DOE-ProxyApps-C++/CLAMR/MallocPlus.h | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/MultiSource/Benchmarks/DOE-ProxyApps-C++/CLAMR/MallocPlus.h b/MultiSource/Benchmarks/DOE-ProxyApps-C++/CLAMR/MallocPlus.h
|
||||
index 138704f..9db368d 100644
|
||||
--- a/MultiSource/Benchmarks/DOE-ProxyApps-C++/CLAMR/MallocPlus.h
|
||||
+++ b/MultiSource/Benchmarks/DOE-ProxyApps-C++/CLAMR/MallocPlus.h
|
||||
@@ -99,9 +99,9 @@ struct malloc_plus_memory_entry {
|
||||
|
||||
struct cmp_str
|
||||
{
|
||||
- bool operator()(char const *a, char const *b)
|
||||
+ bool operator()(const string &a, const string &b)
|
||||
{
|
||||
- return strcmp(a, b) < 0;
|
||||
+ return a.compare(b) < 0;
|
||||
}
|
||||
};
|
||||
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -1,38 +0,0 @@
|
||||
From ad0f01329b13171b2e066dafe306df3237ff1151 Mon Sep 17 00:00:00 2001
|
||||
From: Hans Wennborg <hans@hanshq.net>
|
||||
Date: Tue, 7 Aug 2018 06:57:36 +0000
|
||||
Subject: [PATCH] Merging r338627:
|
||||
------------------------------------------------------------------------
|
||||
r338627 | mgorny | 2018-08-01 22:38:22 +0200 (Wed, 01 Aug 2018) | 7 lines
|
||||
|
||||
[test] Fix %hmaptool path for standalone builds
|
||||
|
||||
Fix %hmaptool path to refer to clang_tools_dir instead of
|
||||
llvm_tools_dir, in order to fix standalone builds. The tool is built
|
||||
as part of clang, so it won't be found in installed LLVM tools.
|
||||
|
||||
Differential Revision: https://reviews.llvm.org/D50156
|
||||
------------------------------------------------------------------------
|
||||
|
||||
|
||||
git-svn-id: https://llvm.org/svn/llvm-project/cfe/branches/release_70@339102 91177308-0d34-0410-b5e6-96231b3b80d8
|
||||
---
|
||||
test/lit.cfg.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/test/lit.cfg.py b/test/lit.cfg.py
|
||||
index ad30988..c962b41 100644
|
||||
--- a/test/lit.cfg.py
|
||||
+++ b/test/lit.cfg.py
|
||||
@@ -71,7 +71,7 @@ llvm_config.add_tool_substitutions(tools, tool_dirs)
|
||||
|
||||
config.substitutions.append(
|
||||
('%hmaptool', "'%s' %s" % (config.python_executable,
|
||||
- os.path.join(config.llvm_tools_dir, 'hmaptool'))))
|
||||
+ os.path.join(config.clang_tools_dir, 'hmaptool'))))
|
||||
|
||||
# Plugins (loadable modules)
|
||||
# TODO: This should be supplied by Makefile or autoconf.
|
||||
--
|
||||
1.8.3.1
|
||||
|
16
clang.spec
16
clang.spec
@ -3,7 +3,7 @@
|
||||
%global maj_ver 7
|
||||
%global min_ver 0
|
||||
%global patch_ver 0
|
||||
%global rc_ver 1
|
||||
%global rc_ver 2
|
||||
|
||||
%global clang_tools_binaries \
|
||||
%{_bindir}/clangd \
|
||||
@ -59,7 +59,7 @@
|
||||
|
||||
Name: %pkg_name
|
||||
Version: %{maj_ver}.%{min_ver}.%{patch_ver}
|
||||
Release: 0.5.rc%{rc_ver}%{?dist}
|
||||
Release: 0.6.rc%{rc_ver}%{?dist}
|
||||
Summary: A C language family front-end for LLVM
|
||||
|
||||
License: NCSA
|
||||
@ -82,14 +82,8 @@ Source100: clang-config.h
|
||||
Patch0: 0001-lit.cfg-Add-hack-so-lit-can-find-not-and-FileCheck.patch
|
||||
Patch1: 0001-GCC-compatibility-Ignore-fstack-clash-protection.patch
|
||||
Patch2: 0001-Driver-Prefer-vendor-supplied-gcc-toolchain.patch
|
||||
# This was merged into the release_70 branch after 7.0.0-rc1
|
||||
Patch3: 0001-Merging-r338627.patch
|
||||
Patch4: 0001-gtest-reorg.patch
|
||||
|
||||
# Test suite Patches
|
||||
Patch100: 0001-Fix-CLAMR-build-with-newer-libstdc.patch
|
||||
Patch101: 0001-ABI-Testsuite-Force-the-old-c-11-ABI-in-mangling-tes.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: cmake
|
||||
@ -233,14 +227,11 @@ suite can be run with any compiler, not just clang.
|
||||
%setup -T -q -b 1 -n %{clang_tools_srcdir}
|
||||
|
||||
%setup -T -q -b 2 -n %{test_suite_srcdir}
|
||||
%patch100 -p1 -b .build-fix
|
||||
%patch101 -p1 -b .old-abi-fix
|
||||
|
||||
%setup -q -n %{clang_srcdir}
|
||||
%patch0 -p1 -b .lit-search-path
|
||||
%patch1 -p1 -b .fstack-clash-protection
|
||||
%patch2 -p1 -b .vendor-gcc
|
||||
%patch3 -p1 -b .hmap-path-fix
|
||||
%patch4 -p1 -b .gtest
|
||||
|
||||
mv ../%{clang_tools_srcdir} tools/extra
|
||||
@ -437,6 +428,9 @@ false
|
||||
|
||||
%endif
|
||||
%changelog
|
||||
* Tue Aug 28 2018 Tom Stellard <tstellar@redhat.com> - 7.0.0-0.6.rc2
|
||||
- 7.0.0-rc2 Release
|
||||
|
||||
* Tue Aug 28 2018 Tom Stellard <tstellar@redhat.com> - 7.0.0-0.5.rc1
|
||||
- Enable unit tests
|
||||
|
||||
|
6
sources
6
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (cfe-7.0.0rc1.src.tar.xz) = 97d8775c36c0883861d6b0732451c3d431d30dbe39d405b2755d87a4d8d217fafea7becd31765dca8d5b7ae0dc33785ada10c6f60331a70d5294b22f00242cd0
|
||||
SHA512 (test-suite-7.0.0rc1.src.fedora.tar.xz) = ed31281b7119d4f9b6b3c65a6c872a7987fe18a589a485485a5b715620ffef4b116a6f72fac039c6638ea2e981b348cad9d6908d111661db3df8bfe96f64e795
|
||||
SHA512 (clang-tools-extra-7.0.0rc1.src.tar.xz) = a7d467b714731f54ed08019b698f7e301060ca84f0fcb23494c374a0d3b6e9d4d3f3bfd62ed83888574a29aff3fb5a718b5af85f59abd49a2683dbb543c7e033
|
||||
SHA512 (cfe-7.0.0rc2.src.tar.xz) = ae4c4f2b5f3c97147bcbb5d74e07588ff2ede7c131cb4e782ff077b68da1f02042a87f44227574a2883da7ce6827cd188898c862b0e09a4a70316df16193811b
|
||||
SHA512 (clang-tools-extra-7.0.0rc2.src.tar.xz) = 4b78046d9247160a566a48c84d0f75fd86fd80df5a9acd659f86c6c27c99b4b6d9296c04dff089697fede0109c531845572c3f8d99ebb28800ebb18c28ce9f6b
|
||||
SHA512 (test-suite-7.0.0rc2.src.fedora.tar.xz) = 95783651d2b24f81de352139a711ac4cae285a5e42c4398a6dc6f5d5b3384c045061bc24aa79ba8c13b7d1ad2967b8b3b08e26af63e29588610a10b80a71c9f9
|
||||
|
Loading…
Reference in New Issue
Block a user