12.0.1-rc1 Release
This commit is contained in:
parent
93869e0cb0
commit
1a54a323be
4
.gitignore
vendored
4
.gitignore
vendored
@ -167,3 +167,7 @@
|
|||||||
/clang-12.0.0.src.tar.xz.sig
|
/clang-12.0.0.src.tar.xz.sig
|
||||||
/clang-tools-extra-12.0.0.src.tar.xz
|
/clang-tools-extra-12.0.0.src.tar.xz
|
||||||
/clang-tools-extra-12.0.0.src.tar.xz.sig
|
/clang-tools-extra-12.0.0.src.tar.xz.sig
|
||||||
|
/clang-tools-extra-12.0.1rc1.src.tar.xz
|
||||||
|
/clang-tools-extra-12.0.1rc1.src.tar.xz.sig
|
||||||
|
/clang-12.0.1rc1.src.tar.xz
|
||||||
|
/clang-12.0.1rc1.src.tar.xz.sig
|
||||||
|
@ -1,224 +0,0 @@
|
|||||||
From ea01f898fd74bae23d8be31f1a29b542e886e3a5 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tom Stellard <tstellar@redhat.com>
|
|
||||||
Date: Tue, 9 Feb 2021 13:35:43 -0800
|
|
||||||
Subject: [PATCH 5/6] [PATCH][clang] Partially Revert "scan-view: Remove
|
|
||||||
Reporter.py and associated AppleScript files"
|
|
||||||
|
|
||||||
This reverts some of commit dbb01536f6f49fa428f170e34466072ef439b3e9.
|
|
||||||
|
|
||||||
The Reporter module was still being used by the ScanView.py module and deleting
|
|
||||||
it caused scan-view to fail. This commit adds back Reporter.py but removes the
|
|
||||||
code the references the AppleScript files which were removed in
|
|
||||||
dbb01536f6f49fa428f170e34466072ef439b3e9.
|
|
||||||
|
|
||||||
Differential Revision: https://reviews.llvm.org/D96367
|
|
||||||
---
|
|
||||||
clang/tools/scan-view/CMakeLists.txt | 1 +
|
|
||||||
clang/tools/scan-view/share/Reporter.py | 183 ++++++++++++++++++++++++++++++++
|
|
||||||
2 files changed, 184 insertions(+)
|
|
||||||
create mode 100644 clang/tools/scan-view/share/Reporter.py
|
|
||||||
|
|
||||||
diff --git a/clang/tools/scan-view/CMakeLists.txt b/clang/tools/scan-view/CMakeLists.txt
|
|
||||||
index dd3d334..eccc6b8 100644
|
|
||||||
--- a/clang/tools/scan-view/CMakeLists.txt
|
|
||||||
+++ b/clang/tools/scan-view/CMakeLists.txt
|
|
||||||
@@ -5,6 +5,7 @@ set(BinFiles
|
|
||||||
|
|
||||||
set(ShareFiles
|
|
||||||
ScanView.py
|
|
||||||
+ Reporter.py
|
|
||||||
startfile.py
|
|
||||||
bugcatcher.ico)
|
|
||||||
|
|
||||||
diff --git a/clang/tools/scan-view/share/Reporter.py b/clang/tools/scan-view/share/Reporter.py
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..31a14fb
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/clang/tools/scan-view/share/Reporter.py
|
|
||||||
@@ -0,0 +1,183 @@
|
|
||||||
+#!/usr/bin/env python
|
|
||||||
+# -*- coding: utf-8 -*-
|
|
||||||
+
|
|
||||||
+"""Methods for reporting bugs."""
|
|
||||||
+
|
|
||||||
+import subprocess, sys, os
|
|
||||||
+
|
|
||||||
+__all__ = ['ReportFailure', 'BugReport', 'getReporters']
|
|
||||||
+
|
|
||||||
+#
|
|
||||||
+
|
|
||||||
+class ReportFailure(Exception):
|
|
||||||
+ """Generic exception for failures in bug reporting."""
|
|
||||||
+ def __init__(self, value):
|
|
||||||
+ self.value = value
|
|
||||||
+
|
|
||||||
+# Collect information about a bug.
|
|
||||||
+
|
|
||||||
+class BugReport(object):
|
|
||||||
+ def __init__(self, title, description, files):
|
|
||||||
+ self.title = title
|
|
||||||
+ self.description = description
|
|
||||||
+ self.files = files
|
|
||||||
+
|
|
||||||
+# Reporter interfaces.
|
|
||||||
+
|
|
||||||
+import os
|
|
||||||
+
|
|
||||||
+import email, mimetypes, smtplib
|
|
||||||
+from email import encoders
|
|
||||||
+from email.message import Message
|
|
||||||
+from email.mime.base import MIMEBase
|
|
||||||
+from email.mime.multipart import MIMEMultipart
|
|
||||||
+from email.mime.text import MIMEText
|
|
||||||
+
|
|
||||||
+#===------------------------------------------------------------------------===#
|
|
||||||
+# ReporterParameter
|
|
||||||
+#===------------------------------------------------------------------------===#
|
|
||||||
+
|
|
||||||
+class ReporterParameter(object):
|
|
||||||
+ def __init__(self, n):
|
|
||||||
+ self.name = n
|
|
||||||
+ def getName(self):
|
|
||||||
+ return self.name
|
|
||||||
+ def getValue(self,r,bugtype,getConfigOption):
|
|
||||||
+ return getConfigOption(r.getName(),self.getName())
|
|
||||||
+ def saveConfigValue(self):
|
|
||||||
+ return True
|
|
||||||
+
|
|
||||||
+class TextParameter (ReporterParameter):
|
|
||||||
+ def getHTML(self,r,bugtype,getConfigOption):
|
|
||||||
+ return """\
|
|
||||||
+<tr>
|
|
||||||
+<td class="form_clabel">%s:</td>
|
|
||||||
+<td class="form_value"><input type="text" name="%s_%s" value="%s"></td>
|
|
||||||
+</tr>"""%(self.getName(),r.getName(),self.getName(),self.getValue(r,bugtype,getConfigOption))
|
|
||||||
+
|
|
||||||
+class SelectionParameter (ReporterParameter):
|
|
||||||
+ def __init__(self, n, values):
|
|
||||||
+ ReporterParameter.__init__(self,n)
|
|
||||||
+ self.values = values
|
|
||||||
+
|
|
||||||
+ def getHTML(self,r,bugtype,getConfigOption):
|
|
||||||
+ default = self.getValue(r,bugtype,getConfigOption)
|
|
||||||
+ return """\
|
|
||||||
+<tr>
|
|
||||||
+<td class="form_clabel">%s:</td><td class="form_value"><select name="%s_%s">
|
|
||||||
+%s
|
|
||||||
+</select></td>"""%(self.getName(),r.getName(),self.getName(),'\n'.join(["""\
|
|
||||||
+<option value="%s"%s>%s</option>"""%(o[0],
|
|
||||||
+ o[0] == default and ' selected="selected"' or '',
|
|
||||||
+ o[1]) for o in self.values]))
|
|
||||||
+
|
|
||||||
+#===------------------------------------------------------------------------===#
|
|
||||||
+# Reporters
|
|
||||||
+#===------------------------------------------------------------------------===#
|
|
||||||
+
|
|
||||||
+class EmailReporter(object):
|
|
||||||
+ def getName(self):
|
|
||||||
+ return 'Email'
|
|
||||||
+
|
|
||||||
+ def getParameters(self):
|
|
||||||
+ return [TextParameter(x) for x in ['To', 'From', 'SMTP Server', 'SMTP Port']]
|
|
||||||
+
|
|
||||||
+ # Lifted from python email module examples.
|
|
||||||
+ def attachFile(self, outer, path):
|
|
||||||
+ # Guess the content type based on the file's extension. Encoding
|
|
||||||
+ # will be ignored, although we should check for simple things like
|
|
||||||
+ # gzip'd or compressed files.
|
|
||||||
+ ctype, encoding = mimetypes.guess_type(path)
|
|
||||||
+ if ctype is None or encoding is not None:
|
|
||||||
+ # No guess could be made, or the file is encoded (compressed), so
|
|
||||||
+ # use a generic bag-of-bits type.
|
|
||||||
+ ctype = 'application/octet-stream'
|
|
||||||
+ maintype, subtype = ctype.split('/', 1)
|
|
||||||
+ if maintype == 'text':
|
|
||||||
+ fp = open(path)
|
|
||||||
+ # Note: we should handle calculating the charset
|
|
||||||
+ msg = MIMEText(fp.read(), _subtype=subtype)
|
|
||||||
+ fp.close()
|
|
||||||
+ else:
|
|
||||||
+ fp = open(path, 'rb')
|
|
||||||
+ msg = MIMEBase(maintype, subtype)
|
|
||||||
+ msg.set_payload(fp.read())
|
|
||||||
+ fp.close()
|
|
||||||
+ # Encode the payload using Base64
|
|
||||||
+ encoders.encode_base64(msg)
|
|
||||||
+ # Set the filename parameter
|
|
||||||
+ msg.add_header('Content-Disposition', 'attachment', filename=os.path.basename(path))
|
|
||||||
+ outer.attach(msg)
|
|
||||||
+
|
|
||||||
+ def fileReport(self, report, parameters):
|
|
||||||
+ mainMsg = """\
|
|
||||||
+BUG REPORT
|
|
||||||
+---
|
|
||||||
+Title: %s
|
|
||||||
+Description: %s
|
|
||||||
+"""%(report.title, report.description)
|
|
||||||
+
|
|
||||||
+ if not parameters.get('To'):
|
|
||||||
+ raise ReportFailure('No "To" address specified.')
|
|
||||||
+ if not parameters.get('From'):
|
|
||||||
+ raise ReportFailure('No "From" address specified.')
|
|
||||||
+
|
|
||||||
+ msg = MIMEMultipart()
|
|
||||||
+ msg['Subject'] = 'BUG REPORT: %s'%(report.title)
|
|
||||||
+ # FIXME: Get config parameters
|
|
||||||
+ msg['To'] = parameters.get('To')
|
|
||||||
+ msg['From'] = parameters.get('From')
|
|
||||||
+ msg.preamble = mainMsg
|
|
||||||
+
|
|
||||||
+ msg.attach(MIMEText(mainMsg, _subtype='text/plain'))
|
|
||||||
+ for file in report.files:
|
|
||||||
+ self.attachFile(msg, file)
|
|
||||||
+
|
|
||||||
+ try:
|
|
||||||
+ s = smtplib.SMTP(host=parameters.get('SMTP Server'),
|
|
||||||
+ port=parameters.get('SMTP Port'))
|
|
||||||
+ s.sendmail(msg['From'], msg['To'], msg.as_string())
|
|
||||||
+ s.close()
|
|
||||||
+ except:
|
|
||||||
+ raise ReportFailure('Unable to send message via SMTP.')
|
|
||||||
+
|
|
||||||
+ return "Message sent!"
|
|
||||||
+
|
|
||||||
+class BugzillaReporter(object):
|
|
||||||
+ def getName(self):
|
|
||||||
+ return 'Bugzilla'
|
|
||||||
+
|
|
||||||
+ def getParameters(self):
|
|
||||||
+ return [TextParameter(x) for x in ['URL','Product']]
|
|
||||||
+
|
|
||||||
+ def fileReport(self, report, parameters):
|
|
||||||
+ raise NotImplementedError
|
|
||||||
+
|
|
||||||
+
|
|
||||||
+class RadarClassificationParameter(SelectionParameter):
|
|
||||||
+ def __init__(self):
|
|
||||||
+ SelectionParameter.__init__(self,"Classification",
|
|
||||||
+ [['1', 'Security'], ['2', 'Crash/Hang/Data Loss'],
|
|
||||||
+ ['3', 'Performance'], ['4', 'UI/Usability'],
|
|
||||||
+ ['6', 'Serious Bug'], ['7', 'Other']])
|
|
||||||
+
|
|
||||||
+ def saveConfigValue(self):
|
|
||||||
+ return False
|
|
||||||
+
|
|
||||||
+ def getValue(self,r,bugtype,getConfigOption):
|
|
||||||
+ if bugtype.find("leak") != -1:
|
|
||||||
+ return '3'
|
|
||||||
+ elif bugtype.find("dereference") != -1:
|
|
||||||
+ return '2'
|
|
||||||
+ elif bugtype.find("missing ivar release") != -1:
|
|
||||||
+ return '3'
|
|
||||||
+ else:
|
|
||||||
+ return '7'
|
|
||||||
+
|
|
||||||
+###
|
|
||||||
+
|
|
||||||
+def getReporters():
|
|
||||||
+ reporters = []
|
|
||||||
+ reporters.append(EmailReporter())
|
|
||||||
+ return reporters
|
|
||||||
+
|
|
||||||
--
|
|
||||||
1.8.3.1
|
|
||||||
|
|
25
clang.spec
25
clang.spec
@ -2,8 +2,9 @@
|
|||||||
|
|
||||||
%global maj_ver 12
|
%global maj_ver 12
|
||||||
%global min_ver 0
|
%global min_ver 0
|
||||||
%global patch_ver 0
|
%global patch_ver 1
|
||||||
#%%global rc_ver 5
|
%global rc_ver 1
|
||||||
|
%global clang_version %{maj_ver}.%{min_ver}.%{patch_ver}
|
||||||
|
|
||||||
%global clang_tools_binaries \
|
%global clang_tools_binaries \
|
||||||
%{_bindir}/clang-apply-replacements \
|
%{_bindir}/clang-apply-replacements \
|
||||||
@ -60,21 +61,21 @@
|
|||||||
%global _smp_mflags -j8
|
%global _smp_mflags -j8
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%global clang_srcdir clang-%{version}%{?rc_ver:rc%{rc_ver}}.src
|
%global clang_srcdir clang-%{clang_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
%global clang_tools_srcdir clang-tools-extra-%{version}%{?rc_ver:rc%{rc_ver}}.src
|
%global clang_tools_srcdir clang-tools-extra-%{clang_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
|
|
||||||
Name: %pkg_name
|
Name: %pkg_name
|
||||||
Version: %{maj_ver}.%{min_ver}.%{patch_ver}%{?rc_ver:~rc%{rc_ver}}
|
Version: %{clang_version}%{?rc_ver:~rc%{rc_ver}}
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A C language family front-end for LLVM
|
Summary: A C language family front-end for LLVM
|
||||||
|
|
||||||
License: NCSA
|
License: NCSA
|
||||||
URL: http://llvm.org
|
URL: http://llvm.org
|
||||||
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{clang_srcdir}.tar.xz
|
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{clang_version}%{?rc_ver:-rc%{rc_ver}}/%{clang_srcdir}.tar.xz
|
||||||
Source3: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{clang_srcdir}.tar.xz.sig
|
Source3: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{clang_version}%{?rc_ver:-rc%{rc_ver}}/%{clang_srcdir}.tar.xz.sig
|
||||||
%if %{without compat_build}
|
%if %{without compat_build}
|
||||||
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{clang_tools_srcdir}.tar.xz
|
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{clang_version}%{?rc_ver:-rc%{rc_ver}}/%{clang_tools_srcdir}.tar.xz
|
||||||
Source2: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{clang_tools_srcdir}.tar.xz.sig
|
Source2: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{clang_version}%{?rc_ver:-rc%{rc_ver}}/%{clang_tools_srcdir}.tar.xz.sig
|
||||||
%endif
|
%endif
|
||||||
Source4: tstellar-gpg-key.asc
|
Source4: tstellar-gpg-key.asc
|
||||||
|
|
||||||
@ -83,7 +84,6 @@ Patch0: 0001-PATCH-clang-Reorganize-gtest-integration.patch
|
|||||||
Patch1: 0002-PATCH-clang-Make-funwind-tables-the-default-on-all-a.patch
|
Patch1: 0002-PATCH-clang-Make-funwind-tables-the-default-on-all-a.patch
|
||||||
Patch2: 0003-PATCH-clang-Don-t-install-static-libraries.patch
|
Patch2: 0003-PATCH-clang-Don-t-install-static-libraries.patch
|
||||||
Patch3: 0004-PATCH-clang-Prefer-gcc-toolchains-with-libgcc_s.so-w.patch
|
Patch3: 0004-PATCH-clang-Prefer-gcc-toolchains-with-libgcc_s.so-w.patch
|
||||||
Patch4: 0005-PATCH-clang-Partially-Revert-scan-view-Remove-Report.patch
|
|
||||||
Patch5: 0006-PATCH-clang-Allow-__ieee128-as-an-alias-to-__float12.patch
|
Patch5: 0006-PATCH-clang-Allow-__ieee128-as-an-alias-to-__float12.patch
|
||||||
|
|
||||||
# Patches for clang-tools-extra
|
# Patches for clang-tools-extra
|
||||||
@ -532,6 +532,9 @@ false
|
|||||||
|
|
||||||
%endif
|
%endif
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 27 2021 Tom Stellard <tstellar@redhat.com> - clang-12.0.1~rc1-1
|
||||||
|
- 12.0.1-rc1 Release
|
||||||
|
|
||||||
* Tue May 18 2021 sguelton@redhat.com - 12.0.0-2
|
* Tue May 18 2021 sguelton@redhat.com - 12.0.0-2
|
||||||
- Use the alternative-managed version of llvm-config
|
- Use the alternative-managed version of llvm-config
|
||||||
|
|
||||||
|
8
sources
8
sources
@ -1,4 +1,4 @@
|
|||||||
SHA512 (clang-12.0.0.src.tar.xz) = f5613b9bffc962467d3bedb7f66b4e057e2781eb63c5dadfd3cf0b02453e29eff0a4f844889031292f06a8b4c081d4d41c515b7f719826ce5c4209a09df9f1f6
|
SHA512 (clang-tools-extra-12.0.1rc1.src.tar.xz) = ced7fa7c4371e877320801bccf16e751f21d157d98013dfe3bf44afbeb65192de8c8b9159646f9a734755b1f98c0c7501eb08a6a861d369939ecc2f7a82f065a
|
||||||
SHA512 (clang-12.0.0.src.tar.xz.sig) = 9780c2f68dfd7ea633dd137dda265ffda6425be658b0724e25dadb6abc54d3368e7850687ce38f4c3bf0c7049a2c1bd2fb299cec5f548c38f3bc4ca1f8877437
|
SHA512 (clang-tools-extra-12.0.1rc1.src.tar.xz.sig) = 7223e89717704daed790d1ba67a31de73746ffe674b7ff0e530c25a29807def1cf1808e05e83a095d1d8cb274fc1eaf305ca7c1870deb6d28773f79e8fa2e00e
|
||||||
SHA512 (clang-tools-extra-12.0.0.src.tar.xz) = e0323a2506da748b5de32a3df53a987f3f74184c2d02d4e7b173e23e54396427e2d9b6600a7962795020bfc2c0dae16b210a69a4b8784086d1470d88f423c330
|
SHA512 (clang-12.0.1rc1.src.tar.xz) = 113c8ad54502adfa1568598bf54bb25456d1f30c742360394c8b50d1dda466b12da3658d52fc38bc17feb8c07d99cf04143a3c7d8da700883305c303c4792d7b
|
||||||
SHA512 (clang-tools-extra-12.0.0.src.tar.xz.sig) = 30afa9c2411417c30a47dcdcfe97ebf353ad1de1a98ed82d45bdfb3fafc30dcb335f6fd18ff3b44e2ed34ff5137932e3a4675289242712df01b8b6da8877fcef
|
SHA512 (clang-12.0.1rc1.src.tar.xz.sig) = 7b047a423d8a2ef75399982d5a70cf6f59c63f142ee3899eecb382c2c352c40df7fed1032e72334d604ec4a1d368db11da85d951c5020b3e1e45d5984f937ac1
|
||||||
|
Loading…
Reference in New Issue
Block a user