Manually apply https://reviews.llvm.org/D141581
This commit is contained in:
parent
e1ea575c35
commit
1919c1aecc
25
D141581.diff
Normal file
25
D141581.diff
Normal file
@ -0,0 +1,25 @@
|
||||
diff --git a/clang/lib/Basic/CMakeLists.txt b/clang/lib/Basic/CMakeLists.txt
|
||||
--- a/clang/lib/Basic/CMakeLists.txt
|
||||
+++ b/clang/lib/Basic/CMakeLists.txt
|
||||
@@ -110,7 +110,7 @@
|
||||
|
||||
DEPENDS
|
||||
omp_gen
|
||||
- RISCVTargetParserTableGen
|
||||
+ LLVMTargetParser
|
||||
)
|
||||
|
||||
target_link_libraries(clangBasic
|
||||
diff --git a/clang/lib/Driver/CMakeLists.txt b/clang/lib/Driver/CMakeLists.txt
|
||||
--- a/clang/lib/Driver/CMakeLists.txt
|
||||
+++ b/clang/lib/Driver/CMakeLists.txt
|
||||
@@ -93,7 +93,7 @@
|
||||
|
||||
DEPENDS
|
||||
ClangDriverOptions
|
||||
- RISCVTargetParserTableGen
|
||||
+ LLVMTargetParser
|
||||
|
||||
LINK_LIBS
|
||||
clangBasic
|
||||
|
@ -64,6 +64,10 @@ Patch2: 0003-PATCH-clang-Don-t-install-static-libraries.patch
|
||||
Patch3: 0001-Driver-Add-a-gcc-equivalent-triple-to-the-list-of-tr.patch
|
||||
Patch6: 0001-Take-into-account-Fedora-Specific-install-dir-for-li.patch
|
||||
|
||||
# Make clangBasic and clangDriver depend on LLVMTargetParser
|
||||
# See https://reviews.llvm.org/D141581
|
||||
Patch7: D141581.diff
|
||||
|
||||
%if %{without compat_build}
|
||||
# Patches for clang-tools-extra
|
||||
# See https://reviews.llvm.org/D120301
|
||||
|
Loading…
Reference in New Issue
Block a user