Remove unnecessary patch and macro
This commit is contained in:
parent
914aca4e35
commit
1903e547f9
@ -1,39 +0,0 @@
|
|||||||
From 3dc5722d5c7673a879f2b4680369d3ac8b6b64b6 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tom Stellard <tstellar@redhat.com>
|
|
||||||
Date: Wed, 4 Aug 2021 14:05:38 -0700
|
|
||||||
Subject: [PATCH] cmake: Allow shared libraries to customize the soname using
|
|
||||||
LLVM_ABI_REVISION
|
|
||||||
|
|
||||||
The LLVM_ABI_REVISION variable is intended to be used for release
|
|
||||||
candidates which introduce an ABI change to a shared library. This
|
|
||||||
variable can be specified per library, so there is not one global value
|
|
||||||
for all of LLVM.
|
|
||||||
|
|
||||||
For example, if we LLVM X.0.0-rc2 introduces an ABI change for a library
|
|
||||||
compared with LLVM X.0.0-rc1, then the LLVM_ABI_REVISION number for
|
|
||||||
library will be incremented by 1.
|
|
||||||
|
|
||||||
In the main branch, LLVM_ABI_REVISION should always be 0, it is only
|
|
||||||
meant to be used in the release branch.
|
|
||||||
|
|
||||||
Differential Revision: https://reviews.llvm.org/D105594
|
|
||||||
---
|
|
||||||
clang/tools/clang-shlib/CMakeLists.txt | 5 +++++
|
|
||||||
3 files changed, 19 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/clang/tools/clang-shlib/CMakeLists.txt b/clang/tools/clang-shlib/CMakeLists.txt
|
|
||||||
index 9c1f8ea452b3..4d785924e4bb 100644
|
|
||||||
--- a/clang/tools/clang-shlib/CMakeLists.txt
|
|
||||||
+++ b/clang/tools/clang-shlib/CMakeLists.txt
|
|
||||||
@@ -1,3 +1,8 @@
|
|
||||||
+# In the main branch, LLVM_ABI_REVISION should always be 0. In the release
|
|
||||||
+# branches, this should be incremented before each release candidate every
|
|
||||||
+# time the ABI of libclang-cpp.so changes.
|
|
||||||
+set(LLVM_ABI_REVISION 0)
|
|
||||||
+
|
|
||||||
# Building libclang-cpp.so fails if LLVM_ENABLE_PIC=Off
|
|
||||||
if (NOT LLVM_ENABLE_PIC)
|
|
||||||
return()
|
|
||||||
--
|
|
||||||
2.27.0
|
|
||||||
|
|
@ -42,7 +42,7 @@
|
|||||||
|
|
||||||
Name: %pkg_name
|
Name: %pkg_name
|
||||||
Version: %{clang_version}%{?rc_ver:~rc%{rc_ver}}
|
Version: %{clang_version}%{?rc_ver:~rc%{rc_ver}}
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: A C language family front-end for LLVM
|
Summary: A C language family front-end for LLVM
|
||||||
|
|
||||||
License: Apache-2.0 WITH LLVM-exception OR NCSA
|
License: Apache-2.0 WITH LLVM-exception OR NCSA
|
||||||
@ -64,7 +64,6 @@ Source7: macros.%{name}
|
|||||||
Patch1: 0003-PATCH-Make-funwind-tables-the-default-on-all-archs.patch
|
Patch1: 0003-PATCH-Make-funwind-tables-the-default-on-all-archs.patch
|
||||||
Patch2: 0003-PATCH-clang-Don-t-install-static-libraries.patch
|
Patch2: 0003-PATCH-clang-Don-t-install-static-libraries.patch
|
||||||
Patch3: 0001-Driver-Add-a-gcc-equivalent-triple-to-the-list-of-tr.patch
|
Patch3: 0001-Driver-Add-a-gcc-equivalent-triple-to-the-list-of-tr.patch
|
||||||
Patch4: 0001-cmake-Allow-shared-libraries-to-customize-the-soname.patch
|
|
||||||
# Drop the following patch after debugedit adds support to DWARF-5:
|
# Drop the following patch after debugedit adds support to DWARF-5:
|
||||||
# https://sourceware.org/bugzilla/show_bug.cgi?id=28728
|
# https://sourceware.org/bugzilla/show_bug.cgi?id=28728
|
||||||
Patch5: 0010-PATCH-clang-Produce-DWARF4-by-default.patch
|
Patch5: 0010-PATCH-clang-Produce-DWARF4-by-default.patch
|
||||||
@ -345,7 +344,6 @@ sed -i 's/\@FEDORA_LLVM_LIB_SUFFIX\@//g' test/lit.cfg.py
|
|||||||
%endif
|
%endif
|
||||||
%if %{with compat_build}
|
%if %{with compat_build}
|
||||||
-DCLANG_BUILD_TOOLS:BOOL=OFF \
|
-DCLANG_BUILD_TOOLS:BOOL=OFF \
|
||||||
-DLLVM_CMAKE_DIR=%{install_libdir}/cmake/llvm \
|
|
||||||
-DCMAKE_INSTALL_PREFIX=%{install_prefix} \
|
-DCMAKE_INSTALL_PREFIX=%{install_prefix} \
|
||||||
-DCLANG_INCLUDE_TESTS:BOOL=OFF \
|
-DCLANG_INCLUDE_TESTS:BOOL=OFF \
|
||||||
%else
|
%else
|
||||||
@ -612,6 +610,9 @@ false
|
|||||||
|
|
||||||
%endif
|
%endif
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 23 2023 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 16.0.0-2
|
||||||
|
- Remove unnecessary patch and macro
|
||||||
|
|
||||||
* Mon Mar 20 2023 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 16.0.0-1
|
* Mon Mar 20 2023 Tulio Magno Quites Machado Filho <tuliom@redhat.com> - 16.0.0-1
|
||||||
- Update to LLVM 16.0.0
|
- Update to LLVM 16.0.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user