Update to 5.5 release

Signed-off-by: Jeff Layton <jlayton@redhat.com>
This commit is contained in:
Jeff Layton 2012-05-30 06:44:58 -04:00
parent 4d5468efaf
commit bfd8da6470
4 changed files with 7 additions and 77 deletions

1
.gitignore vendored
View File

@ -9,3 +9,4 @@ cifs-utils-4.6.tar.bz2
/cifs-utils-5.2.tar.bz2
/cifs-utils-5.3.tar.bz2
/cifs-utils-5.4.tar.bz2
/cifs-utils-5.5.tar.bz2

View File

@ -1,72 +0,0 @@
From 900875dbda261dd8a9283bdda3c3dbe551fe0f7c Mon Sep 17 00:00:00 2001
From: Jeff Layton <jlayton@samba.org>
Date: Wed, 18 Apr 2012 21:41:05 -0400
Subject: [PATCH] mount.cifs: fix up some -D_FORTIFY_SOURCE=2 warnings
...and add -D_FORTIFY_SOURCE=2 to the default $CFLAGS.
Signed-off-by: Jeff Layton <jlayton@samba.org>
---
Makefile.am | 2 +-
mount.cifs.c | 10 ++++++----
mtab.c | 4 +++-
3 files changed, 10 insertions(+), 6 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index d95142a..05729ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,4 @@
-AM_CFLAGS = -Wall -Wextra -Werror
+AM_CFLAGS = -Wall -Wextra -Werror -D_FORTIFY_SOURCE=2
ACLOCAL_AMFLAGS = -I aclocal
root_sbindir = $(ROOTSBINDIR)
diff --git a/mount.cifs.c b/mount.cifs.c
index f0b073e..4f1ea40 100644
--- a/mount.cifs.c
+++ b/mount.cifs.c
@@ -928,9 +928,9 @@ parse_options(const char *data, struct parsed_mount_info *parsed_info)
}
} else {
/* domain/username%password */
- const int max = MAX_DOMAIN_SIZE +
- MAX_USERNAME_SIZE +
- MOUNT_PASSWD_SIZE + 2;
+ const unsigned int max = MAX_DOMAIN_SIZE +
+ MAX_USERNAME_SIZE +
+ MOUNT_PASSWD_SIZE + 2;
if (strnlen(value, max + 1) >= max + 1) {
fprintf(stderr, "username too long\n");
return EX_USAGE;
@@ -1603,8 +1603,10 @@ add_mtab(char *devname, char *mountpoint, unsigned long flags, const char *fstyp
mountent.mnt_passno = 0;
rc = addmntent(pmntfile, &mountent);
if (rc) {
+ int ignore __attribute__((unused));
+
fprintf(stderr, "unable to add mount entry to mtab\n");
- ftruncate(fd, statbuf.st_size);
+ ignore = ftruncate(fd, statbuf.st_size);
rc = EX_FILEIO;
}
tmprc = my_endmntent(pmntfile, statbuf.st_size);
diff --git a/mtab.c b/mtab.c
index de545b7..3d42ac0 100644
--- a/mtab.c
+++ b/mtab.c
@@ -271,8 +271,10 @@ my_endmntent(FILE *stream, off_t size)
/* truncate file back to "size" -- best effort here */
if (rc) {
+ int ignore __attribute__((unused));
+
rc = errno;
- ftruncate(fd, size);
+ ignore = ftruncate(fd, size);
}
endmntent(stream);
--
1.7.7.6

View File

@ -2,8 +2,8 @@
%define pre_release %nil
Name: cifs-utils
Version: 5.4
Release: 2%{pre_release}%{?dist}
Version: 5.5
Release: 1%{pre_release}%{?dist}
Summary: Utilities for mounting and managing CIFS mounts
Group: System Environment/Daemons
@ -12,7 +12,6 @@ URL: http://linux-cifs.samba.org/cifs-utils/
BuildRoot: %{_tmppath}/%{name}-%{version}%{pre_release}-%{release}-root-%(%{__id_u} -n)
Source0: ftp://ftp.samba.org/pub/linux-cifs/cifs-utils/%{name}-%{version}%{pre_release}.tar.bz2
Patch0: 0001-mount.cifs-fix-up-some-D_FORTIFY_SOURCE-2-warnings.patch
BuildRequires: libcap-ng-devel libtalloc-devel krb5-devel keyutils-libs-devel autoconf automake libwbclient-devel
Requires: keyutils
@ -27,7 +26,6 @@ file system.
%prep
%setup -q -n %{name}-%{version}%{pre_release}
%patch0 -p1
%build
%configure --prefix=/usr
@ -62,6 +60,9 @@ rm -rf %{buildroot}
%config(noreplace) %{_sysconfdir}/request-key.d/cifs.spnego.conf
%changelog
* Wed May 30 2012 Jeff Layton <jlayton@redhat.com> 5.5-1
- update to 5.5
* Wed Apr 25 2012 Jeff Layton <jlayton@redhat.com> 5.4-2
- rebuild to fix dependencies due to libwbclient changes

View File

@ -1 +1 @@
dde98336c833b59777114145cb8f3c64 cifs-utils-5.4.tar.bz2
4de6c660ccdb9506d0e2cff4f37b8707 cifs-utils-5.5.tar.bz2